combit List & Label Designer

Designer Handbuch

Die in diesem Handbuch enthaltenen Angaben sind ohne Gewähr und können ohne weitere Mitteilung geändert werden. Die combit GmbH geht hiermit keinerlei Verpflichtungen ein. Die Verfügbarkeit mancher in dieser Anleitung beschriebener Funktionen (bzw. die Vorgehensweise, um darauf zuzugreifen), ist von Version, Release, eingespielten Servicepacks, Ihres Systems (z.B. Betriebssystem, Textverarbeitung, Mailprogramm, etc.) sowie seiner Konfiguration abhängig. Wenden Sie sich im Zweifelsfall an den IT-Verantwortlichen.

Dieses Handbuch oder Ausschnitte aus diesem Handbuch dürfen ohne schriftliche Genehmigung der combit GmbH nicht kopiert oder in irgendeiner anderen (z.B. digitaler) Form vervielfältigt werden.

PDF creation utilizes wPDF (c) wpCubed GmbH - www.pdfcontrol.com

Copyright © combit GmbH 1992-2016; Rev. 21.004

www.combit.net

Alle Rechte vorbehalten.


Einführung

Im Designer erstellen oder bearbeiten Sie verschiedene Druckvorlagen für den Ausdruck von Informationen, die entweder aus einer Datenbank oder einer anderen Datenquelle stammen. Im Designer stehen Ihnen dann alle Daten zur Verfügung und können auf unterschiedliche Weise zum Druck aufbereitet werden.

Dabei setzt der Designer immer auf vom Programm übergebenen Daten auf, d.h. die Selektion und Zusammenstellung der Daten liegt voll und ganz in den Händen der Applikation.

Es gibt daher nicht "den Designer" als eigenständige Anwendung, sondern nur als festen Bestandteil einer Applikation, in die List & Label eingebunden wurde.

Der Designer, der Druck-, Vorschau und Exportdialog wird dann üblicherweise innerhalb einer Applikation über einen Menüpunkt aufgerufen (z.B. Konfiguration > Druck bzw. Ausgabe > Druck).

Siehe auch:


Allgemein

Die verschiedenen Druckvorlagen werden "Projekte" genannt. Neben den eigentlichen Druckinformationen sind in einem Projekt vor allem auch Layout-Angaben wie etwa Seitengröße und Orientierung, Schriften, Farben, Rahmen, Kreise, Linien, Grafiken, etc. festgelegt. Der Designer kennt drei Arten von Projekten: Listen, Etiketten und Karteikarten.

Die einzelnen Bestandteile eines solchen Projekts heißen "Objekte". So kann z.B. ein Projekt z.B. Textobjekte, Bildobjekte und einen Berichtscontainer enthalten.

Die gewünschten Objekte werden üblicherweise über "Einfügen" selektiert, mit der Maus auf dem Arbeitsbereich aufgezogen und dann mit den entsprechenden Inhalten und Layout-Eigenschaften versehen.

Der Designer stellt verschiedene Typen von Objekten zur Verfügung, die im Arbeitsbereich frei platziert und in der Größe verändert werden können.

§ Text/Variableninhalt

§ Linie, Rechteck, Kreis/Ellipse

§ Bilder

§ Barcode

§ Berichtscontainer oder Tabellen-Objekt (je nach Anwendung): Der Berichtscontainer kann Tabellen, Diagramme, Kreuztabellen und Gantt-Diagramme enthalten.

§ Diagramm: Grafische Darstellung von Daten.

§ Kreuztabelle: Zur Darstellung von Daten in mehreren Dimensionen.

§ Gantt-Diagramme: Zur Darstellung des zeitlichen Verlaufs von Vorgangsdaten.

§ Formatierter Text: Für Formatierungswechsel innerhalb einer Zeile.

§ Formularemente: Für Dateneingabe in der Vorschau und im PDF-Format.

§ Datengrafik: Zur einfachen Visualisierung von Daten als Balken oder Symbol.

§ Checkbox: Zur Visualisierung von Boolean-Werten (Wahr, Falsch).

§ Messinstrument: Zur Visualisierung von Daten als Tacho oder Skala.

§ HTML Inhalte: Zur Einbindung von HTML-Seiten.

§ PDF: Zur Einbindung von PDF-Dokumenten.

§ OLE Container: Zur Einbindung von OLE-Dokumenten (z.B. Word, Excel).

§ Vorlagen: Zur Platzierung im Hintergrund des Arbeitsbereiches, um andere Objekte gezielt daran ausrichten zu können.


Oberfläche

Die Oberfläche des Designers besteht aus dem Arbeitsbereich und verschiedenen Toolfenstern.

§ Ein Menüband mit den jeweils verfügbaren Funktionen bzw. die Symbolleisten "Einfügen" und "Aktionen". Sie können die Art der Anzeige (Menüband oder Symbolleiste) über Datei > Optionen > Arbeitsbereich (Projekt > Optionen > Arbeitsbereich) wählen. In diesem Handbuch geben wir die Befehle im Menüband an und dahinter in Klammern die entsprechende Menüoption.

Abbildung 1.1: Das Menüband

Das Menüband kann durch Doppelklick auf die Registerkartenlasche ausgeblendet werden. Die blaue Schaltfläche links oben wird als "Datei" bezeichnet. Das Datei-Menü enthält Befehle zum Speichern und Verwenden des Druckprojekts.

§ Im Arbeitsbereich werden die Objekte platziert. Form und Größe des Arbeitsbereichs verändern Sie über Projekt > Layout-Bereiche (Projekt > Seitenlayout).

§ Am Rand des Arbeitsbereichs können Sie über Tabs den Modus der Ansicht wählen: Layout, Layout-Vorschau, Echtdatenvorschau.

§ Die Statuszeile mit Mauszeigerposition, Arbeitsschritt, Position/Größe und Zoomregler.

§ Toolfenster für die verfügbaren Variablen und Felder (Variablen-/Feldliste), die Objekte, die verschiedenen Darstellungsebenen (Ebenen) und die Eigenschaften des selektierten Objekts bzw. des Projekts (Eigenschaften).


Die ersten Schritte

Dieses Kapitel beschäftigt sich mit der Erstellung einer einfachen Liste auf der Grundlage der combit List & Label Beispielanwendung.

Wenn Sie List & Label als Bestandteil einer Anwendung nutzen, können Sie den Designer meist über einen Menüpunkt o.ä. aufrufen. Die Funktionalität kann dann leicht von dem abweichen, was im Folgenden beschrieben wird.

Siehe auch:

Die Beispiele in diesem Handbuch

Einen einfachen Bericht erstellen

Eine einfache Rechnung erstellen

Eine einfache Aggregation erstellen

Ein einfaches Etikett erstellen


Die Beispiele in diesem Handbuch

Den Designer gibt es nicht als eigenständige Anwendung, sondern nur als festen Bestandteil einer Applikation, in die List & Label eingebunden wurde. Daher werden die Beispiele für dieses Handbuch mit Hilfe einer Beispielanwendung erstellt.

Diese Beispielanwendung basiert auf einer Microsoft-Access-Datenbank für ein fiktives Unternehmen "Northwind" mit Beispieldaten eines Lebensmittel-Großhändlers. Dabei handelt es sich um eine englischsprachige relationale Datenbank, d.h. die Daten sind über mehrere Tabellen verteilt. Jede Tabelle enthält Datenelemente, die miteinander in Beziehung stehen. So enthält eine Tabelle z.B. die Daten der Produkte. Eine andere Tabelle enthält die Produktkategorien. Die Spalten einer Tabelle werden als Felder bezeichnet (Produktname). Die Zeilen einer Tabelle als Datensätze.

Abbildung 2.1: Struktur der Microsoft Northwind-Beispieldatenbank


Einen einfachen Bericht erstellen

Für ein erstes einfaches Beispiel erstellen Sie eine alphabetisch sortierte Produktliste mit Berichtstitel und Firmenlogo.

1. Starten Sie den Designer.

2. Daraufhin erscheint ein Dateiauswahldialog. Um ein neues Projekt zu beginnen, wählen Sie die Schaltfläche Neu.

Hinweis: In Windows XP steht diese Schaltfläche nicht zur Verfügung. Hier geben Sie im Feld "Dateiname" einen Namen für die neue Druckvorlage an und wählen dann "Öffnen".

Um ein bestehendes Projekt zu öffnen bzw. zu bearbeiten, wählen Sie Öffnen.

Abbildung 2.2: Öffnen-Dialog

3. Das Standard-Projekt für die entsprechende Projektart wird angezeigt. Im Regelfall ist dieses Standard-Projekt ein leerer Arbeitsbereich mit einer bestimmten Papiergröße und Ausrichtung.

Hinweis: Ein Standard-Projekt ist eine Standardvorlage für das Erstellen von Projekten. Sie können jedoch das Standard-Projekt nach Ihren Wünschen verändern und wieder unter dem Dateinamen "Default" abspeichern. Sofern ein Default-Projekt vorhanden ist, wird bei der Neuanlage kein Projekt-Assistent angezeigt.

Abbildung 2.3: Leerer Arbeitsbereich

4. Wenn Sie unter Datei > Optionen > Arbeitsbereich (Projekt > Optionen > Arbeitsbereich) "Assistent für Neuanlage" gewählt haben, wird der Projektassistent gestartet. Der Projektassistent erleichtert Ihnen das Anlegen neuer Projekte indem er Sie durch verschiedene Seitenlayout-Optionen führt. Für dieses Beispiel wird kein Assistent verwendet.

Siehe auch:

Ein Firmenlogo in den Bericht einfügen

Einen Titel in den Bericht einfügen

Die Tabelle für die Produktauflistung einfügen

Die Tabellenzellen formatieren

Den Bericht in der Vorschau anzeigen

Eine Seitenzahl hinzufügen

Den Bericht drucken


Ein Firmenlogo in den Bericht einfügen

Für das Firmenlogo verwenden Sie die Bilddatei "combit-logo.gif", die Sie im Verzeichnis der Beispielanwendung finden. Außerdem benötigen Sie das Objekt "Bild". Gehen Sie wie folgt vor:

1. Wählen Sie Einfügen > Bild (Objekte > Einfügen > Bild).

Abbildung 2.4: Registerkarte "Einfügen"

Hinweis: Objekte sind die Bausteine Ihrer Projekte. Sie werden im Arbeitsbereich generiert und dort von einem Rahmen umgeben, über den Größe und Position verändert werden kann. Dieser Rahmen definiert den Platz, den das Objekt einnimmt und damit auch die maximale Ausdehnung, die der jeweilige Inhalt eines Objektes annehmen kann. Objekte dürfen sich ganz oder teilweise überlagern.

2. Zeigen Sie im Arbeitsbereich mit dem Mauszeiger auf den Punkt, an dem die linke obere Ecke des Objektes beginnen soll. Der Mauszeiger verwandelt sich in ein Kreuz. Ziehen Sie mit gedrückter linker Maustaste das Kreuz zur rechten unteren Ecke des geplanten Objekts. Lassen Sie die Maustaste los, wenn das Objekt (der gestrichelte Rahmen) die gewünschte Größe hat.

Hinweis: Objekte können auf verschiedene Weisen auf dem Arbeitsbereich eingefügt werden: über das Menü, über Kurztasten oder per Drag & Drop aus der Variablen-/Feldliste.

3. Wählen Sie aus, ob das Bild aus einer Datei geladen oder der Inhalt über eine Formel/Variable bestimmt wird.

Hinweis: In Windows XP steht dieser Dialog nicht zur Verfügung, es öffnet sich direkt der Dialog zur Auswahl einer Datei.

Abbildung 2.5: Auswahl der Bildquelle

4. Wenn Sie Datei wählen, öffnet sich ein Dateiauswahldialog. Wählen Sie die gewünschte Bilddatei aus.

Hinweis: Folgende Formate sind verfügbar: WMF, EMF, BMP, DIB, PCX, SCR, TIFF, GIF, JPEG, PCD, PNG, ICO. Generell sollten Sie den RGB-Farbraum verwenden (nicht CYMK). Über die entsprechenden Windows-Funktionen wird auch Transparenz in PNG-Dateien unterstützt. Nach unserer Erfahrung ist die Unterstützung bei Druckertreibern aber nicht immer zuverlässig gegeben, so dass Sie Berichte z.B. mit teiltransparenten PNG-Dateien sehr sorgfältig auf der tatsächlich zum Einsatz kommenden Hard-/Softwarekombination testen sollten. Ist dies nicht möglich, empfehlen wir auf Transparenzeffekte in Bildern zu verzichten.

Außerdem haben Sie über die Checkbox-Option "Bilddaten in Projektdatei speichern" die Möglichkeit das Bild in das Projekt einzubetten, damit dieses auch ohne die externe Datei zur Verfügung steht.

5. Nach Auswahl der Datei ist das Logo eingefügt.

Abbildung 2.6: Bericht mit Bildobjekt


Einen Titel in den Bericht einfügen

Um einen Titel in den Bericht einzufügen verwenden Sie das Textobjekt. Textobjekte dienen dazu, einen beliebigen Text auf dem Arbeitsbereich zu platzieren. Zusätzlich zu festem Text können hier auch Feldinhalte (Variablen) aus der Datenbank (z.B. Firmenname) oder auch Funktionen (z.B. Datum) eingesetzt werden.

1. Wählen Sie Einfügen > Text (Objekte > Einfügen > Text).

Abbildung 2.7: Registerkarte "Einfügen"

2. Ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf. Textobjekte sollten stets in der maximal gewünschten Größe erstellt werden, die Höhe minimiert sich dann zum Druckzeitpunkt zur tatsächlich benötigten Größe.

3. Daraufhin erscheint der Formel-Assistent über den Sie den Inhalt des Textobjekts bestimmen können.

Dieser Dialog besteht aus einer Reihe von Registerkarten, die jeweils verschiedene Elemente zur Bearbeitung enthalten. Die Bedeutung dieser Elemente wird in den folgenden Kapiteln noch näher erläutert.

§ Daten und Funktionen: Die verfügbaren Variablen, Felder und Funktionen.

§ Bedingung: Zur Definition von WENN-DANN-SONST Bedingungen.

§ Text: Zur Eingabe von festem Text und Tabulatoren.

§ Datumsformat: Verschiedene Datumsformate.

§ Zahlenformat: Verschiedene Zahlenformate.

§ Operatoren: Verfügbare Verknüpfungsoperatoren.

Es ist auch möglich, den gewünschten Ausdruck direkt in die Bearbeitungszeile einzugeben oder den Ausdruck dort noch zu bearbeiten (z.B. Klammern setzen).

Geben Sie daher direkt unseren Titel "Produkte" ein. Fester Text muss mit Anführungszeichen eingerahmt werden. Daten und Funktionen werden ohne Klammern eingegeben.

Abbildung 2.8: Text im Formel-Assistenten

Hinweis: Bitte beachten Sie, dass bei der Schreibweise von Ausdrücken, je nach Anwendung, zwei unterschiedliche Modi möglich sind. Weitere Informationen finden Sie im Kapitel Variablen, Felder und Ausdrücke.

4. Wenn Sie den Dialog über OK schließen wird der Titel angezeigt.

5. Über Texttools > Text (Mini-Symbolleiste) vergrößern Sie den Schriftgrad.

6. Damit ist der Titel eingefügt:

Abbildung 2.9: Bericht mit Textobjekt


Die Tabelle für die Produktauflistung einfügen

Um eine Tabelle in den Bericht einzufügen verwenden Sie das Objekt "Berichtscontainer". Ein Berichtscontainer kann – wie der Name schon andeutet – mehrere Objekte enthalten: Tabellen, Diagramme und Kreuztabellen können in beliebiger Abfolge eingefügt werden.

Hinweis: Der Berichtscontainer ist nicht in jeder Anwendung verfügbar. In Anwendungen ohne Berichtscontainer nutzen Sie das Objekt "Tabelle".

1. Wählen Sie Einfügen > Berichtscontainer (Objekte > Einfügen > Berichts-container).

Abbildung 2.10: Registerkarte "Einfügen"

2. Ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf.

3. Daraufhin erscheint ein Auswahldialog für das gewünschte Element. Wählen Sie das Element "Tabelle" aus.

Abbildung 2.11: Auswahl Element

4. Im folgenden Dialog geben Sie nun die Datenquelle an. Es werden alle zur Verfügung stehenden Tabellen hierarchisch angezeigt, d.h. unter den Tabellen finden Sie die jeweils relational verknüpften Tabellen.

Abbildung 2.12: Datenquelle auswählen

Für unsere Produktliste wählen Sie die Tabelle "Products" da hier die gewünschten Felder enthalten sind.

5. Daraufhin erscheint ein Auswahldialog mit allen Feldern der Tabelle "Products". Außerdem finden Sie unterhalb der "Products"-Tabelle auch die Felder der 1:1-verknüpften Tabellen "Categories" und "Suppliers".

Abbildung 2.13: Daten-Auswahlassistent

In diesem Dialog wählen Sie nun die Spalten für die Tabelle. Doppelklicken Sie beispielsweise auf das Feld "ProductName". Das Feld wird in den Bereich "Spalten" übernommen.

6. Wiederholen Sie diesen Schritt für alle Felder die in der Tabelle angezeigt werden sollen. Also beispielsweise "CategoryName" aus der verknüpften Tabelle "Categories" und das Feld "UnitPrice" für den Stückpreis. Bestätigen Sie Ihre Auswahl mit OK.

7. Im Arbeitsbereich wird nun die Tabelle angezeigt.

§ Die ausgewählten Felder werden in der Datenzeile ausgegeben, d.h. die Datenzeile enthält die Daten.

§ Außerdem wurde automatisch eine Kopfzeile erstellt. Kopfzeilen werden meist als Spaltenüberschriften genutzt, d.h. hier werden nun die ausgewählten Feldnamen als Text dargestellt.

§ Wenn Sie die Berichtscontainer in der Breite mit gedrückter Strg-Taste größer oder kleiner ziehen, werden die Spalten entsprechend proportional angepasst.

§ Die Breite der Spalten wird automatisch angepasst. Sie können die Breite der Spalte manuell anpassen, indem Sie mit der Maus die Rahmenlinie nach rechts oder links verschieben.

Hinweis: Dies verändert alle Tabellenspalten, deren Separatoren innerhalb eines +/-2mm-Intervalls von der Mausposition sind. Bei gedrückter Strg-Taste wird die Aktion nur für die Linie, auf der sich die Maus befindet, durchgeführt. Bei aktivierter Option "Breite einzeln ändern" (Tabelle > Breite einzeln ändern bzw. Strg+M bzw. Projektoption "Größenveränderung verändert nächste Spalte") ist eine Änderung der Breite von Tabellenspalten auf Kosten der Folgespalte möglich, d.h. die Folgespalte wird entsprechend kleiner.

Abbildung 2.14: Bericht mit Tabelle im Berichtscontainer-Objekt


Die Tabellenzellen formatieren

Wie eine Tabelle detailliert formatiert und angepasst werden kann, sehen Sie in Kapitel Professionelle Tabellen erstellen. An dieser Stelle wird nur auf ein paar grundsätzliche Formatierungsmöglichkeiten eingegangen.

1. Im Spaltentitel der Produktkategorie wird der Feldname "CategoryName" angezeigt. Um diesen Text in "Category" zu ändern, klicken Sie direkt in die entsprechende Zelle. Daraufhin erscheint der Formel-Assistent über den Sie den Inhalt der Zelle ändern können. Denken Sie daran, dass Text mit Anführungszeichen eingerahmt werden muss.

Abbildung 2.15: Formel-Assistent mit Texteingabe

2. Außerdem soll der Einzelpreis als Währung formatiert und die gesamte Spalte rechts ausgerichtet werden. Beide Formatoptionen finden Sie in Tabellentools > Tabelle (Mini-Symbolleiste). Klicken Sie daher in die linke obere Ecke um das Feld mit dem Einzelpreis zu selektieren.

Abbildung 2.16: Eine einzelne Zelle selektieren

3. Klicken Sie dann auf die Schaltfläche "% Format" für den Formatierungsdialog.

Daraufhin erscheint ein Auswahldialog in dem Sie die gewünschte Formatierung für das numerische Feld auswählen können. Wählen Sie dazu auf der linken Seite die Art, also beispielsweise "Währung". Im rechten Bereich des Dialogs können Sie dann detailliert festlegen, wie die Währungsformatierung aussehen soll. Dabei wird standardmäßig die jeweilige Applikationseinstellung verwendet. Alternativ kann die Systemeinstellung oder eine benutzerdefinierte Einstellung gewählt werden.

Abbildung 2.17: Formatierungsdialog

4. Anschließend selektieren Sie beide Zellen (also die Kopf- und die Datenzeile) um diese rechtsbündig auszurichten. Klicken Sie dazu mit gedrückter Strg-Taste jeweils in die linke obere Ecke der beiden Zellen um diese zu selektieren. Wählen Sie dann die Schaltfläche für die rechtsbündige Ausrichtung.

Abbildung 2.18: Mehrfach-Selektion von Zellen


Den Bericht in der Vorschau anzeigen

Bisher sehen Sie den Bericht nur als Struktur mit einem Datensatz in der Entwurfsansicht. Um eine Vorstellung vom Ergebnis zu bekommen, können Sie sich den Bericht in der Vorschau anzeigen lassen. Wechseln Sie dazu über die Tabs unterhalb des Arbeitsbereichs in die Vorschau.

Hinweis: Die Echtdatenvorschau wird nicht von allen Anwendungen unterstützt.

Abbildung 2.19: Toolbar "Vorschauoptionen"

Nun wird der Bericht mit den Daten aus der Tabelle "Products" angezeigt.

Abbildung 2.20: Echtdatenvorschau


Eine Seitenzahl hinzufügen

Im unteren Bereich der Seite bietet es sich an die Seitenzahl einzufügen. Dazu fügen Sie erneut ein Textobjekt ein, da Sie bei diesem Objekt zusätzlich zu festem Text auch Funktionen (wie z.B. die Seitenzahlfunktion) verwenden werden.

1. Wählen Sie Einfügen > Text (Objekte > Einfügen > Text).

Abbildung 2.21: Registerkarte "Einfügen"

2. Ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf.

3. Daraufhin erscheint der Formel-Assistent über den Sie den Inhalt des Textobjekts bestimmen können. Im rechten Bereich werden die verfügbaren Funktionen angezeigt. Über dieser Liste haben Sie ein Eingabefeld für den Autofilter zur Verfügung. Geben Sie in dieses Filterfeld den Ausdruck "Page" ein. Als Folge werden Ihnen alle Funktionen angezeigt, die den Begriff "Page" enthalten.

§ Die Funktion "Page$()" liefert Ihnen die Seitenzahl.

§ Die Funktion "TotalPages$()" liefert Ihnen die Gesamtseitenzahl.

Übernehmen Sie per Doppelklick die Funktion "Page$()" in den Ergebnisbereich.

4. Wenn Sie nun eine Fußzeile im Stil "Seite 1 von 2" ausgeben möchten, können Sie den Text " von " wie gewohnt direkt eingeben. Denken Sie daran, dass einzelne Bestandteile mit einem "+" verbunden werden und Text immer in Anführungszeichen stehen muss.

5. Für die Gesamtzahl der Seiten fügen Sie die Funktion "TotalPages$()" per Doppelklick ein. Die Formel sieht dann in etwa so aus:

Abbildung 2.22: Formel-Assistent mit Eingabe von Funktionen und Text

6. Und im Bericht haben Sie dann wieder wie gewohnt die Möglichkeit, diese Zeile zentriert darzustellen:

Abbildung 2.23: Schnellformatierung über die Texttools

7. Wechseln Sie in die Vorschau um das Ergebnis anzuschauen:

Abbildung 2.24: Echtdatenvorschau im Designer


Den Bericht drucken

Der Druck und Export kann direkt aus dem übergeordneten Programm, aus der Echtdatenvorschau oder über Datei > Drucken gestartet werden.

1. Daraufhin erscheint der Dialog für die Ausgabe-Einstellungen.

§ In der Rubrik "Ausgabemedium" können Sie den Drucker und die Druckereinstellungen ändern.

§ Unter "Ausgabe auf" wählen Sie das Ausgabeformat (z.B. Vorschau, Drucker, Excel).

Abbildung 2.25: Ausgabe-Einstellungen

2. Wenn Sie ein Exportformat (wie z.B. PDF) gewählt haben, wählen Sie im folgenden Dialog "Speichern unter" den Speicherort und geben im Feld "Dateiname" einen Namen für die zu erstellende Datei an.

Abbildung 2.26: Speichern-Dialog beim Export in andere Formate


Eine einfache Rechnung erstellen

In diesem Kapitel sehen Sie weitere Möglichkeiten des Berichtdesigns. Für das nächste Beispiel erstellen Sie eine mehrseitige Rechnung mit Anschreiben, Rechnungskopf, Summierung, Fußtexten, Anhang und Ausfertigungsdruck.

Siehe auch:

Eine neue Druckvorlage erstellen

Firmenlogo einfügen

Anschriftenfeld einfügen

Rechnungskopf mit Nummer und Datum erstellen

Die Postenliste hinzufügen

Ausrichtung und Formatierungen

Hintergrundfarbe und Rahmen

Rechnungsfuß mit Summierungen

Weitere Fußzeilen anlegen


Eine neue Druckvorlage erstellen

1. Starten Sie den Designer.

2. Daraufhin erscheint ein Dateiauswahldialog. Um ein neues Projekt zu beginnen, wählen Sie die Schaltfläche Neu.

Hinweis: In Windows XP steht die Schaltfläche "Neu" nicht zur Verfügung. Hier geben Sie im Feld "Dateiname" einen Namen für die neue Druckvorlage an und wählen dann "Öffnen".


Firmenlogo einfügen

Um ein Logo einzufügen verwenden Sie das Bildobjekt.

1. Wählen Sie Einfügen > Bild (Objekte > Einfügen > Bild).

Abbildung 2.27: Registerkarte "Einfügen"

2. Ziehen Sie das Objekt auf die gewünschte Größe auf und wählen Sie eine Bilddatei aus (siehe Kapitel Ein Firmenlogo in den Bericht einfügen).


Anschriftenfeld einfügen

Um eine Anschrift einzufügen verwenden Sie das Textobjekt. Textobjekte dienen dazu, einen beliebigen Text oder Feldinhalte auf dem Arbeitsbereich zu platzieren.

Text bearbeiten (6)

Abbildung 2.28: Anschriftenfeld: So soll es aussehen.

1. Wählen Sie Einfügen > Text (Objekte > Einfügen > Text).

Abbildung 2.29: Registerkarte "Einfügen"

2. Ziehen Sie das Objekt auf die gewünschte Größe auf. Textobjekte sollten stets in der maximal gewünschten Größe erstellt werden, die Höhe minimiert sich dann zum Druckzeitpunkt zur tatsächlich benötigten Größe.

3. Daraufhin erscheint der Formel-Assistent über den Sie den Inhalt des Textobjekts bestimmen können.

Dieser Dialog besteht aus einer Reihe von Registerkarten. Auf der Registerkarte "Daten und Funktionen" wählen Sie aus der Liste der verfügbaren Variablen die Variable für die Firmenanschrift aus (Firma).

Über der Variablen-/Feldliste finden Sie ein Autofilter-Feld, d.h. Sie können den Begriff "Firma" eingeben um alle Felder und Variablen mit diesem Begriff im Namen anzuzeigen. Die gewünschte Variable wählen Sie dann per Doppelklick aus und bestätigen die Auswahl mit OK. Somit haben Sie die erste Zeile des Anschriftenfeldes definiert.

Abbildung 2.30: Formel-Assistent mit Variable

4. Ein Textobjekt kann beliebig viele Absätze enthalten, die jeweils ganz unterschiedliche Darstellungseigenschaften haben können. Über die Texttools (Mini-Symbolleiste) können weitere Absätze eingefügt werden. Wählen Sie "Anhängen" um einen weiteren Absatz zu definieren.

Abbildung 2.31: Registerkarte "Text"

5. Daraufhin erscheint erneut der Formel-Assistent über den Sie den Inhalt des Absatzes bestimmen können. Nun geben Sie Vorname und Nachname des Empfängers an. Wählen Sie zunächst die Variable "Vorname".

6. Bevor Sie nun die Variable "Nachname" auswählen, sollten Sie noch einen Leerschritt einfügen, damit die beiden Variableninhalte nicht direkt hintereinander ausgeben werden. Ein Leerschritt ist nichts anderes als "Text". Fester Text muss mit Anführungszeichen eingerahmt werden. Daher geben Sie nun ein "+" als Verknüpfungsoperator ein und dann " " für den Leerschritt.

7. Anschließend wählen Sie die Variable "Nachname" aus, verknüpft wird diese natürlich auch mit einem "+". Das ganze sieht dann so aus:

Abbildung 2.32: Variablen und Text verknüpfen

8. Weiter geht's mit den übrigen Variablen Straße und Ort. Und damit ist das Anschriftenfeld fertig.

Text bearbeiten (6)

Abbildung 2.33: Textfeld mit 4 Absätzen


Rechnungskopf mit Nummer und Datum erstellen

Um einen Rechnungskopf mit dem Text "Rechnung", dem Rechnungsdatum und der Rechnungsnummer einzufügen verwenden Sie erneut das Textobjekt.

Abbildung 2.34: Rechnungskopf: So soll er aussehen.

1. Wählen Sie Einfügen > Text (Objekte > Einfügen > Text).

2. Ziehen Sie das Objekt auf die gewünschte Größe auf. Daraufhin erscheint der Formel-Assistent über den Sie den Inhalt des Textobjekts bestimmen können. Geben Sie den Text "Rechnung" ein.

3. Über Texttools > Einfügen (Mini-Symbolleiste) fügen Sie einen weiteren Absatz ein.

4. Daraufhin erscheint der Formel-Assistent. Geben Sie den Text "Datum:" ein.

5. Bevor Sie nun das Rechnungsdatum einfügen geben Sie einen Tabulator an, damit das Datum rechtsbündig angezeigt wird. Einen Tabulator fügen Sie über die Registerkarte "Text" ein. Über die Schaltfläche "Tabulator" erzeugen sie einen Tabulator, über die Schaltfläche "Eigenschaften" bestimmen Sie Position und Ausrichtung.

Abbildung 2.35: Tabulator zu einem Text hinzufügen

Hinweis: Pro Zeile kann ein Tabulator eingefügt werden. Ein Tabulator bewirkt, dass der Text davor bis max. zum Tabulator läuft. Bei einem rechtsbündigen Tabulator wird der Text nach dem Tabulator rechtsbündig angezeigt. Über die Position des Tabulators wird der Abstand vom linken Rand angegeben.

Da es sich bei einem Tabulator auch um ein Zeichen handelt, muss dieses ebenfalls von Anführungszeichen eingerahmt sein bzw. Sie fügen in diesem Beispiel den Tabulator über "Einfügen" zum vorhandenen Text "Datum:" hinzu.

6. Anschließend setzen Sie die Einfügemarke außerhalb des Textfeldes und fügen über die Registerkarte "Daten und Funktionen" die Variable "Belegdatum" ein.

Dabei findet automatisch eine Formatkonvertierung statt.

Diese Formatkonvertierung durch die Funktion "Date$()" ist notwendig, da es sich beim Datumsfeld um den Feldtyp "Datum" handelt und der Rückgabewert durch den eingegebenen Text "Datum:" bereits als "Zeichenkette" festgelegt ist. Der Rückgabewert muss stets eindeutig sein, daher muss der Datumswert über eine Funktion in eine Zeichenkette umgewandelt werden. Eine Möglichkeit hierfür ist die Funktion "Date$()".

Abbildung 2.36: Formatkonvertierung mit Date$()

Bei der automatischen Formatkonvertierung wird als Parameter für die Formatierung "%x" verwendet. Wenn Sie ein anderes Format ausgeben möchten, wechseln Sie im Formel-Assistenten auf die Registerkarte "Datumsformat". Hier können Sie direkt ein Format auswählen und dann als Datumsfeld die Variable "Belegdatum" auswählen.

7. Nun fügen Sie in der gleichen Art und Weise die Rechnungsnummer hinzu.

Dabei findet ebenfalls automatisch eine Formatkonvertierung statt.

Abbildung 2.37: Formatkonvertierung mit Str$()

Diese Formatkonvertierung durch die Funktion "Str$()" ist notwendig, da es sich bei der Rechnungsnummer um den Feldtyp "Zahl" handelt und der Rückgabewert durch den eingegebenen Text "Rechnungsnummer:" bereits als "Zeichenkette" festgelegt ist. Der Rückgabewert muss stets eindeutig sein, daher muss die Zahl über eine Funktion in eine Zeichenkette umgewandelt werden. Eine Möglichkeit hierfür ist die Funktion "Str$()". Diese Funktion hat insgesamt 3 Parameter: Der erste Parameter ist die Zahl die in eine Zeichenkette gewandelt werden soll, der zweite Parameter bestimmt die Mindestlänge und der dritte Parameter die Nachkommastellen.

8. Nun vergrößern Sie noch den Schriftgrad von "Rechnung", d.h. Sie selektieren die entsprechende Zeile.

9. Über die Texttools (Mini-Symbolleiste) setzen Sie die Schriftgröße auf 24.

10. Nun noch den Abstand zur nachfolgenden Zeile erhöhen, d.h. über Doppelklick auf das Textobjekt öffnen Sie den Dialog für die Absatz-Eigenschaften. In diesem Dialog können Sie die Eigenschaften jeder Zeile definieren. Setzen Sie den Wert für die Eigenschaft "Absatzabstand" der ersten Zeile auf 6pt.

Abbildung 2.38: Dialog für die Eigenschaften der Absätze

11. Und im Ergebnis haben Sie einen schönen Rechnungskopf:

Abbildung 2.39: Rechnungskopf


Die Postenliste hinzufügen

Um die Postenliste in den Bericht einzufügen verwenden Sie das Objekt "Berichtscontainer". Ein Berichtscontainer kann – wie der Name schon andeutet – mehrere Objekte enthalten: Tabellen und freier Inhalt, Diagramme, Kreuztabellen und Gannt-Diagramme. Für die Postenliste benötigen Sie das Element "Tabelle", für das Anschreiben den "freien Inhalt". Für eine Einführung in die Tabellenerstellung beachten Sie Kapitel Die Tabelle für die Produktauflistung einfügen.

1. Wählen Sie Einfügen > Berichtscontainer (Objekte > Einfügen > Berichtscontainer).

Abbildung 2.40: Registerkarte "Einfügen"

2. Ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf.

3. Daraufhin erscheint ein Auswahldialog für das gewünschte Element. Wählen Sie das Element "Tabelle" aus.

Abbildung 2.41: Auswahl Element

4. Im folgenden Dialog wählen Sie nun die Datenquelle aus. Es werden alle zur Verfügung stehenden Tabellen hierarchisch angezeigt, d.h. unter den Tabellen finden Sie die jeweils relational verknüpften Tabellen.

Für unsere Postenliste wählen Sie die Tabelle "Posten" da hier die die gewünschten Felder enthalten sind.

Daraufhin erscheint der Daten-Auswahlassistent mit allen Feldern der Tabelle "Posten".

Abbildung 2.42: Daten-Auswahlassistent

In diesem Dialog wählen Sie nun die Spalten für die Postenliste. Doppelklicken Sie nacheinander auf die Felder "Anzahl", "ArtikelNr", "Bezeichnung1", "Stkpreis". Die Felder werden damit in den Bereich "Spalten" übernommen. Bestätigen Sie Ihre Auswahl mit OK.

5. Im Arbeitsbereich wird nun die Tabelle angezeigt. Es wurde automatisch eine Kopfzeile mit Zeichenketten als Spaltenüberschriften und eine Datenzeile mit den Feldinhalten erstellt.

Die Breite der Spalten wird automatisch angepasst. Sie können die Breite der Spalte manuell anpassen, indem Sie mit der Maus die Rahmenlinie nach rechts oder links verschieben.

Hinweis: Dies verändert alle Tabellenspalten, deren Separatoren innerhalb eines +/-2mm-Intervalls von der Mausposition sind. Bei gedrückter Strg-Taste wird die Aktion nur für die Linie, auf der sich die Maus befindet, durchgeführt. Bei aktivierter Option "Breite einzeln ändern" (Tabelle > Breite einzeln ändern bzw. Strg+M bzw. Projektoption "Größenveränderung verändert nächste Spalte") ist eine Änderung der Breite von Tabellenspalten auf Kosten der Folgespalte möglich, d.h. die Folgespalte wird entsprechend kleiner.

Tabelle bearbeiten (Spaltenbreite)

Abbildung 2.43: Spaltenbreite mit der Maus verändern

6. Im nächsten Schritt fügen Sie eine weitere Spalte "Gesamt" hinzu. Klicken Sie dazu in die linke obere Ecke der Zelle "Stkpreis" um dieses zu selektieren. Wählen Sie dann "Rechts einfügen" in den Tabellentools (Mini-Symbolleiste).

Tabelle bearbeiten (Feld selektieren)

Abbildung 2.44: Spalte selektieren

7. Daraufhin erscheint ein Menü für den gewünschten Feldtyp. Hier wählen Sie "Text" aus.

8. Daraufhin erscheint der Formel-Assistent über den Sie den Inhalt der Spalte bestimmen können. Geben Sie den Text "Gesamt" ein und bestätigen Sie mit OK.

Daraufhin erscheint eine Hinweismeldung, die Ihnen anbietet, die Spalten so zu verkleinern, dass die neue Spalte im sichtbaren Bereich angelegt wird. Bestätigen Sie diesen Dialog. Somit haben Sie eine weitere Spalte in der Kopfzeile hinzugefügt. Diese Spalte benötigen Sie nun auch in der Datenzeile.

9. Selektieren Sie nun die (Datenzeilen-)Zelle mit dem Stückpreis und fügen eine weitere Spalte hinzu. Hier soll nun der Gesamtpreis berechnet werden. Der Gesamtpreis wird durch Eingabe von "Anzahl*Stückpreis" berechnet. Wählen Sie dazu die entsprechenden Variablen per Doppelklick aus.

Abbildung 2.45: Multiplikation zweier Werte im Formel-Assistent

Hinweis: Über die Registerkarte "Operatoren" öffnen Sie die Liste der verfügbaren Operatoren. Operatoren verknüpfen zwei oder mehr Werte bzw. Variablen zu einem neuen Wert. Sie können damit arithmetische Ausdrücke (Grundrechenarten) oder logische Ausdrücke formulieren. In einer Bedingung können Sie mehrere Verknüpfungen miteinander kombinieren. Beachten Sie dabei die jeweiligen Bearbeitungshierarchien der verwendeten Operatoren und setzen Sie bei Bedarf Klammern. Von besonderer Bedeutung ist dabei der Operator "+", der sich nicht nur für Additionen (Wertetypen "Zahl" und "Datum") eignet, sondern auch zur Verknüpfung von Zeichenketten dient.


Ausrichtung und Formatierungen

Nutzen Sie die Fülle von Formatierungsmöglichkeiten um die Rechnung in der gewünschten Form zu präsentieren. Ändern Sie z.B. die Spaltentitel und formatieren Sie die Beträge als Währung.

1. Klicken Sie in den zu ändernden Spaltentitel. Daraufhin erscheint der Formel-Assistent über den Sie den Inhalt der Zelle ändern können. Denken Sie daran, dass Text mit Anführungszeichen eingerahmt werden muss.

2. Außerdem soll die Spalte für den Stückpreis und den Gesamtpreis mit den Spaltenüberschriften rechtsbündig ausgerichtet werden. Klicken Sie dazu mit gedrückter Umschalt-Taste in die linke obere Ecke der Datenzeile "Stückpreis" um alle 4 Zellen zu selektieren. Wählen Sie dann die Schaltfläche für die rechtsbündige Ausrichtung in den Tabellentools (Mini-Symbolleiste).

3. Um die beiden Beträge als Währung zu formatieren klicken Sie mit gedrückter Strg-Taste jeweils in die linke obere Ecke der beiden Zellen um diese zu selektieren. Wählen Sie dann die Schaltfläche für den Formatierungsdialog.

Tabelle bearbeiten (Spalten selektieren)

Abbildung 2.46: Mehrfach-Selektion von Zellen

4. Daraufhin erscheint ein Auswahldialog in dem Sie die gewünschte Formatierung für das numerische Feld auswählen können. Wählen Sie dazu auf der linken Seite die Art, also beispielsweise "Währung". Im rechten Bereich des Dialogs können Sie dann detailliert festlegen, wie die Währungsformatierung aussehen soll. Dabei wird standardmäßig die jeweilige Applikationseinstellung verwendet. Alternativ kann die Systemeinstellung oder eine benutzerdefinierte Einstellung gewählt werden.

Abbildung 2.47: Formatieren eines Feldes

5. Das Feld für die Anzahl formatieren Sie als Zahl ohne Nachkommastellen.

6. Damit sieht unsere Postenliste so aus:

Abbildung 2.48: Vorschau


Hintergrundfarbe und Rahmen

Der Hintergrund von Tabellen wird standardmäßig mit einer Designschema-Hintergrundfarbe belegt. Sie können das Designschema ändern oder die Hintergrundfarbe anpassen.

1. Wählen Sie in den Projekt-Eigenschaften ein anderes Designschema, z.B. "combit" um die Farben zu ändern.

2. Alternativ doppelklicken Sie auf einen Spaltentitel um den Dialog für die Spalten- und Zeileneigenschaften zu öffnen. Selektieren Sie mit gedrückter Strg-Taste alle Spalten.

3. Erweitern Sie die Eigenschaftengruppe "Hintergrund" über das +-Zeichen.

4. Wählen Sie als Hintergrund die Eigenschaft "transparent" um keinen Hintergrund anzuzeigen oder wählen Sie als Farbe z.B. LL.Color.SkyBlue. Die LL.Color-Farben erreichen Sie über die Pfeil-Schaltfläche. Den Standard-Farbdialog über die ...-Schaltfläche.

5. Über Tabellentools > Tabelle (Mini-Symbolleiste) formatieren Sie den Text "Fett".

Abbildung 2.49: Objekt-Dialog der Tabelle: Hintergrund

6. Außerdem möchten Sie den Abstand zwischen Kopfzeile und Datenzeile erhöhen. Da es sich dabei um eine Zeileneigenschaft handelt (und nicht um eine Spalteneigenschaft) selektieren Sie die Zeile.

Abbildung 2.50: Objekt-Dialog der Tabelle: Ränder

Damit steht Ihnen die Eigenschaft "Ränder" zur Verfügung. Wählen Sie als "Rand unten" z.B. 3mm um damit Abstand unterhalb der Spaltenüberschrift zu bestimmen.

7. Nun fehlen nur noch die Einstellungen für den Rahmen. Die Rahmeneinstellung kann für jede Zelle einzeln bestimmt werden. In der Regel ist es jedoch sinnvoll, diese für die gesamte Tabelle vorzunehmen. Daher gibt es in den Eigenschaften der Tabelle die Rahmen-Voreinstellung. Die Tabellen-Eigenschaften finden Sie standardmäßig links unten wenn Sie im Toolfenster "Berichtscontainer" die Tabelle selektieren. Wenn Sie die Eigenschaft selektieren, können Sie über eine Schaltfläche den Dialog für die Rahmeneigenschaften öffnen.

Abbildung 2.51: Rahmeneigenschaften

8. Wählen Sie als Farbe "weiß" und klicken Sie auf "Kontur" um die Farbeinstellung anzuwenden.

Bitte beachten: Wenn Sie die Einstellungen nicht anwenden sondern den Dialog lediglich mit OK bestätigen gehen Ihre Einstellungen verloren!

9. Die Rechnung sieht nun in der Vorschau ungefähr so aus:

Abbildung 2.52: Vorschau (Rahmen und Hintergrund)


Rechnungsfuß mit Summierungen

Im Rechnungsfuß geben Sie nun die Nettogesamtsumme, die Mehrwertsteuer und den Gesamtbetrag aus. Sofern diese Werte in einem Feld der Datenbank stehen können Sie diese einfach einfügen. In unserem Fall müssen Sie diese Werte aber erst berechnen. Dazu nutzen Sie die Aggregatsfunktion "Sum()". Diese Funktion summiert den übergebenen Wert.

Da die Summen am Ende der Tabelle ausgegeben werden sollen, definieren Sie für die Ausgabe eine Fußzeile.

1. Klicken Sie in den Tabellentools (Mini-Symbolleiste) auf "Darunter einfügen" (Zeile anhängen) und dann auf "Fußzeile".

Abbildung 2.53: Weitere Zeile hinzufügen

2. Da Sie für diesen Zeilentyp noch keine Zeile definiert haben, werden Sie gefragt, ob Sie eine bestehende Zeilendefinition von einer der anderen Zeilentypen übernehmen wollen. Dies würde aber an dieser Stelle keinerlei Zeitersparnis bedeuten. Daher wählen Sie den Eintrag "Einzelnes Feld oder freier Inhalt".

Abbildung 2.54: Zeilendefinition übernehmen

3. Daraufhin öffnet sich der Formel-Assistent damit Sie Inhalt der ersten Spalte definieren können. Geben Sie den Text "Nettogesamtbetrag" ein und denken Sie dabei an die Einrahmung mit Anführungszeichen.

4. Nachdem Sie die Zeile erstellt haben fügen Sie eine weitere Spalte hinzu für die Summierung. Zur Summierung von Werten verwenden Sie die Funktion "Sum()".

Tippen Sie diese entweder direkt in den Ergebnisbereich im Formel-Assistent oder wählen Sie die Funktion aus der Liste der Aggregatsfunktionen per Doppelklick aus. Als Parameter geben Sie den zu summierenden Wert an, also in diesem Fall Anzahl*Stückpreis.

Abbildung 2.55: Summenbildung mit Sum()

5. Nun soll die ganze Zeile noch etwas nach rechts verschoben werden. Ziehen Sie dazu mit gedrückter Strg-Taste den Spaltentrenner ganz links am äußersten Rand der Tabelle nach rechts. Automatisch wird eine leere 1. Spalte als Abstand erzeugt.

6. Außerdem formatieren Sie dieses Summenfeld als Währung, geben beiden Spalten eine Hintergrundfarbe und der ganzen Zeile einen "Rand oben" von 3mm entsprechend dem "Rand unten" bei der Kopfzeile.

7. Da diese Fußzeile auch bei einer mehrseitigen Rechnung nur auf der letzten Seite ausgegeben werden soll, geben Sie bei der Zeileneigenschaft "Darstellungsbedingung" die Funktion "Lastpage()" oder "LastFooterThisTable()" an.

Abbildung 2.56: Objekt-Dialog mit 3 Spalten

8. Damit ist die erste Fußzeile definiert und die Rechnung sieht so aus:

Abbildung 2.57: Vorschau (Fußzeile)


Weitere Fußzeilen anlegen

Sie können für jeden Zeilentyp (Datenzeile, Fußzeile...) beliebig viele Zeilendefinitionen anlegen. Die verschiedenen Zeilendefinitionen werden im Objekt-Dialog als Baumstruktur angezeigt.

Legen Sie für unser Beispiel zwei weitere Fußzeilen für die Mehrwertsteuer und die Gesamtsumme an.

Abbildung 2.58: Vorschau 3 Fußzeilen

1. Um weitere Zeilen im Objekt-Dialog anzulegen, selektieren Sie zunächst eine bestehende Zeilendefinition. Über die Schaltfläche "Eine Zeilendefinition anhängen" können Sie dann eine weitere Zeilendefinition erstellen.

Alternativ legen Sie eine neue Zeile über das Kontextmenü oder über die Tabellentools bzw. die Mini-Symbolleiste direkt im Arbeitsbereich an.

2. Im folgenden Dialog werden Sie gefragt, ob Sie eine bestehende Zeilendefinition übernehmen wollen. Die Übernahme der bereits angelegten Fußzeile spart uns etwas Zeit, da Sie den Abstand von links, die Ausrichtung und die Hintergrundfarbe nicht mehr anlegen müssen. Daher wählen Sie den Eintrag "Zeilendefinition 1" aus dem Bereich "Fußzeile".

3. Daraufhin wird die Zeile eingefügt. Klicken Sie in die Zelle "Nettogesamtbetrag" um den Inhalt im Formel-Assistenten in "Mehrwertsteuer 19%" zu ändern. Denken Sie dabei an die Einrahmung mit Anführungszeichen.

4. Nachdem Sie die Spalte erstellt haben klicken Sie in die Spalte für die Summierung. Anstelle des Nettogesamtbetrags soll an dieser Stelle die 19%-Mehrwertsteuer ausgegeben werden. Somit multiplizieren Sie diesen Betrag einfach mit 0,19.

Sum (Posten.Anzahl * Posten.Stkpreis * 0.19)

5. Ebenso verfahren Sie mit der dritten Fußzeile. D.h. Sie kopieren die bestehende Fußzeile, ändern den Inhalt ab und als Formel addieren Sie hier die Mehrwertsteuer hinzu, also z.B. so:

Sum (Posten.Anzahl * Posten.Stkpreis * 1.19)

6. Damit sind die Fußzeilen definiert und die Rechnung sieht so aus:

Abbildung 2.59: Rechnung mit 3 Fußzeilen


Eine einfache Aggregation erstellen

Nehmen wir an, Sie möchten den Umsatz pro Land ausgeben:

Abbildung 2.60: Aggregation über Fußzeilen

Das Aggregieren von Daten erfolgt idealerweise über die Aggregatsfunktionen, z.B. Sum(), Count(), Avg(). Diese verwenden Sie dann in Gruppenfußzeilen oder Fußzeilen und setzen die jeweilige Tabellenobjekt-Eigenschaft "Datenzeilen unterdrücken" auf "True", dadurch werden dann eben nur Fußzeilen/Gruppenfußzeilen angezeigt. Durch diese Option können Sie Summenzeilen ausgeben und dadurch Aggregationen darstellen.

Siehe auch:


Tabelle einfügen

Gehen Sie wie folgt vor:

1. Wählen Sie Einfügen > Berichtscontainer (Objekte > Einfügen > Berichtscontainer).

Abbildung 2.61: Registerkarte "Einfügen"

2. Ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf.

3. Daraufhin erscheint ein Auswahldialog für das gewünschte Element. Wählen Sie das Element "Tabelle" aus.

Abbildung 2.62: Auswahl Element

4. Im folgenden Dialog wählen Sie nun die Datenquelle aus. Es werden alle zur Verfügung stehenden Tabellen hierarchisch angezeigt, d.h. unter den Tabellen finden Sie die jeweils relational verknüpften Tabellen.

Für eine Umsatzauswertung je Land wählen Sie z.B. die Tabelle "Orders > Order_Details" damit beide Tabellen zur Verfügung stehen. Die Tabelle "Customers" ist 1:1-relational mit der Tabelle "Orders" verknüpft, daher müssen Sie diese nicht auswählen. In der Tabelle "Order_Details" ist der Umsatz gespeichert.

Abbildung 2.63: Anzeige der verknüpften Tabellen in der Objektliste

5. In der Tabelle "Orders.Order_Details" erstellen Sie eine Datenzeile mit dem Feld "OrderID". Die Datenzeile wird zwar nicht ausgegeben (da wir sie unterdrücken), aber es wird ein Feld benötigt, damit die Tabelle überhaupt gedruckt wird.


Aggregation erstellen

1. Als Fußzeile definieren Sie die eigentliche Statistik, d.h. in der 1. Spalte den Ländernamen und in der 2. Spalte summieren Sie den Umsatz. Diesen berechnen Sie erneut über die Formel "Sum(Order_Details.Quantity * Order_Details.UnitPrice)".

2. In der Tabelle "Orders" erstellen Sie eine Datenzeile mit dem Feld "Country" aus der verknüpften Tabelle "Customers". Die Datenzeile wird zwar nicht ausgegeben (da wir sie unterdrücken), aber es wird ein Feld benötigt, damit die Tabelle überhaupt gedruckt wird.

3. Als Fußzeile definieren Sie die Gesamtsumme über alle Länder, d.h. in der 1. Spalte den Text "Gesamt" und in der 2. Spalte summieren Sie erneut den Umsatz.

Abbildung 2.64: Fußzeilen für Statistik erstellen

4. Nun selektieren Sie im Toolfenster "Objekte" die Tabelle "Orders" und setzen die Eigenschaft "Datenzeilen > Datenzeilen unterdrücken" auf "Ja".

5. Selektieren Sie nun auch die Tabelle "Order_Details" und setzen auch hier die Tabellen-Eigenschaft "Datenzeilen > Datenzeilen unterdrücken" auf "Ja".

Abbildung 2.65: Datenzeilen unterdrücken für Statistiken

6. Die Statistik ist fertig (siehe Abbildung 2.60 ).


Ein einfaches Etikett erstellen

Für ein erstes einfaches Etiketten-Beispiel erstellen Sie ein Artikel-Etikett.

1. Starten Sie den Designer.

2. Daraufhin erscheint ein Dateiauswahldialog. Um ein neues Projekt zu beginnen, wählen Sie die Schaltfläche Neu.

Hinweis: In Windows XP steht diese Schaltfläche nicht zur Verfügung. Hier geben Sie im Feld "Dateiname" einen Namen für die neue Druckvorlage an und wählen dann "Öffnen".

3. Das Standard-Projekt für diese Projektart wird angezeigt. Im Regelfall ist dieses Standard-Projekt ein leerer Arbeitsbereich mit einer bestimmten Papiergröße und Ausrichtung.

4. Wählen Sie über Projekt > Layout-Bereiche (Projekt > Seitenlayout) ein Etikettenformat aus. Über die Registerkarte "Vorlagen" wählen Sie unter den vordefinierten Etikettenformaten verschiedener Hersteller die gewünschte Vorlage aus. Damit wird automatisch festgelegt, wie groß die einzelnen Etiketten sind und wie viele sich davon wie auf dem Blatt verteilen. Weitere Informationen finden Sie in Kapitel Vorlagen für Etikettenformate.

Abbildung 2.66: Etikettenformat festlegen

5. Im Arbeitsbereich wird nun ein einzelnes Etikett angezeigt.

Siehe auch:


Textobjekt und Bild einfügen

Auf dem Etikett soll ein Bildobjekt (für das Artikelbild), zwei Textobjekte (für Artikel.Nr, Bezeichnungen und Preis) und ein Barcode (mit der Artikel.Nr) dargestellt werden. Zwischen dem Text "Artikel-Nr:" und der Variablen "Artikel.Nr" setzen Sie einen Tabulator.

Abbildung 2.67: So soll es aussehen

1. Starten Sie mit der Platzierung des Textobjekts. Wählen Sie Einfügen > Text (Objekte > Einfügen > Text).

Abbildung 2.68: Registerkarte "Einfügen"

2. Ziehen Sie das Objekt auf die gewünschte Größe auf.

3. Daraufhin erscheint der Formel-Assistent über den Sie den Inhalt des Textobjekts bestimmen können.

4. Folgen Sie nun den Schritten ab Kapitel Anschriftenfeld einfügen.

5. Für das Artikelbild verwenden Sie das Bildobjekt. Ziehen Sie die Variable "Bild" aus der Variablen-/Feldliste direkt in den Arbeitsbereich. Ziehen Sie das Objekt auf die gewünschte Größe auf.


Barcode einfügen

1. Um einen Barcode auszugeben, verwenden Sie das Barcode-Objekt. Wählen Sie Einfügen > Barcode (Objekte > Einfügen > Barcode) und ziehen Sie das Objekt auf die gewünschte Größe auf. Daraufhin erscheint der Barcode-Inhalt-Dialog über den Sie den Inhalt des Barcodes bestimmen können.

2. Den Inhalt können Sie in 3 Arten angeben: Text, Formel, Variable. Wählen Sie die Option "Formel" und klicken Sie auf die Schaltfläche "Bearbeiten". Daraufhin erscheint der Formel-Assistent.

3. Ziehen Sie nun per Drag & Drop die Variable "ArtikelNr" auf die Funktion Barcode() um die Zeichenkette in einen Barcode umzuwandeln. Die möglichen Barcodetypen werden Ihnen von der Auto-Vervollständigung des Assistenten als 2. Parameter angeboten.

4. Vervollständigen Sie die Formel, z.B. Barcode (Artikel.Nr,"Datamatrix") und schließen Sie den Dialog mit OK.

5. Zurück im Dialog "Barcode-Inhalt" können Sie über die Schaltfläche "Optionen" bei einigen Barcodes bestimmte Formatierungen angeben. Nähere Informationen finden Sie im Kapitel Barcode-Objekte.

6. Wenn Sie den Dialog über OK schließen wird das Etikett mit Barcode angezeigt.


Etiketten drucken

Der Druck kann direkt aus dem übergeordneten Programm, aus der Echtdatenvorschau oder über Datei > Drucken gestartet werden.

1. Daraufhin erscheint der Dialog für die Ausgabe-Einstellungen.

§ In der Rubrik "Ausgabemedium" können Sie den Drucker und die Druckereinstellungen ändern.

§ Unter "Ausgabe auf" wählen Sie das Ausgabeformat (z.B. Vorschau, Drucker).

2. Über die Schaltfläche "Wählen" können Sie die Anfangsposition für den Druck des Etikettenbogens bestimmen. So können auch bereits verwendete Etikettenbögen zum Druck verwendet werden. Im Dialog zur Auswahl der Anfangsposition finden Sie einen Musteretikettenbogen Ihres Etikettenprojektes. Klicken Sie mit der Maus auf das Etikett, bei dem der Druck beginnen soll.


Effektive Techniken im Arbeitsbereich

In diesem Kapitel finden Sie nützliche Hinweise und die wichtigsten Techniken für einen effektiven Umgang mit dem Designer.

Siehe auch:

Ansichtsmodus

Allgemeine Arbeitsweise

Objekte einfügen und anordnen

Objekte ausrichten

Projektoptionen


Ansichtsmodus

Am oberen oder unteren Rand des Arbeitsbereichs können Sie über die Registerkarten den Modus der Ansicht wählen:

Abbildung 3.1: Registerkarten zur Wahl des Ansichtsmodus

Siehe auch:


Layout

Im Layout-Modus sehen Sie lediglich die Objektrahmen und den Inhalt der Objekte als Formeln.


Layout-Vorschau

Die Layout-Vorschau zeigt die Objekte in WYSIWYG-Ansicht. Zudem werden die Objekte transparent, in der Farbe der Ebene, der Sie zugeordnet sind, gezeichnet.

In den Projektoptionen (Datei (Projekt) > Optionen > Vorschau) Sie verschiedene Voreinstellungen des Vorschaufensters bestimmen:

§ Farben für Vorschau einstellen: Im Bereich "Farben" können Sie über die beiden Comboboxen die Farbe für den Hintergrund und die des simulierten Papierrands bestimmen.

§ Anzeige bei Etiketten / Karteikarten: Bei Etiketten oder Karteikartenprojekten können Sie über die Option "Seiten-Vorschau" bestimmen, ob in der Vorschau jeweils nur ein einzelnes Etikett oder die komplette Seite angezeigt werden soll.

§ Darstellung optimieren: Unter der Rubrik "Ausgabeoptimierungen" können Sie verschiedene Details der Vorschau ausblenden um die Anzeige zu beschleunigen.

§ Objekte in der Layout-Vorschau farblich markieren (entsprechend der Farbe der zugeordneten Ebene).


Echtdatenvorschau

Die Anzeige im Vorschaumodus ist eine Echtdatenvorschau, sofern dies von der Anwendung unterstützt wird. Auf diese Weise können Sie das Layout eines Druckes überprüfen, ohne dafür Papier verschwenden zu müssen. Sie können nach erfolgter Layout-Kontrolle den eigentlichen Druck auch direkt aus der Vorschau starten.

In den Projektoptionen (Datei (Projekt) > Optionen > Vorschau) sie die maximale Zahl der Seiten angeben, die in der Echtdatenvorschau angezeigt werden sollen.

Abbildung 3.2: Echtdatenvorschau im Designer

Weitere Informationen finden Sie unter Echtdatenvorschau im Kapitel Ausgabemöglichkeiten.


Allgemeine Arbeitsweise

Siehe auch:

Seitenlayout wählen

Ansicht vergrößern

Statuszeile

Menüband

Mini-Symbolleiste

Voreinstellung für Schrift und Rahmen

Rückgängigmachen oder Wiederherstellen einer Aktion

Format übertragen

Variablen-/Feldliste und Drag & Drop


Seitenlayout wählen

Zuallererst sollte in einem neuen Projekt das gewünschte Seitenlayout eingerichtet werden. Wählen Sie Projekt > Layout-Bereiche (Projekt > Seitenlayout) um Eigenschaften wie Druckerauswahl, Papiergröße und Ausrichtung festzulegen.

Sofern mehrere Layoutbereiche definiert sind, kann der aktive Arbeitsbereich über die Projekt-Eigenschaft "Aktiver Design-Bereich" ausgewählt werden.


Ansicht vergrößern

Über die Schaltflächen "Bereich wählen", "100%", "Vergrößern" und "Verkleinern" können Sie die Ansicht im Arbeitsbereich anpassen. Über den Zoomregler in der Statuszeile können sie im Bereich 50% - 500% stufenlos verkleinern und vergrößern.

Bei aktivierter Funktion "Bereich wählen" ziehen Sie den gewünschten Ansichtsbereich mit gedrückter linker Maustaste auf. Wählen Sie dazu Start > Bereich wählen (Toolbar Objekte > Ansicht vergrößern).

Abbildung 3.3: Registerkarte "Start"


Statuszeile

Die Statuszeile ist in drei Abschnitte aufgeteilt.

Abbildung 3.4: Statuszeile

§ Momentane Mauszeigerposition von oben links.

§ Aktiver Arbeitsschritt (z.B. Selektieren).

§ Name, Position oben links, Position unten rechts, Breite, Höhe und Ebene des selektierten Objekts.

§ Zoomregler für Arbeitsbereich und Vorschau.


Menüband

Das Menüband enthält Registerkarten, auf die Sie klicken, um zu den Befehlen zu gelangen. Die Befehle sind danach angeordnet, wie sie verwendet werden.

Häufig verwendete Befehle stehen Ihnen schnell zur Verfügung, weniger häufig verwendete Befehle sind im Menüband weniger hervorstechend angeordnet.

Hinweis: Alternativ stehen Ihnen ein klassisches Menü und Symbolleisten zur Verfügung. Sie können die Art der Anzeige in den Projektoptionen (Datei (Projekt) > Optionen > Arbeitsbereich) wählen.

Abbildung 3.5: Das Menüband

Einige andere Befehle werden erst als Reaktion auf eine ausgeführte Aktion angezeigt, wenn Sie sie möglicherweise benötigen.

Siehe auch:

Texttools

Tabellentools

Zeichentools

Minimieren des Menübands

Datei-Menü im Menüband

Symbolleiste für den Schnellzugriff


Texttools

Wenn Sie ein Textobjekt eingefügt haben, werden die Texttools sowie die Registerkarte Text angezeigt. Die Registerkarte enthält die Befehle, die Sie zum Arbeiten mit Textobjekten benötigen.

Abbildung 3.6: Registerkarte "Text"

Über die Texttools können Sie u.a. Schriftarten, Schriftschnitte, Schriftgrade, Ausrichtungen, Textfarben und Formatierungen anwenden, den Objekt-Dialog öffnen, Absatz anhängen/einfügen, Absätze nach unten/oben verschieben.

§ Um einen ganzen Absatz zu selektieren, klicken Sie auf die Leiste auf der linken Seite. Halten Sie die Strg-Taste bzw. Umschalt-Taste gedrückt um mehrere Absätze bzw. einen ganzen Bereich zu selektieren.

Abbildung 3.7: Absatz selektieren


Tabellentools

Wenn Sie eine Tabelle eingefügt haben, werden die Tabellentools sowie die Registerkarte Tabelle angezeigt. Die Registerkarte enthält die Befehle, die Sie zum Arbeiten mit Tabellenobjekten benötigen.

Abbildung 3.8: Registerkarte "Tabelle"

Über die Tabellentools können Sie u.a. eine neue Zeile definieren, eine neue Spalte einfügen, markierte Spalten/Zellen nach links/rechts verschieben, Rahmen definieren, Schriftarten, Schriftgrade, Ausrichtungen, Textfarben und Formatierungen anwenden.

§ Sie können die Breite der Spalte manuell anpassen, indem Sie mit der Maus die Rahmenlinie nach rechts oder links verschieben. Bei aktivierter Option "Breite einzeln ändern" ist eine Änderung der Breite von Tabellenspalten auf Kosten der Folgespalte möglich, d.h. die Folgespalte wird entsprechend kleiner.

§ Um eine ganze Zeile zu selektieren, klicken Sie auf die Leiste auf der linken Seite. Halten Sie die Strg-Taste bzw. Umschalt-Taste gedrückt um mehrere Absätze bzw. einen ganzen Bereich zu selektieren.

Abbildung 3.9: Zeile selektieren

§ Um eine Zelle zu selektieren klicken Sie in die linke obere Ecke der Zelle. Halten Sie die Strg-Taste bzw. Umschalt-Taste gedrückt um mehrere Zellen bzw. einen ganzen Bereich zu selektieren.

Abbildung 3.10: Zelle selektieren

§ Um eine ganze Spalte zu selektieren halten Sie die Alt-Taste gedrückt. Halten Sie die Strg-Taste bzw. Umschalt-Taste gedrückt um mehrere Spalten bzw. einen ganzen Bereich zu selektieren.

Abbildung 3.11: Spalte selektieren


Zeichentools

Wenn Sie ein Zeichnungsobjekt (Linie, Rechteck, Ellipse) eingefügt haben, werden die Zeichentools sowie die Registerkarte Design angezeigt. Die Registerkarte enthält die Befehle, die Sie zum Arbeiten mit Zeichenobjekten benötigen (u.a. Strichdicke, Konturfarbe).

Abbildung 3.12: Registerkarte "Design"


Minimieren des Menübands

Das Menüband kann minimiert werden, um mehr Platz auf dem Bildschirm verfügbar zu machen.

§ Klicken Sie mit der rechten Maustaste auf das Menüband, und klicken Sie dann auf "Menüband minimieren".

§ Sie können das Menüband schnell minimieren, indem Sie auf den Namen der aktiven Registerkarte doppelklicken. Doppelklicken Sie erneut auf die Registerkarte, um das Menüband wiederherzustellen.

§ Drücken Sie Strg+F1, um das Menüband zu minimieren oder wiederherzustellen.

Sie können das Menüband verwenden, während es minimiert ist, indem Sie zuerst auf die gewünschte Registerkarte und dann auf die gewünschte Option bzw. den gewünschten Befehl klicken.


Datei-Menü im Menüband

Über die blaue Schaltfläche links oben gelangen Sie in das Datei-Menü. Hier finden Sie Befehle zum Speichern und Verwenden des Druckprojekts und die Projektoptionen.

Abbildung 3.13: Menü "Datei"


Symbolleiste für den Schnellzugriff

Wenn Sie häufig Befehle verwenden, die nicht so schnell zur Verfügung stehen, wie Sie möchten, können Sie sie der Symbolleiste für den Schnellzugriff hinzufügen. Diese befindet sich über dem Menüband. Die Befehle auf dieser Symbolleiste sind immer sichtbar und griffbereit.

Abbildung 3.14: Symbolleiste für den Schnellzugriff

Um einen Befehl der Symbolleiste für den Schnellzugriff hinzuzufügen, klicken Sie mit der rechten Maustaste auf den Befehl und wählen dann "Zur Symbolleiste für den Schnellzugriff hinzufügen". Zum Löschen einer Schaltfläche klicken Sie mit der rechten Maustaste auf die Schaltfläche, und klicken Sie dann auf "Aus Symbolleiste für den Schnellzugriff entfernen".


Mini-Symbolleiste

Wenn Sie ein Textobjekt oder Tabellenobjekt selektieren, wird eine praktische Symbolleiste im Miniformat anzeigen.

Hinweis: Die Mini-Symbolleiste ist vor allem dann sinnvoll, wenn Sie anstatt dem Menüband das klassisches Menü und Symbolleisten verwenden. Sie können die Art der Anzeige in den Projektoptionen (Datei (Projekt) > Optionen > Arbeitsbereich) wählen. Bei Verwendung des Menübands werden die Funktionen der Mini-Symbolleiste in den Registerkarten "Texttools" und "Tabellentools" angezeigt.

§ Über die Mini-Symbolleiste können Sie z.B. Schriftarten, Schriftschnitte, Schriftgrade, Ausrichtungen, Textfarben und Formatierungen anwenden und den Objekt-Dialog öffnen. Eine detaillierte Beschreibung der Funktionen siehe Abschnitt Menüband.

Abbildung 3.15: Mini-Symbolleiste bei Textobjekten

§ Diese Mini-Symbolleiste kann mit ESC geschlossen werden. Über die Projektoption "Mini-Symbolleisten anzeigen" (Datei (Projekt) > Optionen > Arbeitsbereich) kann die Anzeige dauerhaft unterdrückt werden.


Voreinstellung für Schrift und Rahmen

Öffnen Sie die Projektoptionen (Datei (Projekt) > Optionen) und wechseln Sie auf die Registerkarte "Objekte".

§ Unter der Rubrik "Objektschriftart" können Sie über die Schaltfläche "Wählen" bestimmen, welche Schriftart als Voreinstellung für Objekte gelten soll.

§ Unter der Rubrik "Farb-Voreinstellungen" können Sie den Rahmen und die Füllung von Objekten voreinstellen.

Standardmäßig ist in den jeweiligen Objekt-Eigenschaften (z.B. Schrift.Größe, Schrift.Fett, Schrift.Farbe) die "Voreinstellung" aktiv. Eine im Nachhinein veränderte Voreinstellung wirkt sich also auf alle Eigenschaften aus, bei denen die Schriftart nicht manuell geändert wurde. Um die Schriftart gegenüber der Voreinstellung um 2pt zu vergrößern, wählen Sie „+2“ als Wert für die Größe, entsprechend „-2“ um die Schrift um 2pt zu verkleinern.

Es empfiehlt sich, zu Beginn eines neuen Projektes diese Voreinstellungen auf geeignete Werte zu setzen, damit der Aufwand für manuelle Anpassungen auf ein Minimum beschränkt bleibt. Die Voreinstellungen gelten nur für das aktuelle Projekt.


Rückgängigmachen oder Wiederherstellen einer Aktion

Sie können Aktionen rückgängig machen oder wiederherstellen.

Siehe auch:


Rückgängigmachen einer Aktion

Drücken Sie so oft strg+z (Alt+Rück), bis Sie Ihren Fehler korrigiert haben. Wenn Sie lieber mit der Maus arbeiten, klicken Sie oben links auf der Symbolleiste für den Schnellzugriff auf Rückgängig.

Einige Aktionen können Sie nicht rückgängig machen, wie beispielsweise Befehle im Datei-Menü oder Speichern einer Datei.


Wiederherstellen einer Aktion

Zum Wiederherstellen einer rückgängig gemachten Aktion drücken Sie Strg+Y oder F4. Sie können aber auch auf der Symbolleiste für den Schnellzugriff auf Wiederherstellen klicken.


Format übertragen

Sie können Formatierungen kopieren und an einer anderen Stelle anwenden.

1. Selektieren Sie das Objekt oder das Berichtscontainer-Element (z.B. indem Sie auf die Leiste auf der linken Seite des Berichtscontainers klicken).

In Tabellen können sie auch einzelne Zellen selektieren.

Abbildung 3.16: Zelle einer Tabelle selektieren

In Kreuztabellen können Sie ebenfalls einzelne Zellen selektieren. Öffnen Sie dazu in die Eigenschaften der Kreuztabelle und wechseln Sie auf die Registerkarte "Zellendefinition".

Abbildung 3.17: Zelle einer Kreuztabelle selektieren

2. Klicken Sie im Menüband "Start" auf "Format übertragen" (Bearbeiten > Format übertragen). In Kreuztabellen finden Sie diese Schaltfläche auf der Registerkarte "Zellendefinition" in der rechten oberen Ecke. Der Mauszeiger verwandelt sich in ein Pinselsymbol.

3. Klicken Sie auf das Objekt, die Zelle oder das Element, auf das die Formatierung angewendet werden soll.

Abbildung 3.18: Format übertragen auf ein Diagramm

4. Wenn Sie die Formatierung auf mehr als eine Zelle, ein Objekt oder Element übertragen möchten, doppelklicken Sie auf "Format übertragen". Um die Funktion zu beenden, klicken Sie erneut auf diese Schaltfläche oder drücken Sie Esc.


Variablen-/Feldliste und Drag & Drop

Die Variablen-/Feldliste (Projekt > Variablen/Felder) zeigt alle im aktuellen Projekt verfügbaren Variablen und Felder an und unterstützt Drag & Drop der Variablen und Felder.

§ Wenn Sie Variablen in einen leeren Bereich ziehen wird ein Absatz in einem neuen Textobjekt erzeugt.

§ Wenn Sie Variablen in ein bestehendes Textobjekt ziehen, kann die Variable entweder in einen bestehenden Absatz angefügt werden oder es kann ein neuer Absatz erzeugt werden.

§ Wenn Sie Felder in einen bestehenden Berichtscontainer ziehen, wird eine neue Tabelle erzeugt.

§ Wenn Sie in Tabellen für bestehende Zeilen weitere Spalten einfügen möchten, können Sie die gewünschten Felder einfach aus der Liste an die entsprechende Stelle mit der Maus ziehen. Das Feld kann dabei links oder rechts einer bestehenden Spalte eingefügt werden, ein Symbol zeigt die Einfügeposition grafisch an. Die Spalte (Standardbreite 30mm) wird dabei in der entsprechenden Zeile eingefügt. Beachten Sie, dass dadurch auch Spalten im nicht-sichtbaren Bereich erzeugt werden können.

§ Bei numerischen Feldern wird dabei automatisch eine Fußzeile mit Summen erzeugt. Wenn Sie die Strg-Taste gedrückt halten, wird keine Fußzeile erstellt.

§ Wenn Sie mehrere Felder selektieren, wird die Reihenfolge der Selektion gemerkt und die Felder in der entsprechenden Reihenfolge platziert.

§ Wenn Sie Felder in einen leeren Bereich ziehen wird eine neue Tabelle in einem neuen Berichtscontainer erzeugt.

§ Wenn Sie Felder in einen bestehenden Berichtscontainer ziehen, wird eine neue Tabelle erzeugt.

§ Wenn Sie Felder aus einer relational verknüpften Tabelle auf eine bestehende Tabelle ziehen (z.B. Felder aus "Orders" auf die Tabelle "Customers"), wird eine neue Untertabelle erzeugt.


Objekte einfügen und anordnen

Objekte sind die Bausteine Ihrer Projekte. Sie werden im Arbeitsbereich generiert und dort von einem Rahmen umgeben, über den Größe und Position verändert werden kann. Dieser Rahmen definiert den Platz, den das Objekt einnimmt und damit auch die maximale Ausdehnung, die der jeweilige Inhalt eines Objektes annehmen kann. Objekte dürfen sich ganz oder teilweise überlagern.

Siehe auch:

Objekte einfügen

Größe und Position von Objekten

Objekte anordnen (Druckreihenfolge)

Objekte gruppieren

Objekte kopieren

Objekte importieren


Objekte einfügen

Objekte können auf verschiedene Weisen auf dem Arbeitsbereich eingefügt werden: über die Registerkarte "Einfügen" (Objekte > Einfügen), über Kurztasten oder per Drag & Drop aus der Variablen-/Feldliste. Textobjekte fügen Sie am bequemsten und zugleich effizientesten per Drag & Drop aus der Variablen-/Feldliste ein. Wählen Sie einfach die gewünschte Variable aus und ziehen Sie diese auf einen leeren Teil des Arbeitsbereichs. Alle anderen Objekttypen fügen Sie am einfachsten über die Toolleiste mit der Maus ein.

1. Wählen Sie den gewünschten Objekt-Typ. Der Mauszeiger verwandelt sich in ein Kreuz.

2. Zeigen Sie mit dem Mauszeiger auf den Punkt, an dem eine Ecke des Objektes beginnen soll. Am besten wählen Sie hierzu die linke obere Ecke des geplanten Objekts.

3. Drücken Sie den linken Mausbutton und ziehen Sie – bei gedrücktem Mausbutton – den Mauszeiger zur diagonal gegenüberliegenden Ecke des geplanten Objektes. Haben Sie mit der linken oberen Ecke begonnen, ziehen Sie den Mauszeiger zur rechten unteren Ecke des geplanten Objekts.

4. Während Sie ziehen, erscheint ein gestrichelter Rahmen von der Größe, die das Objekt annehmen würde, wenn Sie jetzt die Maustaste loslassen würden.

5. Lassen Sie den Mausbutton los, wenn das Objekt (der gestrichelte Rahmen) die gewünschte Größe hat.


Größe und Position von Objekten

Sie können jedes selektierte Objekt verschieben oder in der Größe verändern. Wenn mehrere Objekte selektiert sind, können diese wie ein einzelnes Objekt verändert werden.

§ Größe ändern mit der Maus: Selektieren Sie das Objekt. Wenn der Mauszeiger sich über dem Rahmen befindet kann die Größe verändert werden, indem bei gedrückter linker Maustaste der Rahmen in eine der beiden Pfeilrichtungen gezogen wird. Die Abmessungen des Objekts werden während der Größenänderung angezeigt. Um das Objekt gleichzeitig sowohl horizontal als auch vertikal zu verändern, muss sich der Mauszeiger auf einer Ecke des Rahmens befinden.

§ Verschieben mit der Maus: Selektieren Sie das Objekt. Halten Sie die Maustaste gedrückt und ziehen Sie das Objekt an die gewünschte Position. Wenn die Umschalt-Taste gedrückt wird, können Objekte nur horizontal oder vertikal verschoben werden. Die Ausrichtung bleibt erhalten.

§ Größe ändern und Verschieben per Dialog: Sie können Größe und Position eines Objektes auch über die Eigenschaftsliste verändern, dort lassen sich die Werte genau angeben. Wenn Sie in der Eigenschaftsliste auf die Unterrubrik "Position" doppelklicken, dann öffnet sich ein Positionsdialog, der es nochmals vereinfacht, die Größe und Position eines Objekts per Tastatureingabe näher zu bestimmen.

§ Objekte verschieben und Größe verändern mit der Tastatur: Selektieren Sie das Objekt. Benutzen Sie die Richtungs-Tasten, um das Objekt in die entsprechende Richtung zu verschieben. Ein Tastendruck verschiebt um die kleinstmögliche Einheit; wenn die Umschalt-Taste zusätzlich gedrückt ist, wird das Objekt jeweils um das zehnfache der kleinstmöglichen Einheit verschoben.


Objekte anordnen (Druckreihenfolge)

Objekte auf dem Arbeitsbereich können sich gegenseitig verdecken und dabei mehrere Lagen oder Schichten bilden. Über die Registerkarte "Start" (Objekte > Anordnen) bzw. das entsprechende Kontextmenü können Sie Objekte von einer Schicht in eine andere verschieben (Nach vorne, In den Vordergrund, Nach hinten, In den Hintergrund).

Hinweis: Bitte beachten Sie, dass diese Form der Schichtung auf dem Arbeitsbereich nichts mit den unter Arbeiten mit Darstellungsebenen beschriebenen Darstellungsebenen zu tun hat. Über "Anordnen" ändert sich lediglich die Position in der Objektliste, es ändert sich nicht die Zuordnung zu einer Darstellungsebene.

Das oberste Objekt in der Objektliste ist das Objekt im Hintergrund, das unterste/letzte Objekt in der Objektliste das Objekt im Vordergrund.

Abbildung 3.19: Druckreihenfolge in der Objektliste


Objekte gruppieren

Mehrere, zusammengehörige Objekte können zu einer Gruppe zusammengefasst und dann wie ein einzelnes Objekt angesprochen werden.

§ Um zwei oder mehr Objekte zu einer Gruppe zusammenzufassen, selektieren Sie die betreffenden Objekte und wählen dann Gruppierung erstellen im Kontextmenü oder den entsprechenden Befehl "Gruppierung" auf der Registerkarte "Start" (Objekte > Gruppierung erstellen).

§ Um ein gruppiertes Objekt zu bearbeiten halten Sie beim Selektieren die ALT-Taste gedrückt.

§ Um eine Gruppierung wieder rückgängig zu machen, wählen Sie den Befehl Gruppierung lösen/aufheben.

Bitte beachten Sie, dass ein Objekt jeweils nur Mitglied einer Gruppe sein kann. Es ist daher nicht möglich, Gruppen wiederum zu übergeordneten Gruppen zusammenzufassen.


Objekte kopieren

Sie können Objekte einzeln oder mehrfach kopieren.

Siehe auch:


Kopieren eines Objekts

1. Selektieren Sie das Objekt das Sie kopieren möchten, und drücken Sie Strg+C (Start > Kopieren). Sie können auch Strg+X drücken, um das Objekt auszuschneiden.

2. Bewegen Sie die Maus an die Stelle, an der Sie das Element einfügen möchten und drücken Sie Strg+V (Start > Einfügen). Sie können auch den Befehl "Einfügen" im Kontextmenü klicken.


Mehrfachkopien

Wenn Sie mehrere, gleichartige Objekte mit gleichen Abständen auf dem Arbeitsbereich anordnen wollen, selektieren Sie das betreffende Objekt und wählen dann Mehrfachkopien erstellen im Kontextmenü oder den entsprechenden Befehl "Mehrfachkopie" auf der Registerkarte "Start" (Objekte > Einfügen > Mehrfachkopien). Über einen Dialog definieren Sie die Anzahl und Abstände der Objekte horizontal und vertikal.


Objekte importieren

Über Datei > Importieren können Sie eine Kopie aller Objekte eines anderen Projekts zum momentan geladenen Projekt hinzufügen.


Objekte ausrichten

Sie haben verschiedene Möglichkeiten Objekte auszurichten.

Siehe auch:


Ausrichtungsgitter anzeigen

Über Projekt > Gitternetzlinien (Projekt > Optionen > Projekt) können Sie ein Gitter für die Objektausrichtung anzeigen.

Die Eigenschaften der Gitternetzlinien können über die Projektoptionen (Datei (Projekt) > Optionen > Projekt) bestimmt werden. Dabei können Sie angeben, welche Abstände die Gitterlinien jeweils haben sollen. Die Option "horiz./vertikal synchron" erzwingt gleiche Gitterabstände in beiden Richtungen.


Objekte ausrichten

Über die Registerkarte "Start" stehen in der Gruppe "Anordnen" (Objekte > Anordnen > Ausrichtung) Ausrichtungsfunktionen zur Verfügung, um mehrere Objekte aneinander ausrichten. Es müssen mindestens 2 Objekte markiert sein, damit die Funktionen verfügbar sind.

Abbildung 3.20: Symbolleiste für die Ausrichtungsfunktionen

§ Linksbündig, Rechtsbündig, Oben ausrichten, Unten ausrichten: Die selektierten Objekte werden an der gemeinsamen Rahmenkante ausgerichtet.

§ Zentriert: Die selektierten Objekte werden in der jeweiligen Dimension (horizontal oder vertikal) innerhalb der gemeinsamen Rahmenkante zentriert.

§ Größenanpassung: Die selektierten Objekte werden in der jeweiligen Dimension (horizontal oder vertikal) auf die gemeinsame Rahmengröße gezogen.

§ Konstante Zwischenräume: Zwischen den Rändern der selektierten Objekte werden konstante Abstände eingestellt. Maßgeblich sind dabei auch hier die jeweils am weitesten außen liegenden Kanten. Aus Ihnen wird der durchschnittliche Zwischenraum ermittelt und die Objekte entsprechend angeordnet. Falls sich die selektierten Objekte überlagern, d.h. negative Zwischenräume haben, werden die Objekte durch diese Ausrichtung nicht auseinandergeschoben sondern lediglich der Überlappungsgrad auf den Durchschnittswert gesetzt.

§ Konstante Abstände: Zwischen den Zentren der selektierten Objekte werden konstante Abstände eingestellt. Dabei wird aus den Abständen der Zentren der Durchschnittswert errechnet und die Objekte werden entsprechend angeordnet. Falls sich die selektierten Objekte überlagern, werden die Objekte durch diese Ausrichtung nicht auseinandergeschoben sondern lediglich der Überlappungsgrad auf den Durchschnittswert gesetzt.


Hilfslinien im Arbeitsbereich

Sie können horizontale und vertikale Hilfslinien anlegen. Dazu drücken Sie die Maus innerhalb eines Lineals und lassen sie im Arbeitsbereich wieder los. Über den sich dann öffnenden Positionsdialog können Sie die exakte Position angeben. Die neue Hilfslinie hat dieselbe Ausrichtung wie das vorher ausgewählte Lineal. Die Hilfslinien lassen sich nachträglich verschieben.

Eine Fang-Funktion hilft, Objekte genau auf die Hilfslinien zu legen. Die Objekte werden dadurch nicht dauerhaft mit der Hilfslinie verbunden, diese helfen lediglich bei der Positionierung von Objekten.

Wenn Sie die Strg-Taste beim Verschieben der Hilfslinie gedrückt halten, werden die mit der Hilfslinie verbundenen Objekte mitverschoben.

Die Optionen zu Hilfslinien werden über ein Kontextmenü definiert, das Sie über Rechtsklick auf eine Fanglinie erreichen. Damit können Sie für jede Hilfslinie einen Fangbereich in Pixel wählen. Wenn Sie der Hilfslinie dann so nahe kommen, dass Sie nur noch diese Anzahl von Pixel von ihr entfernt sind, wird das Objekt auf die Hilfslinie gezogen. Wenn beim Arbeiten mit Objekten die Strg-Taste gedrückt wird, ist die Fangfunktion generell ausgeschaltet.

Wenn Sie neue Objekte im Arbeitsbereich aufziehen, muss die linke obere Ecke an die Hilfslinie gesetzt werden, damit das Objekt mit der Hilfslinie verbunden wird.

Abbildung 3.21: Kontextmenü für die Hilfslinie

Sie können Hilfslinien unverschiebbar machen, so dass Sie diese nicht versehentlich im Arbeitsbereich verschieben und Sie können die Position der Hilfslinie direkt angeben.


Projektoptionen

In den Projektoptionen (Datei (Projekt) > Optionen) können Sie verschiedene Voreinstellungen für das Projekt, für Objekte, die Vorschau und den Arbeitsbereich bestimmen.

Siehe auch:

Optionen für das Projekt

Voreinstellungen für Schrift und Rahmen

Vorschau

Optionen für den Arbeitsbereich


Optionen für das Projekt

Unter Datei > Optionen > Projekt (Projekt > Optionen > Projekt) finden Sie verschiedene Voreinstellungen.

§ Ausrichtungsgitter definieren: Siehe Objekte ausrichten in Kapitel Effektive Techniken im Arbeitsbereich.

§ Anzahl der Dezimalstellen: Hier können Sie die Anzahl von Dezimalstellen für Zahlenwerte bestimmen. Sobald Sie Zahlenwerte in Text umwandeln, wird der Wert automatisch auf die hier angegebene Anzahl Dezimalstellen gerundet, sofern der Wert nicht explizit über die Funktion Fstr$() formatiert wird.

§ Maximale Verzeichnistiefe für Inhaltsverzeichnis und Index. Siehe auch Inhaltsverzeichnis und Index in Kapitel Seitenlayout.


Voreinstellungen für Schrift und Rahmen

Unter Datei > Optionen > Objekte (Projekt > Optionen > Objekte) finden Sie die Voreinstellungen für Objektschriftart, Rahmenfarbe und Füllungsfarbe. Weitere Informationen siehe Voreinstellung für Schrift und Rahmen in Kapitel Effektive Techniken im Arbeitsbereich.


Vorschau

Unter Datei > Optionen > Vorschau (Projekt > Optionen > Vorschau) finden Sie die Voreinstellungen für die Vorschau. Weitere Informationen siehe Ansichtsmodus in Kapitel Effektive Techniken im Arbeitsbereich.


Optionen für den Arbeitsbereich

Der Arbeitsbereich kann über Datei > Optionen > Arbeitsbereich (Projekt > Optionen > Arbeitsbereich) durch verschiedene Optionen angepasst werden.

Siehe auch:

Schriftart für Formelassistent

Vorgaben für die Bedienung

Spaltenbreitenveränderung über Maus

AutoWiederherstellen


Schriftart für Formelassistent

Hier kann die im Formelassistent verwendete Schriftart eingestellt werden. Somit können Sie die Standardschriftart z.B. zu einer nichtproportionalen Schriftart (Consolas etc.) ändern, um das Schreiben komplexer Ausdrücke zu erleichtern.


Vorgaben für die Bedienung

In der Rubrik "Bedienung" können Sie verschiedene Voreinstellungen festlegen.

§ Über die Option "Objekt-Info" kann die Bezeichnung des Objektes, auf dem der Mauscursor gerade steht, in einem Tooltip angezeigt werden.

§ "Assistent für Neuanlage": Sofern diese Option eingeschaltet ist, hilft Ihnen ein übersichtlicher Assistent bei der Neuanlage aller Projekttypen.

§ Selektionsmodus nach Einfügen eines Objekts: Über diese Option können Sie wählen, ob nach der Anlage eines Objektes automatisch der Selektionsmodus aktiviert werden soll. Dies verhindert z.B., dass Sie unbeabsichtigt weitere Objekte einfügen. Ansonsten können Sie mehrere Objekte des gleichen Typs ohne weitere Auswahl hintereinander generieren.

§ Menüband benutzen: Bei deaktivierter Option wird eine Symbolleiste angezeigt. Siehe dazu auch Menüband im Kapitel Effektive Techniken im Arbeitsbereich.

§ Mini-Symbolleisten anzeigen: Wenn Sie ein Textobjekt oder Tabellenobjekt selektieren, wird eine praktische Symbolleiste im Miniformat angezeigt. Siehe dazu auch Mini-Symbolleiste im Kapitel Effektive Techniken im Arbeitsbereich.

§ Meldungen reaktivieren: Deaktivierte Meldungen werden wieder aktiviert.

§ Eigenschaftslisten: Sie können wählen, ob die Zustände der Eigenschaftslisten permanent gespeichert, beim Beenden des Designers gelöscht oder nicht gespeichert werden sollen.


Spaltenbreitenveränderung über Maus

Die Breite eines Feldes bzw. einer ganzen Spalte kann präzise über die Eigenschaft "Breite" angegeben werden. Sie können die Breite aber auch direkt im Arbeitsbereich mit der Maus ändern, indem Sie dort das gewünschte Tabellenobjekt markieren und die rechte Begrenzungslinie einer Spalte entsprechend verschieben. Dies verändert alle Tabellenspalten, deren Separatoren innerhalb eines +/-2mm-Intervalls von der Mausposition sind.

§ Bei gedrückter Strg-Taste wird die Aktion nur für die Linie, auf der sich die Maus befindet, durchgeführt.

§ Bei nicht gedrückter Shift-Taste, wird die Linie an einen Separatoren-Tickmark gezogen, wenn sie sich innerhalb eines 10-Pixel-Intervalls von ihm befindet. Shift schaltet diese Option aus.

§ Mit der Option "Größenveränderung verändert nächste Spalte" ist eine Änderung der Breite von Tabellenspalten auf Kosten der Folgespalte möglich, d.h. die Folgespalte wird entsprechend kleiner.

§ Deaktivieren Sie "Nur sichtbare Zeilen bearbeiten" wenn auch die Spaltenbreiten verändert werden sollen, die gerade nicht sichtbar sind.


AutoWiederherstellen

Es kann vorkommen, dass ein Projekt nicht ordnungsgemäß beendet wurde und Sie Änderungen nicht speichern konnten. Ursache kann z.B. ein Stromausfall oder ein Fehler in der Anwendung sein.

Mithilfe der Option AutoWiederherstellen wird das Projekt beliebig oft automatisch gespeichert. Somit sind die seit dem letzten Speichern vorgenommenen Änderungen zumindest teilweise in der Datei enthalten, je nachdem wie kurz Sie den Zeitraum für das Speichern wählen.

Der Designer erkennt beim Öffnen des Projekts, dass eine Autowiederherstellen-Datei verfügbar ist. Sie können dann entweder die wiederhergestellte Datei unter einem neuen Dateinamen speichern und öffnen oder die die Datei ignorieren und fortfahren.

Abbildung 3.22: Autowiederherstellen-Datei gefunden


Darstellungsbedingungen meistern

In diesem Kapitel betrachten wir das Konzept der Darstellungsbedingungen am Beispiel eines mehrseitigen Standard- bzw. Serienbriefes. Über Darstellungsbedingungen bestimmen Sie, wann Objekte, Elemente, Absätze, Zeilen oder Spalten gedruckt/angezeigt werden.

Außerdem ist es oft hilfreich, inhaltlich zusammengehörige Objekte einer sog. Darstellungsebene zuzuweisen. Für jede Ebene kann eine Darstellungsbedingung definiert werden die bestimmt, unter welchen Bedingungen die Objekte dieser Ebene gedruckt werden sollen.

Siehe auch:

Wo werden Objekte gedruckt?

Arbeiten mit Darstellungsbedingungen

Arbeiten mit Darstellungsebenen

Praxis: Einen Serienbrief erstellen


Wo werden Objekte gedruckt?

Sofern für Objekte keine Darstellungsbedingung definiert ist werden diese auf jeder Seite gedruckt.

Abweichend davon werden Objekte vom Typ Tabelle, Kreuztabelle, Text und Formatierter Text fortlaufend gedruckt, beginnend auf der 1. Seite.

Bei Text und Formatierter Text muss dabei die Eigenschaft "Seitenumbruch" auf "Ja" gesetzt sein.

Eine weitere Seite wird somit automatisch erzeugt, sobald der zur Verfügung stehende Platz im Objekt nicht mehr ausreicht. Sie müssen eine 2. Seite daher nicht extra erzeugen, diese wird automatisch durch ein Objekt vom Typ Tabelle, Kreuztabelle, Text, Formatierter Text oder durch die Projekteigenschaft "Mindestzahl der Druckseiten" erzeugt.


Arbeiten mit Darstellungsbedingungen

Über Filterbedingungen können die auszugebenden Daten genau kontrolliert werden. So lassen sich sowohl für die Darstellung von Datensätzen, als auch für die Darstellung von Objekten Bedingungen angeben.

Bei diesen Bedingungen handelt es sich um logische Ausdrücke, deren Ergebnis darüber entscheidet, ob ein bestimmter Datensatz oder ein bestimmtes Objekt gedruckt wird, oder nicht. Ist der logische Ausdruck wahr (True) wird der Datensatz oder das Objekt gedruckt. Ist der logische Ausdruck falsch (False) wird der Datensatz oder das Objekt nicht gedruckt.

Um dies zu erreichen definieren Sie eine entsprechende "Darstellungsbedingung". Diese finden Sie in den Eigenschaften von Projekten, Ebenen, Objekten, Elementen, Absätzen, Zeilen oder Spalten.

Wenn Sie z.B. in der Fußzeile einer Postentabelle die Zahlungsbedingungen ausgeben möchten, definieren Sie über die Darstellungsbedingung dieser Zeile, dass diese nur auf der letzten Seite ausgeben wird. Sonst wird diese Fußzeile auf jeder Seite am Ende der Tabelle ausgegeben.

Beispiel "nur letzte Seite": Lastpage()

Oder Sie definieren eine Bedingung, dass das Firmenlogo nur ausgegeben wird, wenn der Brief als PDF-Datei erzeugt wird, da beim Druck auf den Drucker das Firmenlogo bereits auf dem Geschäftspapier aufgedruckt ist.

Beispiel "nur bei PDF-Ausgabe": LL.OutputDevice="PDF"

In Darstellungsbedingungen von Tabellen-Fußzeilen können Sie auch einen vordefinierten Wert "Nur letzte Seite" verwenden. Dieser Eintrag verwendet intern die Funktion "Lastpage()" bzw. "LastFooterThisTable()".

In Darstellungsbedingungen von Tabellen-Kopfzeilen können Sie einen vordefinierten Wert "Nur erste Seite" verwenden. Dieser Eintrag verwendet intern die Funktion "not Lastpage()" bzw. "FirstHeaderThisTable()".


Arbeiten mit Darstellungsebenen

Wenn Sie die Darstellungsbedingung für eine Ebene definieren, können Sie in der Folge dieser Ebene Objekte zuordnen. Gerade bei umfangreichen und komplexen Projekten stellt dies eine große Vereinfachung dar, da Sie die einer Ebene zugeordneten Objekte über die Checkbox im Toolfenster "Ebenen" gezielt ein- und ausblenden können.

Damit vermeiden Sie, dass sich die verschiedenen Objekte auf dem Arbeitsbereich überlagern, was das Bearbeiten einzelner Objekte erschweren würde.

Abbildung 4.1: Toolfenster Ebenen

Siehe auch:


Darstellungsebenen definieren

Darstellungsebenen definieren Sie über Projekt > Ebenen (Projekt > Ebenen bearbeiten) oder über Doppelklick in das Toolfenster "Ebenen".

Im Dialog "Ebenen" können über die Schaltfläche "Neu" oder "Kopieren/Einfügen" beliebig viele Ebenen definiert werden. Jede neue Ebene erscheint zunächst unter dem Namen "Ebene". Über das Feld "Name" vergeben Sie einen aussagekräftigen Namen.

§ Beim Anlegen von neuen Projekten werden automatisch die Ebenen "Basis", "Erste Seite" und "Folgeseiten" vorgegeben.

§ Um die verschiedenen Ebenen auf dem Arbeitsbereich besser voneinander unterschieden zu können, ist es empfehlenswert, den Ebenen verschiedene Farben zuzuweisen. Dadurch werden auch die Objekte der jeweiligen Ebenen im Darstellungsmodus Layout-Vorschau in verschiedenen Farben dargestellt. Auf den tatsächlichen Druck hat diese Farbe jedoch keine Auswirkungen.

§ Wenn Sie eine Ebene löschen, werden die zugeordneten Objekte automatisch der Basisebene zugewiesen. Es muss mindestens eine Ebene definiert werden.

§ Neue Objekte werden automatisch der obersten sichtbaren Ebene zugeordnet.

§ Die Funktion Lastpage() kann in Darstellungsbedingungen von Ebenen nur bei Objekten die mit einer Tabelle verkettet sind, korrekt ausgewertet werden.

§ Benutzervariablen dürfen nicht innerhalb von Darstellungsbedingungen von Ebenen verwendet werden.

Abbildung 4.2: Dialog zur Definition der Ebenen

Im Feld "Bedingung" definieren Sie die Darstellungsbedingung für diese Ebene. Diese Darstellungsbedingung bezieht sich dann auf sämtliche Objekte der betreffenden Ebene, d.h. die zugeordneten Objekte werden nur gedruckt, wenn die Bedingung der Ebene zutrifft.

Typische Darstellungsbedingungen:

Bedingung | Erläuterung
keine Bedingung | Die Objekte dieser Ebene werden immer gedruckt.
Page()=1 | Die Objekte dieser Ebene werden nur auf der ersten Seite gedruckt.
Page()<>1 | Die Objekte dieser Ebene werden ab der zweiten Seite gedruckt.


Objekte einer Ebene zuweisen

Nachdem Sie die Ebenen definiert haben, können Sie die Objekte diesen Ebenen zuordnen. Sie haben dabei 2 Möglichkeiten:

1. Um ein oder mehrere Objekte einer Ebene zuzuweisen, selektieren Sie die Objekte im Arbeitsbereich und wählen Ebene zuweisen aus dem Kontextmenü.

Im daraufhin erscheinenden Dialog wählen Sie die gewünschte Ebene aus und bestätigen den Dialog mit OK.

Abbildung 4.3: Dialog zum Zuordnen von Objekten zu einer Ebene

Die zugewiesenen Objekte erhalten auf dem Arbeitsbereich automatisch die Farbe der entsprechenden Ebene, um sie leichter von anderen Objekten unterscheiden zu können. Das betrifft jedoch nur die Darstellung auf dem Arbeitsbereich, nicht den Druck.

2. Alternativ können Objekte auch in eine Ebene hineinkopiert werden. Das ist praktisch, wenn Sie mehrere gleiche Objekte in verschiedenen Ebenen verwenden wollen. Beispiel: Sie erstellen pro Sprache eine Ebene. Dann kopieren Sie alle Objekte in die neue Sprachebene und übersetzen diese.

Dabei bleibt das Objekt in seiner bisherigen Ebene erhalten und eine Kopie des Objekts wird in einer weiteren Ebene angelegt. Wählen Sie dazu In Ebene Kopieren aus dem Kontextmenü eines selektierten Objekts.


Praxis: Einen Serienbrief erstellen

Die grundsätzlichen Arbeitsweisen haben Sie in Kapitel 2 erfahren. In diesem Kapitel sehen Sie nun weitere Funktionen und Möglichkeiten des Berichtdesigns am Beispiel eines Serienbriefes bzw. Standardbriefes. Im Unterschied zu den bisherigen Beispielen verwenden Sie hier das Formatierte Textobjekt für den Serienbrieftext und ändern ab der zweiten Seite die Position dieses Objektes.

Siehe auch:

Eine neue Druckvorlage erstellen

Firmenlogo einfügen

Anschriftenfeld einfügen

Datum und Seitenzahl einfügen

Formatierten Brieftext einfügen

Position des Brieftextes für die Folgeseiten anpassen

Die Objekte den Darstellungsebenen zuordnen


Eine neue Druckvorlage erstellen

1. Starten Sie den Designer.

2. Daraufhin erscheint ein Dateiauswahldialog. Um ein neues Projekt zu beginnen, wählen Sie die Schaltfläche Neu.

Hinweis: In Windows XP steht diese Schaltfläche nicht zur Verfügung. Hier geben Sie im Feld "Dateiname" einen Namen für die neue Druckvorlage an und wählen dann "Öffnen".


Firmenlogo einfügen

Um ein Logo einzufügen verwenden Sie das Bildobjekt.

1. Wählen Sie Einfügen > Bild (Objekte > Einfügen > Bild).

Abbildung 4.4: Registerkarte "Einfügen"

2. Ziehen Sie das Objekt auf die gewünschte Größe auf und wählen Sie eine Bilddatei aus (siehe Kapitel Ein Firmenlogo in den Bericht einfügen).

3. Das Firmenlogo soll aber nur bei der PDF-Ausgabe gedruckt werden. Beim Druck auf den Drucker soll das Logo nicht gedruckt werden. D.h. Sie selektieren das Bildobjekt und geben in der Objekteigenschaft "Darstellungsbedingung" die logische Bedingung "LL.OutputDevice = "PDF"" an.

Siehe auch Kapitel Übersicht der LL-Variablen und LL-Felder.


Anschriftenfeld einfügen

Um eine Anschrift einzufügen verwenden Sie das Textobjekt. Textobjekte dienen dazu, einen beliebigen Text oder Feldinhalte auf dem Arbeitsbereich zu platzieren.

Text bearbeiten (6)

Abbildung 4.5: Anschriftenfeld: So soll es aussehen.

1. Wählen Sie Einfügen > Text (Objekte > Einfügen > Text).

Abbildung 4.6: Registerkarte "Einfügen"

2. Ziehen Sie das Objekt auf die gewünschte Größe auf.

3. Daraufhin erscheint der Formel-Assistent über den Sie den Inhalt des Textobjekts bestimmen können.

Dieser Dialog besteht aus einer Reihe von Registerkarten. Auf der Registerkarte "Daten und Funktionen" wählen Sie aus der Liste der verfügbaren Variablen und Felder die Variable für die Firmenanschrift aus (Firma).

Über der Variablen-/Feldliste finden Sie ein Autofilter-Feld, d.h. Sie können den Begriff "Firma" eingeben um alle Felder und Variablen mit diesem Begriff im Namen anzuzeigen. Die gewünschte Variable wählen Sie dann per Doppelklick aus und bestätigen die Auswahl mit OK. Somit haben Sie die erste Zeile des Anschriftenfeldes definiert.

Abbildung 4.7: Formel-Assistent mit Variable

4. Ein Textobjekt kann beliebig viele Absätze enthalten, die jeweils ganz unterschiedliche Darstellungseigenschaften haben können. Über die Texttools (Mini-Symbolleiste) können weitere Absätze eingefügt werden. Wählen Sie "Anhängen" (Absatz anhängen) um einen weiteren Absatz zu definieren.

Abbildung 4.8: Registerkarte "Text"

5. Daraufhin erscheint erneut der Formel-Assistent über den Sie den Inhalt des Absatzes bestimmen können. Nun geben Sie Vorname und Nachname des Empfängers an. Wählen Sie zunächst die Variable "Vorname".

6. Bevor Sie nun die Variable "Nachname" auswählen, sollten Sie noch einen Leerschritt einfügen, damit die beiden Variableninhalte nicht direkt hintereinander ausgeben werden. Ein Leerschritt ist nichts anderes als "Text". Fester Text muss mit Anführungszeichen eingerahmt werden. Daher geben Sie nun ein "+" als Verknüpfungsoperator ein und dann " " für den Leerschritt.

7. Anschließend wählen Sie die Variable "Nachname" aus, verknüpft wird diese natürlich auch mit einem "+". Das ganze sieht dann so aus:

Abbildung 4.9: Variablen und Text verknüpfen

8. Weiter geht's mit den übrigen Variablen Straße und Ort. Und damit ist das Anschriftenfeld fertig.

Text bearbeiten (6)

Abbildung 4.10: Textfeld mit 4 Absätzen


Datum und Seitenzahl einfügen

Um ein Briefdatum und die Seitenzahl einzufügen verwenden Sie erneut das Textobjekt.

1. Wählen Sie Einfügen > Text (Objekte > Einfügen > Text).

2. Ziehen Sie das Objekt auf die gewünschte Größe auf.

3. Daraufhin erscheint der Formel-Assistent über den Sie den Inhalt des Textobjekts bestimmen können. Wechseln Sie auf die Registerkarte "Datumsformat".

4. Wählen Sie hier das gewünschte Datumsformat aus. Dabei wird automatisch die Funktion Now() in die Funktion Date$() eingefügt. Damit wird das aktuelle Datum in der gewünschten Formatierung ausgegeben.

5. Anschließend erstellen Sie im Fußbereich ein weiteres Textobjekt für die Seitenzahl. Im Formel-Assistenten geben Sie im Ergebnisbereich direkt die Funktion Page$() für die Ausgabe der Seitenzahl ein.


Formatierten Brieftext einfügen

Den Brieftext geben Sie mit dem Formatierten Textobjekt aus. Mit diesem Objekt können Sie im Gegensatz zum normalen Textobjekt auch Formatierungswechsel innerhalb einer Zeile vornehmen. Ab Windows 8 unterstützt der Dialog die Windows-Rechtschreibprüfung inklusive Korrekturvorschlägen.

1. Wählen Sie Einfügen > Text (Objekte > Einfügen > Text).

Abbildung 4.11: Registerkarte "Einfügen"

2. Ziehen Sie das Objekt auf die gewünschte Größe auf.

3. Daraufhin erscheint ein Dialog über den Sie den Brieftext als fortlaufenden Text schreiben können.

4. Alternativ kann aus der Auswahlliste "Quelle" auch eine Variable im RTF-Format ausgewählt werden sofern eine solche zur Verfügung steht.

Abbildung 4.12: Objekt-Dialog Formatierter Text

Experten-Tipp: Sofern das aktuelle Formatierte Text-Objekt an ein anderes Formatiertes Text-Objekt angehängt ist, bei dem die Option "Seitenumbruch" aktiviert ist, steht die Option "Resttextübernahme von ..." als Quelle zur Verfügung. Wählt man diese Option aus, ist keine Eingabe in dem Formatierten Text-Objekt möglich, da der (Rest-) Text automatisch von dem anderen Formatierten Text-Objekt übernommen wird (z.B. für 2-spaltigen Druck).

5. Über die Formel-Schaltfläche steht Ihnen auch in diesem Dialog der Formel-Assistent zum Einfügen von Variablen zur Verfügung.

Da Sie den Empfänger persönlich ansprechen möchten, erstellen Sie nun die Briefanrede. Dabei beachten Sie bitte, dass am Ende der Anredeformel kein überschüssiges Leerzeichen erzeugt wird, falls das Feld "Name" bei der Briefanrede "Sehr geehrte Damen und Herren" leer sein sollte. Eine Möglichkeit für eine perfekte Formel für die Briefanrede wäre bei Verwendung von Rtrim$() z.B.: «Rtrim$(Empfaenger.BriefAnrede + " " + Empfaenger.Nachname)»,

6. Schreiben Sie nun den Brieftext. Ihnen stehen dabei viele verschiedene Formatierungsoptionen zur Verfügung. Einen Tabulator erzeugen Sie über Strg+Tab.

Alternativ können Sie den Brieftext oder auch Bilder und Grafiken in Ihrer gewohnten Textverarbeitung (z.B. MS Word) erstellen und dann über Strg+C kopieren und in diesem Dialog über strg+V einfügen. Das Layout kann dabei nicht immer 1:1 übernommen werden.

7. Über die Schaltfläche "WYSIWYG" (What You See Is What You Get) wird der Wortumbruch anhand der Objektgröße angezeigt. Dies ist nur ein ungefährer Anhaltspunkt und kann minimal differieren.

8. Der Seitenumbruch wird dabei automatisch erzeugt, wenn der zur Verfügung stehende Platz nicht mehr ausreicht und die Objekt-Eigenschaft "Seitenumbruch" auf "Ja" gesetzt ist. Wenn Sie den Seitenumbruch selbst auslösen möchten, können Sie dies über das Kontextmenü erreichen. Wählen Sie dort das Sonderzeichen Seitenumbruch aus.

Abbildung 4.13: Kontextmenü für benutzerdefinierten Seitenumbruch


Position des Brieftextes für die Folgeseiten anpassen

Damit der Brieftext bei einem mehrseitigen Serienbrief auf der Folgeseite am oberen Blattrand beginnt (auf der ersten Seite beginnt er tiefer wegen der Anschrift), wird die Position (oben, Höhe) des formatierten Text-Objekts mit einer Bedingung gesetzt, die auf den Folgeseiten das Textfeld nach oben verschiebt und in der Höhe vergrößert.

1. Selektieren Sie das formatierte Text-Objekt.

2. Selektieren Sie die Objekt-Eigenschaft "Position.oben" und setzen Sie die Bedingung Cond(Page()=1,100,50)

3. Selektieren Sie die Objekt-Eigenschaft "Position.Höhe" und setzen Sie die Bedingung Cond(Page()=1,170,220)

Abbildung 4.14: Position per Formel bestimmen


Die Objekte den Darstellungsebenen zuordnen

Damit die Objekte für die Anschrift, das Firmenlogo und das Datum nur auf der ersten Seite gedruckt werden, können Sie diese Objekte der entsprechenden Darstellungsebene zuordnen.

1. Selektieren Sie mit gedrückter Strg-Taste die Objekte für die Anschrift, das Firmenlogo und das Datum.

2. Öffnen Sie per Rechtsklick das Kontextmenü und wählen Sie "Ebene zuweisen".

3. Daraufhin erscheint ein Dialog in dem Sie die gewünschte Ebene "Erste Seite" auswählen können. Bestätigen Sie den Dialog mit OK.

4. Die Objekte sind nun der Ebene "Erste Seite" zugeordnet. Sie erkennen dies in der Layout-Vorschau an der grünen Farbe der Objekte, da dieser Ebene diese Farbe zugeordnet wurde.

Abbildung 4.15: Farblich gekennzeichnete Objekte

5. Das Objekt "Formatierter Text" bleibt der Ebene "Basis" zugeordnet damit es auf jeder Seite gedruckt wird!


Professionelle Tabellen erstellen

In diesem Kapitel erweitern wir die bisherigen Beispiele durch weitere Funktionen, geben Daten gruppiert aus, ermöglichen eine mehrseitige Ausgabe durch die Verwendung von Darstellungsbedingungen und Ebenen und fügen weitere Elemente in den Berichtscontainer ein.

Siehe auch:

Arbeiten mit dem Berichtscontainer

Praxis: Unterberichte korrekt definieren

Die Felder und Spalten bearbeiten

Mehrere Zeilenlayouts definieren

Spalteninhalt definieren

Gruppenzeilen definieren

Tabellen in Spalten

Layout bei Tabellen

Sortierungen in der Vorschau


Arbeiten mit dem Berichtscontainer

Um eine Tabelle einzufügen verwenden Sie das Objekt "Berichtscontainer". Ein Berichtscontainer kann – wie der Name schon andeutet – mehrere Elemente enthalten.

Tabellen, Kreuztabellen, Diagramme und Gantt-Diagramme können in beliebiger Abfolge eingefügt werden, auch als Unterelemente von Tabellen. Damit lassen sich Subreports und Unterberichte mit fast beliebigen Relationen zwischen Tabellen definieren.

Zusätzlich zu einem Berichtscontainer kann es beliebig viele weitere Berichtscontainer und zudem auch separate Diagramme, Kreuztabellen oder Gantt-Diagramme geben.

Hinweis: Der Berichtscontainer und die Möglichkeit separate Diagramme, Kreuztabellen oder Gantt-Diagramme einzufügen ist nicht in jeder Anwendung verfügbar. In Anwendungen ohne Berichtscontainer nutzen Sie das Objekt "Tabelle".

Siehe auch:


Berichtscontainer und Objektliste

Neue Elemente sowie die gewünschte hierarchische Struktur definieren Sie direkt im Toolfenster "Objekte".

§ Alle Aktionen sind über ein Kontextmenü erreichbar. Die häufig genutzten Aktionen zusätzlich auch über die Schaltflächen am oberen Rand.

§ Um ein neues Element in den Berichtscontainer einzufügen, wählen Sie die Schaltfläche "Ein Element anhängen" bzw. "Ein Unterelement anhängen". Unterelemente sind nur bei Tabellen möglich.

§ Elemente werden mit der jeweiligen Datenquelle [Relationsname, Sortierungsname] dargestellt.

§ Das jeweils selektierte Element wird im Arbeitsbereich optisch hervorgehoben. Über die Checkboxen können Elemente, Unterelemente und Zweige im Arbeitsbereich gezielt ein- und ausgeblendet werden.

Abbildung 5.1: Toolfenster "Objekte"


Mehrere Berichtscontainer

Auch die Definition von mehreren Berichtscontainern wird unterstützt, damit lassen sich klassische Side-by-Side Berichte erzeugen. Die Datenquellen der Berichtscontainer und deren Elemente können sich dabei unterscheiden.

Abbildung 5.2: Side-by-Side Bericht mit zwei Berichtscontainern


Praxis: Unterberichte korrekt definieren

Nehmen wir an, Sie möchten eine Liste aller Kunden realisieren, in der die Bestellungen des jeweiligen Kunden und alle Bestellposten sichtbar sind.

In der zugrundeliegenden Datenquelle stehen dafür die relational verknüpften Tabellen Kunden (Customers) > Bestellungen (Orders) > Posten (Order_Details) zur Verfügung.

Sie stellen sich das Ergebnis ungefähr so vor:

Abbildung 5.3: Hierarchische Rechnungsliste

Gehen Sie dazu folgendermaßen vor:

1. Wählen Sie Einfügen > Berichtscontainer (Objekte > Einfügen > Berichtscontainer).

Abbildung 5.4: Registerkarte "Einfügen"

2. Ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf.

3. Daraufhin erscheint ein Auswahldialog für das gewünschte Element. Wählen Sie das Element "Tabelle" aus.

Abbildung 5.5: Auswahl Element

4. Geben Sie im folgenden Dialog die Datenquelle an. Es werden alle zur Verfügung stehenden Tabellen hierarchisch angezeigt, d.h. unter den Tabellen finden Sie die jeweils relational verknüpften Tabellen.

Abbildung 5.6: Datenquelle auswählen

Für die Rechnungsliste benötigen Sie die Struktur Kunden (Customers) > Bestellungen (Orders) > Posten (Order_Details).

Sie haben an dieser Stelle nun 2 alternative Vorgehensweisen:

a) Sie wählen die Tabelle "Customers" aus um zuerst die "oberste" Tabelle zu erstellen. Dies entspricht einer TopDown-Vorgehensweise, d.h. anschließend fügen Sie über das Toolfenster "Objekte" die Untertabelle "Orders" und dann die Untertabelle "Order-Details" hinzu.

b) Oder Sie wählen sofort die gewünschte Struktur aus, indem Sie die "unterste" Tabelle auswählen. Dies entspricht einer BottomUp-Vorgehensweise, d.h. alle 3 Tabellen werden erstellt und Sie beginnen mit dem Design der "untersten" Tabelle.

5. Für dieses Beispiel entscheiden Sie sich für die 2. Möglichkeit, d.h. Sie selektieren die Tabelle "Customers > Orders > Order_Details".

6. Daraufhin erscheint ein Auswahldialog mit allen Feldern der Tabelle "Order_Details".

Abbildung 5.7: Daten-Auswahlassistent

In diesem Dialog wählen sie nun die Spalten für diese Untertabelle. Doppelklicken Sie beispielsweise auf die Felder "ProductID", "Quantity", "UnitPrice" und "ProductName" aus der 1:1-verknüpften Tabelle "Products". Die Felder werden damit in den Bereich "Spalten" übernommen. Die Reihenfolge lässt sich dann über die Pfeil-Schaltflächen ändern.

7. Im Arbeitsbereich werden nun alle Tabellen angezeigt, die Tabelle "Order_Details" wird optisch hervorgehoben.

§ Die ausgewählten Felder werden in der Datenzeile ausgegeben, d.h. die Datenzeile enthält die Daten.

§ Außerdem wurde automatisch eine Kopfzeile erstellt. Kopfzeilen werden meist als Spaltenüberschriften genutzt, d.h. hier werden nun die ausgewählten Feldnamen als Text dargestellt.

§ Die Breite der Spalten wird automatisch angepasst. Sie können die Breite der Spalte manuell anpassen, indem Sie mit der Maus die Rahmenlinie nach rechts oder links verschieben.

Hinweis: Dies verändert alle Tabellenspalten, deren Separatoren innerhalb eines +/-2mm-Intervalls von der Mausposition sind. Bei gedrückter Strg-Taste wird die Aktion nur für die Linie, auf der sich die Maus befindet, durchgeführt. Bei aktivierter Option "Breite einzeln ändern" (Tabelle > Breite einzeln ändern bzw. Strg+M bzw. Projektoption "Größenveränderung verändert nächste Spalte") ist eine Änderung der Breite von Tabellenspalten auf Kosten der Folgespalte möglich, d.h. die Folgespalte wird entsprechend kleiner.

8. Um nun die Spalten der Tabelle "Orders" zu definieren doppelklicken Sie diese im Toolfenster "Objekte".


Die Felder und Spalten bearbeiten

Um Tabellen mit weiteren Spalten zu erweitern, diese zu bearbeiten und detailliert zu formatieren stehen Ihnen 3 Vorgehensweisen zur Verfügung:

Siehe auch:


Tabellentools und Mini-Symbolleiste

Wenn Sie eine Tabelle eingefügt haben, werden die Tabellentools sowie die Registerkarte Tabelle angezeigt. Die Registerkarte enthält die Befehle, die Sie zum Arbeiten mit Tabellenobjekten benötigen.

Optional kann auch eine Mini-Symbolleiste genutzt werden (Datei (Projekt) > Optionen > Arbeitsbereich).

Abbildung 5.8: Registerkarte "Tabellentools"

Über die Tabellentools können Sie u.a. eine neue Zeile definieren, eine neue Spalte einfügen, markierte Spalten/Zellen nach links/rechts verschieben, Rahmen definieren, Schriftarten, Schriftgrade, Ausrichtungen, Textfarben und Formatierungen anwenden.

§ Um eine Zelle zu selektieren klicken Sie in die linke obere Ecke der Zelle.

§ Um mehrere Zellen zu selektieren klicken Sie mit gedrückter Strg-Taste jeweils in die linke obere Ecke der Zellen.

§ Für einen ganzen Bereich halten Sie die Umschalt-Taste gedrückt.

§ Um eine ganze Spalte zu selektieren halten Sie die Alt-Taste gedrückt.


Objekt-Dialog

Für weitergehende Funktionalitäten nutzen Sie den Objekt-Dialog. Diesen öffnen Sie über die entsprechende Schaltfläche in der Mini-Symbolleiste oder über Doppelklick auf das Element im Toolfenster "Objekte".

Abbildung 5.9: Objekt-Dialog bei Tabellen

Für jeden Zeilentyp gibt es eine Registerkarte zur Definition der verschiedenen Zeilendefinitionen und Spalten der jeweiligen Zeile. Folgende Zeilentypen sind möglich: Kopfzeilen, Datenzeilen, Fußzeilen, Gruppenkopfzeilen und Gruppenfußzeilen. Wenn für einen Zeilentyp mindestens eine Zeilendefinition vorhanden ist wird dies durch ein Häkchen auf der Registerkartenlasche angezeigt.

§ Kopfzeilen werden meist als Überschriften der Tabellenspalten eingesetzt.

§ Datenzeilen enthalten die Formatierung der tatsächlichen Tabellenzeilen mit den Daten, die in der Tabelle dargestellt werden sollen.

§ Fußzeilen werden ganz am Ende der Tabelle dargestellt und können abschließende Informationen der darüber ausgegebenen Datenzeilen enthalten.

§ Gruppenkopf- und Fußzeilen dienen der Strukturierung der Datenzeilen anhand von "Zwischen-Überschriften" und "Zwischen-Fußzeilen".

Alle Zeilentypen lassen sich unabhängig voneinander definieren.

§ So könnten die Spalten einer Kopfzeile anders aussehen als die darunterliegenden Datenzeilen oder Fußzeilen.

§ Für die einzelnen Zeilentypen lassen sich ebenfalls jeweils verschiedene Zeilenlayouts oder Zeilendefinitionen anlegen. Über spezielle Darstellungsbedingungen können dann je nach Bedarf die verschiedenen Zeilendefinitionen aktiviert werden.


Feldliste und Drag & Drop

Die Variablen-/Feldliste (Projekt > Variablen/Felder) zeigt alle im aktuellen Projekt verfügbaren Variablen und Felder an und unterstützt Drag & Drop der Variablen und Felder. Siehe auch Kapitel Variablen-/Feldliste und Drag & Drop


Mehrere Zeilenlayouts definieren

Für jeden Zeilentyp können verschiedene Layouts definiert werden. In Abhängigkeit von Darstellungsbedingungen wird je nach Situation das jeweils passende Layout verwendet. Auf diese Weise können z.B. 2 Tabellenzeilen pro Datensatz ausgegeben werden:

Abbildung 5.10: Zwei Zeilendefinitionen

Gehen Sie zum Erstellen von Tabellenzeilen im Objekt-Dialog folgendermaßen vor:

1. Wählen Sie zunächst den Zeilentyp aus, den Sie bearbeiten wollen, indem Sie auf die entsprechende Registerkarte klicken, z.B. Datenzeile.

2. Wählen Sie nun über das Kontextmenü "Neue Tabellenzeile einfügen". Alternativ können Sie auch eine bestehende Zeilendefinition selektieren und dann die Schaltfläche "Neu" klicken.

3. Im folgenden Dialog "Auswahl der Definitionszeile" können Sie nun entweder

§ ein bereits bestehendes Layout als Vorgabe für das neue Zeilenlayout auswählen (sehr praktisch wenn das Layout ähnlich ist).

§ den Daten-Auswahlassistent starten (sehr praktisch um mehrere Spalten in einem Arbeitsschritt anzulegen).

§ oder eine leere Zeilendefinition erstellen um die Spalten dann über den Objekt-Dialog anzulegen.

Abbildung 5.11: Auswahl der Definitionszeile

4. Die neue Zeile wird damit erstellt. Die Spalten bearbeiten Sie wie unter Spalteninhalt beschrieben. Die Reihenfolge der Zeilen ändern Sie über die Pfeil-Schaltflächen oder per Drag & Drop.

5. Für die neu angelegte Zeile als Ganzes können Sie dann das Erscheinungsbild festlegen. Hier stehen u.a. folgende Eigenschaften zur Verfügung:

§ Über die "Darstellungsbedingung" bestimmen Sie, wann diese Zeile gedruckt wird. Praktisch, wenn Sie mehrere Zeilenlayouts definieren, die in Abhängigkeit von bestimmten Werten gedruckt werden sollen. Sie gelangen dabei in den bekannten Dialog zur Definition von logischen Ausdrücken.

Beispiel Zeile1: Zwischensumme nicht auf letzter Seite

Darstellungsbedingung: not Lastpage()

Beispiel Zeile 2: Gesamtsumme nur auf letzter Seite

Darstellungsbedingung: Lastpage()

§ Name der Zeile z.B. "Artikeldaten obere Zeile". Dies ermöglicht es Ihnen bei komplexen Layouts, diese Zeile schnell wiederzufinden.

§ Im Designer anzeigen: Damit können Sie Zeilen im Arbeitsbereich ausblenden – sehr nützlich, wenn Sie z.B. sehr viele Zeilendefinitionen haben.

§ Ränder: Hier definieren Sie die Abstände der Zeile nach oben, unten, rechts und links. Die Abstände "oben" bzw. "unten" bewirken dabei entsprechende Leerräume zwischen den einzelnen Tabellenzeilen. Über die Abstände "links" bzw. "rechts" erreichen Sie Einzüge relativ zum Tabellenobjekt, Sie können damit also Zeilen bzw. Spalten einrücken.

§ Über die Eigenschaft "Schriftart-Voreinstellung" können Sie die Schriftart für die ganze Tabellenzeile voreinstellen. Neu eingefügte Spalten erscheinen dann zunächst in dieser Schriftart.

§ Verzeichnisebene des Lesezeichens für die Vorschau oder den PDF-Export.

Siehe auch Kapitel Übersicht der Eigenschaften und Gruppenzeilen definieren.

Abbildung 5.12: Eigenschaften der Zeile


Spalteninhalt definieren

Für jede Zeile können beliebig viele Spalten definiert werden. Sie müssen lediglich darauf achten, dass diese Spalten aufgrund der definierten Breite einer Tabelle auch dargestellt werden können.

Die einzelnen Spalten werden im Objekt-Dialog innerhalb der Baumstruktur angezeigt. Über die Schaltflächen können Sie die selektierten Spalten bearbeiten, löschen, ausschneiden, kopieren, einfügen und verschieben. Spalten können dabei auch per Drag & Drop über Zeilendefinitionen hinweg verschoben werden.

Abbildung 5.13: Eigenschaften der Spalte

Gehen Sie zum Erstellen von neuen Spalten im Objekt-Dialog folgendermaßen vor:

1. Wählen Sie zunächst die Zeile aus, in die Sie eine neue Spalte einfügen möchten.

2. Wählen Sie nun über das Kontextmenü "Neue Spalte in Tabellenzeile einfügen/anhängen" (Alt+Einfg). Alternativ können Sie auch eine bestehende Spaltendefinition selektieren und dann die Schaltfläche "Neu" klicken bzw. auf den kleinen Pfeil nach unten neben dieser Schaltfläche um den Typ der Spalte zu bestimmen.

3. Jede Spalte hat einen bestimmten Typ. Als Spaltentypen stehen Ihnen folgende Objekttypen zur Verfügung: Text, Bild, Barcode, Formatierter Text, Formularelement, Tabelle, Diagramm, Checkbox, Datengrafik Messinstrument, HTML-Text, PDF und OLE Container. Bei Auswahl eines Feldes wird dieser Datentyp aber auch automatisch gesetzt.

4. Zur Definition des Inhalts gelangen Sie in den bekannten Formeleditor, in dem Sie beliebige Ausdrücke als Spalteninhalte definieren können. Weitere Informationen finden Sie unter Variablen, Felder und Ausdrücke.

5. Definieren Sie dann die Eigenschaften der Spalte. Jede Spalte einer Zeile kann separat bearbeitet und formatiert werden. Selektieren Sie die gewünschte Spalte im Objekt-Dialog innerhalb der Baumstruktur. Um mehrere Spalten zu selektieren halten Sie die Strg-Taste bzw. Umschalt-Taste gedrückt.

Ihnen stehen u.a. folgende Eigenschaften zur Verfügung:

§ Formatierung, z.B. als Zahl oder Währung.

§ Name der Spalte: Bei komplexen Ausdrücken können Sie damit die Übersichtlichkeit erhöhen. Wenn Sie den Namen direkt in der Baumstruktur ändern, wird Ihre Änderung auch als "Inhalt" übernommen, sofern dies Sinn macht.

§ Über die "Darstellungsbedingung" bestimmen Sie, wann diese Spalte gedruckt wird. Praktisch, wenn Sie mehrere Spalten definieren die in Abhängigkeit von bestimmten Werten gedruckt werden sollen. Sie gelangen dabei in den bekannten Dialog zur Definition von logischen Ausdrücken.

§ Drehung des Inhalts in 90°-Schritten.

§ Hintergrund, Rahmen, Schrift, Ausrichtung vertikal und horizontal.

§ Eine feste Höhe der Zelle unabhängig vom Inhalt.

§ Die Spaltenbreite in mm.

Siehe auch Kapitel Übersicht der Eigenschaften.


Gruppenzeilen definieren

Ein besonderer Zeilentyp sind die Gruppenzeilen. Diese dienen dazu, die zu druckenden Datenzeilen zu Gruppen zusammenzufassen.

Über die Zeileneigenschaft "Gruppieren nach" wird bestimmt, wie die Daten gruppiert werden. D.h. jedes Mal wenn sich das Ergebnis des Ausdrucks von einer Datenzeile zur nächsten ändert, wird die Zeile gedruckt. Wenn kein Ausdruck angegeben wird, wird die Zeile nicht gedruckt und die Eigenschaft wird im Eigenschaftenfenster rot hervorgehoben.

Ein Gruppenkopf wird entsprechend vor Ausgabe der Datenzeile gedruckt, also z.B. als Gruppenüberschrift "Artikelgruppe XYZ".

Ein Gruppenfuß erscheint nachdem sich die Bedingung der Eigenschaft "Gruppieren nach" geändert hat, also nach Ausgabe der Datenzeile. Gruppenfußzeilen eignen sich z.B. für Summierungen von Daten innerhalb einer Gruppe.

Über die Precalc()-Funktion können Sie im Berichtscontainer eine Gruppensumme auch im Gruppenkopf ausgeben, also z.B. über Precalc (Sum(Artikel.Stkpreis), Left$(Artikel.Nr,1)).

Beispiel: Gruppierung nach dem Anfangsbuchstaben von Feld "Artikel.Nr".

1. Legen Sie auf der Registerkarte "Gruppenkopf" eine neue Zeilendefinition an. Als Inhalt für die Spalte geben Sie z.B. folgenden Ausdruck an:

"'Hauptgruppe: ' + Left$(Artikel.Nr,1)"

Das Ergebnis des Ausdrucks "Left$(Artikel.Nr,1)" ist das erste Zeichen der Variablen "Artikel.Nr".

Für jeden neuen Anfangsbuchstaben bei "Artikel.Nr" würde dann als Zwischenüberschrift der Text "Hauptgruppe: " und der jeweilige 1. Buchstabe gedruckt werden.

2. Als Bedingung für die Eigenschaft "Gruppieren nach" geben Sie "Left$(Artikel.Nr,1)" an.

Mit jedem neuen Anfangsbuchstaben wird also eine entsprechende Zwischenüberschrift in die Liste gedruckt.

Abbildung 5.14: Gruppenzeilen einer Artikelliste

3. Auch bei Gruppenzeilen sind mehrere Zeilenlayouts möglich. Damit lassen sich z.B. hierarchisch abgestufte Zwischenüberschriften realisieren. So können Sie ein Zeilenlayout definieren, das wie im obigen Beispiel Zwischenüberschriften anhand des ersten Buchstabens der Variable "Artikel.Nr" erzeugt. Zusätzlich definieren Sie ein zweites Zeilenlayout, das Zwischenüberschriften anhand der ersten drei Zeichen von "Artikel.Nr" erzeugt.

Legen Sie analog eine weitere Gruppierung für den Untergruppenkopf an. Als Bedingung für die Eigenschaft "Gruppieren nach" geben Sie "Left$(Artikel.Nr,3)" an.

Als Inhalt für die Spalte geben Sie z.B. "'Untergruppe: ' + Left$(Artikel.Nr,3)" an:

Wenn sich die ersten 3 Buchstaben ändern wird nun eine entsprechende Zwischenüberschrift in die Liste gedruckt.

Ihnen stehen neben den Eigenschaften der "normalen" Zeilen u.a. auch folgende Eigenschaften zur Verfügung:

§ Gruppensummen: Hier können Sie verwendete Summenvariablen nach der Ausgabe auf 0 setzen, um Gruppensummen zu realisieren.

§ Seitenumbruch vor Ausgabe einer Gruppenkopfzeile bzw. Umbruch nach Ausgabe einer Gruppenfußzeile.

§ Den Gruppenkopf zusätzlich auch immer am Tabellenanfang anzeigen, wenn die Gruppe durch einen Seitenumbruch getrennt wird.

Siehe auch Kapitel Übersicht der Eigenschaften.

Abbildung 5.15: Gruppenkopfzeilen


Tabellen in Spalten

Sie können Detaildaten einer Untertabelle in einer Spalte ausgeben. Wenn Sie z.B. alle Bestellungen eines Kunden rechts neben dem Kundennamen ausgeben möchten, erstellen Sie eine Spalte vom Typ "Tabelle" und geben dann die Detaildaten aus.

Wenn Sie die Tabelle auswählen, können Sie die Eigenschaften des Tabellenobjekts bearbeiten. Ein Doppelklick bringt Sie zum üblichen Tabelleninhalt-Dialog.

An diese Tabelle können Sie über die Aktion "Untertabelle anhängen" zudem weitere Tabelle anhängen, z.B. die Summe der jeweiligen Bestellpositionen.

Bitte beachten: Wenn in der übergeordneten Tabelle (Elterntabelle) mehrere Zeilendefinitionen definiert werden, muss die Option "Zeilen zusammenhalten" auf "False" gesetzt werden, da bei Untertabellen keine Vorberechnung der Höhe möglich ist und somit nach jeder Datenzeile ein Seitenumbruch ausgelöst wird.

Abbildung 5.16: (Unter-)Tabellen in Spalten ausgeben

1. Erstellen Sie im Berichtscontainer ein neues Element und wählen Sie als Objekttyp "Tabelle".

2. Im folgenden Dialog wählen Sie nun die Datenquelle aus. Für eine Umsatzauswertung je Kunde wählen Sie z.B. die Tabelle "Customers". Als Feld wählen Sie z.B. "Customer.CompanyName".

3. In diese Datenzeile fügen Sie nun eine weitere Spalte hinzu und geben dabei die Daten einer 1:N-verknüpften Tabelle aus. Wählen Sie über das Kontextmenü "Neue Spalte in Tabellenzeile einfügen/anhängen" (Alt+Einfg).

Alternativ können Sie auch eine bestehende Spaltendefinition selektieren und dann auf den kleinen Pfeil nach unten neben dieser Schaltfläche klicken um den Typ der Spalte zu bestimmen.

4. Wählen Sie als Spaltentyp "Tabelle" und dann z.B. die Spalte "Orders.OrderID". Die Datenzeile wird zwar nicht ausgegeben (da wir sie unterdrücken), aber es wird ein Feld benötigt, damit die Tabelle überhaupt gedruckt wird.

5. Zurück im Tabellendialog selektieren Sie die Tabelle "Orders" und setzen die Tabellen-Eigenschaft "Datenzeilen > Datenzeilen unterdrücken" auf "Ja".

Abbildung 5.17: Datenzeilen unterdrücken bei einer Tabellenspalte

6. Wählen Sie nun über das Kontextmenü "Untertabelle anhängen".

Alternativ können Sie auch die Tabelle selektieren und dann auf den kleinen Pfeil nach unten neben dieser Schaltfläche klicken um eine Untertabelle anzuhängen.

7. Wählen Sie als Datenquelle die Tabelle "Order Details" und dann erneut die Spalte "Orders.OrderID". Die Datenzeile wird zwar auch nicht ausgegeben (da wir sie unterdrücken), aber es wird ein Feld benötigt, damit die Tabelle überhaupt gedruckt wird.

8. Als Fußzeile definieren Sie die Summe der Bestellpositionen, d.h. in der 1. Spalte das Bestelldatum (Orders.OrderDate) und in der 2. Spalte summieren Sie den Umsatz. Diesen berechnen Sie z.B. über die Formel "Sum(Order_Details.Quantity * Order_Details.UnitPrice)". Diese beiden Spalten werden dann neben dem Namen des Kunden ausgegeben, da die Ausgabe der Datenzeilen jeweils unterdrückt wird.

Abbildung 5.18: Aggregation in der Fußzeile

9. Zurück im Tabellendialog selektieren Sie die Tabelle "Order Details" und setzen auch hier die Tabellen-Eigenschaft "Datenzeilen > Datenzeilen unterdrücken" auf "Ja".

10. Die Auswertung ist fertig, d.h. Sie sehen neben dem Kundennamen die Bestellungen und daneben die Summe der Bestellpositionen (siehe Abbildung 5.16).


Layout bei Tabellen

Um das Layout einer Tabelle zu beeinflussen, stehen diverse Eigenschaften und Funktionen zur Verfügung. Siehe dazu auch Kapitel Aggregation / Statistiken, Drilldown Berichte (Detailtiefe erhöhen), Seitenlayout und Übersicht der Eigenschaften.

Siehe auch:

Spalten ausrichten

Fixe Größe

Kopfzeilen und Fußzeilen erneut drucken

Größe der Tabelle variabel definieren

Festen Seitenwechsel erzeugen

Abhängigen Seitenwechsel erzeugen

Zeilen zusammenhalten

Summen und Zähler definieren

Freien Inhalt vor und nach einer Tabelle ausgeben

Zeilen verankern (Zellen überlappen)

Ausklappbarer Bereich


Spalten ausrichten

Es gibt diverse Möglichkeiten, die Arbeit mit dem Tabellenobjekt zu vereinfachen.

§ Wenn Sie beim Verkleinern der Tabelle die Strg-Taste gedrückt halten, werden alle Spalten automatisch um den gleichen Faktor verkleinert.

§ Sie können die Breite einer Spalte manuell anpassen, indem Sie im Arbeitsbereich mit der Maus den Spaltenrahmen (Separator) nach rechts oder links verschieben. Dies verändert alle Tabellenspalten, deren Separatoren innerhalb eines +/-2mm-Intervalls von der Mausposition liegen. Bei gedrückter Strg-Taste wird die Aktion nur für die Linie, auf der sich die Maus befindet, durchgeführt.

Bei aktivierter Option "Breite einzeln ändern" (Tabelle > Breite einzeln ändern bzw. Strg+M bzw. Projektoption "Größenveränderung verändert nächste Spalte") ist eine Änderung der Breite von Tabellenspalten auf Kosten der Folgespalte möglich, d.h. die Folgespalte wird entsprechend kleiner.

§ Wenn Sie den ersten Spaltenseparator mit der Maus nach rechts schieben, wird eine leere Spalte in allen Zeilendefinitionen angelegt.

§ Um eine um Spaltenbreiten relativ anzugeben verwenden Sie die Funktion TableWidth(). Diese gibt die Breite des Tabellenobjekts zurück. Mit der Breitenangabe von TableWidth()*30/100 nimmt die Spalte z.B. 30% der Breite ein.

§ Um bei einer Vielzahl von Zeilendefinitionen die Übersichtlichkeit zu erhöhen, können Sie Zeilentypen (Kopfzeilen, Datenzeilen, Fußzeilen, Gruppenzeilen) im Arbeitsbereich ausblenden. Selektieren Sie dazu das Tabellenobjekt und wählen dann Sichtbare Zeilentypen im Kontextmenü.

§ Um (Unter-)Tabellen und Spalten exakt aneinander auszurichten können Sie als optische Unterstützung die Separatorenzeichen im Lineal nutzen (kann über eine Eigenschaft deaktiviert werden).

Abbildung 5.19: Tooltip für ein Spaltenseparatorzeichen


Fixe Größe

Über die Eigenschaft "Fixe Größe" können Sie bestimmen, dass die Tabelle Ihre Größe nicht automatisch anpassen soll, wenn weniger Datenzeilen gedruckt werden als Platz im Tabellenobjekt verfügbar ist.

Diese Eigenschaft ist praktisch, um Fußzeilen immer am Ende der Seite auszudrucken, wenn z.B. die Seitenzahl in einer Fußzeile ausgeben wird. Bei ausgeschalteter Eigenschaft rückt das Ende der Tabelle (und damit die Fußzeilen) automatisch nach oben.


Kopfzeilen und Fußzeilen erneut drucken

Wenn der Druck einer Tabelle aus Platzmangel auf der Folgeseite fortgesetzt wird, wird die Kopfzeile dieser Tabelle und der äußersten Tabelle erneut gedruckt. Um den erneuten Druck der Kopfzeilen auf der Folgeseite zu unterdrücken, verwenden Sie als Darstellungsbedingung die Funktion FirstHeaderThisTable().

Diese Funktionalität gibt es auch bei Fußzeilen, hier verwenden Sie als Darstellungsbedingung die Funktion LastFooterThisTable(). Damit werden die Fußzeilen nur auf der letzten Tabellenseite ausgegeben, falls der Druck der Tabelle aus Platzgründen auf der Folgeseite fortgesetzt wird.


Größe der Tabelle variabel definieren

Es ist möglich, die Höhe und Breite des Berichtscontainers variabel zu definieren, um zu vermeiden, dass Daten abgeschnitten werden, wenn das Seitenformat geändert wird (z.B. von Hochformat auf Querformat).

Selektieren Sie dazu im Toolfenster "Objekte" den Berichtscontainer und verwenden Sie dann für die Angabe der Höhe und Breite die LL.Device.Page-Variablen und die Funktion UnitFromSCM():

Abbildung 5.20: Variable Größendefinition des Berichtscontainers


Festen Seitenwechsel erzeugen

Bei komplexen Projekten mit hierarchischen Tabellen kann es sinnvoll sein, vor Ausgabe einer Datenzeile der "obersten" Tabelle einen Seitenumbruch zu erzeugen. Nutzen Sie dazu die Eigenschaft "Seitenwechselbedingung".

Abbildung 5.21: Aktive Seitenwechselbedingung

Um z.B. bei einer hierarchischen Tabelle jede Datenzeile der Haupttabelle auf einer neuen Seite auszugeben, selektieren Sie in der Objektliste die Haupttabelle und setzen die Eigenschaft "Seitenwechselbedingung" auf "True".


Abhängigen Seitenwechsel erzeugen

Nehmen wir an, Sie möchten bei einer Tabelle vermeiden, dass nach Ausgabe einer Datenzeile der "obersten" Tabelle kein Platz mehr vorhanden ist für die nachfolgende Datenzeile der Untertabelle.

So soll es also nicht aussehen:

Abbildung 5.22: Datenzeile der Haupttabelle ohne Folgezeile

Dies können Sie über die Eigenschaft "Seitenwechselbedingung" und die Funktion RemainingTableSpace() vermeiden. Diese Funktion gibt den zur Verfügung stehenden Platz zurück. Wenn Sie den Parameter "True" angeben, wird dieser Wert in 1/1000mm geliefert.

Wenn Sie nun festlegen möchten, dass ein Seitenumbruch erfolgen soll, wenn vor Ausgabe der Datenzeile der Haupttabelle weniger als 3cm Platz zur Verfügung steht, geben Sie für die Eigenschaft "Seitenwechselbedingung" folgende Formel an:

RemainingTableSpace(True)<30000


Zeilen zusammenhalten

Wenn der Druck einer Tabelle aus Platzmangel auf der Folgeseite fortgesetzt wird, können Sie entscheiden, ob Zeilen getrennt oder wenn möglich zusammengehalten werden sollen.

Diese Option ist z.B. für mehrzeilige Datenzeilen oder die Summen-Fußzeilen einer Rechnung praktisch. Diese Option steht Ihnen bei Datenzeilen, Fußzeilen, Gruppenfußzeilen und Gruppenkopfzeilen in den Eigenschaften der Tabelle zur Verfügung.


Summen und Zähler definieren

Summen und Zähler definieren Sie über Summenvariablen oder die entsprechenden Aggregatsfunktionen. Weitere Informationen finden Sie in den Kapiteln Funktionen verwenden, Übersicht der Funktionen und Summenvariablen.


Freien Inhalt vor und nach einer Tabelle ausgeben

Sie können beliebigen Text vor oder nach einer Tabelle ausgeben. Verwenden Sie dazu z.B. das Formatierte Text-Objekt und binden Sie dieses Objekt über den Berichtscontainer als freien Inhalt in das Projekt ein.

Erzeugen Sie für unser Rechnungs-Beispiel aus Kapitel Eine einfache Rechnung erstellen ein Deckblatt mit einem Anschreiben und einen Anhang mit den AGB.

Abbildung 5.23: freien Inhalt in den Berichtscontainer einfügen

1. Um ein neues Element in den Berichtscontainer einzufügen, wählen Sie die Schaltfläche "Ein Element anhängen" im Toolfenster "Objekte".

2. Daraufhin erscheint ein Auswahldialog für das gewünschte Element. Wählen Sie das Element "Tabelle" aus.

3. Im folgenden Dialog wählen Sie als Datenquelle "freier Inhalt".

4. Im Eigenschaften-Dialog des Tabellen-Objekts fügen Sie dann eine Spalte ein. In unserem Fall möchten wir das Anschreiben als Formatierter Text erstellen. Wählen Sie daher über den kleinen Pfeil rechts der Schaltfläche den Eintrag "Formatierter Text" aus.

Abbildung 5.24: Formatierter Text als Spalteninhalt bestimmen

5. Daraufhin erscheint ein Dialog über den Sie das Anschreiben als fortlaufenden Text schreiben können. Eine detaillierte Anleitung für das Arbeiten mit dem "Formatierter Text"-Objekt finden Sie in Kapitel Praxis: Einen Serienbrief erstellen.

6. Denken Sie daran, beim freien Inhalt den (Spalten-)Rahmen zu entfernen. Idealerweise entfernen Sie den Rahmen über die Eigenschaft "Rahmen-Voreinstellung" in den Elementeigenschaften. Außerdem vergrößern Sie die Spaltenbreite über die Eigenschaft "Breite" auf die Breite des Berichtscontainers.

7. Außerdem müssen Sie u.U. die Bedingung der Ebenen ändern, da auf der 1. Seite nun ein Anschreiben ausgegeben wird.

8. Wenn nun im Anschluss an die Rechnung noch die AGB ausgegeben werden sollen, fügen Sie nach der Postentabelle einen weiteren freien Inhalt in den Berichtscontainer ein. Dann haben Sie mehrere Möglichkeiten:

§ Verwenden Sie ebenfalls das Formatierte Text-Objekt.

§ Verwenden Sie das PDF-Objekt und binden Sie die AGB im PDF-Format ein.

§ Für die Ausgabe auf der Rückseite siehe Rückseite in Kapitel Berichtsabschnitte.


Zeilen verankern (Zellen überlappen)

Nehmen wir an, Sie möchten den Inhalt einer Spalte über 2 Zeilen hinweg ausgeben. Dies können Sie erreichen, indem Sie 2 Zeilen über die Zeileneigenschaft "Verankern an Zeile" aneinander verankern (Index (1-basierend) der Zeile; 0=keine Verankerung). Damit wird der Beginn der nächsten Zeilendefinition an den Beginn oder das Ende einer anderen Zeilendefinition gezwungen. Somit können sich Zellen überlappen.

Hinweis: Diese Funktion wird nicht von allen Exportformaten unterstützt.

Abbildung 5.25: Datenzeilen verankern

Um z.B. 2 Zeilen neben einer Bildspalte auszugeben, gehen Sie folgendermaßen vor:

1. Definieren Sie in der ersten Zeile 3 Spalten: "Artikel.Nr" (Spaltenbreite 30), leerer Inhalt, d.h. einen Leerschritt (Spaltenbreite 30), "Artikel.Bezeichnung1" (Spaltenbreite 90).

2. Definieren Sie in der zweiten Zeile 2 Spalten: leerer Inhalt, "Artikel.Bild" (beide Spaltenbreite 30). in den Zeileneigenschaften setzten Sie die Eigenschaft "Verankern an Zeile" auf "1" um diese mit der ersten Zeilendefinition zu verketten.

3. Definieren Sie in der dritten Zeile ebenfalls 2 Spalten: leerer Inhalt (Spaltenbreite 60), "Artikel.Bezeichnung2" (Spaltenbreite 90).

4. Damit wird die zweite Zeile an der gleichen Anfangsposition wie die erste Zeile ausgegeben und die Zellen können sich überlappen:

Abbildung 5.26: Spalteninhalt über 2 Zeilen


Ausklappbarer Bereich

Wenn Sie die Eigenschaft "Ausklappbarer Bereich" aktivieren, werden die Unterelemente eines Elements beim Druck in die Vorschau zunächst nicht gedruckt, dafür erhält die Zeile selber ein Aufklapp-Symbol. Voraussetzung hierfür sind definierte Datenzeilen. Ein Klick darauf expandiert den Bereich für die entsprechende Zeile, man hat so eine Drilldown-Möglichkeit, ohne die aktuelle Vorschau zu verlassen und ohne dafür ein eigenes Projekt zu designen.

Über das Kontextmenü dieses Aufklapp-Symbols können Sie alle Einträge einer Ebene einklappen oder ausklappen und alle Details eines Eintrags ausklappen.

Abbildung 5.27: Ausklappbare Bereiche


Sortierungen in der Vorschau

Sie können Kopfzeilenfelder so konfigurieren, dass Sie in der Vorschau durch Klick auf das Feld die Sortierung der Daten ändern können. So können Sie z.B. schnell die Kunden von A-Z auflisten.

Gehen Sie wie folgt vor:

1. In einer Kundenliste werden für die Kopfzeilenfelder "Name" und "Land" die jeweils gewünschten Sortierungen über die Eigenschaften "Sortierungen > Aufsteigend" und "Sortierungen > Absteigend" definiert.

Abbildung 5.28: Sortierungen für Kopfzeilenfelder

2. Im Vorschaufenster erscheinen dann neben den Kopfzeilen kleine Symbole, über die die Sortierung angesteuert werden kann. Ein Klick auf das Land und die Kunden sind entsprechend sortiert.

Abbildung 5.29: Kundenliste mit Sortierung in der Vorschau


Auswertungen erstellen

Sie können Daten u.a. durch Diagramme, Messinstrumente, Kreuztabellen, Gantt-Diagramme, Fußzeilen in Tabellen oder Drilldown-Berichte auswerten.

Siehe auch:

Diagramm erstellen

Checkbox erstellen

Datengrafik erstellen

Messinstrument erstellen

Kreuztabelle erstellen

Gantt-Diagramm erstellen

Aggregation / Statistiken

Drilldown Berichte (Detailtiefe erhöhen)

Mehrspaltige Reports


Diagramm erstellen

Diagramme dienen zur grafischen Auswertung und Darstellung von Daten. Damit können Sie sich einen Überblick über Ihre Daten verschaffen und Auffälligkeiten schnell erkennen.

Sie können damit z.B. Umsatzverläufe untersuchen, prozentuale Anteile visualisieren und Daten in mehreren Dimensionen darstellen. Es steht Ihnen eine Vielzahl verschiedener Diagrammtypen zur Verfügung:

§ Kreis/Ring: Torte, Kreis, Ring

§ Balken/Band (Darstellung auch als Zylinder, Pyramide, Kegel, Oktaeder)

§ einfach (z.B. Umsatz je Kunde)

§ gestaffelt (z.B. Umsatz mehrerer Kunden über die Jahre gestaffelt je Kunde)

§ gruppiert (z.B. Umsatz mehrerer Kunden über die Jahre gruppiert)

§ gestapelt (z.B. Umsatzanteile mehrerer Kunden über die Jahre gestapelt)

§ gestapelt relativ (z.B. relative Umsatzanteile mehrere Kunden über die Jahre)

§ Linien/Symbole: einfach, gestaffelt, gestapelt, gestapelt relativ

§ Flächen: einfach, gestapelt, gestapelt relativ

§ Blasen/Punkte: verteilt, geordnet (Darstellung als Kreis, Tropfen oder Bild-Datei)

§ Trichter: vertikal, horizontal (z.B. Darstellung der Verkaufsprozess-Phasen)

§ Landkarte/Shapefile (z.B. Temperaturverteilung auf der Welt)

In Diagrammen stehen Ihnen in der Feldliste spezielle LL.ChartObject-Felder zur Verfügung. Weitere Informationen finden Sie im Kapitel Übersicht der Felder.

Siehe auch:

Ein Diagramm einfügen

Torte, Ring oder Kreisdiagramm

Gestaffeltes Balkendiagramm

Relativ gestapeltes Balkendiagramm

Gestaffeltes Liniendiagramm

Gestapeltes Flächendiagramm

Verteiltes Blasendiagramm

Trichter

Landkarte/Shapefile

Werte über Reihen bestimmen

Diagrammtypen mischen


Ein Diagramm einfügen

Sie haben verschiedene Möglichkeiten, Diagramme auszugeben:

1. Ein Diagramm als Element im Berichtscontainer. Fügen Sie das Objekt über das Toolfenster "Objekte" ein. Wenn noch kein Berichtscontainer im Arbeitsbereich platziert wurde, wählen Sie Einfügen > Berichtscontainer (Objekte > Einfügen > Berichtscontainer) und ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf. Daraufhin erscheint ein Auswahldialog für das gewünschte Element. Wählen Sie das Element "Diagramm" aus.

2. Ein Diagramm als Objekt, sofern dies von der Anwendung unterstützt wird. Wählen Sie Einfügen > Diagramm (Objekte > Einfügen > Diagramm) und ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf.

3. Diagramme und Messinstrumente können in einer Tabellenzelle ausgegeben werden. Wählen Sie dazu im Tabellen-Objektdialog über das Kontextmenü den entsprechenden Eintrag aus. Wenn Sie aggregierte Daten ausgeben möchten, bietet sich die Ausgabe in einer Fußzeile an.

Abbildung 6.1: Diagramm-Objekt in einer Fußzeile

4. Im folgenden Dialog wählen Sie nun die Datenquelle aus. Es werden alle zur Verfügung stehenden Tabellen hierarchisch angezeigt, d.h. unter den Tabellen finden Sie die jeweils relational verknüpften Tabellen.

Für eine Umsatzauswertung je Land wählen Sie in der Beispielanwendung z.B. die Tabelle "Customers > Orders > Order Details" damit Sie alle 3 Tabellen zur Verfügung haben. In der Tabelle "Customers" ist das Land enthalten, in der Tabelle "Orders" das Bestelldatum und in der Tabelle "Order Details" der Umsatz.

5. Daraufhin erscheint der Diagramm-Objektdialog.

Über die Auswahllisten oben links können Sie den Basistyp und jeweiligen Untertyp auswählen.

6. Die Achsen werden über die Registerkarten (Rubrikenachse, Reihenachse, Größenachse, Datenquelle, Segment, Trichterabschnitt, Shapefile usw.) definiert. Sie können direkt in die Live-Vorschau klicken (z.B. auf die Überschrift oder Achsenbeschriftung) um schnell zur zugehörigen Eigenschaft zu wechseln.

Abbildung 6.2: Diagramm-Objektdialog

7. Auf der Registerkarte "Diagramm" wählen Sie die allgemeinen Diagrammoptionen (z.B. Perspektive, Farbmodus). Siehe auch Kapitel Übersicht der Eigenschaften.

8. Auf der Registerkarte "Diagrammbereich" wählen Sie die allgemeinen Layoutoptionen des gesamten Diagrammobjekts (z.B. Überschrift, Position der Überschrift, Hintergrund). Siehe auch Kapitel Übersicht der Eigenschaften.

9. Auf der Registerkarte "Farben" können Sie die Farbdarstellung bestimmen:

§ Designschema: Bestimmt die Farben und Farbreihenfolge für diejenigen Datenreihen, die nicht über "Feste Farben" bestimmt werden. Über die Auswahlliste können Sie ein vordefiniertes Set von Farben auswählen. Über die Eigenschaften können diese Farben noch angepasst werden.

§ Feste Farben: Es ist möglich, bestimmten Achsenwerten feste Farben zuzuordnen. Über die Schaltfläche "Neu" können Sie eine neue Zuordnung eingeben. Definieren Sie dann die Bedingung (z.B. Customers.Country = "Germany") und wählen Sie entweder eine feste Farbe aus oder geben Sie den Farbwert als Formel an.

Abbildung 6.3: Definition der Farben im Objekt-Dialog.


Torte, Ring oder Kreisdiagramm

Nehmen wir an, Sie möchten den Umsatz pro Land untersuchen. Dann ist ein Tortendiagramm die erste Wahl. An diesem können Sie direkt die Anteile ersehen. Gehen Sie wie folgt vor:

1. Wählen Sie als Datenquelle die Tabelle "Customers > Orders > Order Details".

2. Wählen Sie als Diagrammtyp Kreis/Ring > Torte.

3. Bestimmen Sie zuerst den Koordinatenwert der Datenquelle, d.h. denjenigen Wert der das einzelne Segment bestimmt, z.B. Customers.Country.

Abbildung 6.4: Definition der Datenquelle im Objekt-Dialog

4. Wechseln Sie auf die Registerkarte "Segment" um den Koordinatenwert für die Größe des Segments zu bestimmen, also den Umsatz. Doppelklicken Sie in die Eigenschaft "Koordinatenwert".

Im folgenden Dialog "Koordinatenwert" wählen Sie nun die gewünschte Aggregatsfunktion für den Inhalt aus. Da Sie eine Umsatzauswertung erstellen möchten wählen Sie die Aggregatsfunktion "Summe".

Abbildung 6.5: Assistent zum Erstellen der Koordinatenwert-Formel

5. Im oberen Teil des Dialogs können Sie dann den Inhalt bestimmen, indem Sie über die Formel-Schaltfläche den Formel-Assistent aufrufen. Der Umsatz pro Bestellung wird in der Beispielanwendung nicht direkt als Feld geliefert, daher müssen Sie diesen über die Formel "Order_Details.Quantity * Order_Details.UnitPrice" berechnen.

6. Für die Beschriftung der Segmente mit dem Prozentwert ist die "Koordinatenbeschriftung auf Objekt" bereits mit "ja" definiert. Definieren Sie über die Eigenschaft "Formatierung" den Wert als "Prozent" ohne Nachkommastellen

Abbildung 6.6: Definition des Segments im Torte-Diagrammobjekt

7. Sie können über die Eigenschaft "Explosions-Distanz" für die Segmente eine Distanz zur Mitte angeben. Über das LL.ChartObject-Feld "ArcIndex" das die Segmente der Größe nach durchnummeriert, können Sie dann sogar z.B. das größte Segment mit einer größeren Distanz darstellen. Beispiel:

Cond (LL.ChartObject.ArcIndex=1,20,10)

8. Auf der Registerkarte "Diagramm" wählen Sie die allgemeinen Diagrammoptionen. Ihnen stehen u.a. folgende Eigenschaften zur Verfügung:

§ Die Stärke der Perspektive, z.B. stark verzerrt.

§ Den Farbmodus, z.B. einfarbig

Siehe auch Kapitel Übersicht der Eigenschaften.

9. Auf der Registerkarte "Diagrammbereich" wählen Sie die allgemeinen Layoutoptionen. Hier stehen u.a. folgende Eigenschaften zur Verfügung:

§ Überschrift

§ Hintergrund inkl. Füllung, Rand und Schatten, z.B. Rand = transparent

Siehe auch Kapitel Übersicht der Eigenschaften.

Abbildung 6.7: Tortendiagramm


Gestaffeltes Balkendiagramm

Nehmen wir an, Sie möchten den Umsatz mehrerer Länder über die Jahre gestaffelt je Land untersuchen. Dann ist ein gestaffeltes Balkendiagramm die beste Wahl. Sie erhalten ein Diagramm, aus dem Sie für jedes Quartal ablesen können, wie viel Umsatz im jeweiligen Land generiert wurde. Gehen Sie wie folgt vor:

1. Wählen Sie als Datenquelle die Tabelle "Customers > Orders > Order Details".

2. Wählen Sie als Diagrammtyp Balken/Band > gestaffelt (3D)

3. Bestimmen Sie zuerst den Koordinatenwert der Rubrikenachse, d.h. den Wert der x-Achse. Wählen Sie über den Formel-Assistenten das Feld "Customers.Country".

Abbildung 6.8: Definition der Rubrikenachse

4. Bestimmen Sie den Koordinatenwert der Reihenachse, d.h. den Wert der y-Achse. Das Jahr der Bestellung wird in der Beispielanwendung nicht direkt als Feld geliefert, daher müssen Sie diesen Wert über die Formel "Year$(Orders.OrderDate)" berechnen.

Abbildung 6.9: Definition der Reihenachse

5. Bestimmen Sie den Koordinatenwert der Größenachse (z-Achse), d.h. die Höhe der Balken, also den Umsatz. Doppelklicken Sie in die Eigenschaft "Koordinatenwert".

Im folgenden Dialog "Koordinatenwert" wählen Sie nun die gewünschte Aggregatsfunktion für den Inhalt aus. Da Sie eine Umsatzauswertung erstellen möchten wählen Sie die Aggregatsfunktion "Summe".

6. Im oberen Teil des Dialogs können Sie dann den Inhalt bestimmen, indem Sie über die Formel-Schaltfläche den Formel-Assistenten aufrufen. Der Umsatz pro Bestellung wird in der Beispielanwendung nicht direkt als Feld geliefert, daher müssen Sie diesen über die Formel "Order_Details.Quantity * Order_Details.UnitPrice" berechnen.

7. Auf dieser Registerkarte stehen Ihnen u.a. noch folgende Layoutoptionen zur Verfügung:

§ Maximalwertautomatik: Sie können den angezeigten Bereich beschränken, um z.B. "Ausreißer" nach oben zu berücksichtigen.

§ Darstellung: Es stehen unterschiedliche Darstellungsarten zur Verfügung: Zylinder, Balken, Pyramide, Band, Oktaeder, Kegel

§ Dicke der Balken

§ Zebramodus für den Hintergrund

Siehe auch Kapitel Übersicht der Eigenschaften.

Abbildung 6.10: Definition der Größenachse

8. Auf der Registerkarte "Diagramm" wählen Sie die allgemeinen Diagrammoptionen. Ihnen stehen u.a. folgende Eigenschaften zur Verfügung:

§ Die Projektion, z.B. flach.

§ Farbmodus: Bestimmt die farbgebende Achse, also z.B. die y-Achsenwerte

Siehe auch Kapitel Übersicht der Eigenschaften.

Abbildung 6.11: Definition der Diagrammoptionen

9. Auf der Registerkarte "Diagrammbereich" wählen Sie die allgemeinen Layoutoptionen des gesamten Diagramms. Hier stehen u.a. folgende Eigenschaften zur Verfügung:

§ Überschrift

§ Hintergrund inkl. Füllung, Rand und Schatten, z.B. Rand = transparent

Siehe auch Kapitel Übersicht der Eigenschaften.

Abbildung 6.12: Gestaffeltes Balkendiagramm


Relativ gestapeltes Balkendiagramm

Das Tortendiagramm aus dem ersten Beispiel erlaubt einen Überblick über die Prozentanteile des gesamten Auswertungszeitraums. Um nun aber Trends erkennen zu können, wäre es schön, zu sehen wie sich die Anteile im Laufe des Auswertungszeitraums verschoben haben. Genau für diese Anwendung können Sie ein relativ gestapeltes Balkendiagramm verwenden. Der jeweilige Anteil an der Balkenlänge entspricht direkt dem Umsatzanteil des jeweiligen Landes.

Gehen Sie wie folgt vor:

1. Wählen Sie als Datenquelle die Tabelle "Customers > Orders > Order Details".

2. Wählen Sie als Diagrammtyp Balken/Band > gestapelt relativ

3. Bestimmen Sie zuerst den Koordinatenwert der Rubrikenachse, d.h. den Wert der x-Achse. Wählen Sie über den Formel-Assistenten das Feld "Customers.Country".

4. Bestimmen Sie den Koordinatenwert der Reihenachse, d.h. den Wert der y-Achse. Das Jahr der Bestellung wird in der Beispielanwendung nicht direkt als Feld geliefert, daher müssen Sie diesen Wert über die Formel "Year$(Orders.OrderDate)" berechnen.

5. Bestimmen Sie den Koordinatenwert der Größenachse (z-Achse), d.h. Sie berechnen den Umsatz über die Formel "Sum(Order_Details.Quantity * Order_Details.UnitPrice)".

6. Auf der Registerkarte "Diagramm" wählen Sie als "Ausrichtung" den Wert "nach rechts" um ein horizontales Diagramm zu erstellen.

Abbildung 6.13: Relativ gestapeltes Balkendiagramm


Gestaffeltes Liniendiagramm

Als Alternative zum gestaffelten Balkendiagramm bietet sich ein Liniendiagramm an. Hier lassen sich Werte schneller ablesen.

Abbildung 6.14: Gestaffeltes Liniendiagramm

Gehen Sie wie folgt vor:

1. Wählen Sie als Datenquelle die Tabelle "Customers > Orders > Order Details".

2. Wählen Sie als Diagrammtyp Linien/Symbole > gestaffelt

3. Bestimmen Sie zuerst den Koordinatenwert der Rubrikenachse, d.h. den Wert der x-Achse. Wählen Sie als Feld "Orders.OrderDate".

4. Wählen Sie die Eigenschaft "Koordinatenbeschriftung > Formatierung" und definieren Sie "%q/%y" als benutzerspezifische Datumsformatierung.

5. Bestimmen Sie den Koordinatenwert der Reihenachse, d.h. den Wert der y-Achse. Wählen Sie über den Formel-Assistenten das Feld "CategoryName".

6. Bestimmen Sie den Koordinatenwert der Größenachse (z-Achse), d.h. Sie berechnen den Umsatz über die Formel "Sum(Order_Details.Quantity * Order_Details.UnitPrice)".


Gestapeltes Flächendiagramm

Als Alternative zum gestaffelten Liniendiagramm bietet sich ein Flächendiagramm an. Hier lassen sich Verhältnisse schneller ablesen, da die Flächen zwischen den Linien eingefärbt sind.

Abbildung 6.15: Gestapeltes Flächendiagramm

Gehen Sie wie folgt vor:

1. Wählen Sie als Datenquelle die Tabelle "Customers > Orders > Order Details".

2. Wählen Sie als Diagrammtyp Flächen > gestapelt

3. Bestimmen Sie zuerst den Koordinatenwert der Rubrikenachse, d.h. den Wert der x-Achse. Wählen Sie über den Formel-Assistenten das Feld "CategoryName".

4. Bestimmen Sie den Koordinatenwert der Reihenachse, d.h. den Wert der y-Achse. Das Jahr der Bestellung wird in der Beispielanwendung nicht direkt als Feld geliefert, daher müssen Sie diesen Wert über die Formel "Year$(Orders.OrderDate)" berechnen.

5. Bestimmen Sie den Koordinatenwert der Größenachse (z-Achse), d.h. Sie berechnen den Umsatz über die Formel "Sum(Order_Details.Quantity * Order_Details.UnitPrice)".


Verteiltes Blasendiagramm

Blasendiagramme erlauben eine vierdimensionale Darstellung, indem neben der Position in x- und y-Richtung und der Farbe auch die Größe durch Daten definiert werden kann. Für die Blasendarstellung stehen Ihnen verschiedene Optionen zur Verfügung.

Abbildung 6.16: Verteiltes Blasendiagramm

Gehen Sie wie folgt vor:

1. Wählen Sie als Datenquelle die Tabelle "Customers > Orders > Order Details".

2. Wählen Sie als Diagrammtyp Blasen/Punkte > verteilt

3. Bestimmen Sie zuerst den Koordinatenwert der Rubrikenachse, d.h. den Wert der x-Achse. Wählen Sie über den Formel-Assistenten das Feld "Customers.Country".

4. Bestimmen Sie den Koordinatenwert der Reihenachse, d.h. den Wert der y-Achse. Das Jahr der Bestellung wird in der Beispielanwendung nicht direkt als Feld geliefert, daher müssen Sie diesen Wert über die Formel "Year$(Orders.OrderDate)" berechnen.

5. Bestimmen Sie den Koordinatenwert der Größenachse (z-Achse) und den Wert für die Blasengröße, d.h. Sie berechnen den Umsatz über die Formel "Sum(Order_Details.Quantity * Order_Details.UnitPrice)".

Auf dieser Registerkarte finden Ihnen auch die Optionen für die Blasendarstellung. Siehe auch Kapitel Übersicht der Eigenschaften.

6. Auf der Registerkarte "Diagramm" wählen Sie die allgemeinen Diagrammoptionen, auf der Registerkarte "Diagrammbereich" wählen Sie die allgemeinen Layoutoptionen des gesamten Objekts. Auf der Registerkarte "Farben" können Sie die Farbdarstellung bestimmen.


Trichter

Mit einem Trichter/einer Pipeline können Sie z.B. Ihre Verkaufsprozesse in den verschiedenen Phasen darstellen. Für die Darstellung stehen Ihnen verschiedene Optionen zur Verfügung.

Gehen Sie wie folgt vor:

1. Wählen Sie als Datenquelle die Tabelle "SalesStages".

2. Wählen Sie als Diagrammtyp Trichter > Vertikaler Trichter.

3. Bestimmen Sie zuerst den Koordinatenwert der Datenquelle, d.h. denjenigen Wert der den einzelnen Trichterabschnitt bestimmt (die Verkaufsphase). Wählen Sie über den Formel-Assistenten das Feld "SalesStages.StageID" und als Koordinatenbeschriftung "SalesStages.DescriptionDE".

4. Wechseln Sie auf die Registerkarte "Trichterabschnitt" um den Koordinatenwert für die Größe des Trichterabschnitts zu bestimmen (z.B. Anzahl der Verkaufschancen). Doppelklicken Sie in die Eigenschaft "Koordinatenwert". Im folgenden Dialog "Koordinatenwert" wählen Sie nun das Feld "SalesStages.Number" aus und evtl. eine Aggregatsfunktion, z.B. Anzahl.

5. Für die Beschriftung der Trichterabschnitte mit dem Prozentwert ist die "Koordinatenbeschriftung auf Objekt" bereits mit "ja" definiert. Definieren Sie über die Eigenschaft "Formatierung" den Wert als "Prozentanteil ohne Nachkommastellen" oder als "Absolutwert".

6. Sie können über die Eigenschaft "Explosions-Distanz" eine Distanz für die Trichterabschnitte angeben.

7. Auf der Registerkarte "Diagramm" wählen Sie die allgemeinen Diagrammoptionen. Ihnen stehen u.a. folgende Eigenschaften zur Verfügung:

▪ Relative Breite des Trichteranfangs / des Trichterendes.

▪ Farbmodus, z.B. einfarbig

8. Auf der Registerkarte "Diagrammbereich" wählen Sie die allgemeinen Layoutoptionen des gesamten Objekts. Hier stehen u.a. folgende Eigenschaften zur Verfügung:

▪ Überschrift

▪ Hintergrund inkl. Füllung, Rand und Schatten, z.B. Rand = transparent

9. Auf der Registerkarte "Farben" können Sie die Farbdarstellung bestimmen.

Abbildung 6.17: Vertikaler Trichter

Abbildung 6.18: Horizontaler Trichter (Pipeline)


Landkarte/Shapefile

Shapefiles ermöglichen verschiedenste Visualisierungsmöglichkeiten über ein standardisiertes Vektorbeschreibungsformat. Über entsprechende Vorlagen können verschiedenste Landkarten, Sitzpläne oder Grundrisse ausgegeben werden. Das Shapefile bestimmt die Form und eine zugehörige Attributsdatenbank ermöglicht einen Bezug der Shapes zu den Eigenschaften (z.B. Ländername).

Hinweis: Die Verfügbarkeit dieses Diagramms hängt von der Anwendung ab.

Beispiel: Für die Erde soll eine Temperaturverteilungsvisualisierung erstellt werden.

Abbildung 6.19: Temperaturverteilungsvisualisierung

Gehen Sie wie folgt vor:

1. Wählen Sie als Datenquelle die Tabelle "ClimateData".

2. Wählen Sie als Diagrammtyp Landkarte/Shapefile. Daraufhin erscheint ein Auswahldialog für die mitgelieferten Shapefile-Vorlagen. Wählen Sie "Welt mit Ozeanen und Seen" aus.

Abbildung 6.20: Vorlagenauswahl

3. Auf der Registerkarte "Shapefile-Auswahl" sehen Sie nun das vorkonfigurierte Daten-Shapefile. Neben den eigentlichen Daten können Sie auch Vordergrund- und Hintergrundshapefiles auswählen um z.B. die Meere in den Hintergrund und die Flüsse und Seen in den Vordergrund zu legen.

Abbildung 6.21: Shapefile-Auswahl

4. Wechseln Sie auf die Registerkarte "Zuordnung" um die Daten mit den Umrissen zu verknüpfen.

Abbildung 6.22: Zuordnung

Verknüpfen Sie den Koordinatenwert "ISO_CODES" aus den Daten mit dem Attribut "iso_a3" aus dem Shapefile. Somit werden die Daten, die z.B. zu 'DEU' gehören mit dem Umriss von 'DEU' verknüpft, die Temperatur von 'Deutschland' gehört zu 'Deutschland' usw.

5. Wechseln Sie auf die Registerkarte "Wert" und wählen Sie als "Wert" die mittlere Temperatur, also das Feld "ClimateData.Tmean".

6. Wechseln Sie auf die Registerkarte "Farben" um die Legende zu definieren. Definieren Sie als obersten Eintrag die Farbe über die Funktion HeatmapColor(LL.ChartObject.AxisCoordinate,-20,40) und setzen Sie die Bedingung auf "True". Somit wird der Wert für die tatsächliche Einfärbung verwendet und Sie erhalten eine kontinuierliche Einfärbung.

7. Für die weiteren diskreten Legendenwerte geben Sie die jeweilige Funktion an, z.B. HeatmapColor(5,-20,40) mit Legendentext "5°" und setzen die Bedingung auf "False". Somit wird der Wert nur für die Legende verwendet.

Abbildung 6.23: Farben


Werte über Reihen bestimmen

Die Werte der Reihenachse (y-Achse) können bei dreiachsigen Diagrammen auch über Reihen bestimmt werden. Damit definieren Sie die verschiedenen Reihen (z.B. Messwert/Sollwert/Istwert) mit einem einzigen Datensatz und können diese z.B. in einem Balkendiagramm parallel darstellen.

Als Beispiel erstellen wir ein Diagramm, das die Währungsanteile der 3 Wirtschaftsräume darstellt. Die Daten der APAC, EMEA und NAFTA werden als Reihen geliefert.

Abbildung 6.24: Beispiel für ein Reihendiagramm

Gehen Sie wie folgt vor:

1. Wählen Sie als Datenquelle die Tabelle "Sales".

2. Wählen Sie als Diagrammtyp Balken/Band > gestapelt relativ

3. Bestimmen Sie zuerst den Koordinatenwert der Rubrikenachse, d.h. den Wert der x-Achse. Wählen Sie über den Formel-Assistenten das Feld "Sales,Year". Über die Formel "Str$(Sales.Year,0,0)" entfernen Sie die 2 Nachkommastellen.

4. Bestimmen Sie den Koordinatenwert der Reihenachse, d.h. den Wert der y-Achse. Wechseln Sie über die Combobox oberhalb der Eigenschaftsliste zum Eintrag "Werte über Reihen bestimmen".

Abbildung 6.25: Auswahlliste für die Werte-Bestimmung über Reihen

Damit ändern sich die Eigenschaften der Reihenachse und es steht über die Eigenschaft "Reihendefinitionen" ein Dialog zur Definition der Reihen zur Verfügung. Erstellen Sie die einzelnen Reihen und wählen Sie jeweils als Koordinatenwert das Feld "Sales.APAC", "Sales.EMEA" bzw. "Sales.NAFTA" aus.

Abbildung 6.26: Dialog zur Reihendefinition

5. Über die Eigenschaft "Berechnungsart" können sie eine Aggregation wählen, um z.B. einen gleitenden Mittelwert darzustellen.


Diagrammtypen mischen

Sie können Balken- mit Liniendiagrammen vermischen. Neben der Möglichkeit, parallel zu den Balken eine andere Datenreihe als Linie auszugeben, können Sie auch Berechnungsmöglichkeiten wie gleitende Durchschnitte und Aggregations-Möglichkeiten nutzen. Damit sehen Sie auf den ersten Blick Gesamtumsätze, Trends in den Daten oder auch Datenausreißer nach oben oder unten.

Beispiel: Mittelswertgerade.mit Balkendiagramm (Umsatz pro Land) mischen

1. Wählen Sie als Datenquelle die Tabelle "Customers > Orders > Order Details".

2. Wählen Sie als Diagrammtyp Balken/Band > gruppiert

3. Bestimmen Sie zuerst den Koordinatenwert der Rubrikenachse. Wählen Sie über den Formel-Assistenten das Feld "Customers.Country".

4. Bestimmen Sie nun den Koordinatenwert der Reihenachse. Wechseln Sie über die Combobox oberhalb der Eigenschaftsliste zum Eintrag "Werte über Reihen bestimmen".

Abbildung 6.27: Auswahlliste für die Werte-Bestimmung über Reihen

Damit ändern sich die Eigenschaften der Reihenachse und es steht über die Eigenschaft "Reihendefinitionen" ein Dialog zur Definition der Reihen zur Verfügung.

5. Definieren Sie eine neue Reihe "Einzelumsätze" und berechnen Sie den Umsatz über die Formel "Sum(Order_Details.Quantity * Order_Details.UnitPrice)" mit Berechnungsart "normal" und Darstellung "Zylinder".

6. Definieren Sie eine weitere Reihe "Mittelwert" und berechnen Sie den Umsatz über die Formel "Sum(Order_Details.Quantity * Order_Details.UnitPrice)" mit Berechnungsart "Mittelwert" und Darstellung "Linie".

Abbildung 6.28: Reihendefinition

7. Im Ergebnis erhalten Sie Umsatzauswertung mit einer Mittelwertgeraden:

Abbildung 6.29: Mittelwertgerade

8. Bei Berechnungsart "Ausgleichsgerade" erhalten Sie eine Trendlinie:

Abbildung 6.30: Ausgleichsgerade


Checkbox erstellen

Zur Darstellung von Boolean-Werten bieten sich Checkboxen an. Angenommen Sie möchten die Verfügbarkeit eines Produkts visualisieren oder das Ergebnis einer sonstigen beliebigen Bedingung (wahr, falsch). Dann können Sie dies mit einer Checkbox realisieren. Zur Auswahl stehen eine Vielzahl verschiedener Grafiken, zudem können Sie auch eigene Dateien einbinden.

Abbildung 6.31: Checkbox zur Darstellung von Ja/Nein

Siehe auch:


Eine Checkbox einfügen

Sie haben verschiedene Möglichkeiten Datengrafiken auszugeben:

1. Eine Checkbox als Objekt. Wählen Sie Einfügen > Datengrafik (Objekte > Einfügen > Checkbox) und ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf.

2. Eine Checkbox kann in einer Tabellenzelle ausgegeben werden. Wählen Sie dazu im Tabellen-Objektdialog über das Kontextmenü den Eintrag "Checkbox" aus.

Abbildung 6.32: Checkbox in einer Tabellenspalte


Eigenschaften bestimmen

1. Über die Eigenschaft "Inhalt" geben Sie das Feld oder die Formel an, die das Aussehen der Checkbox bestimmt.

2. Wählen Sie die Darstellung für 'Wahr', d.h. wenn die Berechnung der Inhaltsformel 'wahr' ergibt. Wählen Sie eine der internen Grafiken oder bestimmen Sie eine externe Grafik. Bei internen Grafiken können die Rahmenfarbe und die Iconfarbe über Auswahllisten anpassen.

3. Wählen Sie dann die Darstellung für 'Falsch' und 'NULL', also für eine undefinierten Wert.

Siehe auch Kapitel Übersicht der Eigenschaften.


Datengrafik erstellen

Angenommen, Sie haben eine Datenreihe zu den Verkaufszahlen Ihrer Produkte im Zeitraum eines Jahres in einer Tabelle erstellt. Und jetzt wollen Sie direkt daneben das dazugehörige Diagramm platzsparend einbinden. Oder Sie möchten die Kundenbewertung eines Produkts als Symbol darstellen. Genau das geht mit einer Datengrafik. Diese einfachen Diagramme stellen ganze Datenreihen oder Istwerte in einer einzigen Zelle dar. So überblicken Sie schnell die Entwicklung Ihrer Daten. Zur Auswahl stehen Balkengrafiken und Symbole (z.B. Pfeile, Sterne, Ampeln).

Abbildung 6.33: Datengrafik mit Symbolen

Abbildung 6.34: Datengrafik mit Balken

Siehe auch:

Eine Datengrafik einfügen

Werte bestimmen

Balken definieren

Symbol definieren


Eine Datengrafik einfügen

Sie haben verschiedene Möglichkeiten Datengrafiken auszugeben:

1. Eine Datengrafik als Objekt. Wählen Sie Einfügen > Datengrafik (Objekte > Einfügen > Datengrafik) und ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf.

2. Eine Datengrafik kann in einer Tabellenzelle ausgegeben werden. Wählen Sie dazu im Tabellen-Objektdialog über das Kontextmenü den Eintrag "Datengrafik" aus. Wenn Sie aggregierte Daten ausgeben möchten, bietet sich die Ausgabe in einer Fußzeile an.

Abbildung 6.35: Datengrafik in einer Tabellenspalte


Werte bestimmen

Auf der Registerkarte "Allgemein" bestimmen Sie zunächst den Wert der in der Datengrafik dargestellt wird. Dieser bestimmt die Balkenlänge bzw. die Darstellung des Symbols.

Der Minimal- und Maximalwert bezieht sich dabei auf die untere und obere Grenze der Darstellung, d.h. der Minimalwert entspricht 0% bei Prozent-Skalierung und der Maximalwert entspricht 100% bei Prozent-Skalierung. Die Skalierung wird über die jeweilige Eigenschaft "Teilbereiche" bestimmt.

Abbildung 6.36: Werte der Datengrafik


Balken definieren

Auf der Registerkarte "Balken" definieren Sie eine Balkengrafik. Hier stehen u.a. folgende Eigenschaften zur Verfügung:

§ Ausrichtung: wenn Sie "von der Basislinie ausgehend nach links oder rechts" wählen, kann ein Basiswert vorgegeben werden, in dessen Abhängigkeit der Balken nach links oder rechts angezeigt wird. Hier könnte die Precalc()-Funktion nützlich sein.

§ Abrundung, Balkenhöhe

§ Teilbereiche: Definieren Sie über einen Start- und Endwert verschiedene Bereiche um die Farben der Balkenabschnitte zu definieren.

Siehe auch Kapitel Übersicht der Eigenschaften.

Abbildung 6.37: Balken-Eigenschaften


Symbol definieren

Auf der Registerkarte "Symbol" definieren Sie die Symbole.

Abbildung 6.38: Symbol-Eigenschaften

Hier stehen u.a. folgende Eigenschaften zur Verfügung:

§ Zur Auswahl stehen verschiedene Symbolgruppen, wie z.B. Sterne, Pfeile, Ampeln und Balkendiagramme.

§ Symbol-Höhe

§ Teilbereiche: Definieren Sie über einen Start- und Endwert verschiedene Bereiche um das anzuzeigende Symbol dieser Symbolgruppe zu definieren.

Siehe auch Kapitel Übersicht der Eigenschaften.


Messinstrument erstellen

Zur Darstellung von Istwerten bieten sich Messinstrumente an.

Nehmen wir an, Sie möchten den aktuellen Umsatz im Verhältnis zum Zielwert ausgeben. Dann ist ein Messinstrument die erste Wahl. An diesem können Sie direkt den Wert ablesen.

Siehe auch:


Ein Messinstrument einfügen

Sie haben verschiedene Möglichkeiten Messinstrumente auszugeben:

1. Ein Messinstrument als Objekt. Wählen Sie Einfügen > Messinstrument (Objekte > Einfügen > Messinstrument) und ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf.

2. Messinstrumente können in einer Tabellenzelle ausgegeben werden. Wählen Sie dazu im Tabellen-Objektdialog über das Kontextmenü den Eintrag "Messinstrument" aus. Wenn Sie aggregierte Daten ausgeben möchten, bietet sich die Ausgabe in einer Fußzeile an.

Abbildung 6.39: Messinstrument-Objekt in einer Fußzeile


Eigenschaften bestimmen

1. Wählen Sie Typ, Form, Schatten und Zeigerform des Instruments über die Auswahllisten.

2. Über die Eigenschaft "Wert" bestimmen Sie den Wert den der Zeiger anzeigen soll, z.B. Umsatz oder Rating des Kunden. Hier könnte die Precalc()-Funktion nützlich sein.

3. Außerdem stehen Ihnen u.a. noch folgende Layoutoptionen zur Verfügung:

§ Erscheinungsbild: Füllung, Zeigeroptionen, Glaseigenschaften.

§ Beschriftung: Rotationswinkel, Anfangs- und Endabstand des Skalenbereichs, Skalenmarkierungen, Skalenbeschriftung, Signalbereiche, Textfelder

§ Werte: Minimal- und Maximalwert der Skala

Siehe auch Kapitel Übersicht der Eigenschaften.

Abbildung 6.40: Eigenschaften des Messinstruments

4. Ändern Sie den Signalbereich-Anfangs – und Endabstand auf 25% bzw. 15%.

5. Bestimmen Sie z.B. die Einfärbung des Signalbereichs um den optimalen Bereich zu signalisieren.

Abbildung 6.41: Messinstrument mit farbigen Signalbereichen

Setzen Sie dazu die Eigenschaft "Signalbereiche" auf "Anzeigen" und öffnen Sie über die "..." – Schaltfläche den Dialog zur Definition der Bereiche. In diesem Dialog erstellen Sie über die "Neu"-Schaltfläche die jeweiligen Bereiche mit Start- und Endwert und weisen die gewünschte Farbe zu.

Abbildung 6.42: Dialog zur Signalbereichsdefinition

6. Auf die gleiche Weise können Sie auch Textbereiche definieren, d.h. Sie können beliebige Texte an beliebigen Positionen ausgeben.

Abbildung 6.43: Messinstrument mit Textbereich

Setzen Sie dazu die Eigenschaft "Textfelder" auf "Anzeigen" und öffnen Sie über die "..." – Schaltfläche den Dialog zur Definition der Bereiche. In diesem Dialog erstellen Sie über die "Neu"-Schaltfläche die jeweiligen Bereiche mit Position, Drehung, Rahmengröße, Hintergrund, Schrift und Formatierung. Die Position wird dabei in Prozent relativ zur Fläche des Messinstruments angegeben (gemessen von links bzw. oben). D.h. eine vertikale und horizontale Position von jeweils 50% positioniert das Textfeld genau in die Mitte.

Abbildung 6.44: Dialog zur Textbereichsdefinition


Kreuztabelle erstellen

Eine Kreuztabelle dient der Auswertung und Darstellung von Daten in mehreren Dimensionen. Kreuztabellen (auch: Kontingenztafeln) sind somit Tabellen, die die Häufigkeiten von Kombinationen bestimmter Merkmalsausprägungen enthalten.

Diese Häufigkeiten werden ergänzt durch deren Randsummen, die die sogenannten Randhäufigkeiten bilden. Für eine dreidimensionale Kreuztabelle (drei Merkmale) fügt man eine zusätzliche Spaltengruppierung in die Tabelle ein.

Sie können somit z.B. Umsatzverläufe pro Jahr und Region untersuchen, Auswertung der Verkäufe nach Stückzahlen und Kunden, wobei Sie dann Randsummen nach Quartalen und Jahren bilden können.

Im Gegensatz zu einer normalen ("flachen") Tabelle, die in der 1. Zeile Attributbezeichnungen und in allen weiteren Zeilen Ausprägungen dieser Attribute besitzt, enthalten in einer Kreuztabelle sowohl Zeilen- als auch Spaltenüberschriften Merkmalsausprägungen und am Schnittpunkt der entsprechenden Spalte und Zeile wird ein Wert dargestellt, der von den in der jeweiligen Spalte und Zeile angegebenen Merkmalen abhängt.

Abbildung 6.45: Beispiel für eine dreidimensionale Kreuztabelle

Zur grafischen Darstellung zweidimensionaler Kreuztabellen bieten sich gruppierte 3D Balkendiagramme an. Weitere Informationen dazu finden Sie im Kapitel Diagramm erstellen.

Siehe auch:

Ein Kreuztabellenobjekt einfügen

Die Gruppierungen definieren

Die Zelleneigenschaften definieren

Die Layout-Optionen und das Umbruchverhalten

Spezielle Funktionen


Ein Kreuztabellenobjekt einfügen

Nehmen wir an, Sie möchten den Umsatzverlauf pro Jahr, Quartal und Land untersuchen. Gehen Sie wie folgt vor:

1. Die Kreuztabelle ist ein Element im Berichtscontainer, daher fügen Sie dieses Objekt über das Toolfenster "Objekte" ein. Wenn noch kein Berichtscontainer im Arbeitsbereich platziert wurde, wählen Sie Einfügen > Berichtscontainer (Objekte > Einfügen > Berichtscontainer) und ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf.

2. Alternativ kann – sofern von der Anwendung unterstützt - eine Kreuztabelle auch direkt als Objekt platziert werden. Wählen Sie Einfügen > Kreuztabelle (Objekte > Einfügen > Kreuztabelle) und ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf.

3. Daraufhin erscheint ein Auswahldialog für das gewünschte Element. Wählen Sie das Element "Kreuztabelle" aus.

4. Im folgenden Dialog wählen Sie nun die Datenquelle aus. Es werden alle zur Verfügung stehenden Tabellen hierarchisch angezeigt, d.h. unter den Tabellen finden Sie die jeweils relational verknüpften Tabellen.

Für unsere Umsatzauswertung wählen Sie die Tabelle "Customers > Orders > Order Details" damit Sie alle 3 Tabellen zur Verfügung haben. In der Tabelle "Customers" ist das Land enthalten, in der Tabelle "Orders" das Bestelldatum und in der Tabelle "Order_Details" der Umsatz.

5. Daraufhin erscheint ein Assistent, der Sie durch die 3 Konfigurationsdialoge des Kreuztabellen-Objekts führt.


Die Gruppierungen definieren

Im ersten Dialog des Assistenten bzw. auf der Registerkarte "Achsendefinition" bestimmen Sie zunächst die Gruppierungen für die Zeilen und Spalten, also die Merkmale.

1. Klicken Sie im Bereich "Zeilen" auf die Schaltfläche "Eine Zeilengruppierung einfügen".

2. Im Formel-Assistenten geben Sie nun das Feld oder den Ausdruck für die Zeilengruppierung an, z.B. Customers.Country. Damit ist die Zeilengruppierung erstellt und die Daten werden nach diesem Merkmal gruppiert.

3. Klicken Sie im Bereich "Spalten" auf die Schaltfläche "Eine Spaltengruppierung einfügen".

4. Im Formel-Assistenten geben Sie nun das Feld oder den Ausdruck für die Spaltengruppierung an.

Da Sie die Daten zunächst nach dem Jahr der Bestellung gruppieren möchten, geben Sie hier einen Ausdruck an, der Ihnen das Jahr des Bestelldatums liefert. Im Formel-Assistenten steht Ihnen dafür die Funktion Year() zur Verfügung, d.h. Sie wählen diese in der Liste der Funktionen per Doppelklick aus und fügen als Parameter das Bestelldatum ein. Die Formel sieht dann so aus: Year(Orders.OrderDate).

5. Da wir die Daten noch nach einer weiteren Dimension auswerten möchten, fügen Sie nun über die Schaltfläche "Eine Spaltengruppierung einfügen" eine zusätzliche Spaltengruppierung ein.

6. Hier geben Sie nun einen Ausdruck an, der Ihnen das Quartals-Argument des Bestelldatums liefert. Im Formel-Assistenten steht Ihnen dafür die Funktion Quarter() zur Verfügung. Die Formel sieht dann z.B. so aus: Quarter(Orders.OrderDate).

Hinweis: Über die Pfeil-Schaltflächen kann die Reihenfolge der Gruppierungen geändert werden. Die unterste Spalte ist die innerste Gruppierung. Um Zeilen und Spalten zu tauschen (Pivot-Funktion) verwenden Sie auf der Registerkarte "Achsendefinition" die Schaltfläche rechts unten. Diese Schaltfläche steht Ihnen nur im Objekt-Dialog und nicht im Assistent zur Verfügung,

Abbildung 6.46: Alle Spalten und Zeilen vertauschen

7. Damit sind die Gruppierungen erstellt und Sie können den Wert für den Schnittpunkt der entsprechenden Spalten und Zeilen definieren. Klicken Sie im Bereich "Wert der Ergebniszellen" auf die Schaltfläche "Bearbeiten".

8. Im folgenden Dialog "Zelleninhalte" wählen Sie nun die gewünschte Aggregatsfunktion für den Inhalt aus. Da Sie eine Umsatzauswertung erstellen möchten wählen Sie die Aggregatsfunktion "Summe". Im oberen Teil des Dialogs können Sie dann den Inhalt bestimmen, indem Sie über die Formel-Schaltfläche den Formel-Assistenten aufrufen.

9. Der Umsatz pro Bestellung wird in der Beispielanwendung nicht direkt als Feld geliefert, daher müssen Sie diesen über die Formel "Order_Details.Quantity * Order_Details.UnitPrice" berechnen.

Abbildung 6.47: Achsendefinition einer dreidimensionalen Kreuztabelle


Die Zelleneigenschaften definieren

Im zweiten Dialog des Assistenten bzw. auf der Registerkarte "Zellendefinition" bearbeiten Sie die Eigenschaften der verschiedenen Zellen.

Sie können die Zellen direkt in der Skizze im oberen Bereich des Dialogs selektieren und anschließend deren Eigenschaften bearbeiten. Um mehrere Zellen zu selektieren, halten Sie die Strg-Taste gedrückt oder ziehen mit der Maus einen Rahmen um die Zellen.

1. Angenommen die Länder sollen nicht alphabetisch aufgelistet sein, sondern absteigend nach dem Umsatz. Selektieren Sie dazu die entsprechende Zeilenüberschrift (hier: Germany) und wählen Sie dann für die Eigenschaft "Sortierung" den Eintrag "Ergebnis absteigend". In Kombination mit der Eigenschaft "Beschränken auf" erhalten Sie damit eine Top-N-Auswertung.

2. Sie möchten als Spaltenbeschriftung anstelle der reinen Quartalszahl ein "Q" voranstellen. Selektieren Sie dazu die entsprechende Spaltenüberschrift und doppelklicken Sie dann auf die Eigenschaft "Dargestellter Inhalt". Über diese Eigenschaft können Sie nun den Text bestimmen, der in dieser Zelle dargestellt werden soll (unabhängig vom Wert, den Sie für diese Spaltengruppierung definiert haben).

Im Formel-Assistenten definieren Sie nun eine entsprechende Formel, also z.B. "Q " + Str$(Quarter(Orders.OrderDate)).

3. Alternativ nutzen Sie die Eigenschaft "Formatierung". Dann entfernen Sie im Feld "Dargestellter Inhalt die Quarter$()-Funktion (d.h. im Feld steht nur noch das Datumsfeld) und formatieren den Wert dann direkt über die Eigenschaft.

Abbildung 6.48: Zellendefinition der Kreuztabelle

Doppelklicken Sie dafür auf die Eigenschaft "Formatierung", wählen dann als Formatierungsart "Datum" und anschließend über die Auswahlliste den Eintrag "benutzerdefiniert" aus. Am Ende der Liste finden Sie ein Beispiel für eine Quartalsformatierung mit Jahreszahl. Da wir die Jahreszahl nicht benötigen kürzen Sie die Formatierungszeichenkette auf "Q%q".

4. Somit ist diese Zelle formatiert und Sie können nun alle anderen Zellen ebenfalls formatieren. Es stehen Ihnen u.a. folgende Eigenschaften zur Verfügung:

§ Drehung des Inhalts in 90°-Schritten

§ Hintergrund

§ Rahmen

§ Schrift

§ Ausrichtung vertikal und horizontal

§ Maximalbreite, Mindestbreite und Mindesthöhe

§ Siehe auch Kapitel Übersicht der Eigenschaften.


Die Layout-Optionen und das Umbruchverhalten

Im dritten Dialog des Assistenten bzw. auf der Registerkarte "Eigenschaften" bearbeiten Sie die Layout-Eigenschaften und legen das Umbruchverhalten fest.

Abbildung 6.49: Eigenschaften der Kreuztabelle

Es stehen Ihnen u.a. folgende Layout-Eigenschaften zur Verfügung:

§ Hintergrund

§ Rahmen-Voreinstellung

§ Mindestgröße (%) und Mindesthöhe (mm)

Außerdem können Sie das Umbruchverhalten für Spalten und Zeilen bestimmen, denn häufig sind Kreuztabellen breiter und höher als das festgelegte Seitenformat. Es werden so viele Seiten (Schattenseiten) erzeugt, wie notwendig sind. Die Zeilenbezeichner werden dabei standardmäßig auf allen Seiten wiederholt, während die Spaltenbezeichnungen nicht wiederholt werden.

Es stehen Ihnen u.a. folgende Umbruch-Eigenschaften zur Verfügung:

§ Bezeichner wiederholen: Gibt an, ob die Spalten- bzw. Zeilenbeschriftung bei einem Umbruch erneut gedruckt werden soll.

§ Umbruchebene: Gibt die optimale Umbruchebene an, also z.B. "0". Dies entspricht der untersten Gruppe, also z.B. das Quartal.

§ Spalten > Umbruch auf Schattenseiten: Wenn die Kreuztabelle in horizontaler Richtung zu groß wird, werden die Umbruchstücke auf Schattenseiten gedruckt. Eine Schattenseite wird nicht als "echte" Seite gezählt, erhält also auch keine Seitennummer. In der Voreinstellung werden die Umbruchstücke unterhalb der Tabelle ausgegeben.

Siehe auch Kapitel Übersicht der Eigenschaften.


Spezielle Funktionen

In Kreuztabellen stehen Ihnen zusätzliche Funktionen zur Verfügung:

§ Crosstab.Value() gibt den Inhalt der Zelle (als Zahl) zurück.

§ Crosstab.Cells.Avg() liefert den Durchschnittswert der Datenmenge zurück.

§ Crosstab.Cells.Sum() gibt die Summe der Zelleninhalte (pro Gruppe) zurück.

§ Crosstab.Col$() bzw. Crosstab.Row$() liefert den Spalten- bzw. Zeilenbeschreibungstext für die aktuelle Zelle zurück.

Damit könnten Sie z.B. dem Hintergrund einer Spalte oder Reihe eine bestimmte Farbe zuweisen. Im folgenden Beispiel wird die Hintergrundfarbe aller Zellen einer Reihe auf Orange gesetzt, wenn der Zeilenbezeichner "Germany" lautet:

Cond(Crosstab.Row$()="Germany",LL.Color.Orange,LL.Color.White)

Abbildung 6.50: Eine bestimmte Reihe einfärben

§ Crosstab.Cells.Max() bzw. Crosstab.Cells.Min() liefert den größten bzw. kleinsten Wert der gesamten Kreuztabelle zurück. Damit können Sie z.B. den größten oder kleinsten Wert der Datenmenge besonders hervorheben oder damit Berechnungen durchführen. Im folgenden Beispiel wird die Hintergrundfarbe der Zelle mit dem größten Wert auf Grün gesetzt:

Cond(Crosstab.Value=Crosstab.Cells.Max(),LL.Color.Green,

Cond(Crosstab.Row$()="Germany",LL.Color.Orange,LL.Color.White))

Abbildung 6.51: Eine bestimmte Zelle einfärben

§ Crosstab.Col() bzw. Crosstab.Row() liefert den Spalten- bzw. Zeilenindex für die aktuelle Zelle zurück. Damit können Sie z.B. die Hintergrundfarbe jeder zweiten Zeile besonders hervorheben und somit ein Zebramuster erzeugen. Beispiel: Cond(Odd(Crosstab.Row()),LL.Color.LightGray,LL.Color.White)

Abbildung 6.52: Ein Zebramuster erzeugen

§ Join$() gibt die gesammelten Zeichenketten zurück, getrennt durch ein Trennzeichen. Damit könnten Sie z.B. zusätzlich zum Gesamtumsatz die Einzelumsätze ausgeben. Beispiel:

Fstr$(Sum(Order_Details.Quantity*Order_Details.UnitPrice),"-##,###,###") + "¶["+ Join$(Fstr$(Sum(Order_Details.Quantity*Order_Details.UnitPrice),"-##,###,###"))+"]"

Abbildung 6.53: Detaildaten anzeigen

§ Total() kann für Berechnungen über alle Zellen hinweg benutzt werden. Sonst laufen Berechnungen immer über alle Werte, die die jeweilige Zelle betreffen.

Siehe auch Kapitel Übersicht der Funktionen.


Gantt-Diagramm erstellen

Dieser Diagrammtyp erlaubt die grafische Darstellung von Aktivitäten ("Vorgängen") in ihrer zeitlichen Abfolge auf einer Zeitachse.

Die einzelnen Aktivitäten werden in Zeilen mit einem waagerechten Balken visualisiert. Je länger der Balken, desto länger dauert die Aktivität. Sich überschneidende Aktivitäten werden durch überlappende Balken dargestellt. Die Balken können flexibel konfiguriert werden, u.a. mit frei definierbaren Farbbereichen.

Siehe auch:


Ein Gantt-Diagramm einfügen

Nehmen wir an, Sie möchten das Pollenaufkommen im Jahresverlauf darstellen. Über eine farbliche Kennzeichnung soll schwaches, mäßiges und starkes Vorkommen signalisiert werden.

Abbildung 6.54: Pollenvorkommen als Gantt-Diagramm

Gehen Sie wie folgt vor:

1. Das Gantt-Diagramm ist ein Element im Berichtscontainer, daher fügen Sie dieses Objekt über das Toolfenster "Objekte" ein. Wenn noch kein Berichtscontainer im Arbeitsbereich platziert wurde, wählen Sie in der Registerkarte "Einfügen" den Objekt-Typ "Berichtscontainer" und ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf.

2. Alternativ kann – sofern von der Anwendung unterstützt – ein Gantt-Diagramm auch direkt als Objekt platziert werden. Wählen Sie Einfügen > Gantt-Diagramm (Objekte > Einfügen > Gantt-Diagramm ) und ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf.

3. Daraufhin erscheint ein Auswahldialog für das gewünschte Element. Wählen Sie das Element "Gantt-Diagramm" aus.

4. Im folgenden Dialog wählen Sie nun die Datenquelle aus. Es werden alle zur Verfügung stehenden Tabellen hierarchisch angezeigt, d.h. unter den Tabellen finden Sie die jeweils relational verknüpften Tabellen. Wählen Sie die Tabelle "Pollen".

5. Daraufhin erscheint der Eigenschaftsdialog des Gantt-Diagramms.


Eigenschaften bestimmen

Im Bereich "Feldzuordnungen" bestimmen Sie zunächst die Gruppierungen für die Zeilen und Spalten, also die Vorgänge und die Zeitachse.

Bitte beachten: In einem Gantt-Diagramm können keine Aggregatsfunktionen oder LL.Fcount…-Felder verwendet werden.

1. Wählen Sie als Sammelvorgangsname im Formel-Assistenten das Feld "PollenDescriptionDE". Der Sammelvorgangsname definiert einen übergeordneten Vorgang, bei Projekten z.B. Hauptprojekt und Unterprojekte. Sofern Sie keine Sammelvorgänge anzeigen möchten, geben Sie an dieser Stelle den gleichen Wert wie bei "Vorgangsname" an.

Bitte beachten: Ein Sammelvorgang muss immer ein echter Datensatz sein, der entweder aus der "Basistabelle" kommen kann oder aber aus der Tabelle, auf der das Gantt-Diagramm selbst basiert.

2. Wählen Sie als Vorgangsname im Formel-Assistenten das Feld "PollenDescriptionDE". Der Vorgangsname definiert den Vorgang, bei den Pollen z.B. Erle oder Hasel.

Bitte beachten: Bei mehreren Vorgängen für 1 Zeile (z.B. ein Urlaubsplan-Layout) müssen diese Datensätze hintereinander weg kommen, d.h. die Datensätze müssen sortiert sein.

3. Wählen Sie das Feld "PeriodBegin" für den Beginn des Vorgangs. Bei Sammelvorgängen (also z.B. Baum-Pollen) wird dieser automatisch auf den Beginn des ersten Vorgangs gesetzt.

Abbildung 6.55: Eigenschaften des Gantt-Diagramms

4. Wählen Sie das Feld "PeriodEnd" für das Ende des Vorgangs. Bei Sammelvorgängen (also z.B. Baum-Pollen) wird dieser automatisch auf das Ende des letzten Vorgangs gesetzt. Der Vorgang wird als Meilenstein interpretiert, wenn die Endzeit der Anfangszeit entspricht und die Dauer 0 ist.

5. Wählen Sie die Dauer eines Vorgangs in Tagen. In unserem Beispiel die Differenz von Beginn und Ende: DateDiff(Pollen.PeriodEnd,Pollen.PeriodBegin). Bei Sammelvorgängen wird dies automatisch durch die Tagesdifferenz berechnet.

6. Wählen Sie den Fortschritt eines Vorgangs, wenn dieser Wert angezeigt werden soll (z.B. bei einem Projektvorgang).

7. Im Bereich "Erscheinungsbild" haben Sie verschiedene Layout-Möglichkeiten:

§ Definieren Sie Hintergrund und Schrift von Titelzeile, Sammelvorgangszeile und Vorgangszeile.

Die Farbe des Balkens wird über die Eigenschaft "Vorgangszeilen > Balkeneigenschaften > Füllung unerledigt > Farbe" definiert. Um Bereiche unterschiedlich einzufärben, können Sie eine Formel definieren, z.B. Cond(Pollen.PeriodType=1,LL.Scheme.Color3,Cond(Pollen.PeriodType=2,LL.Scheme.Color8,LL.Color.Red))

§ Unter "Tabellenbereich" können Sie bestimmen, welche Werte zusätzlich in Spalten angezeigt werden sollen. Zur Auswahl stehen z.B. ein fortlaufender Index, der Vorgangsname, Vorgangsbeginn, Vorgangsdauer, Vorgangsende, Vorgangsfortschritt.

§ Unter "Diagrammbereich" definieren Sie den angezeigten Zeitbereich. Für unser Pollen-Diagramm wählen wir "Monate". Die übergeordnete Zeiteinheit ist "Jahre". Bei einem Projekt-Diagramm wäre z.B. die Zeiteinheit "Tage" und die übergeordnete Zeiteinheit wäre "Monate".

§ Siehe auch Kapitel "Übersicht der Eigenschaften".

8. Außerdem können Sie das Umbruchverhalten für Spalten und Zeilen bestimmen, denn häufig sind Gantt-Diagramme breiter als das festgelegte Seitenformat. Es werden so viele Seiten (Schattenseiten) erzeugt, wie notwendig sind. Die Zeilenbezeichner werden dabei standardmäßig auf allen Seiten wiederholt, während die Spaltenbezeichnungen nicht wiederholt werden.

Es stehen Ihnen u.a. folgende Umbruch-Eigenschaften zur Verfügung:

§ Umbruch auf Schattenseiten: Wenn das Gantt-Diagramm zu breit wird, werden die Umbruchstücke auf Schattenseiten gedruckt. Eine Schattenseite wird nicht als "echte" Seite gezählt, erhält also auch keine Seitennummer. In der Voreinstellung werden die Umbruchstücke unterhalb der Tabelle ausgegeben.

§ Bezeichner wiederholen: Gibt an, ob die Zeilenbeschriftung bei einem Umbruch erneut gedruckt werden soll.

§ Umbruch gleichmäßig: Gibt an, ob ein Umbruch wenn möglich an den Grenzen des übergeordneten Zeitintervalls (z.B. Monat) durchgeführt werden soll.


Aggregation / Statistiken

Das Aggregieren von Daten erfolgt idealerweise über die Aggregatsfunktionen, z.B. Sum(), Count(), Avg(). Diese verwenden Sie dann in Gruppenfußzeilen oder Fußzeilen und setzen die jeweilige Tabellenobjekt-Eigenschaft "Datenzeilen unterdrücken" auf "True", dadurch werden dann eben nur Fußzeilen/Gruppenfußzeilen angezeigt. Durch diese Option können Sie Summenzeilen ausgeben und dadurch interessante Statistiken erstellen.

Man darf dabei eben nicht die "Darstellungsbedingung" zum Ausblenden der Datenzeilen verwenden, denn dann wird auch nicht summiert oder sonst wie aggregiert. Bei Verwendung von Summenvariablen ist insbesondere die Option "Summierung forcieren" sehr nützlich damit Summen auch dann berechnet werden, wenn eine Datenzeile nicht gedruckt wird.

Nehmen wir an, Sie möchten den Umsatz pro Land ausgeben:

Abbildung 6.56: Statistiken mit Fußzeilen erstellen

Gehen Sie wie folgt vor:

1. Erstellen Sie im Berichtscontainer ein neues Element und wählen als Objekttyp "Tabelle".

2. Im folgenden Dialog wählen Sie nun die Datenquelle aus. Es werden alle zur Verfügung stehenden Tabellen hierarchisch angezeigt, d.h. unter den Tabellen finden Sie die jeweils relational verknüpften Tabellen.

Für eine Umsatzauswertung je Land wählen Sie z.B. die Tabelle "Orders > Order_Details" damit beide Tabellen zur Verfügung stehen. Die Tabelle "Customers" ist 1:1-relational mit der Tabelle "Orders" verknüpft, daher müssen Sie diese nicht auswählen. In der Tabelle "Order_Details" ist der Umsatz gespeichert.

Abbildung 6.57: Hierarchische Tabellen für Statistiken

3. In der Tabelle "Orders.Order_Details" erstellen Sie eine Datenzeile mit dem Feld "OrderID". Die Datenzeile wird zwar nicht ausgegeben (da wir sie unterdrücken), aber es wird ein Feld benötigt, damit die Tabelle überhaupt gedruckt wird.

4. Als Fußzeile definieren Sie die eigentliche Statistik, d.h. in der 1. Spalte den Ländernamen und in der 2. Spalte summieren Sie den Umsatz. Diesen berechnen Sie erneut über die Formel "Sum(Order_Details.Quantity * Order_Details.UnitPrice)".

5. In der Tabelle "Orders" erstellen Sie eine Datenzeile mit dem Feld "Country" aus der verknüpften Tabelle "Customers". Die Datenzeile wird zwar nicht ausgegeben (da wir sie unterdrücken), aber es wird ein Feld benötigt, damit die Tabelle überhaupt gedruckt wird

6. Als Fußzeile definieren Sie die Gesamtsumme über alle Länder, d.h. in der 1. Spalte den Text "Gesamt" und in der 2. Spalte summieren Sie erneut den Umsatz.

Abbildung 6.58: Fußzeilen für Statistik erstellen

7. Nun selektieren Sie im Toolfenster "Objekte" die Tabelle "Orders" und setzen die Eigenschaft "Datenzeilen > Datenzeilen unterdrücken" auf "Ja".

8. Selektieren Sie nun auch die Tabelle "Order_Details" und setzen auch hier die Tabellen-Eigenschaft "Datenzeilen > Datenzeilen unterdrücken" auf "Ja".

Abbildung 6.59: Datenzeilen unterdrücken für Statistiken

9. Die Statistik ist fertig (siehe Abbildung 6.56).


Drilldown Berichte (Detailtiefe erhöhen)

Als Drilldown wird die Navigation in hierarchischen Daten bezeichnet. Drilldown ermöglicht ein "Hineinzoomen", bei dem die vorhandenen Daten in unterschiedlicher Detailtiefe betrachtet werden können. Dazu werden verschiedene Druckvorlagen miteinander verknüpft.

Selbst bei sehr großen und komplexen Datenbeständen kann somit jeder schnell die gesuchte Information aufbereiten.

Es wird zunächst nur eine obere Ebene gedruckt (z.B. Kunden). Ein Klick auf einen Kunden öffnet dann einen neuen Detail-Bericht (z.B. Bestellungen).

Dieser Drilldown-Bericht kann dabei über das Kontextmenü entweder im gleichen Fenster geöffnet werden (Navigation über die Schaltflächen Eine Datei zurück bzw. Eine Datei vor im Vorschaufenster), in einem neuen Tab oder in einem neuen Tab im Hintergrund.

Die Drilldown-Funktionalität steht nur in der Vorschau zur Verfügung. Aus der Vorschau heraus kann dann jeder Drilldown-Bericht in andere Formate, wie z.B. PDF exportiert werden.

Drilldown-Berichte die über Relationen erstellt wurden, können in die Vorschaudatei eingebettet werden, so dass sie komplett versendet oder gespeichert werden können. Die entsprechende Option "Drilldown-Berichte einbetten" finden Sie in den Projekt-Eigenschaften.

Eine Drilldown-Verknüpfung bezieht sich bei Tabellen entweder auf ein einzelnes Feld oder eine ganze Zeile, bei Diagrammen auf die einzelnen Balken/Segmente/Linien etc. Hinter jedes dieser Elemente kann auch eine ganze Reihe von Verknüpfungen gelegt werden, um zum Beispiel verschiedene Darstellungsarten für die Daten anzubieten.

Für Drilldown-Verknüpfungen stehen verschiedene Arten zur Verfügung:

§ Verknüpfung der Daten über Relationen (nur Tabellen)

§ Verknüpfung der Daten über Berichtsparameter (auch Diagramme, Kreuztabelle)

Hinweis: Eine weitere Drilldown-Variante für Tabellen bieten die ausklappbaren Bereiche. Damit werden die Unterelemente eines Elements beim Druck in die Vorschau zunächst nicht gedruckt, dafür erhält die Zeile selber ein Aufklapp-Symbol. Ein Klick darauf expandiert den Bereich für die entsprechende Zeile, man hat so eine Drilldown-Möglichkeit, ohne die aktuelle Vorschau zu verlassen und ohne dafür ein eigenes Projekt zu designen. Weitere Informationen dazu finden Sie im Kapitel Ausklappbarer Bereich.

Abbildung 6.60: Beispiel für einen Bericht mit geöffnetem Drilldown-Bericht

Siehe auch:


Drilldown über Relationen

Dieser Typ steht Ihnen nur bei hierarchischen Tabellen zur Verfügung. Die Verknüpfung verzweigt in einen Bericht, der auf Daten beruht, die mit der aktuellen Datenquelle des aktuellen Elements im Berichtscontainer verknüpft sind. Im Drilldown-Bericht stehen nur die Kind-Daten zur Verfügung.

Diese Art der Verknüpfung kann im Vergleich zur Verknüpfung mit Berichtsparametern zu einem Geschwindigkeitsgewinn führen.

Abbildung 6.61: Datenzeile mit zusätzlicher Spalte für eine Drilldown-Verknüpfung

Gehen Sie folgendermaßen vor um einen Drilldown-Bericht zu erstellen:

1. Wählen Sie Einfügen > Berichtscontainer (Objekte > Einfügen > Berichtscontainer). Ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf. Daraufhin erscheint ein Auswahldialog für den gewünschten Objekttyp. Wählen Sie den Objekttyp "Tabelle" aus.

2. Im folgenden Dialog wählen Sie nun die Datenquelle aus. Es werden alle zur Verfügung stehenden Tabellen hierarchisch angezeigt, d.h. unter den Tabellen finden Sie die jeweils relational verknüpften Tabellen.

Um im nächsten Schritt überhaupt einen Unterbericht per Drilldown öffnen zu können müssen Sie hier eine Tabelle auswählen die auch eine Untertabelle besitzt! In der Beispielanwendung wählen Sie z.B. die Tabelle "Customers" aus, da für diese eine Untertabelle "Orders" existiert.

3. Definieren Sie nun über den Assistenten die Spalten der Tabelle, also z.B. CustomerID, CompanyName, ContactName, City.

4. Im Objekt-Dialog der Tabelle definieren Sie dann zusätzlich noch eine Spalte für die Drilldown-Verknüpfung. Geben Sie als Inhalt den Text "Anzeigen..." an.

5. Über die Spalten-Eigenschaft "Drilldown-Verknüpfungen" öffnen Sie nun den Dialog zum Erstellen der Drilldown-Verknüpfungen.

6. Im folgenden Dialog legen Sie über die Schaltfläche "Neu" eine neue Drilldown-Verknüpfung an.

Abbildung 6.62: Dialoge zur Definition des verknüpften Drilldown-Berichts

7. Daraufhin erscheint ein Dialog über den Sie nun die Druckvorlage für den Unterbericht erstellen können. Wählen Sie die Option "ein neues Projekt anlegen" und geben Sie den Namen für die Druckvorlage an.

8. Es öffnet sich eine zweite Designerinstanz für die Erstellung der Druckvorlage. Gehen Sie nun wie gewohnt vor um diesen Unterbericht zu erstellen. D.h. Sie platzieren einen Berichtscontainer, wählen den Objekttyp "Tabelle", wählen als Datenquelle "Orders" und definieren nun diejenigen Spalten der Orders-Tabelle, die eben in diesem Bericht angezeigt werden sollen.

9. Nachdem Sie den Bericht fertig erstellt haben schließen Sie wieder diese 2. Instanz des Designers.

10. Zurück im Dialog "Drilldown-Verknüpfungen" definieren Sie nun noch die Eigenschaft "Menütext" für diese Verknüpfung. Wenn es mehrere Verknüpfungen gibt, wird dieser Text in einem Kontextmenü angezeigt. Falls der Text variabel ist (also z.B. "Diagramm für " + Customers.CompanyName), wird dieser auch als Tab-Titel verwendet, wenn mehrere Berichte im Vorschaufenster angezeigt werden.

11. Damit ist der Drilldown-Bericht erstellt und Sie können diesen in der Vorschau anzeigen lassen.


Drilldown über Berichtsparameter

Dieser Typ steht Ihnen bei Diagrammen, Kreuztabellen und hierarchischen Tabellen zur Verfügung. Die Verknüpfung verzweigt in einen Bericht mit Berichtsparametern. Der Wert der Parameter kann in den Eigenschaften der Verknüpfung vorgegeben werden. Im Drilldown-Bericht stehen alle Daten zur Verfügung.

Abbildung 6.63: Drilldown-Verknüpfung der Größenachse

Gehen Sie folgendermaßen vor um einen Drilldown-Bericht über Berichtsparameter zu erstellen:

1. Wählen Sie Einfügen > Berichtscontainer (Objekte > Einfügen > Berichtscontainer). Ziehen Sie im Arbeitsbereich mit gedrückter linker Maustaste das Objekt auf die gewünschte Größe auf. Daraufhin erscheint ein Auswahldialog für den gewünschten Objekttyp. Wählen Sie den Objekttyp "Diagramm" aus.

2. Im folgenden Dialog wählen Sie nun die Datenquelle aus. Es werden alle zur Verfügung stehenden Tabellen hierarchisch angezeigt, d.h. unter den Tabellen finden Sie die jeweils relational verknüpften Tabellen. In der Beispielanwendung wählen Sie z.B. die Tabelle "Categories" aus.

3. Im Objekt-Dialog des Diagramms definieren Sie ein einfaches Balken-Diagramm:

a. Rubrikenachse (x): das 1:1-Feld "CategoryName"

b. Größenachse (y): Sum(Order_Details.Quantity * Order_DetailsUnitPrice)

c. Diagramm: Ausrichtung rechts

4. Über die Größenachsen-Eigenschaft "Drilldown-Verknüpfungen" öffnen Sie nun den Dialog zum Erstellen der Drilldown-Verknüpfungen.

5. Im folgenden Dialog legen Sie über die Schaltfläche "Neu" eine neue Drilldown-Verknüpfung an bzw. es erscheint ein Dialog über den Sie nun die Druckvorlage für den Unterbericht erstellen können. Wählen Sie die Option "ein neues Projekt anlegen" und geben Sie den Namen für die Druckvorlage an.

Abbildung 6.64: Dialoge zur Definition des verknüpften Drilldown-Berichts

6. Es öffnet sich eine zweite Designerinstanz für die Erstellung der Druckvorlage. Gehen Sie nun wie gewohnt vor um diesen Unterbericht zu erstellen. D.h. Sie platzieren einen Berichtscontainer, wählen den Objekttyp "Tabelle", wählen als Datenquelle ebenfalls "Categories>Products>Order_Details" und definieren nun diejenigen Spalten der Tabelle, die in diesem Bericht angezeigt werden sollen.

a. Tabelle Categories: Eine Fußzeile mit 2 Spalten: Text "Gesamt" und eine Summenspalte "Sum(Order_Details.Quantity*Order_Details.UnitPrice)".

b. Tabelle Products: Eine Gruppenfußzeile gruppiert nach "Products.Pro-ductName" mit 3 Spalten: Sum(Order_Details.Quantity), 1:1-Feld ProductName, Sum(Oder_Details.Quantity*Order_Details.UnitPrice).

c. Tabelle Order_Details: Eine Datenzeile mit einer beliebigen Spalte. Bei dieser Tabelle setzen Sie die Eigenschaft "Datenzeilen unterdrücken" auf "Ja".

7. Nun erstellen wir den Berichtsparameter um die angezeigten Werte einzuschränken. Wählen Sie dazu Projekt > Berichtsparameter, klicken Sie auf "Einen Parameter einfügen" und vergeben Sie einen aussagekräftigen Namen, z.B. "Category". Alle anderen Eigenschaften sind bei einem Drilldown-Report nicht relevant.

Nähere Informationen zu Berichtsparametern finden Sie im Kapitel Berichtsparameter.

Abbildung 6.65: Liste der Berichtsparameter

8. Definieren Sie nun in der Eigenschaft "Datenfilter" der Tabelle "Categories" die entsprechende Formel für die Einschränkung der Daten.

Beachten Sie dabei die Hinweise im Kapitel Filter.

Abbildung 6.66: Formel für den Datenfilter

9. Nachdem Sie den Bericht fertig erstellt haben schließen Sie wieder diese 2. Instanz des Designers.

10. Zurück im Dialog "Drilldown-Verknüpfungen" definieren Sie nun noch den Berichtsparameter des Projekts, d.h. Sie geben für @Category das entsprechende 1:1-Feld "CategoryName" der Datenbank an.

11. Außerdem definieren Sie die Eigenschaft "Menütext" für diese Verknüpfung. Wenn es mehrere Verknüpfungen gibt, wird dieser Text in einem Kontextmenü angezeigt. Falls der Text variabel ist (also z.B. "Auswertung für " + CategoryName), wird dieser auch als Tab-Titel verwendet, wenn mehrere Berichte im Vorschaufenster angezeigt werden.

Abbildung 6.67: Berichtsparameter des Projekts und Menütext

12. Damit ist der Drilldown-Bericht erstellt und Sie können diesen in der Vorschau anzeigen lassen.

Abbildung 6.68: DrillDown-Bericht mit Berichtsparameter


Mehrspaltige Reports

Bei komplexen Projekten mit vielen verschiedenen Diagrammen kann es sinnvoll sein, diese über mehrere Spalten darzustellen.

Die dazu benötigte Eigenschaft "Spaltenzahl" steht Ihnen sowohl im Berichtscontainer-Objekt als auch in Tabellen zur Verfügung. Sie können bis zu 5 Spalten definieren, wobei der Berichtscontainer und die enthaltenen Tabellen eine unterschiedliche Spaltenanzahl erhalten können.

Hinweis: Beachten Sie auch die Hinweise zur Verwendung von 2 nebeneinander platzierten Berichtscontainer in Kapitel Mehrere Berichtscontainer.

Die Erstellung ist einfach:

1. Selektieren Sie das Objekt "Berichtscontainer" im Toolfenster "Objekte".

2. Setzen Sie die Objekt-Eigenschaft "Spaltenzahl" auf "2".

3. Wenn Sie einzelne Objekte selektieren stehen Ihnen dann noch diverse Eigenschaften zur Umbruchsteuerung zur Verfügung:

§ Spaltenwechsel vor: Vor Ausgabe dieses Objekts erfolgt ein Spaltenumbruch.

§ Spaltenwechselbedingung: Wenn in einer mehrspaltigen Tabelle das Ergebnis bei Ausgabe einer Datenzeile "True" ist, wird ein Spaltenumbruch ausgelöst. Tipp: Das Feld "LL.CurrentTableColumn" liefert den Index der aktuellen Spalte zurück.

§ (Seiten-) Umbruch vor: Vor Ausgabe des Objekts erfolgt ein Seitenumbruch. Bei mehreren mehrspaltigen Objekten wird nach einem Objekt automatisch ein Seitenumbruch ausgelöst, wenn sich die Spaltenanzahl der Objekte unterscheidet (z.B. 2-spaltige Tabelle gefolgt von einer 3-spaltigen Tabelle) und für das nachfolgende Objekt kein Platz mehr vorhanden wäre.

Abbildung 6.69: Mehrspaltiger Berichtscontainer


Funktionen für Fortgeschrittene

In diesem Kapitel beschäftigen wir uns mit Themen, die Sie wahrscheinlich eher selten nutzen. Trotzdem sind die Möglichkeiten der Objektverkettung und der Summen- und Benutzervariablen ein wichtiges und hilfreiches Werkzeug für anspruchsvolle Druckausgaben.

Siehe auch:

Objekte verketten

Filter

Summenvariablen

Benutzervariablen

Sammelvariablen

Projektbausteine

PDF-Seiten einfügen

HTML-Seiten einfügen

OLE-Dokumente einfügen

Vorlagenobjekte einfügen


Objekte verketten

Über das Verketten von Objekten können Sie bewirken, dass manche Objekte zeitlich nachgeordnet zu anderen Objekten gedruckt werden und diese im Überlappungsfall überlagern ("zeitliche Verkettung"), oder dass sich manche Objekte in Größe und Position automatisch an Änderungen in anderen Objekten anpassen ("räumliche Verkettung"). Es wird dabei zwischen drei Arten der Verkettungen unterschieden:

§ zeitlich

§ individuelle Positions- /Größenanpassung

§ an Ende, größenerhaltend

Bei der Verkettung der Objekte gibt es eine Hierarchie, das Hauptobjekt und das angehängte (verkettete) Objekt.

Siehe auch:

Objektliste

Verkettungen erstellen

Die "zeitliche" Verkettung

Die individuellen Positions-/Größenanpassungen

Die "an Ende, größenerhaltende" Verkettung


Objektliste

Die Objektliste bildet eine implizite Druckreihenfolge der Objekte, es gibt also eine automatische zeitliche Verkettung. Über die Pfeil-Schaltflächen können Objekte und Elemente nach oben und unten verschoben werden.

Abbildung 7.1: Objektliste im Toolfenster

Hinweis: Je nach Anwendung werden die Objekte in genau dieser Reihenfolge gedruckt (Variante 1) oder aber zuerst die nicht verketteten Objekte, dann die Tabellen und anschließend diejenigen, die in irgendeiner Weise mit anderen Objekten verkettet sind (Variante 2). Wenn also ein Objekt über einem anderen Objekt gedruckt werden soll, muss es nach diesem Objekt gedruckt werden. Eine zeitliche Verkettung ist daher nur bei Variante 2 notwendig und immer dann, wenn ein nicht verkettetes Objekt nach den verketteten Objekten gedruckt werden soll, ein Objekt über einen Berichtscontainer gedruckt werden soll oder Inhalte erst dann bekannt sind, wenn ein anderes Objekt gedruckt wurde.


Verkettungen erstellen

Verkettungen werden über Projekt > Objektliste (Objekte > Objektliste) erstellt. Alternativ ziehen Sie ein Objekt im Toolfenster "Objekte" mit der rechten Maustaste auf ein anderes Objekt. Im Kontextmenü wählen Sie dann "An dieses Objekt verketten".

Zum Bearbeiten der Verkettungen öffnen Sie den Dialog "Objektliste" über Projekt > Objektliste (Objekte > Objektliste, Num* im numerischen Tastenfeld) oder per Doppelklick auf das Toolfenster "Objekte".

Abbildung 7.2: Verkettungen definieren in der Objektliste

Über die Schaltfläche "Verketten mit..." können Sie das selektierte Objekt mit anderen Objekten verketten. Die Verknüpfung wird in der Objektliste durch eine Baumstruktur angezeigt, aus der hervorgeht, welche Verkettungen definiert wurden. Sie können auch mehrere Objekte mit einem Objekt verketten.

Wenn Sie das verkettete Objekt selektieren stehen Ihnen im unteren Bereich des Dialogs die 3 verschiedenen Verkettungsarten zur Verfügung.

Über die Schaltfläche "Verkettung lösen" können Sie eine bestehende Verkettung wieder lösen, das verkettete Objekt wird anschließend wieder als eigenständiges Objekt in der Objektliste geführt.


Die "zeitliche" Verkettung

Zeitliche Verkettungen machen dann Sinn, wenn das verkettete Objekt erst mit Inhalt gefüllt werden kann, wenn das Hauptobjekt gedruckt worden ist oder ein Objekt über ein anderes Objekt gedruckt werden soll.

Hinweis: Je nach Anwendung werden die Objekte gemäß der Reihenfolge in der Objektliste gedruckt (Variante 1) oder aber zuerst die nicht verketteten Objekte, dann die Tabellen und anschließend diejenigen, die in irgendeiner Weise mit anderen Objekten verkettet sind (Variante 2). Eine zeitliche Verkettung ist daher nur bei Variante 2 notwendig und immer dann, wenn ein nicht verkettetes Objekt nach den verketteten Objekten gedruckt werden soll, ein Objekt über einen Berichtscontainer gedruckt werden soll oder Inhalte erst dann bekannt sind, wenn ein anderes Objekt gedruckt wurde.

Beispiel 1: Sie drucken eine Artikelliste und möchten auf jeder Seite über der Tabelle den Artikelnummernbereich dieser Seite ausgeben.

Abbildung 7.3: Artikelnummernbereich oberhalb der Liste

Die letzte Artikelnummer auf der Seite kennt das Objekt "Artikel_bis" erst, wenn die Tabelle gedruckt worden ist. Daher muss das Textobjekt "Artikel_bis" an die Tabelle "Artikelliste" zeitlich gekettet werden.

Im Objektdialog selektieren Sie das Objekt "Artikel_bis" und verketten dieses mit der Tabelle "Artikelliste". Als Verkettungsart ist "zeitlich" bereits ausgewählt.

Zudem muss auch die Tabelle an das Objekt "Artikel_von" gekettet werden. Die zeitliche Verkettung ist hierbei ausreichend, da keine Änderungen in der Objektposition oder Objektgröße gewünscht ist.

Abbildung 7.4: Objektliste mit zeitlicher Verkettung

Beispiel 2: Sie möchten, dass über einer Tabelle der Text "Kopie" ausgegeben wird.

Sie erstellen daher ein Textobjekt mit dem Inhalt "Kopie". Da nicht verkettete Objekte zuerst und zudem Tabellen als letztes gedruckt werden muss das Textobjekt zeitlich an die Tabelle gekettet werden. Sonst würde es vor der Tabelle und damit unter dem Objekt ausgegeben werden.

Abbildung 7.5: Textobjekt über der Liste

Im Objektdialog selektieren Sie das Textobjekt und verketten dieses mit der Tabelle. Als Verkettungsart ist "zeitlich" bereits ausgewählt.

Abbildung 7.6: Objektliste mit zeitlicher Verkettung


Die individuellen Positions-/Größenanpassungen

Die individuellen Positions-/Größenanpassungen sind räumliche Verkettungsarten, d.h. das verknüpfte Objekt wird dem Hauptobjekt bezüglich der Größe oder Position nachgeordnet. Das bewirkt automatisch auch eine zeitliche Verkettung.

Ändert sich das Hauptobjekt in seiner Größe oder Position, weil die in ihm enthaltenen Variablen weniger Raum einnehmen, als das Objekt zur Verfügung stellt, passen sich die verknüpften Objekte automatisch diesen Änderungen an.

Es stehen daher 2 Verkettungsarten zur Verfügung:

§ Positionsanpassung: Wenn sich das Hauptobjekt in seiner Position verändert, verändert sich die Position des verketteten Objektes. Dabei stehen 3 Optionen zur Auswahl:

§ relativ zu Anfang: Das verkettete Objekt verschiebt sich wie die linke obere Ecke des Eltern-Objektes.

§ relativ zu Ende: Das verkettete Objekt verschiebt sich wie die rechte untere Ecke des Eltern-Objektes.

§ an Ende: Die obere Kante des verketteten Objekts beginnt am Ende des Hauptobjekts, unabhängig von seiner ursprünglichen Position. Dies bewirkt damit eine implizite Größenänderung auf der ersten Seite, auf der das Kind-Objekt gedruckt wird.

§ Größenanpassung: Wenn sich das Hauptobjekt in seiner Größe verändert, verändert sich auch das verkettete Objekt bezüglich der Größe. Dabei stehen 2 Optionen zur Auswahl:

§ proportional: Die Größe des verketteten Objektes verändert sich genauso wie die des Eltern-Objektes. Wird dieses z.B. 10 mm kürzer, so wird auch das verkettete Objekt 10 mm kürzer.

§ invers: Die Größe des verketteten Objekts wird umgekehrt proportional zur Größe des Hauptobjekts angepasst. Wird das Hauptobjekt 10 mm kürzer, so wird das verkettete Objekt 10 mm länger.

Die Verkettung kann dabei jeweils horizontal und/oder vertikal erfolgen:

§ Vertikale Verkettung: Das verknüpfte Objekt passt sich in seiner Position bzw. Höhe an vertikale Positions- bzw. Größenänderungen des Hauptobjekts an.

§ Horizontale Verkettung: Das verknüpfte Objekt passt sich in seiner Position bzw. Breite an horizontale Positions- bzw. Größenänderungen des Hauptobjekts an.

Beispiel Positionsanpassung vertikal relativ zu Ende: Sie drucken eine Rechnung und möchten nach der Tabelle einen Schlusstext ausgeben.

1. Erstellen Sie ein Textobjekt und platzieren Sie es unterhalb der Tabelle.

Abbildung 7.7: Textobjekt unterhalb der Liste

2. Im Objektdialog selektieren Sie das Textobjekt und verketten es mit der Tabelle. Als Verkettungsart wählen Sie "Positions-/Größenanpassung". Auf der Registerkarte "Vertikale Verkettung" aktivieren Sie die Positionsanpassung "vertikal" und wählen die Option "relativ zu Ende", damit das verkettete Textobjekt seine Position anhand der rechten unteren Ecke der Tabelle verändert.

Abbildung 7.8: Skizze Positionsanpassung vertikal relativ zu Ende

3. Wenn die Tabelle kleiner wird, wandert das Textobjekt proportional nach oben. Egal wo die Tabelle endet, das Textobjekt wird immer in der gewählten Größe nach der Tabelle ausgegeben.

Abbildung 7.9: Schlusstext unterhalb der Liste

Beispiel Positionsanpassung vertikal relativ zu Ende & Größenanpassung vertikal invers: Bei einer mehrseitigen Rechnung soll die Postentabelle auf der 1. Seite unterhalb der Anschrift beginnen. Ab der 2. Seite am oberen Rand der Seite.

1. Erstellen Sie einen unsichtbaren Rahmen indem Sie ein Rechteck-Objekt einfügen.

2. Die obere Kante des Objekts ist genau dort, wo auf den Folgeseiten die Rechnungstabelle beginnen soll. Die untere Kante ist genau dort, wo die Rechnungstabelle auf der ersten Seite beginnen soll.

3. Dem Rechteck weisen Sie als Darstellungsbedingung "Page()=1" zu, damit dieses nur auf der 1. Seite gedruckt wird.

Abbildung 7.10: Unsichtbares Rechteck-Objekt oberhalb der Tabelle

4. Erstellen Sie eine Tabelle. Diese beginnt direkt unter dem Rechteckobjekt.

5. Nun verketten Sie die Tabelle mit dem Rechteck (Hauptobjekt) und wählen als Verkettungsart "individuelle Positions-/Größenanpassung".

Abbildung 7.11: Räumliche Verkettung in der Objektliste

6. Auf der Registerkarte "vertikale Verkettung" wählen Sie als Positionsanpassung "relativ zu Ende" und als Größenanpassung "invers".

Abbildung 7.12: Verkettungsoptionen in der Objektliste

Abbildung 7.13: Skizze: Positionsanpassung vertikal relativ zu Ende & Größenanpassung vertikal invers

Somit verändert die Tabelle ihre Position anhand der rechten unteren Ecke des Rechtecks (Hauptobjekts) und passt sich in der Höhe umgekehrt proportional an.

Wenn das Rechteck daher auf der 2. Seite um 80 mm "schrumpft" (da es aufgrund der Darstellungsbedingung Page()=1 nicht mehr gedruckt wird), verschiebt sich die Tabelle proportional nach oben und vergrößert sich um 80 mm.

Abbildung 7.14: Positions- und Größenänderung auf der 2. Seite

Beispiel Positionsanpassung vertikal an Ende: Sie drucken eine Rechnung und möchten nach der Tabelle mehrere Schlusstexte ausgeben.

1. Erstellen Sie 2 Textobjekt und platzieren Sie diese 'über' der Tabelle. Ziehen Sie die Textobjekte auf die gleiche Größe wie den Berichtscontainer und setzen Sie als Darstellungsbedingung "Lastpage()".

2. Im Objektdialog selektieren Sie das 1. Textobjekt und verketten es mit der Tabelle. Als Verkettungsart wählen Sie "Positions-/Größenanpassung". Auf der Registerkarte "Vertikale Verkettung" wählen Sie lediglich die Positionsanpassungs-Option "an Ende" (keine Größenanpassung!), damit das Objekt am Ende der Rechnung ausgeben wird.

3. Selektieren Sie dann das 2. Textobjekt und verketten es mit dem 1. Textobjekt. Als Verkettungsart wählen Sie wieder "Positions-/Größenanpassung" und auf der Registerkarte "Vertikale Verkettung" wählen Sie ebenfalls lediglich die Option "an Ende", damit das Objekt am Ende des 1. Textobjekts ausgeben wird.

Abbildung 7.15: Textobjekte unterhalb der Liste

4. Das verkettete Objekt verändert seine Position anhand des Hauptobjekts. Inbegriffen ist eine Größenänderung, da sich die obere Kante des verketteten Objekts anhand des Hauptobjektes verändert, aber das Hauptobjekt an sich die Position nicht ändert.

Abbildung 7.16: Skizze: Positionsanpassung vertikal an Ende

Das verkettete Objekt muss das Hauptobjekt überlappen. Das Hauptobjekt muss größer als das verkettete Objekt sein. Wenn das Hauptobjekt kleiner wird, verändert das verkettete Objekt seine Position nur von oben her und vergrößert sich. Wenn das Hauptobjekt größer wird, schrumpft das verkettete Objekt sozusagen ein (Hauptobjekt muss dabei im Vordergrund sein).

Beispiel Positionsanpassung vertikal, relativ zu Anfang: Das verkettete Objekt verändert seine Position anhand der linken oberen Ecke des Hauptobjekts. Bei dieser Verkettung verhält es sich genau umgekehrt wie beim "vertikal, relativ zu Ende" Beispiel: Das Hauptobjekt verändert seine Position nach oben aufgrund der Einstellung "Ausrichtung unten = True" im Designer und das verkettete Objekt folgt dieser Positionsanpassung von unten nach oben.

Abbildung 7.17: Skizze: Positionsanpassung vertikal relativ zu Anfang


Die "an Ende, größenerhaltende" Verkettung

Diese Art der Verkettung ist ähnlich der Positionsanpassung. Jedoch wird hier der zur Verfügung stehende Platz des Hauptobjektes berücksichtigt und die Größe des verketteten Objektes wird immer beibehalten. Das heißt das Objekt wird auf jeden Fall innerhalb des Rahmens des Hauptobjekts ausgegeben. Wenn nicht genügend Platz vorhanden ist, wird ein Seitenumbruch ausgelöst.

Das verkettete Objekt muss dabei im Designer das Hauptobjekt überlappen. Wichtig ist, dass das Hauptobjekt in jedem Fall größer ist als das verkettete Objekt, da das verkettete Objekt immer versucht den Platz einzunehmen, der von der ursprünglichen Größe des Hauptobjektes übrig ist (wenn das verkettete Objekt größer ist führt dies zu einer Endlosschleife da nie genug Platz vorhanden ist).

Abbildung 7.18: Skizzierte Funktion der Verkettungsart "an Ende, größenerhaltend"

Beispiel: Sie möchten eine eingescannte Unterschrift nach einem Text ausgeben. Die Größe der Unterschrift soll sich nicht ändern und diese soll innerhalb des Objektrahmens des Textes ausgegeben werden.

1. Sie erstellen daher ein Bildobjekt und platzieren es direkt auf dem Formatierten Textobjekt. Das Bildobjekt ist dabei vertikal kleiner als das Tabellenobjekt.

2. Im Objektdialog selektieren Sie das Bildobjekt und verketten es mit dem Formatierten Textobjekt. Als Verkettungsart wählen Sie "an Ende, größenerhaltend".

3. Egal wo der Text endet, das Bildobjekt wird immer in der gewählten Größe nach dem Text ausgegeben. Wenn es nicht mehr genügend Platz hinter dem Text gibt, wird das Bildobjekt auf der nächsten Seite ausgegeben um die Größe zu wahren.

Abbildung 7.19: Das verkettete Bildobjekt überlappt das Hauptobjekt im Designer

Abbildung 7.20: Die Unterschrift wird größenerhaltend am Ende ausgegeben

4. Auf diese Weise können Sie auch mehrere Objekte untereinander platzieren (etwa Diagramme, Bilder, etc.); dabei ist das "Basisobjekt" der Verkettung das erste Objekt in der Verkettungshierarchie mit aktiviertem Seitenumbruch.


combit List & Label

Filter

Siehe auch:


Projektfilter

Über Projekt > Filter können Sie eine projektglobale Filterbedingung definieren. Nur die Datensätze, die diese Bedingung erfüllen, werden im Bericht ausgegeben.

Wir empfehlen jedoch, die Datensätze direkt durch das Datenbanksystem zu filtern (siehe folgender Abschnitt).


Datenfilter bei Objekten

Über die Eigenschaft Datenfilter bei Berichtscontainer-Elementen können Sie eben-falls eine Filterbedingung definieren. Nur die Datensätze, die diese Bedingung erfüllen, werden im Objekt bzw. Element ausgegeben.

Dabei wird die Filterbedingung – je nach Datenquelle und Applikation - auf Kompatibilität mit dem Datenbanksystem geprüft und dann u.U. ganz oder teilweise dort aus-geführt. Dies kann zu einem erheblichen Geschwindigkeitsgewinn führen.

Es werden 3 Varianten unterschieden:

1. Volle Kompatibilität zur Datenbank: Viele Funktionen können vollständig in native Datenbankanweisungen übersetzt werden. Sollte die Datenquelle z.B. ein SQL-Server sein, können viele Operatoren und Funktionen unterstützt werden (Left$, Right$, Mid$, Round, StartsWith, EndsWith, Contains, Upper$, Lower$, Year, Month, Day, Len, Empty, DateInRange, NumInRange, Artim$, Ltrim$, RTrim$). Microsoft SQL Server unterstützt noch einige zusätzliche Funktionen wie AddDays, AddWeeks etc.

Abbildung 7.21: Ausdruck kann direkt übersetzt werden

2. Teilkompatibilität zur Datenbank: D.h. ein Teil des Ausdrucks kann übersetzt, ein anderer Teil (der mit "and" verkettete) kann nicht übersetzt werden. In diesem Fall wird der unterstützte Teil in eine native Datenbankanweisung übersetzt, während der nicht unterstützte Teil durch den Berichtsgenerator gefiltert wird.

Abbildung 7.22: Ausdruck kann teilweise übersetzt werden

3. Keine Kompatibilität zur Datenbank: Die Filterung erfolgt durch den Berichtsgenerator. In diesem Fall sollten Sie versuchen, die Filterbedingung auf eine unterstützte Syntax zu ändern.

Abbildung 7.23: Ausdruck kann nicht übersetzt werden


Summenvariablen

Summenvariablen sind eine alternative Möglichkeit Summen und Zähler zu bilden und arbeiten grundsätzlich tabellenübergreifend.

Daher bieten sich Summenvariablen genau dann an, wenn Sie Summen über verschiedene Tabellenhierarchien hinweg bilden möchten.

In allen anderen Fällen empfehlen wir zur Bildung von Summen und Zählern die Aggregatsfunktionen Sum() bzw. Count() und CountIf() zu verwenden. Aggregatsfunktionen arbeiten grundsätzlich tabellenspezifisch. Auch statistische Auswertungen lassen sich direkt über Aggregatsfunktionen erstellen, z.B. Median(), Variance(), StdDeviation(). Eine Liste aller Funktionen finden Sie direkt im Formel-Assistenten in der Funktionskategorie "Aggregatsfunktionen".

Summenvariablen können dazu benutzt werden, Summen über Datensätze hinweg zu bilden, z.B. in einer Tabelle die Summe über die Spalte "Artikel.Stkpreis" um den Gesamtpreis zu errechnen. Solche Summen sind zulässig für alle numerischen Variablen oder für Ausdrücke, die als Ergebnis einen numerischen Wert liefern.

Über Summenvariablen lässt sich aber auch bequem ein Zähler definieren, der für jeden gedruckten Datensatz entsprechend aktualisiert wird.

Summiert werden kann dabei wahlweise über alle Datensätze einer Druckseite (Seitensummen) oder über das gesamte Projekt (Gesamtsummen).

Zur Definition gehen Sie folgendermaßen vor:

1. Wählen Sie Projekt > Summenvariablen oder die Schaltfläche "Summenvariable bearbeiten" im Formel-Assistenten.

2. Im folgenden Dialog erstellen Sie über die Schaltfläche "Eine Variable einfügen" eine neue Summenvariable.

3. Daraufhin erscheint ein Eingabedialog für die Bezeichnung der neuen Variablen. Vergeben Sie einen aussagekräftigen Namen, das Zeichen "@" wird automatisch an den Anfang gesetzt.

4. Über die Schaltfläche "Bearbeiten" öffnen Sie den Formel-Assistenten um der neuen Summenvariablen ein Feld oder einen Ausdruck zuzuweisen.

Wenn Sie z.B. die Spalte "Artikel.Stkpreis" aufsummieren möchten, wählen Sie das numerische Feld "Artikel.Stkpreis" aus.

Sie können aber auch über komplexe Ausdrücke summieren, solange das Ergebnis ein numerischer Wert ist. So können Sie z.B. auch aus Nettopreis und MwSt. den Bruttopreis summieren. In das Feld "Summiert über" geben Sie dann z.B. folgenden Ausdruck ein:

Artikel.Stkpreis + Artikel.Stkpreis * (Artikel.MwSt/100)

5. Wenn Sie keine Werte aufsummieren möchten sondern lediglich einen Zähler bzw. eine Nummerierung erstellen möchten ist die Definition simpel: In das Feld "Summiert über" geben Sie einfach denjenigen Wert ein, der zum vorhandenen hinzuaddiert werden soll.

Im einfachsten Fall ist so ein Zähler eine fortlaufende Nummer, die sich für jeden Datensatz um 1 erhöht. Sie geben also lediglich den Wert "1" ein.

6. Über die Checkbox "Seitensumme" können Sie bestimmen, ob die Summen am Ende einer Seite auf 0 gesetzt werden sollen, damit können Sie also Seitensummen und Seitenzähler definieren.

7. Nachdem Sie nun definiert haben, welche Summen in welcher Summenvariablen gespeichert werden sollen, können Sie diese Summenvariablen in Ihren Objekten verwenden. Im Formel-Assistenten finden Sie die Summenvariablen am Ende der Variablen-/Feldliste im Ordner "Benutzerdefinierte Summen". Im Toolfenster "Variablen-/Feldliste" können Summenvariablen direkt per Doppelklick und Kontextmenü bearbeitet werden.

Abbildung 7.24: Summenbildung mit Summenvariablen.


Benutzervariablen

Benutzervariablen sind eine Möglichkeit Werte und Ausdrücke für eine spätere Verwendung zu speichern. Somit müssen Sie diese nicht jedes Mal neu eingeben, wenn Sie häufig in genau der gleichen Form benötigt werden oder wenn Benutzereingaben mehrfach ausgegeben werden sollen. Es handelt sich quasi um "Formelbausteine".

Diese Benutzervariablen können Sie auch in Projektbausteine auslagern, wenn diese auch in anderen Projekten verwendet werden sollen.

Hinweis: Benutzervariablen können nicht innerhalb von Darstellungsbedingungen von Ebenen verwendet werden.

Um lediglich Werte im Variablenspeicher für eine spätere Verwendung zu speichern können Sie auch die Funktionen SetVar() und GetVar() verwenden. Weitere Informationen zu den Funktionen finden Sie im Kapitel Übersicht der Funktionen.

Zur Definition von Benutzervariablen gehen Sie folgendermaßen vor:

1. Wählen Sie Projekt > Benutzervariablen oder die Schaltfläche "Benutzervariable bearbeiten" im Formel-Assistenten.

2. Im folgenden Dialog erstellen Sie über die Schaltfläche "Eine Variable einfügen" eine neue Benutzervariable.

3. Daraufhin erscheint ein Eingabedialog für die Bezeichnung der neuen Variablen. Vergeben Sie einen aussagekräftigen Namen, das Zeichen "@" wird automatisch an den Anfang gesetzt.

4. Über die Schaltfläche "Bearbeiten" öffnen Sie den Formel-Assistenten um der neuen Benutzervariablen ein Feld oder einen Ausdruck zuzuweisen.

Abbildung 7.25: Benutzervariablen bearbeiten

5. Über die Pfeil-Schaltflächen können Sie die Auswertungsreihenfolge bestimmen, die Variablen werden von oben nach unten ausgewertet.

6. Nachdem Sie die Benutzervariable definiert haben, können Sie diese in Ihren Objekten verwenden. Im Formel-Assistenten finden Sie die Benutzervariablen am Ende der Variablen-/Feldliste im Ordner "Benutzerdefinierte Variablen".

7. Im Toolfenster "Variablen-/Feldliste" können Benutzervariablen direkt per Doppelklick und Kontextmenü bearbeitet werden.


Sammelvariablen

Mit Sammelvariablen haben Sie, wie mit Benutzervariablen, eine Möglichkeit Werte und Ausdrücke für eine spätere Verwendung zu speichern. Bei Sammelvariablen können Sie Daten zusätzlich zusammenfassen, kategorisieren und mit zusätzlichen Attributen versehen.

Diese Sammelvariablen können Sie auch in Projektbausteine auslagern, wenn diese auch in anderen Projekten verwendet werden sollen.

Beispiel: Durchschnittspreis pro Artikelkategorie als Diagramm ausgeben.

Gegeben sind Artikelnummern, in denen die Kategorie steckt:

§ Artikelnummer beginnt mit "EX": Reisen

§ Artikelnummer beginnt mit "RNT": Vermietungen

§ Artikelnummer beginnt mit "TRP": Kurztrip

Es gibt daher in den Daten kein Kategorie-Feld, das Sie z.B. in einem Diagramm benutzen könnten um den Durchschnittspreis eines Artikels je Kategorie darzustellen. Mit Sammelvariablen haben Sie aber eine Möglichkeit, die Daten der verschiedenen Kategorien zu sammeln und Eigenschaften wie einen Kategorienamen oder eine Farbe zu bestimmen.

Zur Definition von Sammelvariablen gehen Sie folgendermaßen vor:

1. Wählen Sie Projekt > Sammelvariablen oder die Schaltfläche "Sammelvariablen bearbeiten" im Formel-Assistenten.

Abbildung 7.26: Sammelvariablen bearbeiten

2. Im folgenden Dialog erstellen Sie über die Schaltfläche "Neue Variable einfügen" eine neue Variable. Daraufhin erscheint ein Eingabedialog für die Bezeichnung der neuen Variablen. Vergeben Sie einen aussagekräftigen Namen, z.B. "Kategorie", das Zeichen "@" wird automatisch an den Anfang gesetzt.

Über die Pfeil-Schaltflächen können Sie die Auswertungsreihenfolge bestimmen, die Variablen werden von oben nach unten ausgewertet.

3. Es öffnet sich ein Dialog für die Bearbeitung der Sammelvariable "Kategorie". Über die Schaltfläche "Neue Variable (Spalte) einfügen" legen Sie nun 2 Untervariablen an: "Name" und "Farbe".

Abbildung 7.27: Untervariablen für Sammelvariable bearbeiten

4. Über die Schaltfläche "Neue Sammlung einfügen" legen Sie dann die Kategoriezuordnung an. Wählen Sie für unser Beispiel mit der Artikelnummer den Eintrag "Platzhalter".

Abbildung 7.28: Sammlungstyp einer Sammelvariable bestimmen

5. Es öffnet sich ein Dialog für die Erstellung des Platzhalter-Vergleichs. Wählen Sie das Feld "Artikel.Nr" und geben Sie die Platzhalter-Zeichenkette an: EX*. Fügen Sie mehrere Einträge als einzelne Zeilen ein. Unterstützte Platzhalter sind "*" und "?".

Abbildung 7.29: Platzhalter-Vergleich einer Sammelvariable definieren

6. Diesen Schritt wiederholen Sie für die gewünschten Kategorien und vergeben jeweils einen Namen und eine Farbe. Der Dialog sieht dann so aus:

Abbildung 7.30: Die Untervariablen der Sammelvariable

7. Nachdem Sie die Sammelvariable definiert haben, können Sie diese in Ihren Objekten verwenden. Im Formel-Assistenten finden Sie die Variablen am Ende der Variablen-/Feldliste im Ordner "Sammelvariablen".

8. Die Sammelvariable "@Kategorie.Name" können Sie nun im Diagramm als Koordinatenwert für die x-Achse verwenden.

Abbildung 7.31: Eigenschaften des Diagramms

9. Als y-Wert geben Sie den Durchschnittspreis aller Artikel aus.

10. Als Farbe verwenden Sie die Sammelvariable "@Kategorie.Farbe". Wechseln Sie dafür auf die Registerkarte "Farben". Geben Sie unter "Feste Farben" als Bedingung "True" an und setzen Sie die Sammelvariable "@Kategorie.Farbe" in das Feld "Formel".

Abbildung 7.32: Durchschnittspreis pro Artikelkategorie als Diagramm


Projektbausteine

Sofern Sie mehrere ähnliche Projekte gestalten, bietet es sich an immer wiederkehrende Elemente nicht jedes Mal neu in jedem Projekt zu erstellen, sondern andere Projekte als "Bausteine" einzubinden. Auf diese Art und Weise kann z.B. ein Briefkopf sehr einfach eingebunden werden und Änderungen können zentral an einer Stelle erfolgen, sollte z.B. das Design angepasst werden.

Auch immer wiederkehrende Benutzervariablen (z.B. komplexe Formeln im Anschriftenfeld) können in Bausteine ausgelagert werden.

§ Bausteine können dabei auch weitere Bausteine enthalten, z.B. ein Brief-Baustein der die Bausteine "Fußzeile" und "Kopfzeile" enthält.

§ Elemente können mit Elementen aus Bausteinen verkettet werden. Das Element aus dem Baustein ist dabei stets das Elternelement, da es zuerst gedruckt wird.

Abbildung 7.33: Dialog zum Einbinden von Bausteinen

Über Projekt > Bausteine können Sie andere Projekte projekttyp-übergreifend als Bausteine hinzufügen.

§ Die Objekte dieser Projekte werden im Arbeitsbereich und in der Objektliste angezeigt. Projektbausteine werden immer an den Anfang der Objektliste eingefügt.

§ Unverkettete Objekte aus Projektbausteinen können Sie in der Objektliste über eine Schaltfläche ausblenden.

§ Ebenso werden Summen- und Benutzervariablen eingelesen und verwendet. Bitte achten Sie beim Design darauf, dass Sie hier keine Überschneidungen provozieren (z.B. ein Projekt mit einer Summenvariablen als Baustein verwenden, welche bereits im aktuellen Projekt belegt ist).

§ Über die Eigenschaftsliste kann für jeden Baustein Name, Sichtbarkeit im Designer und die Darstellungsbedingung definiert werden. Die (Druck-) Reihenfolge wird über die Schaltflächen festgelegt.

§ Über die Bearbeiten-Schaltfläche können Sie den Baustein in einer zweiten Designerinstanz öffnen und bearbeiten. Nachdem Sie den Baustein bearbeitet haben schließen Sie wieder diese 2. Instanz des Designers.


PDF-Seiten einfügen

Zur Anzeige von mehrseitigen PDF-Dateien verwenden Sie das PDF-Objekt. Weitere Informationen zu den Eigenschaften finden Sie unter PDF-Objekte im Kapitel Übersicht der Eigenschaften.


HTML-Seiten einfügen

Zur Anzeige von HTML-Inhalten verwenden Sie das HTML-Objekt. Weitere Informationen zu den Eigenschaften finden Sie unter HTML-Text-Objekte im Kapitel Übersicht der Eigenschaften.


OLE-Dokumente einfügen

Um OLE-Server-Dokumente (z.B. Word, Excel, Visio, MapPoint) anzuzeigen verwenden Sie das OLE-Container-Objekt. Es wird dabei nur die erste Seite angezeigt, da kein Standard für mehrseitige OLE-Objekte existiert. Für den Inhalt stehen drei Möglichkeiten zur Verfügung:

§ Dateiname: Link zu einer Datei, die zum Druckzeitpunkt vorhanden sein muss.

§ Eingebettet: Das Dokument wird über den Windows-Standard-Dialog "Objekt einfügen" ausgewählt und in das Projekt eingebettet. Dies kann z.B. für einfache Grafiken oder eher statische Objekte sinnvoll sein.

§ Formel: Erlaubt die dynamische Übergabe des Dateinamens.


Vorlagenobjekte einfügen

Vorlagen sind Bilder, z.B. eingescannte Formulare, die Sie sich als Schablone in den Hintergrund Ihres Arbeitsbereiches legen, damit Sie Objekte genau passend zu dem Formular in einem Projekt platzieren können. Die Vorlagen werden zwar auf dem Arbeitsbereich angezeigt, sie werden jedoch nicht mit ausgedruckt und können auch nicht weiter bearbeitet werden.

Um sich eine Vorlage in den Hintergrund Ihres Arbeitsbereiches zu legen, wählen Sie Einfügen > Vorlage (Objekte > Einfügen > Vorlage). Nach dem Erstellen selektieren Sie Vorlagen-Objekte am besten über das Toolfenster Objekte, da diese auf dem Arbeitsbereich nicht mehr selektiert werden können. Die Positionierung erfolgt idealerweise über die Eigenschaftsliste. Weitere Informationen zu den Eigenschaften finden Sie unter Vorlagen im Kapitel Übersicht der Eigenschaften.


Seitenlayout

Sie haben viele verschiedene Möglichkeiten das Layout Ihres Reports zu beeinflussen. In diesem Kapitel betrachten wir die Möglichkeiten verschiedener Layoutbereiche, definieren einen mehrspaltigen Report und steuern das Umbruchverhalten.

Siehe auch:


Seitenlayout festlegen

Zuallererst sollte in einem neuen Projekt das gewünschte Seitenlayout eingerichtet werden. Wählen Sie Projekt > Layout-Bereiche (Projekt > Seitenlayout) um Eigenschaften wie Druckerauswahl, Papiergröße und Ausrichtung festzulegen. Je nach Projektmodus (Etikett oder Liste) bestehen unterschiedliche Layout-Optionen.

Bei mehrseitigen Projekten kann es sinnvoll sein, für die verschiedenen Seiten (Bereiche) jeweils unterschiedliche Layout-Einstellungen (Drucker, Seitengröße, Ausrichtung, Papierschacht) zu wählen. Weitere Informationen finden Sie im Abschnitt Layout-Bereiche.

Abbildung 8.1: Definition der Layoutbereiche

Wenn Sie die Ausrichtung (Hochformat/Querformat) ändern, können Sie über einen Dialog entscheiden ob die Objekte automatisch an die neue Orientierung angepasst werden sollen.

Siehe auch:

Druckereinstellungen

Ausgabemedien

Vorlagen für Etikettenformate

Etikettenformate selbst definieren


Druckereinstellungen

Über die Eigenschaften können Sie für jeden Bereich die Einstellungen für Drucker, Seitengröße, Ausrichtung, Duplexdruck, Anzahl Exemplare, Exemplare sortieren und Papierschacht (z.B. erste Seite Papier auf Geschäftspapier und für die Folgeseiten Normalpapier) vornehmen.

Die Druckereinstellungen (und geänderte Optionen der Exportformate) werden in einer gesonderten Datei gespeichert (also z.B. Artikelliste.lsp). Ist beim Druck die entsprechende Datei nicht vorhanden, wird der aktuell eingestellte Windows-Standard-Drucker verwendet.

Siehe auch:


Größenanpassung

Bestimmt, ob bei unterschiedlichen Druckern das Projekt auf die Seite eingepasst oder der Maßstab beibehalten werden soll.


Physikalische Seite benutzen

Damit steht im Designer die ganze physikalische Seite als Arbeitsbereich zur Verfügung, inklusive des nicht bedruckbaren Randbereiches. Dies ist zur korrekten Platzierung von Etiketten gelegentlich notwendig, z.B. wenn Sie Etikettenpapier ohne Seitenränder verwenden. Der nicht bedruckbare Rand der Seite wird in der Vorschau jeweils schraffiert angezeigt.

Das ermöglicht Ihnen zwar, z.B. bei der Definition des Etikettenlayouts die komplette Etikettenseite zu nutzen, aber natürlich kann Ihr Drucker diesen Randbereich nicht bedrucken. Wenn Sie also Objekte auf solchen Etiketten platzieren, müssen Sie die nicht bedruckbaren Ränder trotzdem beachten. Ist diese Eigenschaft "False", wird als Arbeitsbereich nur der tatsächlich bedruckbare Bereich der Seite angezeigt.


Seitenformat erzwingen

Sofern keine Druckerdefinitionsdatei vorhanden ist, wird versucht, das beim Design eingestellte Seitenformat (z.B. DIN A4) soweit möglich zu erzwingen. Voraussetzung ist hierbei, dass der gewählte Drucker entweder genau dieses oder aber das Format "Benutzerdefiniert" unterstützt. Andernfalls wird zunächst geprüft, ob das Standardformat des Druckers ausreichend groß ist, ansonsten wird das nächst größere Format gewählt.


Ausgabemedien

Hier werden die verschiedenen Ausgabemöglichkeiten aufgelistet.

Über die beiden Schaltflächen rechts oben können Sie ein selektiertes Format als Voreinstellung für den späteren Druck festlegen und die Optionen für dieses Format bestimmen. Diese Optionen werden in einer gesonderten Datei gespeichert (also z.B. Artikelliste.lsp).

Abbildung 8.2: Voreinstellung des Ausgabeformats


Vorlagen für Etikettenformate

Im Seitenlayout für Etiketten können Sie über die Registerkarte "Vorlagen" unter zahlreichen vordefinierten Etikettenformaten verschiedener Hersteller auswählen. Damit wird automatisch festgelegt, wie groß die einzelnen Etiketten sind und wie viele sich davon wie auf dem Blatt verteilen.

Abbildung 8.3: Definition der Etikettengröße


Etikettenformate selbst definieren

Sie können Etikettenformate auch selbst definieren, falls sich das gewünschte Layout nicht unter den Vorlagen befinden sollte. Über die Bereich-Eigenschaft "Layoutdefinition" können Sie die erforderlichen Einstellungen vornehmen, dafür steht auch ein Dialog zur Verfügung:

Abbildung 8.4: Eigene Definition von Etikettenlayouts

§ Offset: Der Offset gibt den horizontalen bzw. vertikalen Abstand des linken oberen Etiketts zum Rand des gewählten Seitenbereichs (physikalisch / bedruckbar) in mm an.

Hinweis: Die linke obere Ecke des Arbeitsbereichs beginnt in der Bildschirmdarstellung immer bei den Koordinaten 0/0, unabhängig von der ausgewählten Seitengröße und vom eingestellten Offset. Die Wirkung des Offsets sehen Sie jedoch in der Vorschau oder beim Ausdrucken.

§ Größe: Dieser Wert definiert die Größe (horizontal=Breite / vertikal=Höhe) des Etiketts in mm.

§ Abstand: Hier wird der Abstand zum nächsten Etikett in mm angegeben. Bei einspaltigen Etiketten muss nur der vertikale Abstand eingetragen werden.

§ Anzahl: Diese Option gibt die Anzahl der Etiketten pro Seite an (horizontale Anzahl = Anzahl der Spalten pro Seite, vertikale Anzahl = Anzahl der Zeilen pro Seite).

§ Druckreihenfolge: Bestimmt die Reihenfolge des Drucks, wenn mehrere Etiketten auf eine Seite gedruckt werden. Mögliche Werte: 0 (horizontal), 1 (vertikal), 2 (horizontal von unten), 3 (vertikal von unten).

Standard ist es, die Etiketten zeilenweise von links oben nach rechts unten zu bedrucken (horizontal). Bei angefangenen Etikettenbögen kann es jedoch dazu kommen, dass die ersten Etikettenzeilen schon aufgebraucht sind, womit der Etikettenbogen im oberen Teil seine Festigkeit verliert. Manche Drucker haben Probleme, solche angefangenen Etikettenbögen einzuziehen und reagieren mit einem Papierstau. Hier hilft es, die Etikettenbögen statt von oben nach unten umgekehrt von unten nach oben zu bedrucken. Auf diese Weise wird die oberste Etikettenzeile auf dem Bogen stets als letztes bedruckt, und der Bogen behält in diesem für den Papiereinzug kritischen Bereich seine Festigkeit.

Siehe auch:


Abspeichern eigener Etikettenformate in der Etikettenvorlagenliste

Zum Abspeichern eigener Etikettenformate können Sie die Datei "cmll2100.inf" bearbeiten.

Aufbau einer Etikettendefinition (alle Maße in 1/1000 mm):

<A> <B>, <C> = <D>, <E>, <F>, <G>, <H>, <I>, <J>, <K>

A: Code, B: Bezeichnung, C: Seitengröße, D: Etikettenbreite, E: Etikettenhöhe, F: horizontaler Abstand zw. Etiketten, G: vertikaler Abstand zw. Etiketten, H: Anzahl horizontal, I: Anzahl vertikal, J: Rand links und rechts, K: Rand oben und unten

z.B. 3420 Universal Etiketten, 70 x 16,9mm = 70000, 16900, 0, 0, 3, 17, 0, 4850


Layout-Bereiche

Bei mehrseitigen Projekten kann es sinnvoll sein, für die verschiedenen Bereiche jeweils unterschiedliche Layout-Einstellungen (Drucker, Seitengröße, Ausrichtung, Papierschacht) zu wählen.

Die Definition der Layoutbereiche erfolgt über Projekt > Layout-Bereiche (Projekt > Seitenlayout).

Einen neuen Bereich legen Sie über die Schaltfläche "Neu" auf der Registerkarte "Bereiche" an und definieren dann die spezifischen Eigenschaften für diesen Bereich. Eine detaillierte Erläuterung der Eigenschaften finden Sie im Abschnitt Seitenlayout festlegen.

Als "Bedingung" geben Sie an, wann dieser Layout-Bereich angewendet werden soll. Der Bereich "Standard-Layout" ist immer der letzte Bereich mit Bedingung "Wahr" und kann nicht umbenannt werden.

Hinweis: Das Format des Bereichs, dessen Bedingung "Lastpage()" enthält, sollte aber nicht von dem Layout abweichen, mit dem die Seite gedruckt würde, wenn "Lastpage()" nicht "True" wäre. Das liegt darin begründet, dass bei Seitenbeginn noch nicht bekannt ist, ob die Seite die Letzte ist, und daher ein passender Bereich ohne aktives "Lastpage()" ausgewählt wird. Erst nach Abschluss der Seite wird dann der Drucker des Bereichs, der "Lastpage()" enthält, der Seite zugewiesen. Sollten sich Seitengröße oder Orientierung ändern, kann dies zu Größenveränderungen oder abgeschnittenen Daten führen.

Siehe auch:

Aktiver Design-Bereich

Praxis: Report mit wechselnder Seitenausrichtung

Praxis: Ausfertigungssteuerung

Praxis: Einzahlungsschein auf letzter Seite bedrucken


Aktiver Design-Bereich

Wenn Sie verschiedene Layouts definieren, können Sie sich entscheiden, welches Layout als Arbeitsbereich angezeigt werden soll.

Abbildung 8.5: Hinweis zur Auswahl des aktiven Arbeitsbereichs

Über die Projekt-Eigenschaft "Aktiver Design-Bereich" stehen alle definierten Bereiche zur Auswahl.

Abbildung 8.6: Auswahl des aktiven Arbeitsbereichs


Praxis: Report mit wechselnder Seitenausrichtung

Nehmen wir an, Sie möchten die Seitenausrichtung innerhalb eines Reports ändern, d.h. der 1. Bereich mit den Diagrammen soll im Querformat, der 2. Bereich mit der Tabelle im Hochformat ausgegeben werden.

Im Ergebnis soll der Report so aussehen:

Abbildung 8.7: Report mit unterschiedlichen Layoutbereichen

Gehen Sie wie folgt vor:

1. Platzieren Sie den Berichtscontainer im Arbeitsbereich und erstellen Sie das Diagramm und die Tabelle. Weitere Informationen dazu finden Sie in Kapitel Auswertungen erstellen.

2. Da Sie die Seiten-Orientierung ändern möchten, müssen Sie auch die Höhe und Breite des Berichtscontainers anpassen. Ansonsten wird das Diagramm abgeschnitten, wenn der Berichtscontainer im Hochformat positioniert wurde.

Selektieren Sie im Toolfenster "Objekte" den Berichtscontainer und verwenden Sie dann für die Angabe der Höhe und Breite die LL.Device.Page-Variablen und die Funktion UnitFromSCM():

Abbildung 8.8: Variable Größendefinition des Berichtscontainers

3. Das Diagramm benennen Sie "Employees". Dieser Elementname ist dann später im Feld "LL.CurrentContainerItem" verfügbar.

4. Damit die Tabelle jeweils zu Beginn einer Seite gedruckt werden, setzen Sie die Eigenschaft "Seitenwechselbedingung" auf "Ja".

5. Nun definieren Sie die Layoutbereiche. Wählen Sie Projekt > Layout-Bereiche (Projekt > Seitenlayout).

6. Daraufhin erscheint der Dialog zur Definition der Bereiche. Der Default-Bereich "Standard-Layout" ist immer der letzte Bereich mit Bedingung "Wahr" und kann nicht umbenannt werden.

7. Erstellen Sie über die Schaltfläche "Neu" einen neuen Bereich. Über die Eigenschaft "Bezeichnung" geben Sie einen aussagekräftigen Namen für diesen Bereich an, z.B. "Chart-Layout". Wechseln Sie die Eigenschaft "Ausrichtung" auf "Querformat".

8. Als "Bedingung" geben Sie an, wann dieser Layout-Bereich angewendet werden soll, also z.B. wenn das Element mit dem Namen "Employees" gedruckt wird. Die Formel für die logische Bedingung lautet also: LL.CurrentContainerItem = "Employees".

Abbildung 8.9: Layout-Definition für ein bestimmtes Element


Praxis: Ausfertigungssteuerung

Nehmen wir an, Sie möchten zwei Ausfertigungen einer Rechnung erzeugen, die erste Ausfertigung soll auf das Geschäftspapier aus Papierschacht 1 gedruckt werden, die zweite Ausfertigung soll auf das kostengünstige Papier aus Papierschacht 2 gedruckt werden.

1. Geben Sie in den Projekteigenschaften über die Eigenschaft "Anzahl der Ausfertigungen" die Anzahl "2" an.

2. Öffnen Sie den Dialog zur Bereichsdefinition über Projekt > Layout-Bereiche (Projekt > Seitenlayout).

3. Wählen Sie für den Bereich "Standard-Layout" den Papierschacht 1.

4. Erstellen Sie einen Bereich "Kopie" und definieren Sie die logische Bedingung "IssueIndex()=2". Die Funktion IssueIndex() liefert die Nummer der Ausfertigung. Wählen Sie für diesen Bereich den Papierschacht 2.

Wenn für die 2. Ausfertigung zusätzlich der Text "Kopie" ausgegeben werden soll führen Sie noch folgende Schritte durch:

5. Erstellen Sie ein Textobjekt mit dem Inhalt "Kopie".

6. Im Objektdialog selektieren Sie das Textobjekt und setzen die Objekt-Eigenschaft "Anzeigebedingung für Ausfertigungsdruck" auf den Wert IssueIndex()=2. Somit wird dieses Objekt nur bei der 2. Ausfertigung gedruckt.

Abbildung 8.10: Rechnung mit 2. Ausfertigung


Praxis: Einzahlungsschein auf letzter Seite bedrucken

Nehmen wir an, Sie möchten nach der letzten Seite einer mehrseitigen Rechnung einen Einzahlungsschein bedrucken. Der Einzahlungsschein ist auf einem speziellen Papier aus Papierschacht 2 im unteren Bereich der Seite vorgedruckt. Die Feldinhalte müssen exakt an den richtigen Stellen aufgedruckt werden.

Gehen Sie wie folgt vor:

1. Öffnen Sie den Dialog zur Bereichsdefinition über Projekt > Layout-Bereiche (Projekt > Seitenlayout).

2. Erstellen Sie einen Bereich "Letzte Seite". Als "Bedingung" verwenden Sie für diesen Fall die Funktion LastPage(), die Ihnen den Wert "True" liefert sobald alle Datenzeilen der Tabelle gedruckt sind. Wählen Sie für diesen Bereich den Papierschacht 2, damit die letzte Seite immer auf dem speziellen Einzahlungsschein-Vordruck aus Papierschacht 2 gedruckt wird.

3. Platzieren Sie für die Feldinhalte des Einzahlungsscheins alle Textobjekte exakt an der richtigen Stelle. Als Positionierungshilfe können Sie über Einfügen > Vorlage (Objekte > Einfügen > Vorlage) ein Bild des Einzahlungsscheins in den Hintergrund legen. Die Schrift für die Referenzzeile muss für die Schweiz zwingend OCR-B sein, z.B. OCRB LT von LinoType.

Abbildung 8.11: Rechnung mit Feldern und Platzhalter für Einzahlungsschein

4. Setzen Sie die Darstellungsbedingung bei allen Textobjekten auf Lastpage() damit diese nur auf der letzten Seite ausgegeben werden (oder definieren Sie dafür eine Ebene).

5. Außerdem müssen alle Textfelder mit der Tabelle verkettet werden, da die Funktion LastPage() nur in Tabellen, Layoutbereichen oder in an Tabellen angehängten Objekten korrekt ausgewertet werden kann.

Verkettungen werden über den Dialog "Objektliste" erstellt und bearbeitet. Diesen Dialog öffnen Sie über Projekte > Objektliste (Objekte > Objektliste). Selektieren Sie das Tabellenobjekt und verketten dieses über die Schaltfläche "Verketten mit..." mit einem Textobjekt des Einzahlungsscheins. Als Verkettungsart ist "zeitlich" bereits ausgewählt. Die zeitliche Verkettung ist hierbei ausreichend, da keine Änderungen der Objektposition oder Objektgröße gewünscht sind.

Wiederholen Sie diesen Schritt für alle Textobjekte.

6. Nun müssen Sie noch erreichen, dass vor der Ausgabe der Einzahlungsscheinfelder ein Seitenumbruch ausgelöst wird. Setzen Sie dafür beim ersten Textfeld der Einzahlungsscheinfelder die Eigenschaft "Umbruch vor" auf "Ja".


Berichtsabschnitte

Über Projekt > Berichtsabschnitte können Inhaltsverzeichnis, Index und Rückseitendruck definiert werden.

Über die Registerkarte Bausteine können Sie andere Projekte projekttyp-übergreifend als Bausteine hinzufügen. Weitere Informationen zu Bausteinen finden Sie unter Projektbausteine im Kapitel Funktionen für Fortgeschrittene.

Siehe auch:


Inhaltsverzeichnis und Index

Über Projekt > Berichtsabschnitte können automatisch ein Inhaltsverzeichnis und ein Index für Berichte erstellt werden. Inhaltsverzeichnis und Index sind normale Projekte mit vordefinierten Verweis-Feldern.

Im Designer kann für fast jedes Element über die jeweilige Eigenschaft "Ebene im Inhaltsverzeichnis" bzw. "Ebene im Index" ein Eintrag für Inhaltsverzeichnis und Index definiert werden. Über Datei > Optionen > Projekt (Projekt > Optionen > Projekt) können Sie die maximale Verzeichnistiefe und Indextiefe vorgeben.

Zur Druckzeit werden die entsprechenden Werte ausgelesen und Inhaltsverzeichnis und Index an den Beginn und das Ende des Projekts angefügt. In PDF und Vorschau sind die Verzeichniseinträge auch aktive Links.

Gehen Sie wie folgt vor:

1. Öffnen Sie den Dialog zur Definition der Berichtsabschnitte über Projekt > Berichtsabschnitte.

Abbildung 8.12: Dialog zum Einbinden von Inhaltsverzeichnis und Index

2. Selektieren Sie den Abschnitt "Inhaltsverzeichnis" bzw. "Index".

3. Klicken Sie oben auf "Bearbeiten" um den Assistenten für die Erstellung von Inhaltsverzeichnis bzw. Index zu starten.

Abbildung 8.13: Eigenständiges Projekt für das Inhaltsverzeichnis

4. Es öffnet sich ein Dialog, über den Sie ein neues Projekt anlegen können; dabei können Sie u.U. eine vorkonfigurierte, anpassbare Standardvorlage nutzen. Alternativ können Sie auch ein bereits bestehendes Projekt öffnen.

5. Passen Sie die Vorlage entsprechend an. Diese Druckvorlage können Sie jederzeit über die Eigenschaft "Dateiname" zum Bearbeiten öffnen.

§ Zur Ausgabe von Verweistext und Seitenzahl in der Datenzeile stehen Ihnen dabei die Felder Verweis.Text, Verweis.Seitenzahl bzw. Verweis.Index zur Verfügung.

§ Für die Angabe der Inhaltsverzeichnis-Ebene bzw. Index-Ebene in der Darstellungsebene der Datenzeile steht Ihnen das Feld "Verweis.Ebene" zur Verfügung.


Rückseite

Über Projekt > Berichtsabschnitte kann ein Rückseitendruck definiert werden. Zur Druckzeit werden die entsprechenden Werte ausgelesen und die Datei auf jeder Rückseite oder nur auf der ersten bzw. hinter der letzten Seite ausgegeben.

Diese Funktion ist nützlich, um z.B. die AGB auf der Rückseite der letzten Seite einer Rechnung auszugeben.

Gehen Sie wie folgt vor:

1. Öffnen Sie den Dialog zur Definition der Berichtsabschnitte über Projekt > Berichtsabschnitte.

2. Selektieren Sie den Abschnitt "Rückseite".

Abbildung 8.14: Dialog zum Einbinden einer Rückseite

3. Definieren Sie über die Eigenschaften die Position der Rückseite bei Duplexdruck: Rückseite der ersten Seite, Rückseite aller Seiten, nach der letzten Seite. Definieren Sie außerdem die Position der Rückseite bei nicht-Duplexdruck oder Export.

Hinweis: In der Vorschau erscheint die Rückseite ganz zum Schluss.

4. Klicken Sie oben auf "Bearbeiten" um den Assistenten für die Erstellung der Rückseite zu starten.

5. Es öffnet sich ein Dialog, über den Sie ein neues Projekt anlegen können; dabei können Sie u.U. eine vorkonfigurierte, anpassbare Standardvorlage nutzen. Alternativ können Sie auch ein bereits bestehendes Projekt öffnen.

6. Passen Sie die Vorlage entsprechend an. Diese Druckvorlage können Sie jederzeit über die Eigenschaft "Dateiname" zum Bearbeiten öffnen.

Abbildung 8.15: Eigenständiges Projekt für die Rückseite


Ausgabemöglichkeiten

Sie haben zwei Möglichkeiten Projekte zu drucken: Druckaufruf aus der übergeordneten Anwendung oder über die Echtdatenvorschau im Designer (sofern von der Anwendung unterstützt).

Siehe auch:

Ausgabe-Einstellungen

Echtdatenvorschau

Export in andere Formate (PDF, XLS …)

Probedruck im Designer

Berichtsparameter


Ausgabe-Einstellungen

Der Druck kann direkt aus dem übergeordneten Programm über einen Menüpunkt oder aus der Vorschau aufgerufen werden.

Sofern Sie den Druck aus dem übergeordneten Programm aufrufen, wird nach Auswahl der gewünschten Druckvorlage in der Regel der Dialog für die Ausgabe-Einstellungen angezeigt.

Abbildung 9.1: Ausgabe-Einstellungen

Sie haben hier verschiedene Konfigurationsmöglichkeiten:

§ In der Rubrik "Ausgabemedium" können Sie die Druckereinstellungen ändern. Wenn Sie im Seitenlayout mehrere Bereiche definiert haben, können Sie hier auch die Druckereinstellungen der verschiedenen Bereiche ändern. Unter "Exemplare" geben Sie die Anzahl der Exemplare an.

§ Unter "Ausgabe auf" wählen Sie das Ausgabeformat (z.B. Vorschau, Drucker, PDF).

§ Über die Option "Vorschau" haben Sie die Möglichkeit, die Ausgabe nicht sofort auf den Drucker zu schicken, sondern zuerst am Bildschirm in der Echtdatenvorschau anzeigen zu lassen. Auf diese Weise können Sie das Ergebnis überprüfen.

§ Über die Option "Einstellungen permanent speichern" kann die Druckerauswahl und das Ausgabeformat zum Standard für diese Druckvorlage festgelegt werden.

§ Über "Anfangsseite" legen Sie fest, mit welcher Seitenzahl die Nummerierung beginnen soll.

§ Über "Seiten" können Sie bestimmte Seiten oder einen bestimmten Seitenbereich (z.B. 1, 3-4, 10-) auswählen.

§ Über "Einschränkung" kann die Ausgabe auf gerade/ungerade bzw. die oben ausgewählten Seiten beschränkt werden.

§ Beim Etikettendruck können Sie zusätzlich über die Schaltfläche "Wählen" die Anfangsposition für den Druck des Etikettenbogens bestimmen.

Abbildung 9.2: Zusätzliche Ausgabe-Einstellung bei Etiketten

So können auch bereits verwendete Etikettenbögen zum Druck verwendet werden. Im Dialog zur Auswahl der Anfangsposition finden Sie einen Musteretikettenbogen Ihres Etikettenprojektes. Klicken Sie mit der Maus auf das Etikett, bei dem der Druck beginnen soll. Bitte beachten Sie dabei die gewählte Druckreihenfolge. Gedruckt werden kann dabei nicht nur zeilenweise von links oben nach rechts unten, sondern auch spaltenweise oder umgekehrt. Von dem gewählten Anfangsetikett aus wird dann in der angegebenen Reihenfolge gedruckt.


Echtdatenvorschau

Sofern von Ihrer Anwendung unterstützt, steht die Echtdatenvorschau auch direkt im Designer zur Verfügung. Auf diese Weise können Sie das Layout eines Druckes überprüfen, ohne dafür Papier verschwenden zu müssen. Die Ausgabe am Bildschirm erfolgt detailgetreu (WYSIWYG – What You See Is What You Get) genauso, wie sie auch beim echten Druck erfolgen würde. Sie können nach erfolgter Layout-Kontrolle den eigentlichen Druck auch direkt aus der Vorschau starten, ohne den Druckbefehl nochmals aufrufen zu müssen.

Abbildung 9.3: Echtdatenvorschau im Designer

§ Die Seiten werden fortlaufend angezeigt. Über die Schaltfläche "Verschieben" kann der Ansichtsbereich mit der Maus verschoben werden, ansonsten per Bildlaufleiste.

§ Über die Schaltflächen "Bereich wählen", "100%", "Seitenbreite", "Vergrößern" und "Verkleinern" können Sie die Ansicht im Arbeitsbereich anpassen.

§ Wenn Sie die Ansicht verkleinern, werden mehrere Seiten dargestellt.

§ Ein Doppelklick auf eine Seite passt die Ansicht so an, dass die ganze Seite zu sehen ist.

§ Über den Zoomregler in der Statuszeile können sie im Bereich 50% - 500% stufenlos verkleinern und vergrößern.

§ Halten Sie die Strg-Taste fest und drehen Sie gleichzeitig das Mausrad um zu verkleinern und zu vergrößern.

§ Bei aktivierter Funktion "Bereich wählen" ziehen Sie den gewünschten Ansichtsbereich mit gedrückter linker Maustaste auf.

§ Über die Suchfunktion können Sie die Vorschau seitenübergreifend durchsuchen.

§ Zur schnellen, direkten Navigation finden Sie im linken Bereich die Registerkarten "Seiten", "Verzeichnis" und "Index". Informationen zu Verzeichnis und Index finden Sie unter Inhaltsverzeichnis und Index in Kapitel Seitenlayout .

§ Über Datei > Optionen > Vorschau (Projekt > Optionen > Vorschau) können Sie die maximale Zahl der Seiten angegeben, die in der Echtdatenvorschau angezeigt werden sollen. Über die Schaltfläche "Seiteneinschränkung" in der Toolbar kann diese Seitenanzahl aktiviert werden.

§ Die in den Druckoptionen angegebene "Kopienanzahl" wird in der Vorschau nicht berücksichtigt, diese wird erst beim tatsächlichen Druck relevant.


Export in andere Formate (PDF, XLS …)

Druckausgaben können auch in verschiedene Dateiformate ausgegeben werden. Zur Verfügung stehen – je nach Anwendung – z.B. PDF, DOCX, PPT, XHTML, MHTML, HTML, Excel, RTF, XPS, TIFF, PNG, JPEG, Bitmap, EMF, TTY, CSV, Text, XML.

Wählen Sie dazu im Druckdialog der Ausgabe-Einstellungen (aus dem Designer z.B. erreichbar über Datei > Exportieren oder über "Exportieren" in der Vorschau) das entsprechende Ausgabemedium.

Bitte beachten:

§ das Layout kann – formatbedingt – nicht immer 1:1 übernommen werden , da es bei diesen Formaten spezifische Einschränkungen bezüglich der Umsetzung gibt.

§ Der Ausfertigungsdruck wird nur beim PDF-Export unterstützt.

§ Das Microsoft® Word Exportformat erzeugt DOCX-Dateien, die mit Microsoft® Office 2007 und höher kompatibel sind. Tabellen werden seitenübergreifend exportiert und können somit nachträglich bearbeitet werden.

§ Beim RTF-Export wird keine Mischung von verschiedenen Seitenformaten unterstützt.

Über die Schaltfläche "Optionen" erreichen Sie bei diversen Formaten die Einstellungsmöglichkeiten.

§ Beim Excel-Format kann z.B. über die Option "Ausschließlich Daten aus Tabellenobjekten" die Anzahl der Spalten und Zeilen auf die notwendige Anzahl verringert werden. Außerdem können alle Seiten in eine Tabelle exportiert werden und als Ausgabeformat steht neben 'xls' auch 'xlsx' zur Verfügung.

§ Der Bildexport nach JPEG, TIFF und PNG unterstützt als Option das automatische Zuschneiden der Ergebnisse auf den Inhalt. Somit ist z.B. ein exportierter Barcode nur noch genau so groß wie mindestens nötig um den gesamten Inhalt anzuzeigen.

§ Beim PDF-Export finden Sie hier z.B. die Option zur Erstellung einer PDF/A konformen Datei und Sicherheitsoptionen. Informationen zum Erstellen eines PDF-Inhaltsverzeichnisses finden Sie unter Berichtsabschnitte im Kapitel Seitenlayout.

Abbildung 9.4: Ausgabe-Einstellungen für PDF

Wenn Sie den Druck starten, wählen Sie im folgenden Dialog "Speichern unter" den Speicherort und geben im Feld "Dateiname" einen Namen für die zu erstellende Datei an.

§ Über die Option "Nach der Ausgabe die mit der Datei verknüpfte Anwendung starten" können Sie die Datei nach der Erstellung direkt im entsprechenden Programm (z.B. Excel) öffnen.

§ Über die Option "Erzeugte Dateien per Mail verschicken" können Sie die Datei direkt per Mail versenden.

§ Über die Option "Erzeugte Dateien digital signieren" können Sie die Datei digital signieren (nicht in allen Anwendungen verfügbar).

Abbildung 9.5: Speichern unter – Dialog beim Export


Probedruck im Designer

Wählen Sie Datei > Drucken > Probedruck (Datei > Probedruck) für einen Probedruck Ihres momentanen Projekts. Fester Text erscheint im Probedruck wie im Projekt festgelegt, Variablen und Felder werden dabei jedoch durch einen vordefinierten Beispieltext bzw. durch einen einzelnen, sich wiederholenden Beispieldatensatz ersetzt.


Berichtsparameter

Die Berichtsparameter erlauben die Parametrisierung von Berichten, d.h. das Ergebnis der Ausgabe kann beeinflusst werden. Somit kann z.B. ein Datumsbereich ausgewählt oder nur bestimmte Rechnungsnummern gedruckt werden.

Diese Funktionalität kann auch zur Erstellung von DrillDown-Berichten verwendet werden. Weitere Informationen dazu finden Sie im Kapitel Drilldown Berichte (Detailtiefe erhöhen).

Über Projekt > Berichtsparameter können Parameter definiert werden.

Hinweis: Die Zahl der definierbaren Parameter hängt von der Anwendung ab.

Beispiel: Einen Bericht in der Vorschau nach Kategorien und Datum filtern

Gehen Sie wie folgt vor:

1. Gegeben ist eine Produktstatistik über mehrere Produktgruppen und Jahre:

Abbildung 9.6: Produktstatistik

2. Legen Sie nun über Projekt > Berichtsparameter die Parameter an. Vergeben Sie einen aussagekräftigen Namen, z.B. "Categories", das Zeichen "@" wird automatisch an den Anfang gesetzt. Bei "Verfügbare Werte" wählen Sie "Aus Datenquelle" und die Datenquelle "Categories" mit dem Feld "CategoryID".

Abbildung 9.7: Liste der Berichtsparameter – Aus Datenquelle

3. Für die weiteren Berichtsparameter "StartDate" und "EndDate" wählen Sie als "Verfügbare Werte" die "Manuelle Eingabe". Setzen Sie "Typ" und "Control-Typ" auf "Datum" und vergeben Sie eine aussagekräftige Bezeichnung, z.B. "Startdatum" und "Enddatum".

Abbildung 9.8: Liste der Berichtsparameter – Manuelle Eingabe

4. Die Parameter stehen nun in der Variablen-/Feldliste zur Verfügung.

Abbildung 9.9: Berichtsparameter in der Variablen-/Feldliste

5. Definieren Sie nun in der Eigenschaft "Datenfilter" im Diagramm-Objekt die entsprechende Formel für die Einschränkung der Daten.

Beachten Sie dabei die Hinweise im Kapitel 7.2 F ilter .

Abbildung 9.10: Formel für den Datenfilter

6. Beim Druck in die Vorschau können die Parameter dann wie gewünscht eingestellt werden – der Bericht wird nach Kategorien und Datum gefiltert:

Abbildung 9.11: Angewendete Berichtsparameter

7. Wenn Sie nicht auf die Vorschau, sondern z.B. nach PDF drucken, bekommen Sie die Parameterauswahl vorab in einem Dialog angezeigt.

Abbildung 9.12: Berichtsparameter-Auswahl beim Export

8. Sie können nun noch einen weiteren abhängigen Parameter definieren – im Beispiel oben z.B. einen "Produkte"-Parameter, der von der Auswahl bei "Kategorien" abhängig ist. Über die Eigenschaft "Abhängig von" wählen Sie dabei den entsprechenden Parameter aus.

Abbildung 9.13: Definition eines abhängigen Berichtsparameters

9. Damit werden Ihnen im zweiten Parameter "Produkte" nur die Werte angeboten, die zur Auswahl des ersten Parameters passen. Hier im Beispiel nur die Getränke:

Abbildung 9.14: Abhängiger Berichtsparameter


Variablen, Felder und Ausdrücke

Informationen können zum einen als "fester Text" direkt ins Projekt eingegeben werden, wie z.B. eine Absenderzeile in einem Adressetikett oder eine Überschrift über einer Liste. Fester Text wird also genau so gedruckt, wie im Projekt angegeben.

Zum anderen können diese Informationen aus dem übergeordneten Programm dynamisch übernommen werden. Solche Informationen werden als "Variablen" bzw. "Felder" in die Projekte eingefügt.

Felder sind dabei die sich pro Zeile ändernden Daten einer Tabelle, Variablen sind pro Seite gleichbleibend. So können Sie z.B. als Inhalt für die Spalte einer Liste die Variable TELEFON wählen. Gedruckt werden dann in dieser Spalte die verschiedenen Telefonnummern zu den Datensätzen der Datenbank. Variablen sind also Platzhalter.

Mit diesen beiden Informationsarten lassen sich bereits ansprechende Projekte gestalten, die für viele Zwecke genügen. Der Designer bietet jedoch noch weitaus mehr: Mit Hilfe von Formeln und Ausdrücken können die in Variablen und festem Text enthaltenen Informationen nahezu beliebig verknüpft oder verändert werden. Hierzu dienen "Formeln" oder "Ausdrücke". In Formeln oder Ausdrücken können fester Text und Variablen in "Funktionen" eingesetzt und über "Operatoren" miteinander verknüpft werden.

Bei Projekten zum Druck von Adressetiketten können Sie z.B. über einen Ausdruck zu einer in einer Variablen POSTFACH gespeicherten Postfach-Nummer automatisch den Text "Postfach" ergänzen. Damit erschiene auf dem Etikett nicht nur die nackte Postfach-Nummer, sondern eben etwas wie "Postfach 111111".

Oder stellen Sie sich vor, Sie hätten in einer Variable PREIS die Nettopreise von Artikeln zur Verfügung, wollten in Ihrer Liste jedoch die Preise inklusive Mehrwertsteuer drucken. Hier hilft eine Formel, die aus dem Nettopreis die Mehrwertsteuer berechnet und diese hinzuaddiert. Gedruckt würde damit der Bruttopreis.

Siehe auch:

Variablen-/Feldliste

Die Elemente eines Ausdrucks

Arbeiten mit Funktionen

Arbeiten mit Operatoren


Variablen-/Feldliste

Die Variablen-/Feldliste zeigt alle im aktuellen Projekt verfügbaren Variablen an, in Listenprojekten zudem alle verfügbaren Felder.

In der hierarchischen Liste wird zwischen Variablen, Feldern, Datenbankschemata, Tabellen, Benutzervariablen und Summenvariablen unterschieden.

Benutzerdefinierte Variablen und Felder können selbst noch hierarchisch gegliedert sein. Der Inhalt von Variablen ist im Normalfall gleichbleibend zumindest auf einer Druckseite, Felder ändern sich von Tabellenzeile zu Tabellenzeile.

Wenn Sie bestehenden Objekten Variablen bzw. Felder zuweisen wollen, können Sie die gewünschten Variablen und Felder einfach aus der Liste auf das entsprechende Objekt mit der Maus ziehen (Drag & Drop). Das Einfügen erfolgt, wenn möglich, automatisch. Wenn Sie eine Variable auf einen freien Platz auf dem Arbeitsbereich ziehen, dann wird an dieser Stelle ein neues Textobjekt erstellt. Die Größe richtet sich dabei nach der Größe des zuletzt in der Größe bearbeiteten Objekts.

Abbildung 10.1: Variablen-/Feldliste


Die Elemente eines Ausdrucks

Fester Text, Variablen, Formeln, Funktionen, Verknüpfungen und dergleichen – im Folgenden allgemein als "Elemente von Ausdrücken" bezeichnet – werden alle über einen gemeinsamen Dialog eingefügt und kombiniert.

Der Formelassistent unterstützt Sie bei der Eingabe mit einer Reihe von Eingabehilfen:

§ Funktionssyntax anzeigen: Bei Funktionen erscheint ein Tooltip, der die gewählte Funktion beschreibt, die benötigten Parameter auflistet und den Ergebnistyp anzeigt.

§ Auto-Vervollständigen: Nach Eingabe eines Buchstabens werden die verfügbaren Funktionen, Felder und Variablen aufgelistet, die mit diesem Buchstaben beginnen. Innerhalb von Funktionen werden für Parameter passende Werte vorgeschlagen.

§ Syntax-Einfärbung: Funktionen, Parameter, Operatoren und Kommentare werden farblich unterschiedlich dargestellt.

§ Automatische Typ-Konvertierung: Variablen- und Feldtypen werden beim Einfügen in bestehende Ausdrücke automatisch so konvertiert, dass der Datentyp mit dem Erwarteten übereinstimmt.

Abbildung 10.2: Autovervollständigen im Formel-Assistenten

Siehe auch:

Unterschiedliche Ausdrucksmodi

Die Registerkarten

Die Bearbeitungszeile

Variablen einfügen

Festen Text einfügen

Kommentare einfügen


Unterschiedliche Ausdrucksmodi

Bitte beachten Sie, dass bei der Schreibweise von Ausdrücken, je nach Anwendung, zwei unterschiedliche Modi möglich sind:

Zum einen gibt es den normalen Ausdrucksmodus, bei dem Variablennamen und Funktionen ohne Klammern eingegeben werden können. Fester Text muss mit Anführungszeichen eingerahmt werden. Die einzelnen Variablen müssen mit dem Operator "+" zusammengefügt werden.

Zum anderen gibt es den erweiterten Modus, bei dem fester Text ohne Anführungszeichen eingegeben werden kann. Variablen werden mit spitzen Klammern ("<" und ">") eingerahmt, Funktionen mit Chevrons ("«" und "»").

Um diese Chevrons einzufügen (wenn Sie z.B. eine Funktion direkt eingeben möchten) steht Ihnen in diesem Modus die Schaltfläche "Chevrons einfügen" zur Verfügung (auch Alt+174/175). Das Zusammenfügen einzelner Variablen mittels eines Operators entfällt bei diesem Modus. Der erweiterte Modus ist einfacher zu bedienen.

Abbildung 10.3: Erweiterter Modus


Die Registerkarten

Dieser Dialog besteht aus einer Reihe von Registerkarten, die jeweils verschiedene Elemente zur Bearbeitung enthalten.

Die Registerkarte | enthält die Elemente
Daten und Funktionen | Die für diesen Objekttyp verfügbaren Variablen und Funktionen
Bedingung | Spezieller Dialog zur Definition von WENN-DANN-SONST Bedingungen
Text | Dialog zur Eingabe von festem Text und Einstellungsmöglichkeiten für Tabulatoren (nur Textobjekte)
Datumsformat | Verfügbare Datumsformate
Zahlenformat | Verfügbare Zahlenformate
Operatoren | Verfügbare Verknüpfungsoperatoren
Farben | Verfügbare Farben

Auf jeder dieser Registerkarten finden Sie einen Button "Einfügen" über den das ausgewählte Element in die Bearbeitungszeile übernommen werden kann. Die gleiche Wirkung hat ein Doppelklick auf das entsprechende Element. Zudem können Sie die Elemente per Drag & Drop (auch in und von der Funktionsliste) in die Bearbeitungszeile ziehen.

Für die unterschiedlichen Elemente eines Ausdrucks (Variablen, Felder, Text, Funktionen, etc.) gelten jeweils bestimmte Regeln für die Schreibweise und für die Verknüpfung der einzelnen Elemente zu einem Ausdruck. Der Formel-Assistent unterstützt Sie bei der Eingabe über die jeweilige Registerkarte.

Für erfahrene Benutzer ist es ebenfalls möglich, den gewünschten Ausdruck direkt in die Bearbeitungszeile einzugeben oder den Ausdruck dort noch zu bearbeiten (z.B. Klammern setzen).


Die Bearbeitungszeile

Die Bearbeitungszeile enthält den Ausdruck, den Sie über die verschiedenen Registerkarten zusammengesetzt, direkt eingegeben oder per Drag & Drop erstellt haben.

Der Ausdruck wird dabei bereits während seiner Entstehung ständig auf seine korrekte Schreibweise geprüft. Eventuelle Syntaxfehler werden im Infofeld unterhalb der Bearbeitungszeile angezeigt, zusammen mit einem Hinweis auf die Ursache des Fehlers. Solange der Ausdruck nicht vollständig ist, wird die Prüfung in der Regel einen Syntaxfehler ergeben, daran sollten Sie sich nicht stören. Wenn der Ausdruck komplett ist, sollte der daraus entstandene Text mit den Beispiel-Daten des Designers angezeigt werden.

Um komplexe Ausdrücke übersichtlich zu erstellen, können Sie diese mit Return über mehrere Zeilen verteilen. Das Ergebnis wird davon nicht beeinflusst.

Mit den verschiedenen Schaltflächen rechts neben dem Eingabefeld können Sie:

§ die zum Formelausdruck gehörenden Klammern markieren.

§ den gesamten Ausdruck zweier zusammengehöriger Klammermarken markieren.

§ Summen-, Benutzer und Sammelvariablen bearbeiten.

§ Markierung aus- oder einkommentieren

§ die letzte Operation rückgängig machen.

§ die letzte Rückgängig-Operation wiederherstellen machen.


Variablen einfügen

Es existieren unterschiedliche Datentypen für Variablen: "Zeichenkette", "Zahl", "Datum", "Boolean" (logische Werte), "Bild" und "Barcode". Der Datentyp wird wichtig, wenn Sie Variablen als Parameter in Funktionen verwenden wollen, da diese in der Regel immer nur bestimmte Datentypen als Parameter zulassen. So können Sie einen Zahlenwert auch nur mit einem Zahlenwert multiplizieren.

Die Registerkarte "Daten und Funktionen" enthält eine Übersicht aller verfügbaren Variablen, deren Datentyp in Form von einem Icon vor der Variable sowie der verfügbaren Funktionen.

Über das Eingabefeld oberhalb der Variablen-/Feldliste können Sie die Variablen filtern.

Doppelklicken Sie auf die gewünschte Variable oder betätigen Sie die Schaltfläche "Einfügen" oder ziehen Sie die Variable auf die Bearbeitungszeile, um sie zu übernehmen. Die betreffende Variable wird daraufhin in der korrekten Schreibweise in die Bearbeitungszeile übernommen. Sie können Daten auch direkt auf eine Funktion ziehen.

Um weitere Variablen in Ihren Ausdruck aufzunehmen, wiederholen Sie obige Schritte. Falls zwischen den einzelnen Variablen Leerzeichen stehen sollen, z.B. um VORNAME und NAME zu trennen, achten Sie darauf, diese Leerzeichen in die Bearbeitungszeile einzugeben.

Abbildung 10.4: Variablen und freien Text verketten

Sie können Variablen auch einfügen, indem Sie auf dem Arbeitsbereich die gewünschte Variable aus dem Toolfenster "Feld/Variablenliste" per Drag & Drop auf das Zielobjekt oder in einen leeren Bereich "ziehen". Die Variable wird dann automatisch in dem Objekt als neue Zeile eingefügt.


Festen Text einfügen

Ein weiteres wichtiges Element von Ausdrücken ist fester Text, mit dem Sie z.B. einer Variablen eine Bezeichnung voranstellen können, etwa "Telefon: 1234567".

Über die Registerkarte "Text" können Sie freien Text in Ihren Ausdruck aufnehmen, Tabulatoren setzen und Zeilenumbrüche festlegen.

Geben Sie den gewünschten Text ein und klicken Sie auf "Einfügen" um Ihre Eingabe in die Bearbeitungszeile zu übernehmen. Dabei wird der Text automatisch in Anführungszeichen gesetzt. Als Alternative zu Anführungszeichen können Sie Hochkommas nutzen.

Abbildung 10.5: Fester Text im Formel-Assistenten

In obigem Beispiel wurde zuerst über die Registerkarte "Text" der feste Text "Name: " eingefügt und anschließend über die Registerkarte "Daten und Funktionen" die Variablen "Empfaenger.Anrede", "Empfaenger.Vorname" und "Empfaenger.Nachname". Gedruckt würde damit zuerst der Text "Name: " gefolgt von der Anrede, dem Vornamen und Nachnamen aus der Datenbank.

Bitte beachten Sie, dass auch Leerzeichen, die z.B. als Trennzeichen zwischen Variablen oder zwischen Variablen und Text stehen sollen, als "fester Text" gelten.

Je nach Modus können Variablen und fester Text nicht einfach zusammengesetzt werden, sondern müssen über den Verknüpfungsoperator "+" verbunden werden. In diesem Beispiel wird der feste Text "Name: " über den Operator "+" mit der Variablen "Empfaenger.Anrede" verbunden.

Siehe auch:


Zeilenumbrüche einfügen

Über die Schaltfläche "Umbruch" fügen Sie einen Zeilenumbruch ("¶") in Ihre Textzeile ein.

Abbildung 10.6: Umbruch über Schaltfläche einfügen

Ein solcher Umbruch wirkt sich jedoch nur aus, wenn Sie für das betreffende Objekt (Zeile eines Textobjektes oder Spalte eines Tabellenobjektes) Umbrüche zulassen. In diesem Fall werden die Worte, die nicht mehr in die Zeile/Spalte passen, in eine neue Zeile umgebrochen und die darunterliegenden Zeilen um eine Zeile nach unten verschoben. (Achtung: Besteht der Text nicht aus mehreren Worten, sondern nur aus einem langen Wort, wird er nicht umgebrochen, sondern abgeschnitten).

Bei Textobjekten muss hierfür der Wert der "Zeilen-Umbruch"-Eigenschaft in der Eigenschaftsliste des jeweiligen Absatzes "umbrechen" sein.

Bei Tabellenobjekten muss hierfür der Wert der "Einpassen"-Eigenschaft in der Eigenschaftsliste der jeweiligen Spalte "umbrechen" sein.


Tabulatoren einfügen

Tabulatoren sind nur in Textobjekten zulässig, in Tabellenobjekten erscheint diese Schaltfläche daher nicht. Da es sich bei einem Tabulator auch um ein Zeichen handelt, muss dieses ebenfalls von Anführungszeichen eingerahmt sein bzw. Sie fügen dieses zu einem vorhandenen Text hinzu.

Abbildung 10.7: Tabulator in Textobjekten über Schaltfläche einfügen

Über die Schaltfläche "Tabulator" erzeugen sie einen Tabulator, über die Schaltfläche "Eigenschaften" bestimmen Sie Position und Ausrichtung.

Abbildung 10.8: Eigenschaften des Tabulators

Pro Absatz kann ein Tabulator eingefügt werden. Ein Tabulator bewirkt, dass der Text davor bis max. zum Tabulator läuft. Bei einem rechtsbündigen Tabulator wird der Text nach dem Tabulator rechtsbündig angezeigt, bei einem linksbündigen Tabulator entsprechend linksbündig und bei einem Dezimaltabulator am Dezimalzeichen ausgerichtet. Über die Position des Tabulators wird der Abstand vom linken Objektrand angegeben.

Abbildung 10.9: 2 Absätze mit jeweils linksbündigem Tabulator


Kommentare einfügen

Sofern von der Anwendung zur Verfügung gestellt, können in Formeln Kommentare hinzugefügt werden. Dies kann auf zwei Arten erfolgen:

§ "/* <text> */" für Kommentare in der Mitte einer Formel

§ "/* <text>" für Kommentare am Ende der Formel. Damit wird der gesamte Rest der Formel zum Kommentar, nicht nur die Zeile!

Mit den jeweiligen Schaltflächen rechts neben dem Eingabefeld können Sie eine Markierung direkt aus- oder einkommentieren.

Abbildung 10.10: Kommentare einfügen


Arbeiten mit Funktionen

Mit Funktionen wird es bei der Definition von Ausdrücken erst richtig interessant, hier eröffnen sich unzählige Möglichkeiten. So können Sie mit Hilfe dieser Funktionen rechnen, die Ergebnisse von Variablen oder deren Erscheinungsbild beeinflussen, Wertetypen umwandeln und vieles mehr.

Siehe auch:

Schreibweise von Funktionen

Wertetypen

Übersicht über die Funktionen

Funktionen verwenden


Schreibweise von Funktionen

Die Funktionen folgen alle der gleichen, an die Programmiersprache BASIC angelehnten Schreibweise:

Rückgabewert = Funktion(Argumente)

Es werden nur die Funktion und die Argumente angegeben. Groß- und Kleinschreibung ist bei Funktionsnamen bedeutungslos, nicht jedoch bei den Argumenten. Insbesondere wenn Variablen als Argumente benutzt werden, ist die Groß- und Kleinschreibung wichtig.

Dieser Ausdruck wird ausgewertet und der Teil "Funktion(Argumente)" durch den "Rückgabewert" ersetzt. D.h. aus der Eingabezeile Funktion(Argumente) entsteht der Rückgabewert.

Dabei bedeuten:

Element | Bedeutung
Funktion() | Der Name der jeweiligen Funktion in seiner korrekten Schreibweise. Die Klammern () für die Argumente gehören zum Funktionsnamen dazu. Selbst wenn eine Funktion keine Argumente hat, müssen die Klammern angegeben werden.
Argumente | Die Werte, die eine Funktion benutzt, um daraus den Rückgabewert zu erzeugen. Die Argumente schließen sich unmittelbar, d.h. ohne dazwischenliegendes Leerzeichen, an den Funktionsnamen an. Eine Funktion kann keine, eines oder mehrere Argumente haben. Meist erwarten Funktionen Argumente eines bestimmten Wertetyps (siehe unten). Es ist wichtig, dass die Wertetypen der Argumente den von der Funktion erwarteten Typen entsprechen.
Rückgabewert | Das Ergebnis einer Funktion. Der Wertetyp eines Rückgabewertes hängt von der jeweiligen Funktion bzw. dem Wertetyp der Argumente ab.


Wertetypen

Wertetyp | Erläuterung
Boolean | Die logischen Werte "Wahr" oder "Falsch" (bzw. True oder False). Ist die Bedingung erfüllt, ist der Ergebniswert True, andernfalls False.
Zeichenkette | Eine beliebige Zeichenkette. Diese Zeichenkette kann Buchstaben, Zahlen und Sonderzeichen enthalten. Sie muss in Anführungszeichen ("") gesetzt werden, damit sie von Variablennamen unterschieden werden kann.
Datum | Datumswerte nach dem Julianischen Kalender.
Zahl | Eine Zeichenkette, die nur aus den Ziffern 0, 1,..., 9, dem Dezimalpunkt und dem Minuszeichen besteht; andere Zeichen sind nicht erlaubt. Zeichenketten vom Typ Zahl müssen nicht in Anführungszeichen eingeschlossen werden.
Barcode | Eine Zeichenkette, die aus den für Barcodes verwendeten Zeichen besteht.
Bild | Eines der unterstützten Bildformate.
RTF | Ein formatierter Text.


Übersicht über die Funktionen

Eine Übersicht der verfügbaren Funktionen finden Sie auf der Registerkarte "Daten und Funktionen". Dabei erhalten Sie zur jeweils selektierten Funktion eine Erläuterung. Angezeigt werden auch Art und Typ der von der Funktion erwarteten Argumente (Parameter).

Abbildung 10.11: Liste der Funktionen mit Hilfetext und Tooltip

Sind zu einer Funktion keine Argumente angegeben, heißt das, dass die Funktion keine Argumente (außer den leeren Klammern) erwartet. Ansonsten erwartet die jeweilige Funktion genauso viele Argumente wie angegeben. In eckigen Klammern ([ ]) stehende Argumente sind optional, d.h. sie können auch weggelassen werden.

Dabei bedeutet das Argument "Alle", dass das Argument jeden der folgenden Wertetypen annehmen kann (Boolean, Zeichenkette, Datum, Zahl, Bild, Barcode, RTF).

Eine ausführlichere Erläuterung aller Funktionen und Parameter finden Sie unter Übersicht der Eigenschaften.

Die verfügbaren Funktionen auf der Registerkarte "Daten und Funktionen" werden alphabetisch sortiert oder nach Funktionsgruppe angezeigt. Folgende Funktionsgruppen werden angeboten:

§ Numerische Funktionen

§ Mathematische Funktionen

§ Datumsfunktionen

§ Zeichenkettenfunktionen

§ Diverse Funktionen

§ Aggregatsfunktionen

§ Barcodefunktionen

§ Umwandlungsfunktionen

§ Binärfunktionen

§ Bildfunktionen

§ Projekt- und Druckabhängige Funktionen

§ Logische Funktionen

§ Währungsfunktionen

Über das Eingabefeld oberhalb der Funktionsliste können Sie die Funktionen filtern.

Wenn Sie eine der Funktionen selektieren, erhalten Sie im Infobereich unten eine kurze Erläuterung dazu. Um die Funktion in die Bearbeitungszeile zu übernehmen, doppelklicken Sie auf die gewünschte Funktion, betätigen die Schaltfläche "Einfügen" oder ziehen ein Feld/eine Variable auf die Funktion.


Funktionen verwenden

Nachfolgend werden Beispiele einiger ausgewählter Funktionen beschrieben.

Siehe auch:

Eine Zahl in eine Zeichenkette mit Str$() umwandeln

Eine Zeichenkette mit Val() in eine Zahl umwandeln.

Eine Zeichenkette mit Date() in ein Datum umwandeln

Eine Zeichenkette mit Barcode() in einen Barcode umwandeln

Eine Zeichenkette mit Drawing() in ein Bild umwandeln

Zeichenketten abschneiden

Datumswerte mit Date$() formatieren

Zahlenwerte mit Fstr$() formatieren

Währungen mit LocCurrL$() oder LocCurr$() formatieren

Seitenzahlen mit Page$() oder Page()

Werte zählen mit Count()

Nur bestimmte Werte zählen mit CountIf()

Summen bilden mit Sum()

Benutzereingabe über AskString$() und AskStringChoice$()

Darstellungsbedingungen mit Lastpage()

Logische Bedingungen mit Cond()

Arbeiten mit Null-Werten


Eine Zahl in eine Zeichenkette mit Str$() umwandeln

Die Funktion Str$() wandelt eine Zahl in eine Zeichenkette.

Der (optionale) 2. Parameter gibt die Länge der gewünschten Zeichenkette an. Wenn die Zahl für dieses Format jedoch zu groß ist, kann die resultierende Zeichenkette länger als gewünscht werden. Wenn die Zahl zu klein ist, werden Leerstellen angehängt, je nach Vorzeichen rechts (negativ) oder links (positiv).

Der (optionale) 3. Parameter gibt die Zahl der Nachkommastellen an. Ist er positiv, wird die Zahl als Gleitkommazahl dargestellt, ist er negativ, in wissenschaftlicher Schreibweise. Wenn kein dritter Parameter angegeben ist, wird die Zahl der Nachkommastellen bei einem Ganzzahlwert auf 0 und bei einem Fließkommawert aus Kompatibilitätsgründen auf 5 gesetzt.

Beispiele:

Str$(Constant.Pi()) Ergebnis: "3.14159"
Str$(Constant.Pi(),0,3) Ergebnis: "3.141"
Str$(Constant.Pi(),6,3) Ergebnis: " 3.141"
Str$(-Constant.Pi(),0,-3) Ergebnis: "-3.141e+00"

Gehen Sie zum Erstellen z.B. folgendermaßen vor:

1. Suchen Sie die Funktion in der alphabetischen Liste oder filtern Sie die Funktionen, indem Sie in das Filterfeld über der Funktionenliste "Str$" eingeben.

§ Doppelklicken Sie die Funktion "Str$()" um diese in die Bearbeitungszeile zu übertragen.

§ Ziehen Sie die Funktion per Drag & Drop in die Bearbeitungszeile.

§ Um eine Variable und eine Funktion gleichzeitig einzufügen, ziehen Sie die gewünschte Variable per Drag & Drop direkt auf die Funktion in der Funktionsliste. Die Variable wird als erster Parameter eingefügt.

2. Mit eingefügt werden Platzhalter für die Parameter, welche die Funktion erwartet oder zulässt. Der erste dieser Parameter ist automatisch markiert und Sie werden aufgefordert, diesen Platzhalter durch einen gültigen Wert zu ersetzen. Es empfiehlt sich, zuerst alle Parameter der Funktion durch die entsprechenden Werte zu ersetzen, bevor Sie mit der Definition des Ausdrucks fortfahren.

3. Für die meisten Parameter sind auch Funktionen als Werte zulässig. Solange Sie diese ebenfalls über die Registerkarte "Funktion" einfügen, achtet der Designer für Sie auf die korrekte Schreibweise.

4. Alternativ tippen Sie direkt in der Bearbeitungszeile den Funktionsnamen "Str$" ein und übernehmen dann die Funktion aus der Vorschlagsliste.


Eine Zeichenkette mit Val() in eine Zahl umwandeln.

Die Funktion "Val()" wandelt eine Zeichenkette in eine Zahl. Wenn ein Fehler auftritt, ist das Resultat 0. Das Dezimalzeichen muss immer als "." angegeben werden.

Beispiel:

Val ("3.141") Ergebnis: 3.14

Die Funktion "LocVal()" wandelt eine Zeichenkette in eine Zahl und formatiert das Ergebnis in der für das Land gültigen Formatierung.

Beispiele:

LocVal ("12,00","de-de") Ergebnis: 12,00

LocVal ("12,00","en-us") Ergebnis: 1200,00


Eine Zeichenkette mit Date() in ein Datum umwandeln

Die Funktion "Date()" wandelt eine Zeichenkette in ein Datum. Dabei wird das Trennzeichen entsprechend ausgewertet:

Beispiel:

Date ("04.07.1776") Ergebnis: 04.07.1776


Eine Zeichenkette mit Barcode() in einen Barcode umwandeln

Die Funktion "Barcode()" wandelt eine Zeichenkette in einen Barcode. Diese Funktion kann nur in einem Tabellen- oder einem Barcodeobjekt verwendet werden.

Die möglichen Barcodetypen werden Ihnen von der Auto-Vervollständigung des Assistenten als 2. Parameter angeboten. Für einige Barcodes gibt es bestimmte Formatierungen, die eingehalten werden müssen. Nähere Informationen finden Sie im Kapitel Barcode-Objekte.

Beispiel:

Barcode ("Hallo Welt","GS1 128")


Eine Zeichenkette mit Drawing() in ein Bild umwandeln

Die Funktion "Drawing()" wandelt eine Zeichenkette in eine Bilddatei.

Beispiel:

Drawing("sunshine.gif")


Zeichenketten abschneiden

Die Funktion "Left$()" kürzt eine Zeichenkette von links um eine bestimmte Zeichenanzahl. Die Funktion "Right$()" kürzt die Zeichenkette von rechts und die Funktion "Mid$()" schneidet einen Teil aus der Zeichenkette aus.

Der zweite Parameter gibt die max. Anzahl der Stellen des Resultats.

Beispiele:

Left$("combit", 1) Ergebnis: "c"

Mid$("combit",1,2) Ergebnis: "om"

Right$("combit",3) Ergebnis: "bit"

Die Funktion "StrPos()" bzw. "StrRPos()" liefert die Position des n-ten Vorkommens einer Suchzeichenkette in einer Zeichenkette zurück. Über einen dritten Parameter kann mitgegeben werden, das wievielte Vorkommen des Suchbegriffs in der Zeichenkette zurückgegeben werden soll. Das erste Zeichen der Zeichenkette entspricht Position 0. D.h. mit dieser Funktion können Sie in Abhängigkeit eines Zeichens einen Teil der Zeichenkette zurückgeben, z.B. ab dem ersten Leerzeichen.

Beispiel:

Left$("Peter Müller",StrPos("Peter Müller"," ")) Ergebnis: "Peter"

Die Funktion "Rtrim$()" entfernt Leerzeichen am Ende einer Zeichenkette, die Funktion "Atrim$()" am Anfang und Ende einer Zeichenkette.

Beispiel:

Rtrim$("Hallo Welt ") Ergebnis: "Hallo Welt"


Datumswerte mit Date$() formatieren

Über die Funktion Date$() können Datumswerte formatiert werden. Damit Sie den Formatierungs-Parameter nicht selbst erstellen müssen, können Sie über die Registerkarte "Datumsformat" diesen Parameter aus einer Liste auswählen.

So können Sie bestimmen, ob Tage oder Monate ausgeschrieben werden sollen, oder ob das Jahr mit 2 oder 4 Stellen angegeben werden soll, etc. In der Formatliste finden Sie links die jeweiligen Formatierungsanweisungen und rechts das jeweilige Ergebnis.

Als Datumswert wird hier automatisch die Funktion "Now()" gewählt, die das aktuelle Datum liefert. Wenn Sie dagegen einen anderen Datumswert formatieren wollen, ersetzen Sie in dem Ausdruck "Now()" durch den gewünschten Datumswert. Weitere Informationen zur Funktion "Date$()" finden Sie unter Übersicht der Funktionen.

Abbildung 10.12: Beispiel mit Date$()


Zahlenwerte mit Fstr$() formatieren

Über die Funktion Fstr$() können Zahlenwerte formatiert werden. Dies ist besonders dann nützlich, wenn Sie numerische Werte zusammen mit Text ausgeben möchten. Damit Sie den Formatierungs-Parameter nicht selbst erstellen müssen, können Sie über die Registerkarte "Zahlenformat" diesen Parameter aus einer Liste auswählen.

So können Sie die Anzahl der Vor- und Nachkommastellen, führende Zeichen und dergleichen einstellen. Achten Sie bei komplexeren Ausdrücken mit Berechnungen darauf, dass Sie das Ergebnis formatieren und nicht einen Wert, der in der Rechenformel vorkommt. Sonst kann die Berechnung nicht durchgeführt werden.

In der Formatliste finden Sie links die jeweiligen Formatierungsanweisungen und rechts das jeweilige Ergebnis. Über Doppelklick oder "Einfügen" übernehmen Sie das gewünschte Zahlenformat in die Bearbeitungszeile.

Fügen Sie dann als Parameter den zu formatierenden Zahlenwert ein. Weitere Informationen zur Funktion "Fstr$()" finden Sie unter Übersicht der Funktionen.

Abbildung 10.13: Beispiel mit Fstr$()


Währungen mit LocCurrL$() oder LocCurr$() formatieren

Die Funktion "LocCurrL$()" gibt eine Zeichenkette mit der für das Land gültigen Währungsformatierung mit Währungssymbol zurück. Fügen Sie als Parameter den zu formatierenden Zahlenwert ein. Der (optionale) 2. Parameter ist das ISO 3166-Landeskürzel desjenigen Landes, dessen Währungsformatierung verwendet werden soll.

Beispiel:

LocCurrL$(1000) Ergebnis: "1.000,00 €"

Die Funktion "LocCurr$()" gibt eine Zeichenkette mit der für das Land gültigen Währungsformatierung ohne Währungssymbol zurück.

Beispiel:

LocCurr$(1000) Ergebnis: "1.000,00"

Weitere Informationen zu diesen Funktionen finden Sie unter Übersicht der Funktionen.


Seitenzahlen mit Page$() oder Page()

Die Funktion "Page$()" gibt die Seitenzahl der Druckseite als Zeichenkette zurück.

Beispiel:

"Seite " + Page$() + "/" + TotalPages$() Ergebnis: Seite 1/3

Die Funktion "Page()" gibt die Seitenzahl der Druckseite als Zahl zurück und bietet sich daher eher für Ausdrücke oder Formeln an, also z.B. in Bedingungen.

Beispiel:

Cond(Page()>1, "Seite " + Page$())


Werte zählen mit Count()

Die Funktion "Count()" zählt die Anzahl der Werte des ersten Arguments.

Der 1. Parameter bestimmt die zu zählenden Werte. Der (optionale) 2. Parameter bestimmt, ob nach der Ausgabe die für die Berechnung gemerkten Werte gelöscht werden sollen (True, Voreinstellung).

Beispiele:

Count (Order_Details.ProductID, False)

Count (1)


Nur bestimmte Werte zählen mit CountIf()

Die Funktion "CountIf()" zählt die Anzahl der Werte, für die die Bedingung zutrifft. Verwenden Sie zusätzlich die Funktion "Distinct()", wenn mehrfach vorkommende Werte nur einmal in die Berechnung eingehen sollen.

Der 1. Parameter bestimmt den Ausdruck für den Vergleich. Der (optionale) 2. Parameter bestimmt, ob nach der Ausgabe die für die Berechnung gemerkten Werte gelöscht werden sollen (True, Voreinstellung).

Beispiele:

CountIf (Region="D")

CountIf (Distinct(Region="D")) zählt mehrfach vorkommende Werte nur einmal

CountIf (IsNull (Orders.OrderDate)) zählt alle Werte mit leerem Feldinhalt


Summen bilden mit Sum()

Die Funktion "Sum()" summiert die Werte des ersten Arguments.

Der (optionale) 2. Parameter bestimmt, ob nach der Ausgabe die für die Berechnung gemerkten Werte gelöscht werden sollen (True, Voreinstellung).

Beispiel:

Sum (Order_Details.UnitPrice)


Benutzereingabe über AskString$() und AskStringChoice$()

Über die Funktion "AskString$()" können während der Laufzeit des Drucks Informationen vom Anwender abgefragt werden. Beim Druck erscheint dann eine Dialogabfrage, in der die gewünschte Information einzugeben ist.

Der erste Parameter enthält den Text, der als Eingabeaufforderung in dem Dialog zur Benutzereingabe erscheinen soll.

Der zweite Parameter ermöglicht es, festzulegen, ob die Benutzerabfrage nur einmal zu Beginn des Drucks erscheinen soll (False, Voreinstellung), oder ob die Information für jeden Datensatz individuell abgefragt werden soll (True).

Der dritte Parameter enthält die Zeichenkette, die als Vorschlagswert im Eingabefeld des Dialogs zur Benutzereingabe erscheinen soll.

Der letzte Parameter gibt die Anzahl der Stellen an, die als Benutzereingabe zulässig sein sollen. Beispiel:

AskString$("Geben Sie den Betreff an",False,"Ihre Anfrage vom " + Date$(Now()))

Abbildung 10.14: Eingabedialog durch AskString$()

Über die Funktion "AskStringChoice$()" wird der Wert über einen Dialog mit Combobox abgefragt.


Darstellungsbedingungen mit Lastpage()

Die boolsche Funktion "Lastpage()" gibt an, ob die momentane Seite die letzte Seite ist, d.h. das Ergebnis dieser Funktion ist "True" oder "False".

Diese Funktion kann nur in Fußzeilen von Tabellen, als Bedingung in einer Layoutbereichsbedingung oder in an Tabellen angehängten Objekten verwendet werden! In allen anderen Fällen ist "Lastpage()" immer "False".


Logische Bedingungen mit Cond()

Die Funktionen "Cond()" und "If()" erlauben das Formulieren beliebiger Bedingungen. Das erste Argument ist ein logischer Ausdruck, der auf seinen Wahrheitsgehalt geprüft wird. Ist der Ausdruck wahr (True), so wird das zweite Argument als Ergebnis zurückgegeben. Ist der Ausdruck falsch (False), so wird das dritte Argument als Ergebnis zurückgegeben.

Ein einfaches Beispiel: Nehmen wir an, Sie möchten in der Fußzeile einer Rechnung die Seitensumme der Artikelpreise ausgeben. Auf der letzten Seite möchten Sie die Gesamtsumme der Artikelpreise ausgeben.

Abbildung 10.15: Beispiel für Cond()

Diese Funktion erstellen Sie im Formel-Assistenten entweder direkt in der Bearbeitungszeile oder über die die Registerkarte "Bedingung".

1. Als "Bedingung" (1. Parameter) geben Sie den Ausdruck ein, der auf WAHR oder FALSCH geprüft werden soll. In unserem Beispiel wird mit Hilfe der Funktion "not Lastpage()" geprüft, ob es sich um die letzte Seite handelt.

2. Als "Ausdruck, wenn Bedingung WAHR ist" (2. Parameter) geben Sie den Ausdruck ein, der gelten soll, wenn die oben angegebene Bedingung WAHR ist. In unserem Beispiel ist die Bedingung wahr, wenn es nicht die letzte Seite ist, und für diesen Fall soll die Seitensumme ausgegeben werden (Parameter der "Sum()"-Funktion ist "True").

3. Als "Ausdruck, wenn Bedingung FALSCH ist" (optionaler 3. Parameter) geben Sie den Ausdruck ein, der gelten soll, wenn die oben angegebene Bedingung FALSCH ist. In unserem Beispiel ist die Bedingung falsch, wenn es die letzte Seite ist, und für diesen Fall soll die Gesamtsumme ausgegeben werden (Parameter der "Sum()"-Funktion ist "False").

4. Wenn Sie diese Funktion über die Registerkarte "Bedingung" erstellt haben, können Sie über die Schaltfläche "Einfügen" die fertige Bedingung in Ihre Bearbeitungszeile übernehmen.


Arbeiten mit Null-Werten

Es gibt verschiedene Funktionen für das Arbeiten mit Null-Werten (nicht definierte Feldinhalte).

§ Wenn in einem Ausdruck Null-Werte vorkommen, kann der gesamte Ausdruck Null werden. Um dies zu vermeiden nutzen Sie für Felder die leer sein könnten (z.B. Anrede oder Titel) die Funktion "NullSafe()". Diese Funktion überprüft den übergebenen Wert auf Null, und gibt einen Ersatzwert zurück, wenn das der Fall ist, ansonsten das Ergebnis des Ausdrucks.

Beispiel: Cond (Empty(FIRMA),NullSafe(VORNAME) + " " + NAME)

§ Mit der Funktion "IsNull()" bzw. "IsNullOrEmpty()" können Sie überprüfen, ob der übergebene Wert oder das Ergebnis des Ausdrucks Null ist, also ein leerer Feldinhalt.

Beispiel: Cond (IsNullOrEmpty(FIRMA),VORNAME + " " + NAME)

§ Mit der Funktion "Null()" können Sie einen Null-Wert setzen.


Arbeiten mit Operatoren

Über die Registerkarte "Operatoren" öffnen Sie die Liste der verfügbaren Operatoren. Diese dienen dazu, Variablen und frei eingegebenen Text zu komplexeren Bedingungen zusammenzusetzen und Vergleiche oder Berechnungen durchzuführen.

Auf der Registerkarte "Operatoren" finden Sie in der Spalte ganz links die jeweiligen Operatoren, in der mittleren Spalte die Schreibweise und in der rechten Spalte die Wertetypen, auf welche der jeweilige Operator anwendbar ist.

Operatoren verknüpfen zwei oder mehr Werte bzw. Variablen zu einem neuen Wert. Sie können damit arithmetische Ausdrücke (Grundrechenarten) oder logische Ausdrücke formulieren. Der Wertetyp des Ergebnisses eines Ausdruckes ist dabei abhängig von den Wertetypen der einzelnen Elemente des Ausdruckes.

Von besonderer Bedeutung ist dabei der Operator "+", der sich nicht nur für Additionen (Wertetypen "Zahl" und "Datum") eignet, sondern auch zur Verknüpfung von Variablen mit festem Text dient (Wertetyp "Zeichenkette").

In ein und derselben Bedingung können Sie mehrere Verknüpfungen miteinander kombinieren. Hierfür gelten die üblichen Bearbeitungsregeln: Logische Operatoren werden vor arithmetischen Operatoren und diese vor Vergleichsoperatoren ausgewertet. Wenn Sie eine andere Bearbeitungsreihenfolge wünschen, müssen Sie Klammern setzen. Die am weitesten "innen" stehende Klammer wird jeweils zuerst ausgewertet.

Die allgemeine Bearbeitungshierarchie ist

Priorität | Operator
1 | Klammern ()
2 | Funktionen
3 | Logische Operatoren
4 | Arithmetische Operatoren
5 | Vergleichsoperatoren

Siehe auch:

Arithmetische Operatoren

Vergleichsoperatoren

Logische Operatoren

Formelfehler


Arithmetische Operatoren

Für arithmetische Operatoren gilt die bekannte Bearbeitungshierarchie "Punkt vor Strich". Zuerst wird der Operator "Modulo" ausgewertet, dann die Punktrechnung ("*" und "/") zuletzt die Strichrechnung ("+" und "-").

Beispiel: NETTOPREIS+(NETTOPREIS*0.19)

Operator | Bedeutung | Datentypen
+ | Addition | Zeichenkette, Datum, Zahl
- | Subtraktion | Datum, Zahl
* | Multiplikation | Zahl
/ | Division | Zahl
% | Modulo (Rest bei der Division) | Zahl


Vergleichsoperatoren

Vergleichsoperatoren bestehen aus zwei Werten desselben Datentyps, die miteinander verglichen werden und einen Wahrheitswert liefern. Das Ergebnis (Rückgabewert) ist der Boolean-Wert True (wahr) oder False (falsch).

Beispiel: Page()>1

Operator | Bedeutung | Datentypen
> | Größer | Zeichenkette, Zahl, Datum
>= | Größer oder gleich | Zeichenkette, Zahl, Datum
< | Kleiner | Zeichenkette, Zahl, Datum
<= | Kleiner oder gleich | Zeichenkette, Zahl, Datum
= | Gleich | Zeichenkette, Zahl, Datum
== | Gleich | Zeichenkette, Zahl, Datum
<> | Ungleich | Zeichenkette, Zahl, Datum
!= | Ungleich | Zeichenkette, Zahl, Datum


Logische Operatoren

Ein Logischer Operator ist eine Funktion, die einen Wahrheitswert liefert. Das Ergebnis (Rückgabewert) ist der Boolean-Wert True (wahr) oder False (falsch). Je nach Art des Verknüpfungsoperators ist der zusammengesetzte Ausdruck zum Beispiel genau dann wahr, wenn beide verknüpften Ausdrücke wahr sind (UND-Verknüpfung) oder wenn mindestens einer der verknüpften Ausdrücke wahr ist (ODER-Verknüpfung). Als Bearbeitungshierarchie gilt: Zuerst werden "Negierungen" ausgewertet, dann das "logische UND", zuletzt das "logische ODER".

Beispiel: PLZ>=70000 AND PLZ<=80000

Operator | Bedeutung | Datentyp
NOT oder .NOT. | Negierung | Boolean
AND oder .AND. | logisches UND | Boolean
OR oder .OR. | logisches ODER | Boolean
XOR oder .XOR. | logisches exklusiv-ODER | Boolean

Abbildung 10.16: Beispiel einer Multiplikation von 2 Feldern


Formelfehler

Das Toolfenster "Formelfehler" wird automatisch geöffnet, wenn beim Öffnen des Projekts Fehler gefunden werden.

Abbildung 10.17: Formelfehlerfenster

Die Syntax- und Argumentfehler werden im linken Bereich aufgelistet und bei Selektion der Fehlerort in einer Baumdarstellung angezeigt. Wenn Sie einen Fehler doppelklicken wird der Eigenschaftsdialog geöffnet und die entsprechende Stelle selektiert. Der Doppelklick funktioniert an allen Stellen, an denen Sie eine Formel erstellen können, also z.B. bei Spalten, Absätzen, Eigenschaften, Summenvariablen usw.

Wenn ein Fehler behoben ist, können Sie diesen über die entsprechende Schaltfläche als erledigt kennzeichnen oder über die Schaltfläche "Liste aktualisieren" die Fehlerliste neu erzeugen.


Übersicht der LL-Variablen und LL-Felder

Es stehen – je nach Anwendung – automatisch einige Variablen und Felder zur Verfügung. Sie finden die Variablen und Felder in den "LL"-Unterordnern in der Variablen-/Feldliste.

Siehe auch:


Übersicht der Variablen

Name

Erläuterung

LL.Color.*

Farbwert der entsprechenden Farbe.

LL.Device.Name

Name des Ausgabegerätes (Druckers).

LL.Device.Page.Name

Bezeichnung des gewählten Papierformats (z.B. "A4").

LL.Device.Page.Size.cx

Physikalische Seitenbreite des Ausgabegeräts in der Projekteinheit. Kann z.B. in Formeln verwendet werden, um Objekte dynamisch an größere Ausgabeformate anzupassen.

Beispiel: Setzen Sie in der Eigenschaftsliste die Eigenschaft Position.Links auf den Wert 0, die Eigenschaft Position.Rechts auf LL.Device.Page.Size.cx. Das Objekt füllt jetzt stets die gesamte Seitenbreite aus.

LL.Device.Page.Size.cy

Physikalische Seitenhöhe in der Projekteinheit.

LL.Device.PrintableArea.Offset.cx

Breite des linken nicht bedruckbaren Rands in der Projekteinheit.

Beispiel: Setzen Sie in der Eigenschaftsliste die Eigenschaft Position.Links auf den Wert LL.Device.PrintableArea.Offset.cx. Das Objekt liegt jetzt immer genau am linken Rand des bedruckbaren Bereichs des Druckers.

LL.Device.PrintableArea.Offset.cy

Höhe des oberen nicht bedruckbaren Rands in der Projekteinheit.

LL.Device.PrintableArea.Size.cx

Bedruckbare Seitenbreite in der Projekteinheit.

LL.Device.PrintableArea.Size.cy

Bedruckbare Seitenhöhe in der Projekteinheit.

LL.Scheme.Color*

Der jeweilige Farbwert der verfügbaren 4 Designschema-Vordergrund-Farben.

LL.Scheme.BackgroundColor*

Der jeweilige Farbwert der 10 verfügbaren Designschema-Hintergrund-Farben.

LL.Scheme.BackgroundFillMode

Füllung des Designschema-Hintergrunds (1).

LL.CountData
(nicht bei Multitabellen)

Anzahl der übergebenen Datensätze. Diese Anzahl enthält auch die Datensätze, die aufgrund einer Filterbedingung nicht gedruckt wurden. Diese Anzahl wird also bei jedem Datensatz hochgezählt.

LL.CountDataThisPage
(nicht Multitabellen)

Anzahl der übergebenen Datensätze auf der aktuellen Seite. Diese Anzahl enthält auch die Datensätze, die aufgrund einer Filterbedingung nicht gedruckt wurden. Diese Anzahl wird also bei jedem Datensatz hochgezählt.

LL.CountPrintedData
(nicht bei Multitabellen)

Anzahl der tatsächlich gedruckten Datensätze.

LL.CountPrintedDataThisPage
(nicht bei Multitabellen)

Anzahl der tatsächlich gedruckten Datensätze auf der aktuellen Seite.

LL.CurrentContainer

Bezeichnung des aktuellen Berichtscontainers.

LL.CurrentContainerItem

Bezeichnung des aktuellen Elements im Berichtscontainer. Steht z.B. für Anzeige- und Layoutbereichsbedingungen zur Verfügung.

LL.CurrentLanguage

Liefert die Drucksprache zurück, z.B. "en-EN"

LL.CurrentTableColumn

Liefert bei mehrspaltigen Projekten den Index der aktuellen Spalte zurück.

LL.FilterExpression

Gewählter Projektfilter.

LL.IsForcedPage

Gibt an, ob die Seite eine durch die Projekteigenschaft "Mindestzahl der Druckseiten" erzwungene Seite ist.

LL.OutputDevice

Ausgabemedium. Kann z.B. verwendet werden, um Objekte für ein bestimmtes Ausgabeformat (HTML, RTF,PDF,…) in besonderer Weise zu formatieren.

Format Wert

PDF PDF
HTML HTML
RTF RTF
MS Word DOCX
PowerPoint PPTX
SVG SVG
Bitmap PICTURE_BMP
EMF PICTURE_EMF
TIFF PICTURE_TIFF
Multi-TIFF PICTURE_MULTITIFF
JPEG PICTURE_JPEG
PNG PICTURE_PNG
Excel XLS
XPS XPS
MHTML MHTML
XHTML/CSS XHTML
XML XML
Text TXT
Nadeldrucker TTY
Vorschau PRV
Drucker PRN
Datei FILE
Präsentation PRES
Jquery Mobile JQM

LL.SortStrategy

Vom Benutzer gewählte Sortierreihenfolge. Diese Funktion ist veraltet und sollte nicht mehr benutzt werden.

Berichtsabschnitt.Bezeichnung

Liefert die Bezeichnung des Berichtsabschnitts: Index oder Inhaltsverzeichnis

Berichtsabschnitt.Maximale Verzeichnistiefe
(nur bei Inhaltsverzeichnis)

Wert der Eigenschaft "max. Verzeichnistiefe" in den Projektoptionen.

Berichtsabschnitt.SeiteRelativ
(nur bei Index)

Relative Seitenzahl für den Index, d.h. die Seitenzahl beginnt bei 1.

@LLFAX.RecipName

Fax-Versand: Empfängername

@LLFAX.RecipNumber

Fax-Versand: Empfängerfaxnummer

@LLFAX.SenderBillingCode

Fax-Versand: Absenderverrechnungscode

@LLFAX.SenderCompany

Fax-Versand: Absenderfirma

@LLFAX.SenderDept

Fax-Versand: Absenderabteilung

@LLFAX.SenderName

Fax-Versand: Absendername


Übersicht der Felder

Name | Erläuterung
LL.ChartObject.ArcIndex (nur bei Kreisdiagramm) | Index des momentanen Segments. Die Segmente sind der Größe nach sortiert. Das größte Segment hat den Index 1.
LL.ChartObject.ArcPerc (nur bei Kreisdiagramm) | Größe des momentanen Segments in Prozent.
LL.ChartObject.ArcTotal (nur bei Kreisdiagramm) | Absoluter Wert der gesamten Datenmenge.
LL.ChartObject.ArcTypeIsOthers (nur bei Kreisdiagramm) | True, wenn das momentane Segment das "Andere"-Stück ist.
LL.ChartObject.ArcValue (nur bei Kreisdiagramm) | Absoluter Wert des momentanen Segments.
LL.ChartObject.AxisCoordinate (nur bei Diagramm) | Koordinatenwert (verwendbar in Achsenbeschriftungen).
LL.ChartObject.AxisPercentage (nur bei Diagramm) | Größe in Prozent (verwendbar z.B. in der Koordinatenbeschriftung der Größenachse beim relativ gestapelten Diagramm).
LL.ChartObject.Shape.Attribute.* (nur bei Shapefiles) | Shapefile-Attribute
LL.ChartObject.ValueIsOthers (nicht bei Kreisdiagrammen) | liefert True, wenn der aktuelle Balken der "Andere"-Balken ist.
LL.CurrentRelation (nur bei Multitabellen) | Bezeichnung der aktuellen Relation zur übergeordneten Tabelle.
LL.CurrentSortOrder (nur bei Multitabellen) | Bezeichnung der aktuellen Sortierung in der Tabelle.
LL.CurrentTable (nur bei Multitabellen) | Bezeichnung der aktuell verwendeten Tabelle.
LL.CurrentTablePath (nur bei Multitabellen) | Bezeichnung der aktuell verwendeten Tabelle (hierarchisch mit übergeordneten Tabellen.
LL.FcountData | Anzahl der übergebenen Datensätze. Diese Anzahl enthält auch die Datensätze, die aufgrund einer Filterbedingung nicht gedruckt wurden.
LL.FcountDataThisPage | Anzahl der übergebenen Datensätze auf der aktuellen Seite. Diese Anzahl enthält auch die Datensätze, die aufgrund einer Filterbedingung nicht gedruckt wurden.
LL.FcountPrintedData | Anzahl der tatsächlich gedruckten Datensätze.
LL.FcountPrintedDataThisPage | Anzahl der tatsächlich gedruckten Datensätze auf der aktuellen Seite.
LL.GanttObject.CurrentBarLabel (nur bei Gantt-Diagramm) | Liefert die Balkenbeschriftung des aktuellen Balkens.
LL.GanttObject.CurrentProjectDepth (nur bei Gantt-Diagramm) | Liefert die Ebene des Sammelvorgangs (0...).
LL.TableLineIndex | Gibt den fortlaufenden Index der Datenzeilen einer Tabelle zurück.
LL.VisibleTableLineIndex | Gibt den fortlaufenden Index der ausgegebenen Datenzeilen einer Tabelle zurück.
LL.Tables.* (nur bei Multitabellen) | Verfügbare Tabellen.
Verweis.Ebene | Ebene im Inhaltsverzeichnis oder Index. Kann über die entsprechende Eigenschaft definiert werden. Siehe auch Inhaltsverzeichnis und Index in Kapitel Seitenlayout.
Verweis.Seitenindex | Seitenzahl für den Indexeintrag.
Verweis.Seitenzahl | Seitenzahl für den Inhaltsverzeichnis-Eintrag.
Verweis.Text | Text, der im Inhaltsverzeichnis oder Index angezeigt werden soll. Kann über die entsprechende Eigenschaft definiert werden.


Übersicht der Funktionen

Hier finden Sie alle verfügbare Funktionen als alphabetische Liste. Im Formel-Assistenten steht Ihnen zusätzlich eine nach Funktionsgruppe sortierte Liste zur Verfügung.


Abs

combit List & Label

Abs

Aufgabe:

Gibt den Absolutwert einer Zahl zurück, d.h. eine evtl. negative Zahl wird positiv zurückgegeben, eine positive Zahl bleibt unverändert.

Parameter:

Zahl

Rückgabewert:

Zahl

Beispiele:

Abs(-3) Ergebnis: 3

Abs(3.12) Ergebnis: 3.12


AddDays

combit List & Label

AddDays

Aufgabe:

Addiert die angegebene Anzahl von Tagen zu dem Datum hinzu, bzw. zieht diese bei negativen Werten ab.

Parameter:

Datum

Zahl

Rückgabewert:

Datum

Beispiele:

AddDays(Date("04.07.1776"),3) Ergebnis: 07.07.1776

AddDays(Date("04.07.1776"),-3) Ergebnis: 01.07.1776


AddHours

combit List & Label

AddHours

Aufgabe:

Addiert die angegebene Anzahl von Stunden zu dem Datum hinzu, bzw. zieht diese bei negativen Werten ab.

Parameter:

Datum

Zahl

Rückgabewert:

Datum

Beispiele:

AddHours(Date("04.07.1776"),48) Ergebnis: 06.07.1776

AddHours(Date("04.07.1776"),-48) Ergebnis: 02.07.1776


AddMinutes

combit List & Label

AddMinutes

Aufgabe:

Addiert die angegebene Anzahl von Minuten zu dem Datum hinzu, bzw. zieht diese bei negativen Werten ab.

Parameter:

Datum

Zahl

Rückgabewert:

Datum

Beispiele:

AddMinutes(Date("04.07.1776"),2880) Ergebnis: 06.07.1776

AddMinutes(Date("04.07.1776"),-2880) Ergebnis: 02.07.1776


AddMonths

combit List & Label

AddMonths

Aufgabe:

Addiert die angegebene Anzahl von Monaten zu dem Datum hinzu, bzw. zieht diese bei negativen Werten ab.

Parameter:

Datum

Zahl

Rückgabewert:

Datum

Beispiele:

AddMonths(Date('04.07.1776'),3) Ergebnis: 04.10.1776

AddMonths(Date('04.07.1776'),-3) Ergebnis: 04.04.1776


AddSeconds

combit List & Label

AddSeconds

Aufgabe:

Addiert die angegebene Anzahl Sekunden zu dem Datum hinzu, bzw. zieht diese bei negativen Werten ab.

Parameter:

Datum

Zahl

Rückgabewert:

Datum

Beispiele:

AddSeconds(Date("04.07.1776"),172800) Ergebnis: 06.07.1776

AddSeconds(Date("04.07.1776"),-172800) Ergebnis: 02.07.1776


AddWeeks

combit List & Label

AddWeeks

Aufgabe:

Addiert die angegebene Anzahl von Wochen zu dem Datum hinzu, bzw. zieht diese bei negativen Werten ab.

Parameter:

Datum

Zahl

Rückgabewert:

Datum

Beispiele:

AddWeeks(Date("04.07.1776"),4) Ergebnis: 01.08.1776

AddWeeks(Date("04.07.1776"),-4) Ergebnis: 06.06.1776


AddYears

combit List & Label

AddYears

Aufgabe:

Addiert die angegebene Anzahl von Jahren zu dem Datum hinzu, bzw. zieht diese bei negativen Werten ab.

Parameter:

Datum

Zahl

Rückgabewert:

Datum

Beispiele:

AddYears(Date("04.07.1776"),4) Ergebnis: 04.07.1776

AddYears(Date("04.07.1776"),-4) Ergebnis: 04.07.1772


Alias$

combit List & Label

Alias$

Aufgabe:

Gibt den Wert zurück, der für den Schlüssel (erster Parameter), bei den Schlüssel/Wertepaaren (zweiter Parameter) angegeben wird.

Parameter:

Zeichenkette Ausdruck für den zu suchenden Wert.

Zeichenkette Liste der Werte (Form: <Schlüsselwert>| [<Schlüsselwert>]. Um "|" oder "=" im Wert oder Schlüssel verwenden zu können, stellen Sie diesen ein "\" voran.

Zeichenkette (optional) Voreinstellung wenn der Wert nicht gefunden werden kann.

Rückgabewert:

Zeichenkette

Beispiel:

Alias$("DEU", "DEU=Deutschland|UK= United Kingdom") Ergebnis: "Deutschland"


ApplicationPath$

combit List & Label

ApplicationPath$

Aufgabe:

Gibt den Pfad der Applikation zurück.

Parameter:

Boolean (optional) Gibt an, ob der Pfad inklusive Dateiname zurückgeliefert wird (Voreinstellung: False).

Rückgabewert:

Zeichenkette

Beispiel:

ApplicationPath$() Ergebnis: "C:\Program Files (x86)\combit\LL\"


ArcCos

combit List & Label

ArcCos

Aufgabe:

Berechnet den Arkus-Kosinus des Werts (in Grad, wenn keine andere Einheit gewählt ist).

Parameter:

Zahl Wert

Zahl (optional) Modus (0=Grad, 1=Radiant). Voreinstellung: 0.

Rückgabewert:

Zahl

Beispiel:

ArcCos (0) Ergebnis: 90


ArcSin

combit List & Label

ArcSin

Aufgabe:

Berechnet den Arkus-Sinus des Werts (in Grad, wenn keine andere Einheit gewählt ist).

Parameter:

Zahl Wert

Zahl (optional) Modus (0=Grad, 1=Radiant). Voreinstellung: 0.

Rückgabewert:

Zahl

Beispiel:

ArcSin(0.5) Ergebnis: 30,00


ArcTan

combit List & Label

ArcTan

Aufgabe:

Berechnet den Arkus-Tangens des Werts (in Grad, wenn keine andere Einheit gewählt ist).

Parameter:

Zahl Wert

Zahl (optional) Modus (0=Grad, 1=Radiant). Voreinstellung: 0.

Rückgabewert:

Zahl

Beispiel:

ArcTan(1) Ergebnis: 45,00


Asc

combit List & Label

Asc

Aufgabe:

Gibt den ASCII-Code des ersten Zeichens der Zeichenkette zurück.

Parameter:

Zeichenkette

Rückgabewert:

Zahl

Beispiel:

Asc("A") Ergebnis: 65


AskString$

combit List & Label

AskString$

Aufgabe:

Hierüber können während der Laufzeit des Drucks Informationen vom Anwender abgefragt werden. Ein typisches Anwendungsbeispiel wäre das Projekt eines Überweisungsformulars. Feststehende Angaben wie Name und Bankverbindungen des Absenders lassen sich über festen Text oder Variablen direkt in das Projekt integrieren. Die zu überweisenden Beträge werden sich jedoch von Fall zu Fall unterscheiden und können daher schlecht im Projekt vorgegeben werden. Über die Funktion AskString$() kann jedoch eine solche Information während des Drucks vom Anwender erfragt werden.

Beim Druck erscheint dann eine Dialogabfrage, in der die gewünschte Information einzugeben ist.

Der Dialog erlaubt den eingegebenen Wert entweder zu übernehmen (Button OK) oder die Funktion abzubrechen (Button Abbrechen). Das Abbrechen der Funktion bedeutet, dass der Druckvorgang abgebrochen wird.

Über die Schaltfläche "Alles" können alle noch ausstehenden Benutzereingaben automatisch durch den aktuell eingegebenen Wert beantwortet werden. Dies ist hilfreich, wenn der Dialog für jeden einzelnen Datensatz erscheint, jedoch für alle Datensätze derselbe Wert eingegeben werden soll.

Parameter:

Zeichenkette Text, der als Eingabeaufforderung in dem Dialog zur Benutzereingabe erscheinen soll. Dieser erste Parameter muss angegeben werden, die übrigen Parameter sind optional. Falls keine weiteren Parameter angegeben werden, ist der erste Parameter zugleich der Vorschlagswert für die Benutzereingabe.

Boolean (optional) Gibt an, ob die Benutzerabfrage nur einmal zu Beginn des Drucks erscheinen soll (False, Voreinstellung), oder ob die Information für jeden Datensatz individuell abgefragt werden soll (True).

Zeichenkette (optional) Der Vorschlagswert im Eingabefeld des Dialogs.

Zahl (optional) Gibt die Anzahl der Stellen an, die als Benutzereingabe zulässig sein soll. Ein Wert von 8 beispielsweise bedeutet, dass der Benutzer maximal 8 Stellen eingeben kann.

Rückgabewert:

Zeichenkette

Beispiele:

AskString$("Betreff",True,"Ihre Anfrage von heute",50)

Öffnet eine Dialogbox mit dem Titel "Überweisungsbetrag", dem vorgeschlagenen Wert "50,00 EUR" und zulässigen Stellenanzahl von 8 Stellen für die Eingabe. Da der zweite Parameter True lautet, erscheint diese Abfrage für jeden Datensatz im Druck.


AskStringChoice$

combit List & Label

AskStringChoice$

Aufgabe:

Wie AskString$(), jedoch wird der Wert über einen Dialog mit Combobox abgefragt.

Parameter:

Zeichenkette Text der als Eingabeaufforderung in dem Dialog zur Benutzereingabe erscheinen soll.

Boolean (optional) Gibt an ob einmal pro Druck (False, Voreinstellung), oder bei jeden Datensatz (True) abgefragt werden soll.

Zeichenkette (optional) Die Combobox-Einträge. Die einzelnen Einträge der Combobox werden mit "|" getrennt. Wenn einer der Einträge '***' (drei Sternchen) ist, dann ist der Text veränderbar, d.h. es kann ein von den in der Liste angebotenen Einträgen abweichender Text eingegeben werden.

Zahl (optional) Maximallänge (Voreinstellung: 8192 Zeichen).

Rückgabewert:

Zeichenkette

Beispiel:

AskStringChoice$("Belegtyp",False,"Angebot|Rechnung|Lieferschein|***")

Öffnet eine Dialogbox mit dem Titel "Belegtyp". In der Combobox sind die Einträge "Angebot|Rechnung|Lieferschein" auswählbar. Da der zweite Parameter False lautet, erscheint diese Abfrage nur für den ersten Datensatz im Druck.


Atrim$

combit List & Label

Atrim$

Aufgabe:

Entfernt Leerzeichen von Anfang und Ende einer Zeichenkette.

Parameter:

Zeichenkette

Rückgabewert:

Zeichenkette

Beispiele:

Atrim$(" Hallo Welt ") Ergebnis: "Hallo Welt"


Avg

combit List & Label

Avg

Aufgabe:

Liefert den arithmetischen Mittelwert der Datenmenge, die sich aus dem ersten Argument ergibt.

Parameter:

Zahl Ausdruck für den zu mittelnden Wert

Boolean (optional) True: nach der Ausgabe werden die für die Berechnung gemerkten Werte gelöscht (Voreinstellung: True). Bitte beachten Sie, dass die für die Berechnung gemerkten Werte generell bei jedem (Unter-)Tabellenende gelöscht werden. Der zweite Parameter bestimmt lediglich, ob die Werte bei einer Ausgabe schon innerhalb der Tabelle gelöscht werden.

Rückgabewert:

Zahl

Beispiel:

Avg(Anzahl * Stückpreis) Ergebnis: Mittelwert Gesamtpreis


Barcode

combit List & Label

Barcode

Aufgabe:

Wandelt eine Zeichenkette in einen Barcode um.

Parameter:

Zeichenkette Barcodewert (Inhalt)

Zeichenkette Barcodetyp. Die möglichen Barcodetypen werden Ihnen von der Auto-Vervollständigung des Assistenten angeboten. Wenn der Barcode nicht korrekt interpretiert werden kann, wird er auch nicht gedruckt. Für einige Barcodes gibt es bestimmte Formatierungen, die eingehalten werden müssen. Nähere Informationen finden Sie im Kapitel Barcode-Objekte.

Rückgabewert:

Barcode

Beispiel:

Barcode("Hallo Welt","GS1 128")


Barcode$

combit List & Label

Barcode$

Aufgabe:

Gibt den Textinhalt eines Barcodes zurück.

Parameter:

Barcode

Rückgabewert:

Zeichenkette

Beispiel:

Barcode$(Artikel.Nr_EAN128) Ergebnis: "4711"


BarcodeType$

combit List & Label

BarcodeType$

Aufgabe:

Gibt den Typ des Barcodes als Zeichenkette zurück.

Parameter:

Barcode

Rückgabewert:

Zeichenkette

Beispiel:

BarcodeType$(Artikel.Nr_EAN128) Ergebnis: "EAN 128"


BasedStr$

combit List & Label

BasedStr$

Aufgabe:

Gibt den Wert zu einer beliebigen Basis aus.

Parameter:

Zahl Wert.

Zahl Basis (2 bis 36).

Zahl (optional) Mindestlänge der Zeichenkette (ohne optionalem Präfix). 0 für die minimale Länge (Voreinstellung).

Boolean (optional) gibt an, ob ein Präfix ('0b' für Basis 2, '0o' für Basis 8, '0x' für Basis 16) vor der Zeichenkette eingefügt werden soll (Voreinstellung: False).

Rückgabewert:

Zeichenkette

Beispiel:

BasedStr$(1,2,1,True) Ergebnis: "0b1"


BinaryAND

combit List & Label

BinaryAND

Aufgabe:

Verknüpft die beiden (ganzzahligen) Parameter binär mit 'und' und gibt das Resultat zurück.

Parameter:

Zahl Wert.

Zahl Wert.

Rückgabewert:

Zahl

Beispiel:

BinaryAND(01,10) Ergebnis: 0

BinaryAND(10,11) Ergebnis: 10


BinaryNOT

combit List & Label

BinaryNOT

Aufgabe:

Negiert den Wert binär und gibt das Resultat zurück.

Parameter:

Zahl Wert.

Rückgabewert:

Zahl

Beispiel:

BinaryNOT(10) Ergebnis: 5 (Zehn = 1010, Fünf = 0101)


BinaryOR

combit List & Label

BinaryOR

Aufgabe:

Verknüpft die beiden (ganzzahligen) Parameter binär mit 'oder' und gibt das Resultat zurück.

Parameter:

Zahl Wert.

Zahl Wert.

Rückgabewert:

Zahl

Beispiel:

BinaryOR(01,10) Ergebnis: 11

BinaryOR(10,11) Ergebnis: 11


BinarySHL

combit List & Label

BinarySHL

Aufgabe:

Verschiebt den Wert binär nach links.

Parameter:

Zahl Wert.

Zahl Zahl der Bits, um die der Wert verschoben wird.

Rückgabewert:

Zahl

Beispiel:

BinarySHL(10,1) Ergebnis: 20


BinarySHR

combit List & Label

BinarySHR

Aufgabe:

Verschiebt den Wert binär nach rechts.

Parameter:

Zahl Wert.

Zahl Zahl der Bits, um die der Wert verschoben wird.

Rückgabewert:

Zahl

Beispiel:

BinarySHR(10,1) Ergebnis: 5


BinaryXOR

combit List & Label

BinaryXOR

Aufgabe:

Verknüpft die beiden (ganzzahligen) Parameter binär mit 'exklusiv oder' und gibt das Resultat zurück.

Parameter:

Zahl Wert.

Zahl Wert.

Rückgabewert:

Zahl

Beispiel:

BinaryXOR(01,10) Ergebnis: 11

BinaryXOR(10,11) Ergebnis: 1


BMPMapToGray

combit List & Label

BMPMapToGray

Aufgabe:

Wandelt ein Bild in Graustufen. Es wird nur das BMP-Format unterstützt.

Parameter:

Bild oder Zeichenkette

Rückgabewert:

Bild

Beispiel:

BMPMapToGray("sunshine.gif")


BMPRotate

combit List & Label

BMPRotate

Aufgabe:

Dreht ein Bild. Es wird nur das BMP-Format unterstützt.

Parameter:

Bild oder Zeichenkette

Zahl Drehwinkel

Zahl (optional) Modus (0=Grad, 1=Radiant)

Rückgabewert:

Bild

Beispiel:

BMPRotate(Artikel.Bild,90)


Capitalize$

combit List & Label

Capitalize$

Aufgabe:

Gibt eine Zeichenkette zurück, in der bei den einzelnen Wörtern der erste Buchstabe groß-, der Rest kleingeschrieben ist.

Parameter:

String

Rückgabewert:

Zeichenkette

Beispiel:

Capitalize$(Produkt.Kategorie) Ergebnis: “Tee, Kaffee, Und Softdrinks“


Case$

combit List & Label

Case$

Aufgabe:

Wandelt eine Zahl je nach Wert in eine Zeichenkette um. Die Zuordnung wird über eine Formatierungs-Zeichenkette gemacht, der die zu ersetzende Zeichenkette für Zahlenwerte von 0 aufsteigend enthält.

Parameter:

Zahl Umzuwandelnde Zahl (n). In die Rückgabezeichenkette wird nun der n-te Wert des Zeichenkettefeldes kopiert, wenn nicht genug Werte existieren, ist die Zeichenkette leer.

Zeichenkette Ansammlung von verketteten Zeichenketten, die durch ein bestimmtes Zeichen getrennt sind. Wenn kein 3. Parameter existiert, ist dies "|", ansonsten das erste Zeichen dieses Parameters.

Zeichenkette (optional) Trennzeichen für die Formatierungs-Zeichenkette (Voreinstellung: "|").

Rückgabewert:

Zeichenkette

Beispiel:

Case$(4,"0|I|II|III|IV|V|VI|VII|VIII|IX|X") Ergebnis: "III"


Ceil

combit List & Label

Ceil

Aufgabe:

Berechnet ausgehend vom übergebenen Wert die nächstgrößere Ganzzahl. Siehe auch Funktion Floor().

Parameter:

Zahl

Rückgabewert:

Zahl

Beispiel:

Ceil(5.6) Ergebnis: 6


Century

combit List & Label

Century

Aufgabe:

Bestimmt das Jahrhundert eines Datums und gibt es als Zahl zurück.

Parameter:

Datum

Boolean (optional) Bestimmt, ob die Berechnung "einfach" (Jahrhundert beginnt mit Jahr 0) oder historisch (Jahrhundert beginnt mit Jahr 1) durchgeführt werden soll. Voreinstellung: False (historisch).

Rückgabewert:

Zahl

Beispiel:

Century(Date("04.07.1776")) Ergebnis: 18


ChangeLightness

combit List & Label

ChangeLightness

Aufgabe:

Ändert die Helligkeit des übergebenen Farbwertes.

Parameter:

Zahl Farbe, z.B. über RGB-Funktion.

Zahl Faktor um den die Farbe abgedunkelt oder aufgehellt wird. Die Farbe ist z.B. bei '0.5' halb so hell und bei '2' doppelt so hell.

Rückgabewert:

Zahl

Beispiel:

ChangeLightness(LL.Color.Red,2)


CheckMod10

combit List & Label

CheckMod10

Aufgabe:

Gibt die Modulo 10 Prüfziffer der übergebenen Zeichenkette zurück. Eine spezielle Funktion mit den gewichteten Werten "{0, 9, 4, 6, 8, 2, 7, 1, 3, 5}" für die entsprechenden Stellen. Dies wird in einigen Barcodes verwendet.

Parameter:

Zeichenkette

Rückgabewert:

Zahl

Beispiel:

CheckMod10("1010101") Ergebnis: 5


Chr$

combit List & Label

Chr$

Aufgabe:

Wandelt eine Zahl in eine Zeichenkette mit einem Zeichen. Dieses Zeichen hat den ANSI-Code der angegebenen Zahl. Bei Unicode ist der Wert der Zeichenwert (code point). Siehe auch www.unicode.org.

Parameter:

Zahl

Rückgabewert:

Zeichenkette

Beispiel:

Chr$(64) Ergebnis: "@"


ChrSubst$

combit List & Label

ChrSubst$

Aufgabe:

Untersucht eine Zeichenkette auf Zeichen, die im zweiten Parameter angegeben sind. Jedes Vorkommen eines dieser Zeichen wird durch die komplette Zeichenkette im dritten Parameter ersetzt. Wenn kein dritter Parameter existiert, werden die Zeichen entfernt.

Parameter:

Zeichenkette

Zeichenkette

Zeichenkette (optional)

Rückgabewert:

Zeichenkette

Beispiel

ChrSubst$("Hallo Welt", "l", "_") Ergebnis: "Ha__o We_t"

ChrSubst$("Hallo Welt", "aeiou","_") Ergebnis: "H_ll_ W_lt"


Cond

combit List & Label

Cond

Aufgabe:

Erlaubt das Formulieren beliebiger Bedingungen. Das erste Argument ist ein logischer Ausdruck, der auf seinen Wahrheitsgehalt geprüft wird. Ist der Ausdruck wahr (True), so wird das zweite Argument als Ergebnis zurückgegeben. Ist der Ausdruck falsch (False), so wird das dritte Argument als Ergebnis zurückgegeben. Ist kein drittes Argument angegeben, nimmt der Rückgabewert bei False in Abhängigkeit vom Wertetyp des zweiten Argumentes folgende Standardwerte an:

2. Argument vom Typ | Rückgabewert bei Bedingung = False
Boolean | False
Zeichenkette | "" (leere Zeichenkette)
Datum | Julianischer Datumswert 0
Zahl | 0
Bild | "" (leere Zeichenkette)
Barcode | "" (leere Zeichenkette)

Parameter:

Boolean

Alle

Alle (optional) Das dritte Argument muss vom gleichen Typ wie das zweite Argument sein.

Rückgabewert:

Alle

Beispiel:

Cond(Even(5), "gerade", "ungerade") Ergebnis: ungerade


Constant.Pi

combit List & Label

Constant.Pi

Aufgabe:

Gibt den Wert der Kreiszahl Pi zurück.

Parameter: -

Rückgabewert:

Zahl

Beispiel:

Constant.Pi () Ergebnis: 3,14159 (je nach Anzahl der Dezimalstellen)


Contains

combit List & Label

Contains

Aufgabe:

Überprüft, ob eine Zeichenkette eine andere Zeichenkette (zweiter Parameter) enthält.

Parameter:

Zeichenkette

Zeichenkette

Zahl (optional) 0 für Beachten der Groß- und Kleinschreibung, 1 für Ignorieren (Voreinstellung: 0)

Rückgabewert:

Boolean

Beispiel:

Contains ("Hallo", "ll") Ergebnis: True


Continued

combit List & Label

Continued

Aufgabe:

Gibt an, dass ein Text- oder Formatiertes Text-Objekt einen Seitenumbruch hatte, d.h. die Ausgabe jetzt eine Folge des Seitenumbruchs ist.

Parameter: -

Rückgabewert:

Boolean


Cos

combit List & Label

Cos

Aufgabe:

Berechnet den Cosinus des Werts (in Grad, wenn keine andere Einheit gewählt ist).

Parameter:

Zahl Wert

Zahl (optional) Modus (0=Grad, 1=Radiant). Voreinstellung: 0.

Rückgabewert:

Zahl

Beispiel:

Cos(90) Ergebnis: 0


Count

combit List & Label

Count

Aufgabe:

Zählt die Anzahl der Werte des Arguments. Aggregatsfunktionen arbeiten grundsätzlich tabellenspezifisch.

Bei dieser Funktion werden Null-Werte des Arguments zur Anzahl hinzugezählt. Verwenden Sie die Funktion CountIf(), wenn Sie Null-Werte ausschließen möchten.

Hinweis: Summenvariablen (siehe Kapitel Summenvariablen) sind eine alternative Möglichkeit Summen und Zähler zu bilden. Summenvariablen arbeiten grundsätzlich tabellenübergreifend.

Parameter:

Alle Zu zählender Wert (bestimmt die zu zählenden Werte). Erforderlich um die (Unter-)Tabelle zu definieren, für die die Werte gezählt werden.

Boolean (optional) True: nach der Ausgabe werden die für die Berechnung gemerkten Werte gelöscht (Voreinstellung: True). Bitte beachten Sie, dass die für die Berechnung gemerkten Werte generell bei jedem (Unter-)Tabellenende gelöscht werden. Der zweite Parameter bestimmt lediglich, ob die Werte bei einer Ausgabe schon innerhalb der Tabelle gelöscht werden.

Rückgabewert:

Zahl

Beispiel:

Count (LL.FcountData) Ergebnis: 1 (1 gedruckter Datensatz)


CountIf

combit List & Label

CountIf

Aufgabe:

Zählt die Anzahl der Werte, für die die Bedingung zutrifft. Verwenden Sie zusätzlich die Funktion Distinct(), wenn mehrfach vorkommende Werte nur einmal in die Berechnung eingehen sollen.

Parameter:

Boolean Ausdruck für den Vergleich.

Boolean (optional) True: nach der Ausgabe werden die für die Berechnung gemerkten Werte gelöscht (Voreinstellung: True). Bitte beachten Sie, dass die für die Berechnung gemerkten Werte generell bei jedem (Unter-)Tabellenende gelöscht werden. Der zweite Parameter bestimmt lediglich, ob die Werte bei einer Ausgabe schon innerhalb der Tabelle gelöscht werden.

Rückgabewert:

Zahl

Beispiel:

CountIf(Customers.Region="D") Zählt alle Werte aus "D"

CountIf(IsNull (Orders.OrderDate)) Zählt alle Werte mit leerem Feldinhalt


Crosstab.Cells.Avg

combit List & Label

Crosstab.Cells.Avg

Aufgabe:

Gibt (in Kreuztabellen) den Mittelwert der Zelleninhalte zurück.

Parameter:

Boolean (optional) True: Nur definierte Werte gehen in die Berechnung ein (Voreinstellung: False). Definierte Werte: Wenn Sie z.B. eine Auswertung über Kunden und Quartale erstellen, entsprechen die Quartale ohne Umsatz einem "nicht definierten Wert" und können bei der Berechnung extra behandelt werden.

Zahl (optional) Zeilen-Ebene (0= unterste Ebene bzw. innerste Gruppierung, 1= nächsthöhere, ...). Voreinstellung: 0.

Zahl (optional) Spalten-Ebene (0= unterste Ebene bzw. innerste Gruppierung, 1= nächsthöhere, ...). Voreinstellung: 0.

Rückgabewert:

Zahl

Beispiel:

Crosstab.Cells.Avg(True,2,0) Ergebnis: Mittelwert der Zeile


Crosstab.Cells.Max

combit List & Label

Crosstab.Cells.Max

Aufgabe:

Gibt (in Kreuztabellen) den größten Wert der Zelleninhalte zurück.

Parameter und Rückgabewert siehe Funktion Crosstab.Cells.Avg().

Beispiel:

Crosstab.Cells.Max(True,2,0) Ergebnis: Maximalwert der Zeile


Crosstab.Cells.Min

combit List & Label

Crosstab.Cells.Min

Aufgabe:

Gibt (in Kreuztabellen) den kleinsten Wert der Zelleninhalte zurück.

Parameter und Rückgabewert siehe Funktion Crosstab.Cells.Avg().

Beispiel:

Crosstab.Cells.Min(True,2,0) Ergebnis: Minimalwert der Zeile


Crosstab.Cells.Sum

combit List & Label

Crosstab.Cells.Sum

Aufgabe:

Gibt (in Kreuztabellen) die Summe der Zelleninhalte zurück.

Parameter und Rückgabewert siehe Funktion Crosstab.Cells.Avg().

Beispiel:

Crosstab.Cells.Sum(True,2,0) Ergebnis: Summe der Zeile


Crosstab.Col$

combit List & Label

Crosstab.Col$

Aufgabe:

Gibt (in Kreuztabellen) den Spaltenbezeichner für die momentan auszugebende Zelle zurück.

Parameter:

Zahl (optional) Spalten-Ebene (0= unterste Ebene bzw. innerste Gruppierung, 1= nächsthöhere, ...). Voreinstellung: 0.

Rückgabewert:

Zeichenkette


Crosstab.Col

combit List & Label

Crosstab.Col

Aufgabe:

Gibt (in Kreuztabellen) den Spaltenindex für die momentan auszugebende Zelle zurück. Die erste Spalte hat den Index 0.

Parameter:

Boolean (optional) True: Nur Zellen der gleichen Ebene zählen (Voreinstellung False).

Rückgabewert:

Zahl


Crosstab.Row$

combit List & Label

Crosstab.Row$

Aufgabe:

Gibt (in Kreuztabellen) den Zeilenbezeichner für die momentan auszugebende Zelle zurück. Die erste Zeile hat den Index 0.

Parameter:

Zahl (optional) Zeilen-Ebene (0= unterste Ebene bzw. innerste Gruppierung, 1= nächsthöhere, ...). Voreinstellung: 0.

Rückgabewert:

Zeichenkette


Crosstab.Row

combit List & Label

Crosstab.Row

Aufgabe:

Gibt (in Kreuztabellen) den Zeilenindex für die momentan auszugebende Zelle zurück. Wird diese Funktion im Zeilenbezeichner verwendet bzw. ausgegeben, wird immer Null zurückgegeben, da zum Zeitpunkt der Bestimmung des Label-Textes nur die Koordinate, aber nicht der Spalten-/Zeilenindex bekannt ist.

Parameter:

Boolean (optional) True: Nur Zellen der gleichen Ebene zählen (Voreinstellung False).

Rückgabewert:

Zahl


Crosstab.Value

combit List & Label

Crosstab.Value

Aufgabe:

Gibt (in Kreuztabellen) den Inhalt der Zelle zurück.

Parameter: -

Rückgabewert:

Zahl


CStr$

combit List & Label

CStr$

Aufgabe:

Formatiert eine Zahl mit Hilfe einer Format-Zeichenkette. Diese ist identisch mit der Formatierungsinformation für die printf()-Funktion der Sprache C. Hierbei wird der erste Parameter als numerischer Wert doppelter Präzision übergeben, der Konversionsoperator kann z.B. folgende Werte annehmen:

'f', 'g', 'G', 'e', 'E'.

Parameter:

Zahl

Zeichenkette Formatierung in C-Notation, also meist "%<Formatierung>f".

Rückgabewert:

Zeichenkette

Beispiel:

CStr$(1234.5678,"%5.2f") Ergebnis: "1234.78"

CStr$(Pi,"%5.1f") Ergebnis: "3.1"

CStr$(100*Pi,"nun: %g") Ergebnis: nun: "3.141593e+02"


CurrentDataLineIndex

combit List & Label

CurrentDataLineIndex

Aufgabe:

Gibt den fortlaufenden Index der ausgegebenen Datenzeilen einer Tabelle zurück.

Parameter:

Zeichenkette (optional) Tabellenname (inkl. Hierarchie). Voreinstellung: aktive Tabelle.

Rückgabewert:

Zahl


CurrentLineIndex

combit List & Label

CurrentLineIndex

Aufgabe:

Gibt den fortlaufenden Index der Zeilendefinition zurück, in der die Funktion benutzt wird. Per Darstellungsbedingung ausgeblendete Zeilen werden nicht gezählt.

Parameter: -

Rückgabewert:

Zahl


CurrentLineTypeIndex

combit List & Label

CurrentLineTypeIndex

Aufgabe:

Gibt den fortlaufenden Index des Zeilentyps (Kopf, Fuß, Daten, ...) zurück, in der die Funktion benutzt wird. Per Darstellungsbedingung ausgeblendete Zeilen werden nicht gezählt.

Parameter: -

Rückgabewert:

Zahl


Date

combit List & Label

Date

Aufgabe:

Wandelt eine Zeichenkette in ein Datum um.

§ Wenn die Zeichenkette einen Punkt "." enthält, wird er als "t.m.j" eingelesen (deutsch).

§ Wenn er einen Schrägstrich "/" enthält, wird er als "m/t/j" eingelesen (englisch).

§ Wenn er einen Strich "-" enthält, wird er als "j-m-t" eingelesen (ANSI).

§ Wenn er nicht fehlerlos interpretiert werden kann, repräsentiert das Datum einen Wert, der größer ist als alle anderen Daten (1e100), das Rückgabedatum kann also über "<JulianToDate(1e100)" auf Korrektheit geprüft werden.

Parameter:

Zeichenkette

Rückgabewert:

Datum

Beispiel:

Date ("04.07.1776") Ergebnis: 04.07.1776

Date ("07/04/1776") Ergebnis: 07/04/1776

Date ("1776-07-04") Ergebnis: 1776-07-04

Hinweis:

Werden ein- oder zweistellige Jahreszahlen übergeben, so werden alle Werte unter 30 dem 21. Jahrhundert (also 20xx) und alle darüber dem 20. Jahrhundert (also 19xx) zugeordnet.


Date$

combit List & Label

Date$

Aufgabe:

Wandelt ein Datum über eine Format-Zeichenkette in eine entsprechend formatierte Zeichenkette um.

Aufbau der Format-Zeichenkette: Dies ist eine gewöhnliche Zeichenkette, in dem Platzhalter eingebettet werden können.

Platzhalter | Bedeutung
%d | Tag (1..31)
%<n>d | Tag auf <n> Stellen
%0<n>d | Tag auf <n> Stellen, links mit '0'en aufgefüllt
%w | Wochentag (1..7)
%<n>w | Wochentag auf <n> Stellen
%0<n>w | Wochentag auf <n> Stellen, links mit '0'en aufgefüllt
%m | Monat (1..12)
%<n>m | Monat auf <n> Stellen
%0<n>m | Monat auf <n> Stellen, links mit '0'en aufgefüllt
%y | Jahr
%<n>y | Jahr, auf <n> Stellen
%0<n>y | Jahr, auf <n> Stellen, links mit '0'en aufgefüllt
%D | Wochentag, ausgeschrieben
%M | Monat, ausgeschrieben
%Q | Quartal
"%e", "%<n>e" | Jahr im lokalisierten Kalender (Japan: Emperor's year)
"%g", "%<n>g" | Area des lokalisierten Kalenders (Japan: Emperor area)
"%g", "%1g" | Einbuchstabig, lateinischer Buchstabe
"%gg", "%2g" | Einbuchstabig, lokalisiert
"%ggg", "%3g" | Langname, lokalisiert
"%gggg", "%4g" | Langname, lateinische Buchstaben
"%x" | Lokalisiertes Datum, Kurzform
%H | Stunden im 24-Stundenformat
%h | Stunden im 12-Stundenformat
%<n>h | Stunden auf <n> Stellen
%i | Minuten
%<n>i | Minuten auf <n> Stellen
%s | Sekunden
%<n>s | Sekunden auf <n> Stellen
%PM | Anzeige der Tageshälfte (AM oder PM)

Sofern eine der obigen Formatierungsanweisungen verwendet wird, kann über den optionalen dritten Parameter das zu verwendende Locale festgelegt werden. Enthält der zweite Parameter hingegen ein gültiges ISO 3166-Länderkürzel, so kann über den dritten Parameter angegeben werden, ob das kurze ("0") oder lange ("1") Datumsformat zurückgegeben werden soll.

Parameter:

Datum Zu formatierender Wert.

Zeichenkette (optional) Formatbeschreibung oder Landeskürzel.

Zeichenkette (optional) ISO 3166-Landeskürzel oder Datumsformat .

Rückgabewert:

Zeichenkette

Beispiel:

Date$(Date("04.07.1776"), "en-us","1") Ergebnis:"Thursday, July 4, 1776"

Date$(Date("04.07.1776"),"de-de","1") Ergebnis: "Donnerstag, 4. Juli 1776"

Date$(Date("04.07.1776"),"%2w.Woche; %2d.%2m.%4y")

Ergebnis: "4. Woche; 4. 7. 1776"

Date$(Date("04.07.1776"),"%02d.%02m.%4y") Ergebnis: "04.07.1776"

Date$(Now(),"%02H:%02i:%02s") Ergebnis: "16:12:40"


DateDiff

combit List & Label

DateDiff

Aufgabe:

Berechnet den Abstand der übergebenen Datumswerte in Tagen.

Parameter:

Datum erster Datumswert

Datum zweiter Datumswert

Rückgabewert:

Zahl

Beispiel:

DateDiff(Date("04.07.1776"), Date("04.07.2015")) Ergebnis: 87292


DateDiff$

combit List & Label

DateDiff$

Aufgabe:

Berechnet den Abstand der übergebenen Datumswerte in Tagen und gibt ihn gemäß der Formatierung als Zeichenkette zurück.

Aufbau der Format-Zeichenkette: Dies ist eine gewöhnliche Zeichenkette, in dem Platzhalter eingebettet werden können.

Platzhalter | Bedeutung
%y | Anzahl Jahre
%<n>y | Jahr, auf <n> Stellen
$y | Text "Jahre"
%m | Anzahl Monate
%<n>m | Monate auf <n> Stellen
$m | Text "Monat" bzw. "Monate"
%w | Anzahl Wochen
%<n>w | Wochentag auf <n> Stellen
$w | Text "Woche" bzw. "Wochen"
%d | Anzahl Tage
%<n>d | Anzahl Tage auf <n> Stellen
$d | Text "Tag" bzw. "Tage"
%h | Anzahl Stunden
%<n>h | Stunden auf <n> Stellen
$h | Text "Stunde" bzw. "Stunden"
%i | Anzahl Minuten
%<n>i | Minuten auf <n> Stellen
$i | Text "Minute" bzw. "Minuten"
%s | Anzahl Sekunden
%<n>s | Sekunden auf <n> Stellen
%.<n>s | Sekunden mit <n> Nachkommastellen
$s | Text "Sekunde" bzw. "Sekunden"

Parameter:

Datum erster Datumswert

Datum zweiter Datumswert

Zeichenkette (optional) Formatierung

Rückgabewert:

Zeichenkette

Beispiel:

DateDiff$(Date("04.07.1776"), Date("04.07.2015"))
Ergebnis: "238 Jahre, 12 Monate"


DateHMS

combit List & Label

DateHMS

Aufgabe:

Wandelt drei Zahlen für Stunde, Minute und Sekunde in ein Datum um.

Parameter:

Zahl Stunde

Zahl Minute

Zahl Sekunde

Rückgabewert:

Datum

Beispiel:

DateHMS(55554000,90000000,45) Ergebnis: 03.08.1796


DateInLeapYear

combit List & Label

DateInLeapYear

Aufgabe:

Überprüft, ob das angegebene Datum in einem Schaltjahr liegt oder nicht. Dabei wird die Berechnung nach dem proleptischen gregorianischen Kalender vorgenommen.

Parameter:

Datum Zu überprüfendes Datum.

Rückgabewert:

Boolean

Beispiel:

DateInLeapYear(Date("04.07.1176")) Ergebnis: True


DateInRange

combit List & Label

DateInRange

Aufgabe:

Testet, ob das Datum sich innerhalb des durch die Grenzen angegebenen Intervalls befindet. Das Intervall ist abgeschlossen, also ist ein mit einer Grenze identischer Wert noch innerhalb. Um halboffene Intervalle zu definieren, kann die die JulianToDate()-Funktion verwendet werden:

Minimales Datum: JulianToDate(0)

Maximales Datum: JulianToDate(1e100)

Parameter:

Datum Zu überprüfendes Datum.

Datum Untere Grenze des Testintervalls.

Datum Obere Grenze des Testintervalls.

Rückgabewert:

Boolean

Beispiel:

DateInRange(Date('04.07.1776'),Date('01.01.1770'),Date('04.04.2000'))

Ergebnis: True


DateToJulian

combit List & Label

DateToJulian

Aufgabe:

Bestimmt den julianischen Wert eines Datums. Dabei wird jedem Tag (auch solchen in der Vergangenheit) eine eindeutige Zahl zugeordnet.

Parameter:

Datum

Rückgabewert:

Zahl

Beispiel:

DateToJulian(Date("04.07.1776")) Ergebnis: 2369915


DateYMD

combit List & Label

DateYMD

Aufgabe:

Wandelt drei Zahlen für Tag, Monat und Jahr in ein Datum um.

Parameter:

Zahl Jahr

Zahl Monat

Zahl Tag

Rückgabewert:

Datum

Beispiel:

DateYMD (1776,7,4) Ergebnis: 04.07.1776


Day

combit List & Label

Day

Aufgabe:

Bestimmt den Tag (1..31) des Monats eines Datums und gibt ihn als Zahl zurück.

Parameter:

Datum

Rückgabewert:

Zahl

Beispiel:

Day (Date("04.07.1776")) Ergebnis: 4


Day$

combit List & Label

Day$

Aufgabe:

Bestimmt den Tag (1..31) des Monats eines Datums und gibt ihn als Zeichenkette zurück.

Parameter:

Datum

Rückgabewert:

Zeichenkette

Beispiel:

Day$(Date("04.07.1776")) Ergebnis: "4"


Decade

combit List & Label

Decade

Aufgabe:

Bestimmt das Jahrzehnt eines Datums und gibt es als Zahl zurück. Dieser Wert ist immer relativ zum Jahrhundert (mögliche Werte: 1-10).

Parameter:

Datum

Boolean (optional) Bestimmt, ob die Berechnung "einfach" (Jahrzehnt beginnt mit Jahr 0) oder historisch (Jahrzehnt beginnt mit Jahr 1) durchgeführt werden soll. Voreinstellung: False (historisch).

Rückgabewert:

Zahl

Beispiel:

Decade(Date("04.07.1776")) Ergebnis: 7

Decade(Date("04.07.1776"),True) Ergebnis: 8


DisplayValues$

combit List & Label

DisplayValues$

Aufgabe:

Wandelt die Inhalte des Berichtsparameters in deren Darstellungen (gemäß der Konfiguration des Parameters).

Parameter:

Alle Berichtsparameter

Rückgabewert:

Zeichenkette

Beispiel:

DisplayValues$(@Param1) Ergebnis: "Wert1; Wert2; Wert3"


Distinct

combit List & Label

Distinct

Aufgabe:

Wirkt auf die übergeordnete Aggregatsfunktion (z.B. Sum(), Avg(), Count()...) und bewirkt, dass gleiche Werte nur einfach in die Berechnung eingehen.

Parameter:

Alle

Rückgabewert:

Alle

Beispiel:

Count(Distinct(Customers.Country))

NthLargest(Artikel.Stkpreis,Count(Distinct(Artikel.Stkpreis),True) -1, True)

berechnet den zweitkleinsten Wert und berücksichtigt dabei mehrfach vorkommende Werte nur einmal.


Dow

combit List & Label

Dow

Aufgabe:

Gibt den Wochentag als Zahl zurück (1..7), 1=Sonntag, 2=Montag, ...

Parameter:

Datum

Rückgabewert:

Zahl

Beispiel:

Dow(Date("04.07.1776")) Ergebnis: 5 (Donnerstag)


Dow$

combit List & Label

Dow$

Aufgabe:

Gibt den Wochentag als Zeichenkette gemäß der Ländereinstellung zurück, "Sonntag", "Montag", ...

Parameter:

Datum

Rückgabewert:

Zeichenkette

Beispiel:

Dow$(Date("04.07.1776")) Ergebnis: "Donnerstag"


Drawing

combit List & Label

Drawing

Aufgabe:

Wertet Zeichenkette als Pfad für eine Bilddatei aus.

Parameter:

Zeichenkette

Rückgabewert:

Bild


Drawing$

combit List & Label

Drawing$

Aufgabe:

Gibt Bild-Pfad als Zeichenkette zurück.

Parameter:

Bild

Rückgabewert:

Zeichenkette


DrawingHeightSCM

combit List & Label

DrawingHeightSCM

Aufgabe:

Gibt die Höhe des Bildes in SCM-Einheiten (1/1000 mm) zurück.

Parameter:

Bild

Rückgabewert:

Zahl


DrawingWidthSCM

combit List & Label

DrawingWidthSCM

Aufgabe:

Gibt die Breite des Bildes in SCM-Einheiten (1/1000 mm) zurück.

Parameter:

Bild

Rückgabewert:

Zahl


Empty

combit List & Label

Empty

Aufgabe:

Testet, ob die Zeichenkette leer ist. Wenn der zweite Parameter True ist, wird die Zeichenkette noch von den umgebenden Leerzeichen entfernt (implizites Atrim$()).

Parameter:

Zeichenkette

Boolean (optional)

Rückgabewert:

Boolean

Beispiele:

Empty("Hallo Welt") Ergebnis: False

Empty("") Ergebnis: True


EndsWith

combit List & Label

EndsWith

Aufgabe:

Testet, ob die Zeichenkette im ersten Argument mit der Zeichenkette im zweiten Argument endet.

Parameter:

Zeichenkette

Zeichenkette

Boolean Gibt an, ob Groß-/Kleinschreibung beachtet werden soll. Voreinstellung: False

Rückgabewert:

Boolean

Beispiele:

EndsWith("Hallo Welt","elt") Ergebnis: True

EndsWith("Hallo Welt","llo") Ergebnis: False


Evaluate

combit List & Label

Evaluate

Aufgabe:

Berechnet die übergebene Formel.

Parameter:

Zeichenkette

Rückgabewert:

Alle

Beispiel:

Evaluate("5*5") Ergebnis: 25

Evaluate("4-3") Ergebnis: 1


Even

combit List & Label

Even

Aufgabe:

Testet, ob eine Zahl gerade ist oder nicht. Im geraden Fall wird True zurückgegeben, sonst False.

Parameter:

Zahl

Rückgabewert:

Boolean

Beispiel:

Even(2) Ergebnis: True


Exists

combit List & Label

Exists

Aufgabe:

Prüft, ob die Variable bzw. das Feld mit dem übergebenen Namen existiert. Wird häufig im Zusammenhang mit GetValue() verwendet.

Parameter:

Zeichenkette

Rückgabewert:

Boolean

Beispiel:

Exists("CustomerID") Ergebnis: False

If(Exists("Kunde.Status"), Evaluate("Kunde.Status"), "In Ihrer Datenbank ist kein Status für den Kunden vergeben")


Exp

combit List & Label

Exp

Aufgabe:

Gibt den Exponenten zur Basis e zurück (e^x).

Parameter:

Zahl

Rückgabewert:

Zahl

Beispiel:

Exp(3) Ergebnis: 20.08553692


Exp10

combit List & Label

Exp10

Aufgabe:

Gibt den 10er Exponenten zurück (10^x).

Parameter:

Zahl

Rückgabewert:

Zahl

Beispiel:

Exp10(3) Ergebnis: 1000


ExtractDate

combit List & Label

ExtractDate

Aufgabe:

Gibt das Argument als Datum ohne Zeitanteil zurück.

Parameter:

Datum

Rückgabewert:

Datum

Beispiel:

ExtractDate(Date('04.07.1776 12:00:00')) Ergebnis: 04.07.1776


ExtractTime

combit List & Label

ExtractTime

Aufgabe:

Gibt das Argument als Zeit ohne Datumsanteil zurück.

Parameter:

Datum

Rückgabewert:

Datum

Beispiel:

Date$(ExtractTime(Date('04.07.1776 12:11:10')), "%02h:%02i:%02s")
Ergebnis: 12:11:10


FirstHeaderThisTable

combit List & Label

FirstHeaderThisTable

Aufgabe:

Liefert zurück, ob die Kopfzeile der aktuellen Tabelle zum ersten Mal ausgegeben wird. Diese Funktion kann als Darstellungsbedingung der Kopfzeile verwendet werden, um die erneute Ausgabe der Kopfzeile zu unterdrücken, falls der Druck einer Tabelle aus Platzmangel auf der Folgeseite fortgesetzt wird. Die Kopfzeile wird dann nur zu Beginn der Tabelle ausgegeben. Diese Funktion steht nur im Multitabellenmodus zur Verfügung.

Parameter: -

Rückgabewert:

Boolean


Floor

combit List & Label

Floor

Aufgabe:

Berechnet ausgehend vom übergebenen Wert die nächstkleinere Ganzzahl. Siehe auch Funktion Ceil().

Parameter:

Zahl

Rückgabewert:

Zahl

Beispiel:

Floor (5.6) Ergebnis: 5


Frac

combit List & Label

Frac

Aufgabe:

Gibt den Nachkommaanteil einer Zahl zurück

Parameter:

Zahl

Rückgabewert:

Zahl

Beispiel:

Frac(1.234) Ergebnis: 0.234

Frac(Constant.Pi()) Ergebnis: 0.1415926535


Fstr$

combit List & Label

Fstr$

Aufgabe:

Formatiert eine Zahl mit Hilfe der Format-Zeichenkette.

Dieser besteht aus folgenden Zeichen ('wenn negativ' bezieht sich auf den zu formatierenden Wert):

* | Ziffer oder '*'-Präfix
$ | Lokales Währungszeichen
- | Ziffer oder Vorzeichen, wenn negativ
+ | Ziffer oder Vorzeichen
( | Ziffer oder '('-Präfix wenn negativ
) | ')'-Postfix wenn negativ
# | Ziffer oder Leerzeichen-Präfix
& | Ziffer oder '0'
. | Dezimalpunkt
, | Komma, oder Leerzeichen-Präfix

Ein Präfix ist dabei ein Zeichen, das einem Wert bei Bedarf vorangestellt wird. Der Ausdruck Fstr$(1, "***") ergibt z.B. "**1". Dem Wert "1" werden dabei die Zeichen "**" vorangestellt, weil es kürzer als die drei reservierten Stellen ist. Ein Postfix ist ein Zeichen, das einem Wert bei Bedarf nachgestellt wird. Diese Formatierungs-Zeichen dürfen beliebig kombiniert werden. Wenn die Zahl zu groß ist für die gewünschte Formatierung, wird eine Zeichenkette aus '*' erstellt.

Über den dritten (optionalen) Parameter kann zusätzlich die Formatierung gesteuert werden.

Wert | Bedeutung
1 | Entfernung führender Leerzeichen. Die Anwendung entspricht den Funktionen Rtrim$() und Ltrim$().
2 | Leere Zeichenkette wenn Wert Null.
3 | Entfernung führender Leerzeichen und leere Zeichenkette wenn Wert Null.
4 | Entfernung von '0' am Ende der Dezimalstellen.

Parameter:

Zahl

Zeichenkette Format-Zeichenkette

Zahl (optional) zusätzliche Formatierung

Rückgabewert:

Zeichenkette

Beispiele:

Fstr$(3.142,"#") Ergebnis: "3"

Fstr$(0,"#",2) Ergebnis: ""

Fstr$(0003.142,"#.###",1) Ergebnis: "3,142"

Fstr$(3.1,"######&.###",4) Ergebnis: "3,1"

Fstr$(3.1,"######&.###") Ergebnis: "3,100"

Fstr$(.1,"######&.###") Ergebnis: "0,100"

Fstr$(5003.1,"#,###.&&") Ergebnis: "5.003,10"

Fstr$(3.142,"#.###") Ergebnis: "3,142"

Fstr$(3.142,".######") Ergebnis: "*******"

Fstr$(3.142,"(#.###)") Ergebnis: " 3,142 "

Fstr$(-3.142,"(#.###)") Ergebnis: "(3,142)"

Fstr$(3.142,"+#.###") Ergebnis: "+3,142"

Fstr$(3.142,"-#.###") Ergebnis: " 3,142"

Fstr$(-3.142,"-#.###") Ergebnis: "-3,142"

Fstr$(3.142,"&&&.&&&") Ergebnis: "003,142"

Fstr$(3.142,"***.***") Ergebnis: "**3,142"

Fstr$(3.142,"$$$.$$$") Ergebnis: "$$3,142"

Fstr$(3.142,"###.***") Ergebnis: " 3,142"

Fstr$(5003.1,"#,###.&&") Ergebnis: "5.003,10"

Fstr$(3.142,"#####") Ergebnis: " 3"


GeometricAvg

combit List & Label

GeometricAvg

Aufgabe:

Bestimmt das geometrische Mittel. Das geometrische Mittel ist ein geeignetes Lagemaß für Größen, von denen das Produkt anstelle der Summe interpretierbar ist, z.B. von Verhältnissen oder Wachstumsraten.

Parameter:

Zahl Ausdruck für den zu mittelnden Wert

Boolean (optional) True: nach der Ausgabe werden die für die Berechnung gemerkten Werte gelöscht (Voreinstellung: True). Bitte beachten Sie, dass die für die Berechnung gemerkten Werte generell bei jedem (Unter-) Tabellenende gelöscht werden. Der zweite Parameter bestimmt lediglich, ob die Werte bei einer Ausgabe schon innerhalb der Tabelle gelöscht werden.

Rückgabewert:

Zahl


GetValue

combit List & Label

GetValue

Aufgabe:

Liefert den Wert der Variablen bzw. des Feldes mit dem übergebenen Namen. Wird häufig im Zusammenhang mit Exists() verwendet.

Parameter:

Zeichenkette

Rückgabewert:

Alle

Beispiel:

GetValue("Customers.CustomerID") Ergebnis: 1234

If (Exists("Kunde.Status"), Evaluate("Kunde.Status"), "In Ihrer Datenbank ist kein Status für den Kunden vergeben")


GetVar

combit List & Label

GetVar

Aufgabe:

Holt einen Wert, der über die SetVar()-Funktion gesetzt wurde, aus dem Variablenspeicher. Die Aufgabe dieser Funktionen ist die eines einfachen Zwischenspeichers für Werte. Sie sollten keine komplexen Verschachtelungen mit GetVar/SetVar durchführen oder die beiden Funktionen miteinander kombinieren – hier können, insbesondere in Kopf-, Fuß- und Gruppenzeilen, unerwartete Effekte auftreten.

Parameter:

Alle Bezeichnung der Variablen

Rückgabewert:

Alle

Beispiel:

GetVar("Seite") Ergebnis: Inhalt von "Seite", der über SetVar() gesetzt wurde


HeatmapColor

combit List & Label

HeatmapColor

Aufgabe:

Berechnet einen Farbwert innerhalb eines 7-stufigen Farbgradienten entsprechend dem Wert des ersten Parameters.

Parameter:

Zahl Wert der dargestellt werden soll.

Zahl Unterer Grenzwert.

Zahl Oberer Grenzwert.

Rückgabewert:

Zahl

Beispiel:

HeatmapColor(10,-20,40) Ergebnis: Ordnet 10° auf einer Skala
zwischen -20° und 40° ein.


Hour

combit List & Label

Hour

Aufgabe:

Bestimmt die Stunde des Datums und gibt sie als Zahl zurück. Wenn der Parameter weggelassen wird, wird die Stunde der Druckzeit zurückgeliefert.

Parameter:

Datum (optional)

Rückgabewert:

Zahl

Beispiel:

Hour()=10


HSL

combit List & Label

HSL

Aufgabe:

Berechnet einen Farbwert im HSL-Farbraum, bei dem man die Farbe mit Hilfe des Farbtons (englisch hue), der Farbsättigung (saturation) und der relativen Helligkeit (lightness) bestimmt.

Parameter:

Zahl Farbton [0-360] als Farbwinkel H auf dem Farbkreis (z.B. 0°=Rot, 120°=Grün, 240°=Blau).

Zahl Sättigung [0-1] als Intervall von Null bis Eins (0=Neutralgrau, 0.5= wenig gesättigte Farbe, 1=gesättigte, reine Farbe).

Zahl Helligkeit bzw. Dunkelstufe [0-1] als Intervall von Null bis Eins (0=keine Helligkeit, 1=volle Helligkeit).

Rückgabewert:

Zahl


HTMLtoPlainText$

combit List & Label

HTMLtoPlainText$

Aufgabe:

Gibt den reinen unformatierten Text des HTML-Inhalts zurück.

Parameter:

Zeichenkette HTML-Inhalt.

Rückgabewert:

Zeichenkette


Hyperlink$

combit List & Label

Hyperlink$

Aufgabe:

Die Funktion Hyperlink$ erzeugt für den HTML, XHTML und MHTML-Export einen Hyperlink. Für andere Exportziele verwenden Sie die jeweilige Link-Eigenschaft.

Enthält ein Objekttext die Zeichenfolge:

<!–begin:hyperlink="ziel"à"Anzeigetext"<!–end:hyperlinkà

dann wird an dieser Stelle automatisch ein Hyperlink auf das angegebene Ziel erzeugt. Die Hyperlink-Funktion erstellt automatisch eine Zeichenkette mit der benötigten Syntax.

Parameter:

Zeichenkette Anzeigetext

Zeichenkette Hyperlink

Boolean (optional) True: Link wird eingebettet (Voreinstellung)

Rückgabewert:

Zeichenkette

Beispiel:

Hyperlink$("domain.com",http://www.domain.com)


If

combit List & Label

If

vgl. Cond()


IssueIndex

combit List & Label

IssueIndex

Aufgabe:

Gibt den Index der Ausfertigung (1..) zurück. Verfügbar in einer Anzeige- und Layoutbereichsbedingung wenn in den Projektparametern mehrere Ausfertigungen gewählt wurden.

Parameter:

Zahl

Rückgabewert:

Zahl


Int

combit List & Label

Int

Aufgabe:

Gibt den ganzzahligen Anteil einer Zahl zurück. Der Wert wird abgeschnitten.

Parameter:

Zahl

Rückgabewert:

Zahl

Beispiele

Int(3,1) Ergebnis: 3


IsNull

combit List & Label

IsNull

Aufgabe:

Überprüft ob der übergebene Wert oder das Ergebnis des Ausdrucks Null ist, also ein leerer Feldinhalt.

Parameter:

Alle

Rückgabewert:

Boolean


IsNullOrEmpty

combit List & Label

IsNullOrEmpty

Aufgabe:

Überprüft eine Zeichenkette, ob sie leer oder Null() ist.

Parameter:

String die zu überprüfende Zeichenkette

Boolean (optional) Wenn der Wert True ist, dann werden Leerzeichen am Anfang und Ende der Zeichenkette entfernt. Voreinstellung: False

Rückgabewert:

Zeichenkette

Beispiel:

IsNullOrEmpty(" ", True) Ergebnis: True


Join$

combit List & Label

Join$

Aufgabe:

Gibt die gesammelten Zeichenketten zurück, getrennt durch ein Trennzeichen.

Parameter:

Zeichenkette Werte

Zeichenkette (optional) Trennzeichen für die Werte (Voreinstellung: ";").

Zahl (optional) Maximalzahl der Werte (danach wird '...' angehängt). Voreinstellung: alle Werte".

Boolean (optional) True: nach der Ausgabe werden die gemerkten Werte gelöscht (Voreinstellung: True). Bitte beachten Sie, dass die gemerkten Werte generell bei jedem (Unter-)Tabellenende gelöscht werden. Der zweite Parameter bestimmt lediglich, ob die Werte bei einer Ausgabe schon innerhalb der Tabelle gelöscht werden.

Rückgabewert:

Zeichenkette

Beispiel:

Join$(Str$(Anzahl * Stückpreis,0,2),"+") Ergebnis: "12,55 + 33,45 + 12,12"


JulianToDate

combit List & Label

JulianToDate

Aufgabe:

Interpretiert eine Zahl als julianisches Datum (jedem Tag wird eine eindeutige Zahl zugeordnet) und gibt das entsprechende Datum zurück.

Parameter:

Zahl

Rückgabewert:

Datum

Beispiel:

JulianToDate(2369915) Ergebnis: 04.07.1776


LangCase$

combit List & Label

LangCase$

Aufgabe:

Gibt entsprechend der eingestellten Sprache einen der Teile der Zeichenkette zurück.

Parameter:

Zeichenkette Zeichenkette die zurückgegeben wird, wenn keine Lokalisierungszeichenkette gefunden werden kann. Hierbei muss es sich um ein gültiges ISO 639-Sprachkürzel handeln.

Zeichenkette Zeichenkette mit Übersetzungstexten, getrennt durch "|" (oder durch optionalen dritten Parameter). Übersetzungstexte müssen in "ISO 639-Sprachkürzel = Übersetzungstext |[ISO 639-Sprachkürzel = Übersetzungstext |…] formatiert sein. Um "|" oder "=" im Wert oder Schlüssel verwenden zu können, stellen Sie diesen ein "\" voran, z.B. "USA=He\=llo".

Wir empfehlen die Verwendung eines vollständigen Sprachkürzels im Format <ISO639>-<ISO3166> wie z.B. de-de oder en-us.

http://msdn.microsoft.com/en-us/library/cc233968%28v=PROT.10%29.aspx

Zeichenkette (optional) Trennzeichen (Voreinstellung: "|")

Rückgabewert:

Zeichenkette

Beispiel:

LangCase$("Hallo","USA=Hello|ESP=Hóla") Ergebnis: "Hallo" (auf dt. System)


LastFooterThisTable

combit List & Label

LastFooterThisTable

Aufgabe:

Liefert zurück, ob die Fußzeile der aktuellen Tabelle zum letzten Mal ausgegeben wird. Diese Funktion kann als Darstellungsbedingung der Fußzeile verwendet werden, um die Ausgabe der Fußzeile zu unterdrücken, falls der Druck einer Tabelle aus Platzmangel auf der Folgeseite fortgesetzt wird. Die Fußzeile wird dann nur auf der letzten Seite der Tabelle ausgegeben. Diese Funktion steht nur im Berichtscontainer zur Verfügung.

Parameter:

-

Rückgabewert:

Boolean


Lastpage

combit List & Label

Lastpage

Aufgabe:

Gibt an, ob alle Datenzeilen der letzten Tabelle (des letzten Berichtscontainers) ausgegeben sind. Für alle nachfolgenden Seiten (mit Fußzeilen, angehängten Objekten usw.) bleibt Lastpage() auf True.

Diese Funktion kann nur in Fußzeilen von Tabellen, als Bedingung in Layoutbereichen oder in an Tabellen angehängten Objekten (solange nicht während des Drucks der angehängten Objekte ein Seitenumbruch erfolgt ist) verwendet werden! In allen anderen Fällen ist Lastpage() immer False.

Parameter:

-

Rückgabewert:

Boolean

Beispiel:

Cond(Lastpage(),"Endsumme","Zwischensumme")


Left$

combit List & Label

Left$

Aufgabe:

Kürzt eine Zeichenkette von rechts um so viele Zeichen, dass gerade noch die unter Zahl angegebene Anzahl von Zeichen übrigbleibt. Wenn die ursprüngliche Zeichenkette schon klein genug ist, wird diese nicht verändert.

Parameter:

Zeichenkette Der zu kürzende Wert.

Zahl max. Anzahl der Stellen des Resultats (inkl. Punkte).

Boolean (optional) True: Der abgeschnittene Wert wird mit "..." beendet (Voreinstellung False). Bei Zahl < 3 wird die Einstellung ignoriert.

Rückgabewert:

Zeichenkette

Beispiele:

Left$("ABCD", 2) Ergebnis: "AB"


Len

combit List & Label

Len

Aufgabe:

Gibt die Anzahl der Zeichen einer Zeichenkette zurück.

Parameter:

Zeichenkette

Rückgabewert:

Zahl

Beispiel:

Len("1234"+"56"+"78") Ergebnis: 8


LibraryPath$

combit List & Label

LibraryPath$

Aufgabe:

Gibt den Pfad der List & Label DLL zurück.

Parameter:

Boolean (optional) Gibt an, ob der Pfad inklusive Dateiname zurückgeliefert wird (Voreinstellung: False).

Rückgabewert:

Zeichenkette

Beispiel:

LibraryPath$() Ergebnis: "C:\Program Files (x86)\combit\"


LoadFile$

combit List & Label

LoadFile$

Aufgabe:

Gibt den Inhalt der Datei als Zeichenkette aus.

Wichtig: Bitte beachten Sie, dass die Darstellung von RTF-Texten aus Variablen/Feldern auf Inhalte ausgelegt ist, welche mit Hilfe des Microsoft RTF-Controls erzeugt wurden. Sie können diese Inhalte beispielsweise mit der Windows Anwendung "Wordpad" generieren. Inhalte, die in Microsoft Word erzeugt wurden, sind unter Umständen nicht mit dem vom Control verwendeten RTF-Standard kompatibel und sollten deshalb auch nicht verwendet werden.

Parameter:

Zeichenkette

Zeichenkette (optional) Wenn die Datei nicht vorhanden ist, wird der hier angegebene Wert verwendet.

Rückgabewert:

Zeichenkette

Beispiel:

LoadFile$(ProjectPath$()+"\agb.txt","Datei ist nicht vorhanden")


Locale$

combit List & Label

Locale$

Aufgabe:

Gibt Informationen zu den Ländereinstellungen zurück wie z.B. Währung, Dezimalstellen, Separatoren, Sprache, Länderkürzel. Das Kürzel für das entsprechende Land wird im zweiten Parameter angegeben – wenn kein zweiter Parameter angegeben ist, wird das eingestellte Land verwendet.

Parameter:

Zahl Index des Locale-Eintrags.

http://msdn.microsoft.com/en-us/library/bb507201.aspx

Zeichenkette (optional) ISO-Kürzel der Sprache und des Landes, dessen Formatierung verwendet werden soll. Format: <ISO639>-<ISO3166> wie z.B. de-de oder en-us.

http://msdn.microsoft.com/en-us/library/cc233968%28v=PROT.10%29.aspx

Rückgabewert:

Zeichenkette

Beispiel:

Locale$(42,"de-de") Ergebnis: "Montag"


LocCurr$

combit List & Label

LocCurr$

Aufgabe

Gibt eine Zeichenkette mit der für das Land gültigen Währungsformatierung ohne Währungssymbol zurück.

Parameter:

Zahl Zu formatierender Wert.

Zeichenkette (optional) ISO-Kürzel der Sprache und des Landes, dessen Formatierung verwendet werden soll. Format: <ISO639>-<ISO3166> wie z.B. de-de oder en-us.

Voreinstellung: eingestellte Locale

http://msdn.microsoft.com/en-us/library/cc233968%28v=PROT.10%29.aspx

Rückgabewert:

Zeichenkette

Beispiel:

LocCurr$(1500,"de-de") Ergebnis: "1.500,00"


LocCurrL$

combit List & Label

LocCurrL$

Aufgabe

Gibt eine Zeichenkette mit der für das Land gültigen Währungsformatierung mit Währungssymbol zurück.

Parameter:

Zahl Zu formatierender Wert.

Zeichenkette (optional) ISO-Kürzel der Sprache und des Landes, dessen Formatierung verwendet werden soll. Format: <ISO639>-<ISO3166> wie z.B. de-de oder en-us.

Voreinstellung: eingestellte Locale

http://msdn.microsoft.com/en-us/library/cc233968%28v=PROT.10%29.aspx

Rückgabewert:

Zeichenkette

Beispiel:

LocCurrL$(1500,"de-de") Ergebnis: "1.500,00 €"


LocDate$

combit List & Label

LocDate$

Aufgabe

Gibt eine Zeichenkette mit dem für das Land gültigen Datumsformat zurück.

Parameter:

Datum Datum das formatiert werden soll.

Zeichenkette (optional) Ländercode/ISO-Kürzel der Sprache und des Landes, dessen Formatierung verwendet werden soll. Format: <ISO639>-<ISO3166> wie z.B. de-de oder en-us.

Voreinstellung: eingestellte Locale

http://msdn.microsoft.com/en-us/library/cc233968%28v=PROT.10%29.aspx

Zahl (optional) 0=Kurzform (Voreinstellung), 1=Langform, 2=Kurzform, alternativer Kalender, 3=Langform, alternativer Kalender

Rückgabewert:

Zeichenkette

Beispiel:

LocDate$(Date("04.07.1776"),"de-de") Ergebnis: "04.07.1776"

LocDate$(Date("04.07.1776"),"de-de",1) Ergebnis: "Donnerstag, 4. Juli 1776"


LocDateTime

combit List & Label

LocDateTime

Aufgabe

Wandelt die Zeichenkette in ein Datum (mit Zeit wenn erforderlich). Es wird angenommen, dass die Zeichenkette entsprechend dem angegebenen Länderkürzel formatiert ist.

Parameter:

Zeichenkette Datum

Zeichenkette (optional) ISO-Kürzel der Sprache und des Landes, dessen Formatierung verwendet werden soll. Format: <ISO639>-<ISO3166> wie z.B. de-de oder en-us.

Voreinstellung: eingestellte Locale

http://msdn.microsoft.com/en-us/library/cc233968%28v=PROT.10%29.aspx

Rückgabewert:

Datum

Beispiel:

LocDateTime("07/04/1776","de-de") Ergebnis: 04.07.1776


LocNumber$

combit List & Label

LocNumber$

Aufgabe

Gibt eine Zeichenkette mit der für das Land gültigen Zahlenformatierung zurück.

Parameter:

Zahl Zu formatierender Wert.

Zeichenkette (optional) ISO-Kürzel der Sprache und des Landes, dessen Formatierung verwendet werden soll. Format: <ISO639>-<ISO3166> wie z.B. de-de oder en-us.

Voreinstellung: eingestellte Locale

http://msdn.microsoft.com/en-us/library/cc233968%28v=PROT.10%29.aspx

Rückgabewert:

Zeichenkette

Beispiel:

LocNumber$(123,"de-de") Ergebnis: "123,00"


LocTime$

combit List & Label

LocTime$

Aufgabe

Gibt eine Zeichenkette mit der für das Land gültigen Zeitformatierung zurück.

Parameter:

Datum Zu formatierender Wert.

Zeichenkette (optional) ISO-Kürzel der Sprache und des Landes, dessen Formatierung verwendet werden soll. Format: <ISO639>-<ISO3166> wie z.B. de-de oder en-us.

Voreinstellung: eingestellte Locale

http://msdn.microsoft.com/en-us/library/cc233968%28v=PROT.10%29.aspx

Zahl (optional) Formatierungswert: 0=normal (Voreinstellung), 1=immer 24h-Format, 2=normal, kein AM/PM, 3=24h-Format, kein AM/PM, Formatierungswert +10 = keine Sekunden, Formatierungswert +20 = keine Minuten und keine Sekunden

Rückgabewert:

Zeichenkette

Beispiel:

LocTime$(Now(),"de-de") Ergebnis: aktuelle Systemzeit

LocTime$(Now(),"",11) Ergebnis: immer 24h-Format, keine Sekunden


LocVal

combit List & Label

LocVal

Aufgabe

Interpretiert die Zeichenkette als Zahl und gibt deren Wert zurück. Ggf. vorkommende lokalisierte Dezimal- und Tausendertrennzeichen werden berücksichtigt.

Parameter:

Zeichenkette Zahl (als Zeichenkette).

Zeichenkette (optional) ISO-Kürzel der Sprache und des Landes, dessen Formatierung verwendet werden soll. Format: <ISO639>-<ISO3166> wie z.B. de-de oder en-us.

Voreinstellung: eingestellte Locale

http://msdn.microsoft.com/en-us/library/cc233968%28v=PROT.10%29.aspx

Rückgabewert:

Zahl

Beispiel:

LocVal("12","de-de") Ergebnis: 12,00

LocVal("12,00","en-us") Ergebnis:1200,00


Log

combit List & Label

Log

Aufgabe:

Gibt den Logarithmus zur Basis e zurück (ln(x)).

Parameter:

Zahl

Rückgabewert:

Zahl

Beispiel:

Log(Exp(1)) Ergebnis: 1

Log(3) Ergebnis: 1,10


Log10

combit List & Label

Log10

Aufgabe:

Gibt den 10er Logarithmus zurück (log(x)).

Parameter:

Zahl

Rückgabewert:

Zahl

Beispiel:

Log10(1000) Ergebnis: 3


Lower$

combit List & Label

Lower$

Aufgabe:

Wandelt die Zeichen in Kleinbuchstaben um.

Parameter:

Zeichenkette

Rückgabewert:

Zeichenkette

Beispiel:

Lower$("HALLO WELT") Ergebnis: "hallo welt"


Ltrim$

combit List & Label

Ltrim$

Aufgabe:

Entfernt die führenden Leerzeichen am Anfang einer Zeichenkette.

Parameter:

Zeichenkette

Rückgabewert:

Zeichenkette

Beispiel:

Ltrim$(" Hallo Welt") Ergebnis: "Hallo Welt"


Max

combit List & Label

Max

Aufgabe:

Vergleicht zwei Werte vom Typ Zahl oder zwei Werte vom Typ Datum und gibt den größeren der beiden Werte zurück.

Parameter:

Zahl oder Datum

Zahl oder Datum

Rückgabewert:

Zahl oder Datum

Beispiel:

Max(100,10) Ergebnis: 100


Maximum

combit List & Label

Maximum

Aufgabe:

Liefert den größten Wert der Datenmenge, die sich aus dem ersten Argument ergibt.

Parameter:

Zahl

Boolean (optional) True: nach der Ausgabe werden die für die Berechnung gemerkten Werte gelöscht (Voreinstellung: True). Bitte beachten Sie, dass die für die Berechnung gemerkten Werte generell bei jedem (Unter-)Tabellenende gelöscht werden. Der zweite Parameter bestimmt lediglich, ob die Werte bei einer Ausgabe schon innerhalb der Tabelle gelöscht werden.

Rückgabewert:

Zahl

Beispiel:

Maximum(Anzahl * Stückpreis) Ergebnis: Maximum Gesamtpreis


Median

combit List & Label

Median

Aufgabe:

Liefert den Median der Datenmenge, die sich aus dem ersten Argument ergibt.

Parameter:

Zahl Ausdruck für den zu mittelnden Wert

Boolean (optional) True: nach der Ausgabe werden die für die Berechnung gemerkten Werte gelöscht (Voreinstellung: True). Bitte beachten Sie, dass die für die Berechnung gemerkten Werte generell bei jedem (Unter-) Tabellenende gelöscht werden. Der zweite Parameter bestimmt lediglich, ob die Werte bei einer Ausgabe schon innerhalb der Tabelle gelöscht werden.

Rückgabewert:

Zahl

Beispiel:

Median(Stückpreis) Ergebnis: Median Stückpreis


Mid$

combit List & Label

Mid$

Aufgabe:

Die resultierende Zeichenkette wird aus dem ursprünglichen gewonnen, indem ab der Anfangsposition die gewünschte Anzahl von Zeichen zurückgegeben wird.

Wenn der 3. Parameter wegfällt, dann wird die Zeichenkette von der Anfangsposition bis zum Ende zurückgegeben.

Das erste Zeichen der Zeichenkette entspricht Position 0.

Parameter:

Zeichenkette

Zahl Anfangsposition

Zahl (optional) Anzahl der gewünschten Zeichen.

Rückgabewert:

Zeichenkette

Beispiel:

Mid$("Hallo Welt",3,5) Ergebnis: "lo We"


Min

combit List & Label

Min

Aufgabe:

Vergleicht zwei Werte vom Typ Zahl oder zwei Werte vom Typ Datum und gibt den kleineren der beiden Werte zurück.

Parameter:

Zahl oder Datum

Zahl oder Datum

Rückgabewert:

Zahl oder Datum

Beispiel:

Min(100,10) Ergebnis: 10


Minimum

combit List & Label

Minimum

Aufgabe:

Liefert den kleinsten Wert der Datenmenge, die sich aus dem ersten Argument ergibt.

Parameter:

Zahl

Boolean (optional) True: nach der Ausgabe werden die für die Berechnung gemerkten Werte gelöscht (Voreinstellung: True). Bitte beachten Sie, dass die für die Berechnung gemerkten Werte generell bei jedem (Unter-)Tabellenende gelöscht werden. Der zweite Parameter bestimmt lediglich, ob die Werte bei einer Ausgabe schon innerhalb der Tabelle gelöscht werden.

Rückgabewert:

Zahl

Beispiel:

Minimum(Anzahl * Stückpreis) Ergebnis: [Kleinster Gesamtpreis]


Minute

combit List & Label

Minute

Bestimmt die Minute des übergebenen Datums und gibt sie als Zahl zurück. Wenn der Parameter weggelassen wird, wird die Minute der Druckzeit zurückgeliefert.

Parameter:

Datum (optional)

Rückgabewert:

Zahl


Mode

combit List & Label

Mode

Aufgabe:

Liefert den Modus (häufigsten Wert) der Datenmenge, die sich aus dem ersten Argument ergibt.

Parameter:

Zahl Ausdruck für den zu untersuchenden Wert.

Boolean (optional) True: nach der Ausgabe werden die für die Berechnung gemerkten Werte gelöscht (Voreinstellung: True). Bitte beachten Sie, dass die für die Berechnung gemerkten Werte generell bei jedem (Unter-) Tabellenende gelöscht werden. Der zweite Parameter bestimmt lediglich, ob die Werte bei einer Ausgabe schon innerhalb der Tabelle gelöscht werden.

Rückgabewert:

Zahl


Month

combit List & Label

Month

Aufgabe:

Bestimmt den Monat (1..12) eines Datums und gibt ihn als Zahl zurück.

Parameter:

Datum

Boolean (optional) bestimmt ob die Berechnung relativ zum Jahr (1…12, Voreinstellung: False) oder absolut seit 1.1.0001 (1…) zurückgegeben werden soll

Rückgabewert:

Zahl

Beispiel:

Month(Date("04.07.1776"), False) Ergebnis: 7


Month$

combit List & Label

Month$

Aufgabe:

Bestimmt den Monat (1..12) eines Datums und gibt ihn als Zeichenkette zurück.

Parameter:

Datum

Rückgabewert:

Zeichenkette

Beispiel:

Month$(Date("04.07.1776")) Ergebnis: "Juli"


NativeAvg

combit List & Label

NativeAvg

Aufgabe:

Liefert den arithmetischen Mittelwert der Datenmenge, die sich aus dem ersten Argument ergibt. Die Berechnung erfolgt direkt auf dem Datenbanksystem. Diese Funktion steht nicht in allen Anwendungen zur Verfügung.

Parameter:

Alle Feld bzw. Ausdruck über den aggregiert wird.

Boolean (optional) Filterbedingung für das zu aggregierende Feld bzw. Ausdruck. Voreinstellung: True (alle Daten).

Boolean (optional) Gibt an das nur über die eindeutigen Werte aggregiert werden soll (DISTINCT). Voreinstellung: False.

Rückgabewert:

Zahl

Beispiel:

NativeAvg(OrderDetails.Quantity,OrderDetails.ProductID=Products.ProductID)


NativeCount

combit List & Label

NativeCount

Aufgabe:

Liefert die Anzahl der Werte innerhalb der Datenmenge, die sich aus dem ersten Argument ergibt. Die Berechnung erfolgt direkt auf dem Datenbanksystem. Diese Funktion steht nicht in allen Anwendungen zur Verfügung.

Parameter:

Alle Feld bzw. Ausdruck über den aggregiert wird.

Boolean (optional) Filterbedingung für das zu aggregierende Feld bzw. Ausdruck. Voreinstellung: True (alle Daten).

Boolean (optional) Gibt an das nur über die eindeutigen Werte aggregiert werden soll (DISTINCT). Voreinstellung: False.

Rückgabewert:

Zahl

Beispiel:

NativeCount(OrderDetails.Quantity,OrderDetails.ProductID=Products.Pro-ductID)


NativeMax

combit List & Label

NativeMax

Aufgabe:

Liefert den größten Wert innerhalb der Datenmenge, die sich aus dem ersten Argument ergibt. Die Berechnung erfolgt direkt auf dem Datenbanksystem. Diese Funktion steht nicht in allen Anwendungen zur Verfügung.

Parameter:

Alle Feld bzw. Ausdruck über den aggregiert wird.

Boolean (optional) Filterbedingung für das zu aggregierende Feld bzw. Ausdruck. Voreinstellung: True (alle Daten).

Boolean (optional) Gibt an das nur über die eindeutigen Werte aggregiert werden soll (DISTINCT). Voreinstellung: False.

Rückgabewert:

Zahl

Beispiel:

NativeMax(OrderDetails.Quantity,OrderDetails.ProductID=Products.Pro-ductID)


NativeMin

combit List & Label

NativeMin

Aufgabe:

Liefert den kleinsten Wert innerhalb der Datenmenge,, die sich aus dem ersten Argument ergibt. Die Berechnung erfolgt direkt auf dem Datenbanksystem. Diese Funktion steht nicht in allen Anwendungen zur Verfügung.

Parameter:

Alle Feld bzw. Ausdruck über den aggregiert wird.

Boolean (optional) Filterbedingung für das zu aggregierende Feld bzw. Ausdruck. Voreinstellung: True (alle Daten).

Boolean (optional) Gibt an das nur über die eindeutigen Werte aggregiert werden soll (DISTINCT). Voreinstellung: False.

Rückgabewert:

Zahl

Beispiel:

NativeVarPop(OrderDetails.Quantity,OrderDetails.ProductID=Products.Pro-ductID)


NativeStdDevPop

combit List & Label

NativeStdDevPop

Aufgabe:

Liefert die statistische Standardabweichung für die Grundgesamtheit (Population) aller Werte innerhalb der Datenmenge, die sich aus dem ersten Argument ergibt. Die Berechnung erfolgt direkt auf dem Datenbanksystem. Diese Funktion steht nicht in allen Anwendungen zur Verfügung.

Parameter:

Alle Feld bzw. Ausdruck über den aggregiert wird.

Boolean (optional) Filterbedingung für das zu aggregierende Feld bzw. Ausdruck. Voreinstellung: True (alle Daten).

Boolean (optional) Gibt an das nur über die eindeutigen Werte aggregiert werden soll (DISTINCT). Voreinstellung: False.

Rückgabewert:

Zahl

Beispiel:

NativeStdDev(OrderDetails.Quantity,OrderDetails.ProductID=Products.Pro-ductID)


NativeStdDevSamp

combit List & Label

NativeStdDevSamp

Aufgabe:

Liefert die statistische Standardabweichung aller Werte innerhalb der Datenmenge, die sich aus dem ersten Argument ergibt. Die Berechnung erfolgt direkt auf dem Datenbanksystem. Diese Funktion steht nicht in allen Anwendungen zur Verfügung.

Parameter:

Alle Feld bzw. Ausdruck über den aggregiert wird.

Boolean (optional) Filterbedingung für das zu aggregierende Feld bzw. Ausdruck. Voreinstellung: True (alle Daten).

Boolean (optional) Gibt an das nur über die eindeutigen Werte aggregiert werden soll (DISTINCT). Voreinstellung: False.

Rückgabewert:

Zahl

Beispiel:

NativeStdDevSamp(OrderDetails.Quantity,OrderDetails.ProductID=Products. ProductID)


NativeSum

combit List & Label

NativeSum

Aufgabe:

Liefert die Summe aller Werte innerhalb der Datenmenge, die sich aus dem ersten Argument ergibt. Die Berechnung erfolgt direkt auf dem Datenbanksystem. Diese Funktion steht nicht in allen Anwendungen zur Verfügung.

Parameter:

Alle Feld bzw. Ausdruck über den aggregiert wird.

Boolean (optional) Filterbedingung für das zu aggregierende Feld bzw. Ausdruck. Voreinstellung: True (alle Daten).

Boolean (optional) Gibt an das nur über die eindeutigen Werte aggregiert werden soll (DISTINCT). Voreinstellung: False.

Rückgabewert:

Zahl

Beispiel:

Products.UnitPrice*NativeSum(OrderDetails.Quantity,OrderDetails.ProductID =Products.ProductID)


NativeVarPop

combit List & Label

NativeVarPop

Aufgabe:

Liefert die statistische Varianz für die Grundgesamtheit aller Werte innerhalb der Datenmenge, die sich aus dem ersten Argument ergibt. Die Berechnung erfolgt direkt auf dem Datenbanksystem. Diese Funktion steht nicht in allen Anwendungen zur Verfügung.

Parameter:

Alle Feld bzw. Ausdruck über den aggregiert wird.

Boolean (optional) Filterbedingung für das zu aggregierende Feld bzw. Ausdruck. Voreinstellung: True (alle Daten).

Boolean (optional) Gibt an das nur über die eindeutigen Werte aggregiert werden soll (DISTINCT). Voreinstellung: False.

Rückgabewert:

Zahl

Beispiel:

NativeVarPop(OrderDetails.Quantity,OrderDetails.ProductID=Products.Pro-ductID)


NativeVarSamp

combit List & Label

NativeVarSamp

Aufgabe:

Liefert die statistische Varianz aller Werte innerhalb der Datenmenge, die sich aus dem ersten Argument ergibt.. Die Berechnung erfolgt direkt auf dem Datenbanksystem. Diese Funktion steht nicht in allen Anwendungen zur Verfügung.

Parameter:

Alle Feld bzw. Ausdruck über den aggregiert wird.

Boolean (optional) Filterbedingung für das zu aggregierende Feld bzw. Ausdruck. Voreinstellung: True (alle Daten).

Boolean (optional) Gibt an das nur über die eindeutigen Werte aggregiert werden soll (DISTINCT). Voreinstellung: False.

Rückgabewert:

Zahl

Beispiel:

NativeVarSamp(OrderDetails.Quantity,OrderDetails.ProductID=Products.Pro-ductID)


Now

combit List & Label

Now

Aufgabe:

Gibt das aktuelle Datum mit Uhrzeit zurück.

Parameter: -

Rückgabewert:

Datum


NthLargest

combit List & Label

NthLargest

Aufgabe:

Liefert den n.-größten Wert der Datenmenge, die sich aus dem ersten Argument ergibt.

Parameter:

Zahl

Zahl <n>, d.h. der Index für den auszugebenden Wert (1-basiert).

Boolean (optional) True: nach der Ausgabe werden die für die Berechnung gemerkten Werte gelöscht (Voreinstellung: True). Bitte beachten Sie, dass die für die Berechnung gemerkten Werte generell bei jedem (Unter-)Tabellenende gelöscht werden. Der zweite Parameter bestimmt lediglich, ob die Werte bei einer Ausgabe schon innerhalb der Tabelle gelöscht werden.

Rückgabewert:

Zahl

Beispiel:

NthLargest(Stückpreis,2) berechnet den zweitgrößten Wert


NthLargestIndex

combit List & Label

NthLargestIndex

Aufgabe:

Liefert den Index des n.-größten Werts der Datenmenge, die sich aus dem ersten Argument ergibt. Wird z.B. für NthValue() benötigt.

Parameter:

Zahl

Zahl <n>, d.h. der Index für den auszugebenden Wert.

Boolean (optional) True: nach der Ausgabe werden die für die Berechnung gemerkten Werte gelöscht (Voreinstellung: True). Bitte beachten Sie, dass die für die Berechnung gemerkten Werte generell bei jedem (Unter-)Tabellenende gelöscht werden. Der zweite Parameter bestimmt lediglich, ob die Werte bei einer Ausgabe schon innerhalb der Tabelle gelöscht werden.

Rückgabewert:

Zahl

Beispiel:

NthLargestIndex(Produkt.Stückpreis,2)


NthValue

combit List & Label

NthValue

Aufgabe:

Liefert den Inhalt des n. Wertes der Datenmenge, die sich aus dem ersten Argument ergibt. Wird gerne im Zusammenhang mit der übergeordneten Aggregatsfunktion NthLargestIndex() verwendet.

Parameter:

Alle

Zahl <n>, d.h. der Index für den auszugebenden Wert, berechnet über NthLargestIndex())

Boolean (optional) True: nach der Ausgabe werden die für die Berechnung gemerkten Werte gelöscht (Voreinstellung: True). Bitte beachten Sie, dass die für die Berechnung gemerkten Werte bei jedem (Unter-)Tabellenende gelöscht werden. Der zweite Parameter bestimmt lediglich, ob die Werte bei einer Ausgabe schon innerhalb der Tabelle gelöscht werden.

Rückgabewert:

Alle

Beispiel:

NthValue(Produkt.Produktname, NthLargestIndex (Produkt.Stückpreis,2))

Ergebnis: Name des zweitteuersten Produktes


Null

combit List & Label

Null

Aufgabe:

Ergibt einen Null-Wert (Wert nicht vorhanden).

Parameter:

-

Rückgabewert:

Alle


NullSafe

combit List & Label

NullSafe

Aufgabe:

Überprüft den Parameter auf Null, und gibt einen Ersatzwert zurück, wenn das der Fall ist, ansonsten das Ergebnis des Ausdrucks.

Parameter:

Alle

Alle (optional) Wert, der zurückgegeben werden soll, wenn der Ausdruck Null ist (Voreinstellung: Leere Zeichenkette bzw. 0, je nach Typ).

Rückgabewert:

Alle


NumInRange

combit List & Label

NumInRange

Aufgabe:

Testet, ob die Zahl sich innerhalb des durch die Grenzen angegebenen Intervalls befindet. Das Intervall ist abgeschlossen, also ist ein mit einer Grenze identischer Wert noch innerhalb.

Parameter:

Zahl

Zahl Untere Grenze.

Zahl Obere Grenze.

Rückgabewert:

Boolean

Beispiel:

NumInRange(50,25,100) Ergebnis: True


Odd

combit List & Label

Odd

Aufgabe:

Testet, ob die Zahl ungerade ist oder nicht. Im ungeraden Fall wird True zurückgegeben, sonst False.

Parameter:

Zahl

Rückgabewert:

Boolean

Beispiel:

Odd(5) Ergebnis: True


Ord

combit List & Label

Ord

Aufgabe:

Liefert den ASCII-Wert des ersten Zeichens zurück.

Parameter:

Zeichenkette

Rückgabewert:

Zahl

Beispiel:

Ord("Hallo Welt") Ergebnis: 72


Page

combit List & Label

Page

Aufgabe:

Gibt die momentane Seitenzahl zurück.

Parameter:

Zahl (optional) einzuberechnender Offset, wird zur Seitenzahl hinzuaddiert

Rückgabewert:

Zahl

Beispiel:

Page() Ergebnis: aktuelle Seitenzahl

Page(3) Ergebnis: aktuelle Seitenzahl + 3


Page$

combit List & Label

Page$

Aufgabe:

Gibt die Seitenzahl der Druckseite als Zeichenkette zurück.

Parameter:

Zahl (optional) einzuberechnender Offset, wird zur Seitenzahl hinzuaddiert

Rückgabewert:

Zeichenkette

Beispiel:

Page$() Ergebnis: aktuelle Seitenzahl

Page$(3) Ergebnis: aktuelle Seitenzahl + 3


PlainTexttoHTML$

combit List & Label

PlainTexttoHTML$

Aufgabe:

Gibt den unformatierten Text als HTML-Inhalt zurück.

Parameter:

String Text-Inhalt

Rückgabewert:

String


Pow

combit List & Label

Pow

Aufgabe:

Entspricht der Funktion (Basis) ^ (Exponent).

Parameter:

Zahl Basis

Zahl Exponent

Rückgabewert:

Zahl

Beispiel:

Pow(2,3) Ergebnis: 8


Precalc

combit List & Label

Precalc

Aufgabe:

Berechnet den Wert der Aggregatsfunktion für die Tabelle. Diese Funktion steht nur im Berichtscontainer zur Verfügung.

Parameter:

Alle Variable, Feld oder Formel

Alle (optional) Gruppierungsfunktion um z.B. im Gruppenkopf eine Gruppensumme auszugeben. Üblicherweise der gleiche Wert wie "Gruppieren nach".

Boolean (optional) Bedingung für die Aggregierung. Nur wenn die Bedingung zutrifft, wird der Wert in die Aggregatsfunktion übernommen.

Rückgabewert:

Alle

Beispiel:

Precalc (Sum(Artikel.Stkpreis)) Summe der folgenden Preise

Precalc (Sum(Artikel.Stkpreis),Left$(Artikel.Nr,1)) Summe der Artikelgruppe


Previous

combit List & Label

Previous

Aufgabe:

Gibt den Wert der Variablen, des Feldes bzw. der Formel zurück, den sie bei dem letzten Datensatz hatte.

Parameter:

Alle Variable, Feld oder Formel

Rückgabewert:

Alle

Beispiel:

Previous(NAME) Ergebnis: vorheriger Name


PreviousUsed

combit List & Label

PreviousUsed

Aufgabe:

Gibt den Wert der Variablen, des Feldes bzw. der Formel zurück, den sie bei der letzten tatsächlichen Berechnung der Funktions-Instanz hatte.

Parameter:

Alle Variable, Feld oder Formel

Rückgabewert:

Alle

Beispiel:

PreviousUsed(NAME) Ergebnis: letzter Name


ProjectParameter$

combit List & Label

ProjectParameter$

Aufgabe:

Gibt den Wert eines Projekt-Parameters aus. Mögliche Parameter:

LL.FAX.Queue | Druck-Warteschlange
LL.FAX.RecipName | Empfängername
LL.FAX.RecipNumber | Empfängerfaxnummer
LL.FAX.SenderName | Absendername
LL.FAX.SenderCompany | Absenderfirma
LL.FAX.SenderDepartment | Absenderabteilung
LL.FAX.SenderBillingCode | Absenderverrechnungscode
LL.MAIL.To | An (To)
LL.MAIL.CC | An (CC)
LL.MAIL.BCC | An (BCC)
LL.MAIL.Subject | Betreff
LL.MAIL.From | Von (From)
LL.MAIL.ReplyTo | Von (ReplyTo)
LL.MinPageCount | Mindestzahl der Druckseiten
LL.ProjectDescription | Projektbeschreibung
LL.SlideShow.TransformationID | Transformation für Präsentationsmodus
LL.MAIL.ShowDialog | Maildialog anzeigen

Parameter:

Zeichenkette Name des Projekt-Parameters

Boolean (optional) Bestimmt ob der Rückgabewert direkt zurückgegeben werden soll (True), oder berechnet werden soll (False). Voreinstellung: False.

Rückgabewert:

Zeichenkette

Beispiel:

ProjectParameter$("LL.ProjectDescription") Ergebnis: "Artikelliste"

ProjectParameter$("LL.Mail.To") Ergebnis: "name@combit.de"


ProjectPath$

combit List & Label

ProjectPath$

Aufgabe:

Gibt den Pfad der Projektdatei an, optional inklusive des Dateinamens (sonst mit "\" am Ende).

Parameter:

Boolean (optional) Gibt an, dass der Pfad inklusive des Dateinamens zurückgeliefert wird (True). (Voreinstellung False).

Rückgabewert:

Zeichenkette

Beispiel:

ProjectPath$() Ergebnis: "C:\Programme\LL\"

ProjectPath$() Ergebnis:"C:\Programme\LL\x.lst"


Quarter

combit List & Label

Quarter

Aufgabe:

Bestimmt die Quartalszahl eines Datums und gibt diese als Zahl zurück.

Parameter:

Datum

Boolean (optional) Bestimmt, ob die Berechnung Quartal relativ zum Jahr (1..4) oder absolut seit 01.01.0001 (1..) zurückgegeben werden soll. Voreinstellung: False (relativ).

Rückgabewert:

Zahl

Beispiel:

Quarter(Date("04.07.1776")) Ergebnis: 3

Quarter(Date("04.07.1776"),True) Ergebnis: 7103


RainbowColor

combit List & Label

RainbowColor

Aufgabe:

Berechnet einen Farbwert zwischen Blau und Rot entsprechend des Wertes des ersten Parameters. Z.B. für Regenbogenfarben in Crosstabs.

Parameter:

Zahl Wert, der dargestellt werden soll.

Zahl Wert bis zu dem die dargestellte Farbe Blau ist.

Zahl Wert ab dem die dargestellte Farbe Rot ist.

Rückgabewert:

Zahl


RegExMatch$

combit List & Label

RegExMatch$

Aufgabe:

Gibt den einen Teil der Zeichenkette zurück, der der Regular Expression entspricht oder die Gruppe entsprechend dem 3. Parameter.

Die Regular Expression entspricht dabei der Pearl 5 Syntax, sowie in den meisten Details der Regular Expression-Syntax der Visual Basic Scripting Engine.

Parameter:

Zeichenkette

Zeichenkette

Number

Rückgabewert:

Zeichenkette

Beispiele:

RegExMatch$("1234xyz5678", "[0-9]+") Ergebnis: "1234"


RegExSubst$

combit List & Label

RegExSubst$

Aufgabe:

Ersetzt die Teile des ersten Arguments, bei denen der reguläre Ausdruck zutrifft, durch einen neuen Wert.

Parameter:

String die zu überprüfende Zeichenkette

String regulärer Ausdruck

String Ersetzungsausdruck (kann "\0" für den gesamten Match, oder "\1“… "\9“ für die entsprechende Gruppe enthalten

Boolean (optional) Gibt an, ob nur das erste Vorkommen ersetzt werden soll. Voreinstellung: False

Rückgabewert:

Zeichenkette

Beispiel:

RegExSubSt$("1234xyz6789","[0-9]+", "a") Ergebnis: "axyza“

RegExSubst$("1234xyz6789","[0-9]+","a",True) Ergebnis: "axyz6789"


RemainingTableSpace

combit List & Label

RemainingTableSpace

Aufgabe:

Gibt den in dem Tabellenobjekt für Daten und Gruppenzeilen zur Verfügung stehenden Platz zurück. Der Parameter gibt die Einheit des Rückgabewerts an. Diese Funktion kann verwendet werden, um bedingte Seitenumbrüche vor Gruppenzeilen durchführen, z.B. "Wenn nur 5% Platz übrig, dann vorher umbrechen".

Parameter:

Boolean (optional) True: der Wert ist in SCM-Einheiten (1/1000mm), False: der Wert ist der Prozentwert der gesamten Tabellengröße (Voreinstellung: False)

Rückgabewert:

Zahl


Rep$

combit List & Label

Rep$

Aufgabe:

Gibt eine Zeichenkette zurück, die aus der entsprechenden Anzahl Zeichen des ersten Parameters gebildet wird.

Parameter:

Zeichenkette

Zahl

Rückgabewert:

Zeichenkette

Beispiele:

Rep$("-",10) Ergebnis: "----------"

Rep$("+-",5) Ergebnis: "+-+-+-+-+-"


ReportSectionID$

combit List & Label

ReportSectionID$

Aufgabe:

Gibt die Bezeichnung des Berichtsabschnitts zurück ("IDX" für Index, "TOC" für Inhaltsverzeichnis). Kann in Bedingungen genutzt werden um herauszufinden, wo man sich gerade befindet.

Parameter: -

Rückgabewert:

Zeichenkette

Beispiele:

ReportSectionID$()="IDX"


RGB

combit List & Label

RGB

Aufgabe:

Berechnet einen Farbwert anhand relativer Rot-, Grün- und Blau-Anteile (zwischen 0 und 255). Dabei bedeutet 0 kein Farbwert und 255 der maximale Farbwert. Diese Funktion kann verwendet werden, um z.B. die Schriftfarbe in Textobjekten per Formel zu bestimmen.

Parameter:

Zahl Rotanteil

Zahl Grünanteil

Zahl Blauanteil

Rückgabewert:

Zahl

Beispiel:

Cond(Betrag<0, RGB(255,0,0), RGB(0,0,0))


Right$

combit List & Label

Right$

Aufgabe:

Kürzt eine Zeichenkette von links um so viele Zeichen, dass gerade noch die unter Zahl angegebene Anzahl von Zeichen übrigbleibt. Wenn die ursprüngliche Zeichenkette schon klein genug ist, wird diese nicht verändert.

Parameter:

Zeichenkette

Zahl

Boolean (optional) True: Der abgeschnittene Wert beginnt mit "..." (Voreinstellung False). Bei Zahl < 3 wird die Einstellung ignoriert.

Rückgabewert:

Zeichenkette

Beispiel:

Right$("ABCD", 2) Ergebnis: "CD"


Roman$

combit List & Label

Roman$

Aufgabe:

Liefert die römische Darstellung des Absolutwertes der übergebenen Zahl.

Parameter:

Zahl

Zahl (optional) Art der Darstellung: 0: Großbuchstaben (Voreinstellung), 1: Kleinbuchstaben, 2: Großbuchstaben Unicode, 3: Kleinbuchstaben,

Rückgabewert:

Zahl

Beispiele:

Roman$(11) Ergebnis: "XI"


Round

combit List & Label

Round

Aufgabe:

Rundet den Wert einer Zahl auf die im zweiten Argument angegebene Anzahl Nachkommastellen. Die voreingestellte Anzahl Nachkommastellen ist 0.

Parameter:

Zahl

Zahl (optional)

Rückgabewert:

Zahl

Beispiele:

Round(3.1454,2) Ergebnis: 3,15

Round(2.5) Ergebnis: 3


RTFtoPlainText$

combit List & Label

RTFtoPlainText$

Aufgabe:

Gibt den reinen, unformatierten Text des RTF-Textes zurück.

Parameter:

Zeichenkette RTF-Text.

Rückgabewert:

Zeichenkette


Rtrim$

combit List & Label

Rtrim$

Aufgabe:

Entfernt Leerzeichen am Ende einer Zeichenkette.

Parameter:

Zeichenkette

Rückgabewert:

Zeichenkette

Beispiel:

Rtrim$("Hallo Welt ") Ergebnis: "Hallo Welt"


Script$

combit List & Label

Script$

Interpretiert das Resultat eines Skripts als Zeichenkette. Diese Funktion steht nicht in allen Anwendungen zur Verfügung.

Parameter:

Zeichenkette Skriptsprache (z.B. 'CSharpScript' oder 'VBScript')

Zeichenkette Code

Zeichenkette (optional) Funktion

Rückgabewert:

Zeichenkette

Beispiel:

Script$("CSharpScript", LoadFile$(ProjectPath$(False) + "Script.cs"))


ScriptBool

combit List & Label

ScriptBool

Interpretiert das Resultat eines Skripts als Boolean. Diese Funktion steht nicht in allen Anwendungen zur Verfügung.

Parameter:

Zeichenkette Skriptsprache (z.B. 'CSharpScript' oder 'VBScript')

Zeichenkette Code

Zeichenkette (optional) Funktion

Rückgabewert:

Boolean

Beispiel:

ScriptBool("CSharpScript", "WScript.Result=DateTime.IsLeapYear(1971);")


ScriptDate

combit List & Label

ScriptDate

Interpretiert das Resultat eines Skripts als Datum. Diese Funktion steht nicht in allen Anwendungen zur Verfügung.

Parameter:

Zeichenkette Skriptsprache (z.B. 'CSharpScript' oder 'VBScript')

Zeichenkette Code

Zeichenkette (optional) Funktion

Rückgabewert:

Datum

Beispiel:

ScriptDate("CSharpScript", "WScript.Result=new DateTime(1971,10,25);")


ScriptVal

combit List & Label

ScriptVal

Interpretiert das Resultat eines Skripts als Zahl. Diese Funktion steht nicht in allen Anwendungen zur Verfügung.

Parameter:

Zeichenkette Skriptsprache (z.B. 'CSharpScript' oder 'VBScript')

Zeichenkette Code

Zeichenkette (optional) Funktion

Rückgabewert:

Zahl

Beispiel:

ScriptVal("CSharpScript", LoadFile$(ProjectPath$(False) + "Script.cs"))


Second

combit List & Label

Second

Bestimmt die Sekunde des übergebenen Datums und gibt sie als Zahl zurück. Wenn der Parameter weggelassen wird, wird die Sekunde der Druckzeit zurückgeliefert.

Parameter:

Datum (optional)

Rückgabewert:

Zahl


SetVar

combit List & Label

SetVar

Setzt einen Wert in den Variablenspeicher für eine spätere Verwendung über die GetVar()-Funktion. Die Aufgabe dieser Funktionen ist die eines einfachen Zwischenspeichers für Werte. Sie sollten keine komplexen Verschachtelungen mit GetVar/SetVar durchführen oder die beiden Funktionen miteinander kombinieren – hier können, insbesondere in Kopf-, Fuß- und Gruppenzeilen, unerwartete Effekte auftreten.

Parameter:

Zeichenkette Bezeichnung der Variablen

Alle zu speichernder Wert

Boolean Bestimmt ob die Funktion den Wert auch zurückliefern oder ob das Ergebnis ein Leerstring sein soll. Voreinstellung: Zurückliefern (True).

Rückgabewert:

Alle

Beispiel:

SetVar("Seite", Page())


Sign

combit List & Label

Sign

Aufgabe:

Gibt das Vorzeichen des Werts zurück (+1 für positiven Wert, -1 für negativen Wert, oder 0, wenn der Wert 0 ist).

Parameter:

Zahl Wert

Rückgabewert:

Zahl

Beispiel:

Sign(-3) Ergebnis: -1


Sin

combit List & Label

Sin

Aufgabe:

Berechnet den Sinus des Werts (in Grad, wenn keine andere Einheit gewählt ist).

Parameter:

Zahl Wert

Zahl (optional) Modus (0=Grad, 1=Radiant). Voreinstellung: 0.

Rückgabewert:

Zahl

Beispiel:

Sin(90) Ergebnis: 1


Sqrt

combit List & Label

Sqrt

Aufgabe:

Gibt die Quadratwurzel einer Zahl zurück.

Parameter:

Zahl

Rückgabewert:

Zahl

Beispiel:

Sqrt(4) Ergebnis: 2


StartsWith

combit List & Label

StartsWith

Aufgabe:

Testet, ob die Zeichenkette im ersten Argument mit der Zeichenkette im zweiten Argument beginnt.

Parameter:

Zeichenkette

Zeichenkette

Boolean Gibt an, ob Groß-/Kleinschreibung beachtet werden soll. Voreinstellung: False

Rückgabewert:

Boolean

Beispiele:

StartsWith("Hallo Welt","hal") Ergebnis: True

StartsWith("Hallo Welt","elt") Ergebnis: False


StdDeviation

combit List & Label

StdDeviation

Aufgabe:

Liefert die Standardabweichung der Datenmenge, die sich aus dem ersten Argument ergibt.

Parameter:

Zahl

Boolean (optional) True: nach der Ausgabe werden die für die Berechnung gemerkten Werte gelöscht (Voreinstellung: True). Bitte beachten Sie, dass die für die Berechnung gemerkten Werte generell bei jedem (Unter-)Tabellenende gelöscht werden. Der zweite Parameter bestimmt lediglich, ob die Werte bei einer Ausgabe schon innerhalb der Tabelle gelöscht werden

Rückgabewert:

Zahl

Beispiel:

StdDeviation(Anzahl * Stückpreis)


Str$

combit List & Label

Str$

Aufgabe:

Wandelt eine Zahl oder ein Datum in eine Zeichenkette. Die Zahl wird mit 5 Nachkommastellen formatiert, dabei eventuell gerundet. Die Länge ist variabel.

Parameter:

Zahl oder Datum

Zahl (optional) Gibt die Länge der gewünschten Zeichenkette an. Wenn die Zahl für dieses Format jedoch zu groß ist, kann die resultierende Zeichenkette länger als gewünscht werden. Wenn die Zahl zu klein ist, werden Leerstellen angehängt, je nach Vorzeichen rechts (negativ) oder links (positiv).

Zahl (optional) Gibt die Zahl der Nachkommastellen an. Ist sie positiv, wird die Zahl als Gleitkommazahl dargestellt, ist sie negativ, in wissenschaftlicher Schreibweise. Wenn kein dritter Parameter angegeben ist, wird die Zahl der Nachkommastellen bei einem Ganzzahlwert auf 0 und bei einem Fließkommawert aus Kompatibilitätsgründen auf 5 gesetzt.

Rückgabewert:

Zeichenkette

Beispiele:

Str$(Constant.Pi()) Ergebnis: "3.14159"

Str$(Constant.Pi(),0,3) Ergebnis: "3,142"

Str$(Constant.Pi(),6,3) Ergebnis: " 3,142"

Str$(-Constant.Pi(),0,-3) Ergebnis: "-3.141e+00"


StrPos

combit List & Label

StrPos

Aufgabe:

Liefert die Position des n-ten Vorkommens einer Suchzeichenkette in einer Zeichenkette zurück. Über einen dritten Parameter kann mitgegeben werden, das wievielte Vorkommen des Suchbegriffs in der Zeichenkette zurückgegeben werden soll. Der Default ist 1.

Das erste Zeichen der Zeichenkette entspricht Position 0.

-1 als Rückgabewert bedeutet, dass die Zeichenkette nicht (mehr) vorkommt.

Parameter:

Zeichenkette

Zeichenkette Such-Zeichenkette

Zahl (optional)

Rückgabewert:

Zahl

Beispiel:

StrPos("Hallo Welt","o") Ergebnis: 4


StrRPos

combit List & Label

StrRPos

Aufgabe:

Liefert die Position einer Suchzeichenkette in einer Zeichenkette zurück. Es wird von hinten her gesucht. Über den dritten Parameter kann mitgegeben werden, das wievielte Vorkommen des Suchbegriffs von hinten gesucht werden soll. Die Voreinstellung ist 1.

Das erste Zeichen der Zeichenkette entspricht Position 0.

-1 als Rückgabewert bedeutet, dass die Zeichenkette nicht (mehr) vorkommt.

Parameter:

Zeichenkette

Zeichenkette Such-Zeichenkette

Zahl (optional)

Rückgabewert:

Zahl

Beispiele:

StrRPos("Hallo Welt","a") Ergebnis: 1


StrSubst$

combit List & Label

StrSubst$

Aufgabe:

Durchsucht eine Zeichenkette nach Vorkommen einer Such-Zeichenkette und ersetzt ihn durch die Zeichenkette des dritten Arguments (Ersetzungs-Zeichenkette). Ist kein drittes Argument vorhanden, wird die dem zweiten Argument entsprechende Zeichenkette einfach gelöscht.

Parameter:

Zeichenkette

Zeichenkette Such-Zeichenkette

Zeichenkette (optional) Ersetzungs-Zeichenkette

Rückgabewert:

Zeichenkette

Beispiel:

StrSubst$("Hallo Welt","ll","nn") Ergebnis: "Hanno Welt"


Sum

combit List & Label

Sum

Aufgabe:

Liefert die Summe des ersten Argumentes. Aggregatsfunktionen arbeiten grundsätzlich tabellenspezifisch.

Hinweis: Summenvariablen (siehe Kapitel Summenvariablen) sind eine alternative Möglichkeit Summen und Zähler zu bilden. Summenvariablen arbeiten grundsätzlich tabellenübergreifend.

Parameter:

Zahl

Boolean (optional) True: nach der Ausgabe werden die für die Berechnung gemerkten Werte gelöscht (Voreinstellung: True). Bitte beachten Sie, dass die für die Berechnung gemerkten Werte generell bei jedem (Unter-)Tabellenende gelöscht werden. Der zweite Parameter bestimmt lediglich, ob die Werte bei einer Ausgabe schon innerhalb der Tabelle gelöscht werden.

Rückgabewert:

Zahl

Beispiel:

Sum(Stückpreis) Ergebnis: Summe Stückpreise


TableWidth

combit List & Label

TableWidth

Aufgabe:

Gibt die Breite des Tabellenobjekts zurück. Kann verwendet werden um Spaltenbreiten relativ anzugeben.

Parameter:

Boolean (optional) True: der Wert ist in SCM-Einheiten (1/1000mm), False: der Wert ist in Projekteinheiten (Voreinstellung: False).

Rückgabewert:

Zahl

Beispiel:

TableWidth()*30/100 Ergebnis: Spalte nimmt 30% der Breite ein.


Tan

combit List & Label

Tan

Aufgabe:

Berechnet den Tangens des Wertes (in Grad, wenn keine andere Einheit gewählt ist).

Parameter:

Zahl Wert

Zahl (optional) Modus (0=Grad, 1=Radiant). Voreinstellung: 0.

Rückgabewert:

Zahl

Beispiel:

Tan(45) Ergebnis: 1,00


TextWidth

combit List & Label

TextWidth

Aufgabe:

Gibt die Breite des Texts mit dem entsprechenden Font zurück.

Parameter:

String Text

String Schriftart in der Form '{(0,0,0),12,0,0,0,0,400,0,0,0,0,40,0,0,0, Arial}' - die Größe in Pt, gefolgt von den LOGFONT-Struktur-Werten.

Rückgabewert:

Number


Time$

combit List & Label

Time$

Aufgabe:

Liefert die aktuelle Zeit, die über eine Zeichenkette formatiert wird.

Folgende Formatschalter stehen zur Verfügung:

Schalter | Bedeutung
%h | Stunden im 12-Stundenformat
%H | Stunden im 24-Stundenformat
%m oder %i | Minuten
%s | Sekunden
%P | Anzeige der Tageshälfte (A.M. / P.M.)
%p | Anzeige der Tageshälfte (a.m. / p.m.)

Parameter:

Zeichenkette

Rückgabewert:

Zeichenkette

Beispiel:

Time$("%02h:%02m:%02s")


Today

combit List & Label

Today

Aufgabe:

Gibt das aktuelle Datum im Format "tt.mm.jjjj" zurück.

Parameter: -

Rückgabewert:

Datum

Beispiel:

Today()


ToFrac$

combit List & Label

ToFrac$

Aufgabe:

Wandelt eine Zahl in einen Bruch.

Parameter:

Zahl

Rückgabewert:

Zeichenkette

Beispiel:

ToFrac$(7.25,True,0.00001) Ergebnis: 7 1/4


Token$

combit List & Label

Token$

Aufgabe:

Gibt die n-te Zeichenkette aus dem ersten Argument zurück, das durch den Separator des dritten Parameters in einzelne Zeichenketten getrennt ist.

Parameter:

Zeichenkette

Zahl <n>, d.h. Position der Zeichenkette (0-basiert)

Zeichenkette Trennzeichen

Zeichenkette (optional) Zeichenkette die zurückgegeben wird, falls Wert außerhalb

Rückgabewert:

Zeichenkette

Beispiel:

Token$("ABC;DEF;GHI;JKL",2,";") Ergebnis: "GHI"


ToNumber

combit List & Label

ToNumber

Aufgabe:

Gibt das Argument als Zahl zurück.

Parameter:

Alle

Rückgabewert:

Zahl


ToRTF$

combit List & Label

ToRTF$

Aufgabe:

Liefert eine Zeichenkette im RTF-Format zurück. Das ist deshalb notwendig, weil Zeichenketten möglicherweise eines der im RTF-Format speziell definierten Symbole ('\', '{' oder '}') enthalten können. Aus Kompatibilitätsgründen arbeitet die Funktion erst dann wie beschrieben, wenn der optionale zweite Parameter True ist.

Parameter:

Zeichenkette

Boolean (optional) erzwingt das Ersetzen von RTF-Tokens zu Plaintext (Voreinstellung: False)

Rückgabewert:

Zeichenkette

Beispiel:

Wenn beispielsweise das Feld PRODCODE eins der Zeichen enthalten könnte, dann müsste man den Text folgendermaßen einfügen:

"<<ANREDE>> <<NAME>>, Sie haben unser Produkt <<PRODUKT>>, Code <<ToRTF$(PRODCODE)>> erhalten..."


ToString$

combit List & Label

ToString$

Aufgabe:

Gibt das Argument als Zeichenkette zurück. Die Funktion unterstützt alle Datentypen.

Parameter:

Alle

Rückgabewert:

Zeichenkette

Beispiel:

Achsenbeschriftung eines Diagramms muss eine Zeichenkette sein, der Datentyp der Achse ist aber variabel (Zahl, Datum, Zeichenkette).


Total

combit List & Label

Total

Aufgabe:

Berechnet den Ausdruck im Argument für das gesamte Kreuztabellen-Objekt (z.B. kategorienübergreifend die Summe aller Umsätze).

Parameter:

Alle

Rückgabewert:

Alle

Beispiel:

Prozentualer Umsatzanteil einer Kategorie:

Sum(Umsatz)/Total(Sum(Umsatz))*100


TotalPages$

combit List & Label

TotalPages$

Aufgabe:

Liefert die Gesamtzahl der Seiten. Die zurückgegebene Zeichenkette wird beim Ausdruck durch die Gesamtzahl der Seiten ersetzt. Diese Funktion dient nur der Anzeige und kann nicht in Formeln verwendet werden. Eine Berechnung der Formel val(TotalPages$) ist nicht möglich.

Bitte beachten Sie, dass sich bei Verwendung dieser Funktion das Zeitverhalten beim Ausdruck ändern kann. Ein eventuell vorhandener Fortschrittsbalken wird schneller die 100% erreichen, durch die notwendige Nachbearbeitung der Ausgabe kann sich dann allerdings eine Verzögerung bis zur tatsächlichen Anzeige des Druckergebnisses ergeben. Beachten Sie, dass bei vieltausendseitigen Projekten eine Verwendung dieser Funktion nicht sinnvoll ist, da die Seiten der Ausgabe zwischengespeichert werden müssen, was ggf. die verfügbaren Hardwaremöglichkeiten nicht erlauben.

Parameter

Zahl (optional) einzuberechnendes Offset, d.h. dieser Wert wird zur Gesamtzahl der Seiten addiert. Voreinstellung: 0.

Rückgabewert:

Zeichenkette

Beispiel:

"Seite "+Page$()+"/"+TotalPages$() Ergebnis: "Seite 1/3"


Translate$

combit List & Label

Translate$

Aufgabe:

Übersetzt den übergebenen Text, sofern er in dem von der Applikation übergebenen Wörterbuch enthalten ist.

Parameter:

Zeichenkette

Rückgabewert:

Zeichenkette

Beispiel:

Translate$("Page {0} of {1}", Page$(), TotalPages$())

Ergebnis in deutscher Sprache z.B.: Seite 1 von 2


UnitFromSCM

combit List & Label

UnitFromSCM

Aufgabe:

Wandelt eine SCM-Einheit (1/1000 mm) in die Druckeinheit (inch/mm) um. Wichtig, um Eigenschaftswerte unabhängig von der gewählten Druckeinheit zu machen.

Parameter:

Zahl

Rückgabewert:

Zahl

Beispiel:

Cond(Page()=1,UnitFromSCM(100000),UnitFromSCM(20000))


Upper$

combit List & Label

Upper$

Aufgabe:

Wandelt die Zeichen einer Zeichenkette in Großbuchstaben um.

Parameter:

Zeichenkette

Rückgabewert:

Zeichenkette

Beispiel:

Upper$("hallo welt") Ergebnis: "HALLO WELT"


URLDecode$

combit List & Label

URLDecode$

Aufgabe:

Gibt den URL konformen Text als reinen unformatierten Text zurück.

Parameter:

Zeichenkette

Rückgabewert:

Zeichenkette


URLEncode$

combit List & Label

URLEncode$

Aufgabe:

Gibt den reinen unformatierten Text als URL konformen Text zurück.

Parameter:

Zeichenkette

Boolean (optional) Reservierte Zeichen (!*'();:@&=+$,/?%#[]) ebenfalls kodieren (Voreinstellung: False)

Rückgabewert:

Zeichenkette


Val

combit List & Label

Val

Aufgabe:

Die Zeichenkette wird als Zahl interpretiert und in eine solche gewandelt. Wenn ein Fehler auftritt, ist das Resultat 0. Das Dezimalzeichen muss immer als "." angegeben werden.

Parameter:

Zeichenkette

Rückgabewert:

Zahl

Beispiele:

Val("3.141") Ergebnis: 3.141


Variance

combit List & Label

Variance

Aufgabe:

Liefert die Varianz der Datenmenge, die sich aus dem ersten Argument ergibt.

Parameter:

Zahl

Boolean (optional) True: nach der Ausgabe werden die für die Berechnung gemerkten Werte gelöscht (Voreinstellung: True). Bitte beachten Sie, dass die für die Berechnung gemerkten Werte bei jedem (Unter-)Tabellenende gelöscht werden. Der zweite Parameter bestimmt lediglich, ob die Werte bei einer Ausgabe schon innerhalb der Tabelle gelöscht werden.

Rückgabewert:

Zahl

Beispiel:

Variance(Anzahl * Stückpreis)


WildcardMatch

combit List & Label

WildcardMatch

Aufgabe:

Berechnet, ob der Inhalt zu einer der zeichenketten-Wildcards passt..

Parameter:

Zeichenkette zu überprüfende Zeichenkette

Zeichenkette Wildcard (Platzhalter) – Zeichenkette(n)

Zeichenkette (optional) Trennzeichen für die Übergabe mehrerer Wildcard-Zeichenketten.

Rückgabewert:

Boolean

Beispiele:

WildcardMatch("123xyz456","*xyz*") Ergebnis: True


Woy

combit List & Label

Woy

Aufgabe:

Gibt die Wochennummer des übergebenen Datums zurück.

Parameter:

Datum

Zahl (optional) Der optionale zweite Parameter bestimmt, wie die erste Woche des Jahres bestimmt wird.

0 | Woche mit dem ersten Arbeitstag (Voreinstellung)
1 | Woche des 1. Januars
2 | Erste Woche mit mindestens 4 Tagen
3 | Erste Woche mit 7 Tagen
4 | Woche mit dem ersten Montag

Rückgabewert:

Zahl

Beispiel:

Woy(Date("04.07.1776"),0) Ergebnis: 27


Year

combit List & Label

Year

Aufgabe:

Bestimmt das Jahr eines Datums und gibt es als Zahl zurück.

Parameter:

Datum

Rückgabewert:

Zahl

Beispiel:

Year(Date("04.07.1776")) Ergebnis: 1776


Year$

combit List & Label

Year$

Aufgabe:

Bestimmt das Jahr eines Datums und gibt es als Zeichenkette zurück.

Parameter:

Datum

Rückgabewert:

Zeichenkette

Beispiel:

Year$(Date("04.07.1776")) Ergebnis: "1776"


Übersicht der Eigenschaften

Alle Eigenschaften des Projekts und der Objekte werden hier zentral beschrieben.

Eigenschaften werden über die jeweiligen Eigenschaftenlisten definiert.

§ Die Eigenschaften können dabei über die jeweiligen Schaltflächen entweder nach Rubrik oder alphabetisch sortiert werden.

§ Über die +-Schaltfläche können konstante Formeln ein- oder ausgeblendet werden (z.B. False).

§ Über das Eingabefeld können Sie die Eigenschaften filtern.

§ Selektieren Sie mehrere Objekte, können Sie gemeinsame Eigenschaften gleichzeitig einstellen.

Abbildung 13.1: Toolfenster "Eigenschaften"

Um den Wert zu bestimmen haben Sie je nach Eigenschaft verschiedene Möglichkeiten:

§ Über die "Pfeil nach unten"-Schaltfläche eine Werteliste aufklappen.

Beispiel: Darstellungsbedingung, Schriftfarbe, Schriftmuster. Am Ende der Werteliste steht Ihnen fast immer der Eintrag "Formel" zur Verfügung.

§ Über die Formel-Schaltfläche bzw. den Eintrag "Formel" der Werteliste den Wert per Formel setzen.

Beispiel: Wenn Sie die Schriftfarbe auf Rot setzen möchten wenn der Wert negativ ist, setzen Sie die Eigenschaft "Voreinstellung" für "Schrift" auf "False" und definieren dann die Eigenschaft "Schriftfarbe" per Formel, z.B.:

Cond(Artikel.Stkpreis < 0,LL.Color.Red,LL.Color.Black)

§ Über die Dialog-Schaltfläche "..." einen Konfigurationsdialog öffnen.

Dialoge stehen z.B. für folgende Eigenschaften zur Verfügung: Formatierung, Schrift, Rahmen, Position, Etikettenformat.

§ Den Wert direkt in das Eigenschaftenfeld eingeben.

Beispiel: Projektbeschreibung in den Projekteigenschaften.

§ Über den Öffnen-Dialog einen Dateipfad setzen.

Beispiel: Dateiname des Projektbausteins, Dateiname der Bilddatei.

Siehe auch:

Projekt-Eigenschaften

Gemeinsame Objekt-Eigenschaften

Textobjekte

Linienobjekte

Rechteckobjekte

Kreis- und Ellipsenobjekte

Bildobjekte

Barcode-Objekte

Berichtscontainer-Objekt

Tabellenobjekte

Diagramm-Objekte

Kreuztabellen-Objekte

Gantt-Diagramm-Objekte

Messinstrument-Objekte

Datengrafik-Objekte

Checkbox-Objekte

Formatierte Textobjekte

Formularelement-Objekte

HTML-Text-Objekte

PDF-Objekte

OLE Container

Vorlagen


Projekt-Eigenschaften

Das Eigenschaftsfenster des Projekts wird angezeigt, wenn im Arbeitsbereich keine Objekte selektiert sind.

Die Projekteigenschaften stehen auch als Felder (siehe Übersicht der Felder) zur Verfügung und können über die Funktion ProjectParameter$() ausgewertet werden.

Um den Pfad des aktuell geöffneten Projekts in die Zwischenablage zu kopieren, klicken Sie mit der rechten Maustaste auf "Projekt" im Toolfenster "Objekte" und wählen "Projektpfad kopieren" im Kontextmenü. Diese Funktion findet sich auch im Kontextmenü des Arbeitsbereichs sofern kein Objekt selektiert ist.

Siehe auch:


Allgemeine Einstellungen

Siehe auch:

Projektbeschreibung

Aktiver Design-Bereich

Anzahl der Ausfertigungen

Anzeigebedingung für Ausfertigungsdruck

Drilldown-Berichte einbetten

Mindestzahl der Druckseiten

Sprache für den Druck

Designschema

Sortierung

Transformation für Präsentationsmodus


Projektbeschreibung

Im Feld "Projektbeschreibung" können Sie eine Beschreibung des jeweiligen Projektes eingeben. Diese Beschreibung wird dann im Dialog Datei > Öffnen angezeigt und erleichtert es Ihnen, schnell das gewünschte Projekt auszuwählen. Alternativ kann diese Beschreibung auch im Dialog Datei > Speichern unter angegeben werden.

Abbildung 13.2: Projekt-Eigenschaften


Aktiver Design-Bereich

Bei mehrseitigen Projekten kann es sinnvoll sein, für die verschiedenen Seiten jeweils unterschiedliche Layout-Einstellungen zu wählen (Seitengröße, Ausrichtung). Im Feld "Aktiver Design-Bereich" geben Sie dann an, welche Layout-Einstellung im Arbeitsbereich angezeigt werden soll.


Anzahl der Ausfertigungen

Bestimmt die Anzahl der Ausfertigungen für Druck und Vorschau. Aktiviert zudem die Funktion IssueIndex() für Anzeige- und Layoutbereichsbedingungen.

Wenn Sie mehrere Ausfertigungen bestimmen, steht Ihnen bei Objekten eine Eigenschaft "Anzeigebedingung für Ausfertigungsdruck" zur Verfügung, die den bedingten Druck von Objekten für die verschiedenen Ausfertigungen ermöglicht.

Beim Export werden die Ausfertigungen nur beim PDF-Format unterstützt.


Anzeigebedingung für Ausfertigungsdruck

Ermöglicht den bedingten Druck von Seiten für die verschiedenen Ausfertigungen, z.B. beim Druck der Kopie soll die letzte Seite mit den AGB nicht gedruckt werden.

Beispiel: If (IssueIndex()=2, not Lastpage(), True)


Drilldown-Berichte einbetten

Bei Drilldown-Verknüpfungen über Relationen können Drilldown-Berichte über diese Option in die Vorschaudatei eingebettet werden, so dass sie komplett versendet oder gespeichert werden können.


Mindestzahl der Druckseiten

Bei Karteikartenprojekten wird automatisch mindestens die hier angegebene Zahl an Seiten ausgegeben. Wenn Sie also z.B. ein vierseitiges Formular mit unterschiedlichem Layout für die vier Seiten ausgeben möchten, legen Sie für jede der Seiten eine eigene Ebene an und platzieren die Objekte auf diesen Ebenen wie für die gewünschte Ausgabe benötigt. Stellen Sie anschließend "4" als Mindestanzahl der Druckseiten ein.

Bei Listenprojekten bestimmt die hier angegebene Zahl die Seitenzahl, ab der die Tabelle/der Berichtscontainer ausgegeben wird. Wenn Sie z.B. ein Deckblatt benötigen, so können Sie der Tabelle die Ebene "Folgeseiten" zuweisen und die Ebene "Erste Seite" wie gewünscht gestalten. Stellen Sie dann "2" als Mindestanzahl der Druckseiten ein.


Sprache für den Druck

Diese Eigenschaft steht nur zur Verfügung, wenn die Funktion Translate$() im Projekt verwendet wird und diese Option von der Anwendung unterstützt wird. Bestimmt die Sprache für den Druck, Wenn Sie das Feld leer lassen wird die Systemsprache verwendet, weitere mögliche Werte sind abhängig von der Anwendung. Diese Einstellung wirkt sich nicht in der Designer-Echtdatenvorschau aus.


Designschema

Es kann ein Designschema ausgewählt werden, um schnell optisch ansprechende Ergebnisse zu erzielen. Über die Liste sind verschiedene vordefinierte Schemata verfügbar. Diese Auswahl ist die projektglobale Voreinstellung und steht dann in den Objekten über den Eintrag "Projekt-Designschema" zur Verfügung.

Über den Eintrag "Benutzerdefiniert" steht Ihnen eine "…"-Schaltfläche zur Verfügung um ein benutzerdefiniertes Schema zu definieren. Dieses Schema steht dann in den Objekten über den Eintrag "Benutzerdefiniert" zur Verfügung.

Abbildung 13.3: Designschema anpassen

Eigenschaft

Beschreibung

Wert

Beschreibung

Farbe Vordergrund

Zehn Schemafarben für den Vordergrund: Steht in den Objekten als LL.Scheme.Color0…9 zur Auswahl.

Die Farbe kann über einen Farb-Dialog, eine Auswahlliste mit vordefinierten Farben oder über eine Formel bzw. Funktion frei bestimmt werden (Eintrag "Formel" am Ende der Liste). Als Funktion nutzen Sie die Funktion RGB() oder HSL()

Farb-Dialog

Auswahl vordefinierter Farben und Formel-Assistent

Farbe Hintergrund

Vier Schemafarben für den Hintergrund: Steht in den Objekten als LL.Scheme.BackgroundColor0…3 zur Auswahl.

Farb-Dialog

Auswahl vordefinierter Farben und Formel-Assistent

Setzen auf…

Wenn Sie hier ein Designschema auswählen, werden die Vorder- und Hintergrundfarben wieder auf die Farben des gewählten Designschemas zurückgesetzt.

Liste

Schemata


Sortierung

Bei Etikettenprojekten kann hier je nach Applikation eine Sortierung der Daten gewählt werden.


Transformation für Präsentationsmodus

Bestimmen Sie hier die Voreinstellung für die Art des Seitenübergangs im Präsentations-Modus der Vorschau.


Fax- und Mailvariablen

Das Faxen von Dokumenten erfolgt über den Druck auf den jeweiligen Fax(drucker)treiber, d.h. Voraussetzung zum Faxen ist, dass ein Faxprogramm installiert ist.

Wenn das Fax über den Windows Faxtreiber versendet werden soll, müssen die Faxparameter (mindestens die Faxnummer) in den Projekteigenschaften angegeben werden. Geben Sie dazu im Bereich "Faxparameter" die jeweiligen Variablen an.

Wenn das Fax über einen anderen Fax(drucker)treiber versendet werden soll, übergeben Sie die Faxnummer und andere Feldinformationen (sofern unterstützt) über sogenannte Steuerbefehle (z.B. DvISE Befehle bei Tobit David). Diese Steuerbefehle platzieren Sie direkt in einem Textfeld im Druckprojekt. Dadurch wird beim Druck der Empfängerdialog unterdrückt, da alle Informationen im Dokument bereits eingebettet sind. Die genaue Vorgehensweise finden in der Dokumentation zu Ihrer Faxsoftware beschrieben.

Sie können Dokumente auch direkt per Mail versenden. Die dazu notwendigen Mail-Variablen werden ebenfalls im Eigenschaftsfenster des Projekts definiert. Die Mail-Einstellungen (SMTP, MAPI, XMAPI) werden in der jeweiligen Anwendung konfiguriert.


Gemeinsame Objekt-Eigenschaften

Die meisten Objekt-Eigenschaften werden über die Eigenschaftsliste festgelegt und / oder über zusätzliche Dialoge. Die Eigenschaften sind für jeden Objekttyp individuell verschieden. Es gibt dabei allerdings eine Reihe von Merkmalen, die allen Objekten gemeinsam sind, wie z.B. Größe, Position, Name und Darstellungsbedingung. Diese Eigenschaften werden hier nun zentral beschrieben und in den darauf folgenden Abschnitten nicht näher erläutert.

Siehe auch:

Gesperrt

Anzeigebedingung für den Ausfertigungsdruck

Bedingte Formatierung

Darstellungsbedingung

Designschema

Ebene im Index

Ebene im Inhaltsverzeichnis

Export als Bild

Farbe

Format

Hintergrund / Füllung / Zebramuster

Inhalt

Muster

Name

Position

Rahmen

Schrift

Umbruch vor Objektausgabe


Gesperrt

Sperrt das Objekt vor unbeabsichtigter Selektion durch einen Mausklick. Diese Eigenschaft ist nur für den Entwurf relevant, hat also keine Auswirkung auf den späteren Druck. Wenn "Gesperrt" auf "True" gesetzt ist, kann das entsprechende Objekt nicht mehr im Arbeitsbereich selektiert werden und wird in der Objektliste durch ein kleines rotes Logo gekennzeichnet. Ein gesperrtes Objekt kann nach wie vor in der Objektliste selektiert werden und ist damit dann auch wieder veränderbar.

Abbildung 13.4: Gesperrte Objekte in der Objektliste

Eigenschaft | Beschreibung | Wert | Beschreibung
Gesperrt | Sperrt das Objekt vor unbeabsichtigter Selektion durch einen Mausklick im Arbeitsbereich | True False | gesperrt nicht Gesperrt


Anzeigebedingung für den Ausfertigungsdruck

Ermöglicht den bedingten Druck von Objekten für die verschiedenen Ausfertigungen. Diese Eigenschaft steht erst dann zur Verfügung, wenn in den Projekteigenschaften mehrere Ausfertigungen bestimmt wurden. Über die Funktion IssueIndex() kann der Index der Ausfertigung angegeben werden, also z.B. IssueIndex()=2. Weitere Informationen zur Ausfertigungssteuerung finden Sie im Kapitel Projekt-Eigenschaften.

Eigenschaft | Beschreibung | Wert | Beschreibung
Anzeigebedingung für Ausfertigungsdruck | Ermöglicht den bedingten Druck von Objekten für die verschiedenen Ausfertigungen, also z.B. IssueIndex()=2. | True False Formel | anzeigen nicht anzeigen Formel-Assistent


Bedingte Formatierung

Mit der Eigenschaft bedingte Formatierung kann die Schrift- und Hintergrundfarbe, der Rahmen und das Format bestimmt werden. Zur Definition steht ein Dialog zur Verfügung.

Eine neue bedingte Formatierung legen Sie über die Schaltfläche "Neu" an und definieren dann die Bedingung für diese Formatierung. Je nach Feldtyp können Sie dann zwischen mehreren vordefinierten Funktionen wählen (Text beginnt mit/enthält/ist leer/ist nicht leer, Wert ist leer/ist nicht leer, Wert ist größer/kleiner als, Wert ist größer/kleiner oder gleich, Wert ist, Wert ist NULL/nicht NULL, Wert liegt zwischen … und) oder Sie wählen den Eintrag "Formel bearbeiten" und definieren die Bedingung im Formel-Assistenten. Verwenden sie dabei das Feld "LL.CurrentValue".

Je nach Feldtyp definieren Sie dann die Formatierung (z.B. Schrift, Rahmen, Hintergrundfarbe, Format). Bei der Schrift stehen Ihnen die Schriftfarbe und diverse Schriftstile zur Verfügung, die Definition der Schriftart wird nicht unterstützt. Den Rahmen, die Hintergrundfarbe und das Format definieren Sie über die bekannten Dialoge. Über die Pfeil-Schaltfläche können Sie die Einstellung jeweils auf die Voreinstellung zurücksetzen.

Die Bedingungen werden in der angezeigten Reihenfolge angewendet. Sie können die Reihenfolge über die Pfeil-Schaltflächen ändern. Wenn Sie bei einer Bedingung die Option "Anhalten" aktivieren, werden die nachfolgenden Bedingungen ignoriert, wenn die Bedingung zutrifft.

Abbildung 13.5: Bedingte Formatierung


Darstellungsbedingung

Für jedes Objekt lässt sich eine Darstellungsbedingung vergeben, die bestimmt, unter welchen Umständen das Objekt ausgedruckt werden soll. Eine Anleitung zur Definition solcher Bedingungen finden Sie unter Variablen, Felder und Ausdrücke.

Eigenschaft

Beschreibung

Wert

Beschreibung

Darstellungs- bedingung

Darstellungsbedingung für den Druck. Es erfolgt keine Ausgabe wenn das Ergebnis False ist.

In Darstellungsbedingungen von Tabellen-Fußzeilen können Sie auch einen vordefinierten Wert "Nur letzte Seite" verwenden. Dieser Eintrag verwendet intern die Funktion Lastpage() bzw. LastFooterThisTable().

In Darstellungsbedingungen von Tabellen-Kopfzeilen können Sie einen vordefinierten Wert "Nur erste Seite" verwenden. Dieser Eintrag verwendet intern die Funktion not Lastpage() bzw. FirstHeaderThisTable().

True

False

Formel

Immer anzeigen

Nie anzeigen

Nur erste Seite

Nur letzte Seite

Formel-Assistent


Designschema

Es kann ein Designschema ausgewählt werden, um schnell optisch ansprechende Ergebnisse zu erzielen.

Eigenschaft | Beschreibung | Wert | Beschreibung
Designschema | Über die Liste sind verschiedene vordefinierte Designschemata verfügbar. Die Einträge "Projekt-Designschema" und "Benutzerdefiniert" beziehen sich auf die Schema-Definitionen in den Projekt-Eigenschaften. |  | Auswahl vordefinierter Schemata.


Ebene im Index

Über Projekt > Berichtsabschnitte kann ein Index erstellt werden. Die Ebene des Eintrags und der jeweilige Text werden über diese Eigenschaft definiert und stehen dann im Projekt für den Index als Felder Verweis.Ebene und Verweis.Text zur Verfügung. Die maximale Indextiefe kann über Datei > Optionen > Projekt (Projekt > Optionen > Projekt) definiert werden.

Ebene im Index | Gibt die Ebene des Indexeintrags an (0=nicht im Index). | Zahl Formel | Formel-Assistent
Text | Der Text, der im Index aufgenommen wird (kann tabulatorsepariert sein, wenn man mehrere Einträge wünscht). | Text | Formel-Assistent


Ebene im Inhaltsverzeichnis

Über Projekt > Berichtsabschnitte kann ein Inhaltsverzeichnis erstellt werden. Die Ebene des Eintrags und der jeweilige Text werden über diese Eigenschaft definiert und stehen dann im Projekt für das Inhaltsverzeichnis als Felder Verweis.Ebene und Verweis.Text zur Verfügung. Die maximale Verzeichnistiefe kann über Datei > Optionen > Projekt (Projekt > Optionen > Projekt) definiert werden.

Ebene im Inhaltsverzeichnis | Gibt die Ebene des Verzeichniseintrags an (0=nicht im Verzeichnis). | Zahl Formel | Formel-Assistent
Text | Der Text, der im Verzeichnis aufgenommen wird. | Text | Formel-Assistent


Export als Bild

Um Objekte im Bildformat zu exportieren, wenn ein Vektorexport nicht zum Ziel führt bzw. um eine bessere Darstellung zu erzielen.

Eigenschaft | Beschreibung | Wert | Beschreibung
Export als Bild | Wenn das Ergebnis "True" ist, wird das Objekt als Bild exportiert. | True False Formel | Ja Nein Formel-Assistent


Farbe

Mit der Eigenschaft Farbe kann die Schrift- oder Hintergrundfarbe bestimmt werden. Für eine Hintergrundfarbe müssen Sie zusätzlich die Eigenschaft "Hintergrund" auf einen Wert>0 setzen, also z.B. auf "Muster/feste Farbe".

Die Farbe kann über eine Auswahlliste ausgewählt oder über eine Formel bzw. Funktion frei bestimmt werden. Zur Definition steht ein Dialog zur Verfügung.

Abbildung 13.6: Farbdialog

Eigenschaft

Beschreibung

Wert

Beschreibung

Farbe

Die Farbe kann aus einer fest vordefinierten Auswahl von Standard- und Designschemafarben gewählt werden.

Auswahl vordefinierter Farben

Weitere Farben…

Die Farbe kann über einen Farb-Dialog bestimmt werden.

Farb-Dialog

Formel…

(1) Die Farbe kann über die Funktion RGB() bestimmt werden. Dabei setzt sich die Farbe aus einem Rot-, Grün- und Blauanteil zusammen. Jeder Farbanteil kann einen Wert zwischen 0 und 255 annehmen.

(2) Die Farbe kann über die Funktion HSL() bestimmt werden. Dabei setzt sich die Farbe aus einem Farbtonanteil (0-360), Sättigungsanteil (0-1) und Helligkeitsanteil (0-1) zusammen.

Formel-Assistent


Format

Über die Eigenschaft "Format" kann der gesamte Feldinhalt über einen Dialog als Währung, Zahl, Datum, Zeit, Datum und Zeit, Prozent, Winkel oder Datum-/Zeitdifferenz formatiert werden.

Abbildung 13.7: Formatdialog

Dabei wird standardmäßig die jeweilige Applikationseinstellung verwendet.

Alternativ kann die Systemeinstellung oder eine benutzerdefinierte Einstellung gewählt werden. Wenn keine Applikationseinstellung von der Anwendung übergeben wird, ist die Applikationseinstellung identisch mit der Systemeinstellung.

Die Formatierung bezieht sich dabei auf das Ergebnis des gesamten Ausdrucks.

Möchten Sie nur Teilbereiche eines Ausdrucks formatieren verwenden Sie die Formatierungsfunktionen im Formel-Assistenten (z.B. Date$, LocCurrL$ oder FStr$).


Hintergrund / Füllung / Zebramuster

Mit der Eigenschaft Hintergrund / Füllung kann eine feste Farbe oder ein Farbgradient bestimmt werden.

Eigenschaft | Beschreibung | Wert | Beschreibung
Füllung / Hintergrund / Zebramuster | Wählen Sie die Art des Gradienten aus und bestimmen Sie je nach Hintergrund die Eigenschaften Farbe, Zwischenfarbe, Endfarbe und Einblendfaktor. Wert 7 nur bei Tabelle, Diagramm, Rechteck, Kreis. | 0 1 2 3 4 5 6 7 8 Formel | transparent Muster/feste Farbe horiz. Gradient vert. Gradient hor. 2-teiliger Gradient vert.2-teiliger Gradient teiltransparent Bild Glaseffekt Formel-Assistent


Inhalt

Manche Objekte lassen sich nicht ausschließlich über die Eigenschaftsliste definieren. Sie enthalten Unterobjekte (oder "Inhalte"), wie z.B. das Textobjekt, dass aus mehreren Absätzen besteht. Über die Eigenschaft "Inhalt" (sofern verfügbar) öffnet sich ein Dialogfester. Eine Beschreibung der Inhaltsdialoge der einzelnen Objekte finden Sie bei den einzelnen Objektbeschreibungen.


Muster

Mit der Eigenschaft Muster kann die Beschaffenheit einer Farbe bestimmt werden.

Eigenschaft | Beschreibung | Wert | Beschreibung
Muster | Legen Sie hier ein Muster fest aus einer Vielzahl vordefinierter Muster. Eine Zahl repräsentiert jeweils ein Muster. Die Zahl kann über eine Formel auch frei bestimmt werden (Eintrag "Formel" am Ende der Liste). Diese Eigenschaft wird nur dann ausgewertet, wenn "Füllung" bzw. "Hintergrund" auf "Muster/feste Farbe" gesetzt wurde. |  | Auswahl vordefiniertes Muster und Formel-Assistent


Name

Wenn Sie ein Objekt neu auf dem Arbeitsbereich einfügen, so erscheint im rechten Segment der Statuszeile eine Objektbeschreibung, die sich aus dem Typ des Objekts (z.B. "Text") und seinen Koordinaten zusammensetzt. Dies ist der voreingestellte Name für dieses Objekt.

Wenn Sie jedoch eine größere Anzahl gleichartiger Objekte in Ihrem Projekt haben, werden diese Bezeichnungen schnell unübersichtlich. Sie haben daher die Möglichkeit, Objekten über das Toolfenster Objekte oder über die Eigenschaftsliste des Objektes einen neuen aussagekräftigen Namen zu geben, indem Sie einfach einmal auf den bestehenden Namen klicken und ihn dann verändern. Wenn Sie die Option Objekt-Info unter Datei > Optionen > Arbeitsbereich (Projekt > Optionen > Arbeitsbereich) eingeschaltet haben, erscheint der Objektname auch im eingeblendeten Tooltip.

Eigenschaft | Beschreibung | Wert | Beschreibung
Name | Name des Objekts | Name |


Position

Die Eigenschaftsgruppe "Position" eines Objekts definiert die x- und y-Koordinate der linken oberen Ecke des Objekts, die Objektbreite und –höhe.

Zur Definition steht auch ein Dialog zur Verfügung.

Eigenschaft | Beschreibung | Wert | Beschreibung
Position | Position und Größe des Objekts, alle Angaben in der Maßeinheit des Arbeitsbereichs |  | Positions- dialog
links | horizontaler Abstand der linken oberen Ecke des Objekts von der linken oberen Ecke des Arbeitsbereichs | Formel | Formel-Assistent
oben | vertikaler Abstand der linken oberen Ecke des Objekts von der linken oberen Ecke des Arbeitsbereichs | Formel | Formel-Assistent
Breite | Breite des Objekts | Formel | Formel-Assistent
Höhe | Höhe des Objekts | Formel | Formel-Assistent


Rahmen

Die Eigenschaftsgruppe "Rahmen" definiert die Rahmeneigenschaften und Abstände zu den Rahmen.

Zur Definition steht auch ein Dialog zur Verfügung:

Abbildung 13.8: Dialog für die Rahmeneigenschaften

Eigenschaft | Beschreibung | Wert | Beschreibung
Rahmen (-Voreinstellung) | Rahmeneigenschaften und Abstände können über einen Dialog definiert werden. Um die gewählte Linienart, die Farbe oder die Breite anzuwenden, klicken Sie auf eine der Voreinstellungen, auf die Linien der Vorschau oder verwenden Sie die Schaltflächen. |  | Rahmen- dialog
Rahmen-Voreinstellung (bei Tabellenzellen) | Bei True wird der Default-Rahmen verwendet, der im Tabellenobjekt definiert ist. | True False Formel | Linie Keine Linie Formel-Assistent
Layout | Beschreibt die Linienführung des Rahmens (nur relevant bei mehrlinigen Rahmen). | 0 1 2 Formel | Umlaufend Horiz. Priorität Vert. Priorität Formel-Assistent
links/oben rechts/unten | Einstellungen für die jeweilige Rahmenlinie. |  |
Abstand | Abstand zwischen Inhalt und Rahmen in mm. | Formel | Formel-Assistent
Linie | Sichtbarkeit der Rahmenlinie. | True False Formel | Linie Keine Linie Formel-Assistent
Farbe | Linienfarbe. |  |
Linientyp | Linientyp. | Linie Formel | Auswahl vordefinierter Linien (20) Formel-Assistent
Breite | Linienbreite. | Formel | Formel-Assistent


Schrift

Wenn Voreinstellung auf "Ja" gesetzt ist, wird die Schriftart der Voreinstellung verwendet. Siehe auch Kapitel Voreinstellung für Schrift und Rahmen. Zur Definition steht auch ein Dialog zur Verfügung.

Eigenschaft | Beschreibung | Wert | Beschreibung
Schrift | Die Schrift-Eigenschaften können über einen Dialog definiert werden. |  | Schrift-Dialog
Voreinstellung | Es wird die Voreinstellungs-Schriftart statt der gesetzten Werte benutzt. | True False Formel | Voreingestellte Schriftart Nein Formel-Assistent
Name | Auswahl der Schriftart. Es werden alle installierten Schriftarten angezeigt. | Liste Formel | Schriftart Formel-Assistent
Zeichensatz | Bestimmt die Länder-Interpretation des Zeichensatzes. Es werden alle verfügbaren Zeichensätze angezeigt. | Zahl | Zeichensatz
Größe | Größe der Schriftart in Punkten. Zeigt eine Liste der verfügbaren Größen der ausgewählten Schriftart an. | Zahl Formel | Vordefinierte Größe Formel-Assistent
Laufweite | Gibt die Laufweite der Schriftart an. 0 bedeutet Standard-Laufweite, ansonsten wird die mittlere Zeichenbreite angegeben. | Zahl Formel | Laufweite Formel-Assistent
Fett | Fette Zeichen. | True False Formel | Ja Nein Formel-Assistent
Kursiv | Schräggestellte Zeichen. | True False Formel | Ja Nein Formel-Assistent
Unterstrichen | Unterstrichene Zeichen. | True False Formel | Ja Nein Formel-Assistent
Durch- gestrichen | Durchgestrichene Zeichen. | True False Formel | Ja Nein Formel-Assistent
Farbe | Schriftfarbe. |  |


Umbruch vor Objektausgabe

Jedes Objekt kann vor seinem Druck einen Umbruch auslösen, d.h. das Objekt beginnt dann auf einer neuen Seite.

Eigenschaft | Beschreibung | Wert | Beschreibung
Umbruch vor | Wenn die Bedingung "True" ergibt, wird vor der Ausgabe des Objekts ein Seitenumbruch ausgelöst. | True False Formel | Umbruch kein Umbruch Formel-Assistent


Textobjekte

Textobjekte dienen dazu, einen beliebigen Text auf dem Arbeitsbereich zu platzieren. Ein Textobjekt kann beliebig viele Absätze enthalten, die jeweils ganz unterschiedliche Darstellungseigenschaften haben können. Diese Absätze und ihre Eigenschaften stellen den Inhalt des Textobjekts dar.

Textobjekte sollten stets in der maximal gewünschten Größe erstellt werden, die Höhe minimiert sich dann zum Druckzeitpunkt zur tatsächlich benötigten Größe. Dieses Verhalten ist besonders für Verkettungen nützlich.

Im Dialog Absatz-Eigenschaften können Sie die einzelnen Absätze des Textobjekts bearbeiten und mit Inhalten füllen.

Siehe auch:


Objekt-Eigenschaften

Siehe auch Kapitel Gemeinsame Objekt-Eigenschaften.

Eigenschaft | Beschreibung | Wert | Beschreibung
Ausrichtung unten | Ausrichtung unten innerhalb des Objektrahmens. Ist diese Option aktiviert, so werden die Texte des Objekts am unten Rand des Objekts ausgegeben, wenn nicht, am oberen Rand. Voraussetzung ist, dass die Absätze nicht größer als das Objekt werden, ansonsten wird der Text wie gewohnt unten abgeschnitten bzw. umgebrochen. Diese Option ist sehr nützlich, wenn z.B. Texte unbekannter Länge am unteren Ende einer Seite ausgegeben werden sollen. | True False Formel | Ja Nein Formel-Assistent
Drehung | Dreht das Objekt gegen den Uhrzeigersinn. Beachten Sie, dass nur TrueType-Schriftarten gedreht werden können. | 0 1 2 3 Formel | 0° 90° 180° 270° Formel-Assistent
Seitenumbruch | Bestimmt, ob das Objekt einen Seitenumbruch auslösen kann. Wenn Die Eigenschaft aktiviert ist, so wird ein die Größe des Objektes überschreitender Inhalt automatisch auf die nächste Seite umgebrochen. Dies ist z.B. bei Textobjekten interessant, die über mehrere Seiten gehen sollen. Bei Etiketten wird das nächste Etikett erst angefangen, wenn alle Objekte mit dieser Option des vorherigen Etiketts komplett gedruckt wurden. Es ist möglich, dass diese Eigenschaft nicht einstellbar ist, wenn der Seiten-Umbruch vom übergeordneten Programm nicht unterstützt wird. | True False Formel | Ja Nein Formel-Assistent


Absatzeigenschaften

Siehe auch Kapitel Gemeinsame Objekt-Eigenschaften.

Eigenschaft

Beschreibung

Wert

Beschreibung

Absatzabstand

Abstand zum nächsten Absatz ("Absatzendeabstand"). Der Abstand wird in Punkten angegeben: Um einen 1,5 zeiligen Abstand bei einer 10 Punktschrift zu erreichen, geben Sie 5 Punkte an. Auch negative Werte sind erlaubt.

Zahl

Formel

Formel-Assistent

Ausrichtung

Hier können Sie wie in Ihrer Textverarbeitung die Ausrichtung der einzelnen Textzeilen festlegen.

0

1

2

Formel

links

zentriert

rechts

Formel-Assistent

Blocksatz

Ein Text im Blocksatz ist links- und rechtsbündig. Diese Eigenschaft wirkt sich nur aus, wenn die betreffende Zeile am Zeilenende umgebrochen wird, d.h. die Zeile muss länger als der zur Verfügung stehende Platz sein, aus mehreren Worten bestehen und die Option "Zeilen-Umbruch" muss eingeschaltet sein.

Die letzte Zeile wird gemäß der Eigenschaft "Ausrichtung" dargestellt.

True

False

Formel

Ja

Nein

Formel-Assistent

Formatierung

Beachten Sie, dass sich die Formatierung auf das Ergebnis des gesamten Ausdrucks bezieht. Möchten Sie nur Teilbereiche eines Ausdrucks formatieren (z.B. bei Text und Zahl innerhalb eines Ausdrucks) verwenden Sie die Funktionen Date$() und Fstr$() im Formel-Assistent.

True

False

Dialog

Leerzeichen-Optimierung

Über die Leerzeichen-Optimierung können unerwünschte Leerzeichen (führende, eingeschlossene und übrig gebliebene) entfernt werden.

Stellen Sie sich vor, Sie drucken in einem Etikettenprojekt eine Zeile mit den Variablen

<ANREDE> <VORNAME> <NAME>

wobei die einzelnen Variablen jeweils durch Leerzeichen getrennt werden. Falls nun zu einem Datensatz keine Anrede existiert, bleibt diese Variable leer, das folgende Leerzeichen würde jedoch gedruckt. Vorname und Name erschienen um eine Stelle eingerückt (führendes Leerzeichen)

Wenn z.B. die Variable "Vorname" leer wäre stünden zwischen "Anrede" und "Name" zwei Leerzeichen (eingeschlossene Leerzeichen).

Wenn alle drei Variablen ohne Inhalt wären, blieben die beiden Leerzeichen stehen (übrig gebliebene Leerzeichen). Diese Zeile ist damit nicht leer und wird folglich auch nicht automatisch unterdrückt.

In diesen Fällen hilft die Option "Leerzeichen-Optimierung", mit der führende, eingeschlossene und übrig gebliebene Leerzeichen automatisch entfernt werden können. Mehrfach vorkommende eingeschlossene Leerzeichen werden dabei automatisch auf ein einzelnes Leerzeichen zurückgesetzt.

True

False

Formel

Ja

Nein

Formel-Assistent

Unlöschbar

Komplett leer gebliebene Zeilen werden automatisch unterdrückt. Die nachfolgenden Zeilen rücken in diesem Fall nach oben. Dies ist im Regelfall sinnvoll, kann jedoch z.B. beim Ausfüllen von Formularen auch einmal unerwünscht sein.

Über die Option "Unlöschbar" bleibt die betreffende Zeile auch erhalten, wenn sie nach dem Einsetzen der Variablen leer wäre.

True

False

Formel

Ja

Nein

Formel-Assistent

Zeilen-Umbruch

Bestimmt das Verhalten, wenn der Text zu lang für eine Zeile wird.

0: Der Inhalt wird am Ende der Zeile abgeschnitten.

1: Der Inhalt wird umgebrochen. Damit lange Wörter nicht abgeschnitten werden, können Sie über die Option "Umbruch erzwingen" sicherstellen, dass nach dem letzten passenden Zeichen umgebrochen wird.

2: Die Schriftgröße wird bei Bedarf so weit verkleinert, dass der Absatz ohne Umbruch komplett dargestellt werden kann.

3: Der Zeichenabstand wird bei Bedarf verringert, damit der Absatz ohne Umbruch komplett dargestellt werden kann.

4: Die Schriftgröße wird soweit verkleinert oder vergrößert, das der Absatz das Objekt möglichst vollständig (vertikal/horizontal) ausfüllt. Diese Option sollte nur für den letzten Absatz verwendet werden, da Folgeabsätze ggf. wegfallen.

Die Optionen 2-4 sollten nur bis zu einer gewissen Grenze verwendet werden um die Lesbarkeit zu gewährleisten.

0

1

2

3

4

Formel

abschneiden

umbrechen

verkleinern

verschmälern

optimal einpassen

Formel-Assistent

Seitenumbruch erlaubt

Wenn das Textobjekt einen Seitenumbruch auslösen kann (siehe Objekt-Eigenschaft "Seitenumbruch"), können Sie über diese Eigenschaft festlegen, dass der Absatz bei einem evtl. Seitenumbruch nicht getrennt wird.

True

False

Formel

Umbruch

Zusammen-halten

Formel-Assistent

Umbruch erzwingen

Wenn ein langes Wort nicht umgebrochen werden kann, wird ein Umbruch nach dem letzten passenden Zeichen erzwungen.

True

False

Formel

Ja

Nein

Formel-Assistent

Zeilenabstand

Der Zeilenabstand definiert den Abstand zwischen den einzelnen Zeilen des Absatzes.

Der Abstand wird in Punkten angegeben: Um einen 1,5 zeiligen Abstand bei einer 10 Punktschrift zu erreichen, geben Sie 5 Punkte an. Auch negative Werte sind erlaubt.

Die Einstellung der Objektschriftart unter Datei > Optionen > Objekte (Projekt > Optionen > Objekte) sollte unbedingt vorgenommen werden.

Zahl

Formel

Formel-Assistent


Linienobjekte

Linien werden über Ausrichtung, Breite und Typ definiert.

Siehe auch:


Objekt-Eigenschaften

Siehe auch Kapitel Gemeinsame Objekt-Eigenschaften.

Eigenschaft | Beschreibung | Wert | Beschreibung
Ausrichtung | Ausrichtung innerhalb des Objekt-Rechtecks. Wenn Sie bei der Größenveränderung mit der Maus die Umschalt-Taste gedrückt halten, wird die Linie entweder vertikal oder horizontal ausgerichtet. | 0 1 2 3 Formel | Diagonal \ Diagonal / Horizontal Vertikal Formel-Assistent
Breite | Linienbreite in der Maßeinheit des Arbeitsbereichs. 0 bedeutet 1px. | Zahl Formel | Formel-Assistent
Linientyp | Auswahl des Linientyps. | 0, 1, 3, 4 Formel | 4 vordefinierte Linien Formel-Assistent


Rechteckobjekte

Rechtecke werden über Rand, Rundung und Schatten definiert.

Siehe auch:


Objekt-Eigenschaften

Siehe auch Kapitel Gemeinsame Objekt-Eigenschaften.

Eigenschaft | Beschreibung |  |  | Wert | Beschreibung
Rand | Hier legen Sie fest, ob das Rechteck einen Rand haben soll. |  |  | 0 1 Formel | transparent Muster/ Farbe Formel-Assistent
 | Farbe | Farbe des Rands. |  |  |
 | Breite | Breite des Rands in der Maßeinheit des Arbeitsbereichs |  | Zahl Formel | Formel-Assistent
Rundung | Rundungsfaktor für die Ecken des Rechtecks in % der kurzen Rechteckkante. 0% bedeutet: eckig; 100% bedeutet: Die kurze Kante des Rechtecks ist komplett rund. |  |  | Zahl Formel | Formel-Assistent
Schatten | Hier wird festgelegt, ob das Rechteck einen Schatten haben soll. |  |  | 0 1 Formel | transparent Muster/ Farbe Formel-Assistent
 | Muster |  | Schattenmuster. |  |
 | Farbe |  | Schattenfarbe. |  |
 | Breite |  | Schattenbreite in der Maßeinheit des Arbeitsbereichs. | Zahl Formel | Formel-Assistent


Kreis- und Ellipsenobjekte

Kreise und Ellipsen werden über Rand und Füllung definiert.

Siehe auch:


Objekt-Eigenschaften

Siehe auch Kapitel Gemeinsame Objekt-Eigenschaften.

Eigenschaft

Beschreibung

Wert

Beschreibung

Kreis

Hier können Sie bestimmen, dass die Ellipse immer als Kreis dargestellt wird (zentriert im Objektrechtreck).

Diese Eigenschaft kann beim Aufziehen mit gedrückter Shift-Taste (kleinere Achse), Strg-Taste (größere Achse) oder Shift- und Strg-Taste (False) gesetzt werden.

True

False

Formel

Ja

Nein

Formel-Assistent

Rand

Hier legen Sie fest, ob die Ellipse einen Rand haben soll.

0

1

Formel

transparent

Muster/ Farbe

Formel-Assistent

Farbe

Farbe des Rands.

Breite

Breite des Rands in der Maßeinheit des Arbeitsbereichs.

Zahl

Formel

Formel-Assistent


Bildobjekte

Bildobjekte dienen zur Darstellung von festen Dateien oder variablen Inhalten.

Folgende Formate sind verfügbar: WMF, EMF, BMP, DIB, PCX, SCR, TIFF, GIF, JPEG, PCD, PNG, ICO. Generell sollten Sie den RGB-Farbraum verwenden (nicht CYMK). Über die entsprechenden Windows-Funktionen wird auch Transparenz in PNG-Dateien unterstützt. Nach unserer Erfahrung ist die Unterstützung bei Druckertreibern aber nicht immer zuverlässig gegeben, so dass Sie Berichte z.B. mit teiltransparenten PNG-Dateien sehr sorgfältig auf der tatsächlich zum Einsatz kommenden Hard-/Softwarekombination testen sollten. Ist dies nicht möglich, empfehlen wir auf Transparenzeffekte in Bildern zu verzichten.

Wenn Sie als Datenquelle einen Dateinamen oder eine Variable auswerten, können Sie diese auch per Doppelklick auf das Objekt auswählen.

Siehe auch:


Objekt-Eigenschaften

Siehe auch Kapitel Gemeinsame Objekt-Eigenschaften.

Eigenschaft

Beschreibung

Wert

Beschreibung

Datenquelle

Wählen Sie, wie die Bild-Datenquelle, d.h. der Dateiname ermittelt werden soll.

Dateiname

Formel

Variable

Formel-Assistent

Dateiname

Der Dateiname wird ausgewertet, falls bei der Eigenschaft Datenquelle "Dateiname" ausgewählt wurde. Danach wählen Sie mit dem Dateiauswahldialog die gewünschte Bilddatei aus. In diesem Dialog haben Sie mit der Option "Bilddaten in Projektdatei speichern" die Möglichkeit, das Bild in das Projekt zu übernehmen. Damit steht das Bild auch ohne die externe Datei zur Verfügung. Als Dateiname wird in diesem Fall (eingebettete Datei) angezeigt.

Datei öffnen-Dialog

Relativpfad

Der Pfad ist relativ zum Projektpfad.

True

False

Ja

Nein

Formel

Der Dateiname ergibt sich aus einer Formel, falls bei der Eigenschaft Datenquelle "Formel" ausgewählt wurde. Das Ergebnis dieser Formel muss ein Wert vom Typ "Bild" sein. Sie können auch einen gültigen Dateinamen übergeben, dieser muss aber zuvor mit der Funktion Drawing() in einen Wert vom Typ "Bild" konvertiert werden.

Formel

Formel-Assistent

Variable

Der Dateiname wird einer Variablen entnommen, falls bei der Eigenschaft Datenquelle "Variable" ausgewählt wurde.

Wählen Sie aus der Liste die gewünschte Variable aus. In der Liste finden Sie alle Variablen vom Typ "Bild", die in Ihrer Anwendung definiert sind.

Variable

Eigenschaften

Abhängig von Ihrer Anwendung kann an dieser Stelle eventuell ein Dialog geöffnet werden, über den Sie weitere Eigenschaften definieren können.

Öffnet Dialog

Als JPEG speichern

Das Bild als JPEG-Datei ausgeben, wenn möglich (nicht alle Dateitypen, z.B. ICO, WMF, EMF, unterstützen diese Option).

True

False

Formel

Ja

Nein

Formel-Assistent

Originalgröße

Beschreibt, ob das Bild in Originalgröße (wenn diese ermittelt werden kann) gezeichnet wird, oder sich der Rahmengröße des Bildobjekts anpassen soll

True

False

nicht definiert

Ja

Nein

nicht definiert

Proportionen erhalten

Über diese Option können Sie festlegen, ob das Bild so eingefügt werden soll, dass das Verhältnis von Höhe und Breite erhalten bleibt (True) oder ob sich das Bild vollständig dem Rahmen des Bildobjekts anpassen soll, aber möglicherweise verzerrt ist (False).

True

False

Formel

Ja

Nein

Formel-Assistent

Anordnung

Beschreibt, wie das Bild auf der Fläche angeordnet werden soll.

0

1

2

3

4

5

6

7

8

9

Zentriert

Nebeneinander (Kacheln)

Links oben

Links unten

Rechts oben

Rechts unten

Links

Rechts

Oben

Unten


Barcode-Objekte

Ein Barcode besteht normalerweise aus einer Serie unterschiedlich breiter Balken und Zwischenräume, wobei je nach Code auch in den Zwischenräumen Information übermittelt wird.

Siehe auch:


Objekt-Eigenschaften

Siehe auch Kapitel Gemeinsame Objekt-Eigenschaften.

Eigenschaft | Beschreibung |  |  | Wert | Beschreibung
Balkenbreite | Die dünnste Strichdicke eines einzelnen Balkens in SCM-Einheiten (1/1000 mm). 0 = automatische Anpassung. Wird nicht von allen Barcodes unterstützt. |  |  | Formel | Formel-Assistent
 | Orientierung | Orientierung des Barcodes innerhalb des Objektrahmens |  | 0 1 2 Formel | Links Zentriert Rechts Formel-Assistent
Balkenfarbe | Farbe für den gewählten Barcode. |  |  |  |
Drehung | Dreht das Objekt gegen den Uhrzeigersinn |  |  | 0 1 2 3 Formel | 0° 90° 180° 270° Formel-Assistent
Druckoptimierung | Gibt den Barcode (notfalls verkleinert oder vergrößert) so aus, dass die Schwärzungen mit der Druckerauflösung übereinstimmen, um optimale Lesbarkeit zu erzielen. |  |  | True False Formel | Ja Nein Formel-Assistent
 | Verkleinerung |  | Anzahl der Druckerpixel, um die die Balken verkleinert werden. Bei Tintenstrahldruckern empfohlen. | Zahl | Formel-Assistent
Optimale Größe | Stellt die optimale Größe des Barcodes ein. Diese Eigenschaft wirkt sich bei Größenänderungen aus, ist z.B. bei den folgenden Formaten möglich: EAN 13 (alle), DP-Leitcode, DP-Identcode, German Parcel, Postnet und FIM. |  |  | True False Formel | Ja Nein Formel-Assistent
Schrift | Schriftart für den Barcode-Text. Wird nur ausgewertet, wenn die Eigenschaft " Text ausgeben" aktiviert ist. |  |  |  | Schrift-Dialog
Strichdicken-Verhältnis | Das Verhältnis der Strichdicken verschiedener Balken oder Leerräume untereinander. Wird nicht von allen Barcodes unterstützt. |  |  | Formel | Formel-Assistent
Text ausgeben | Hier können Sie bestimmen, ob der Inhalt des Barcodes auch noch im Klartext erscheinen soll. |  |  | True False Formel | Ja Nein Formel-Assistent


Barcodeinhalt

Über den Inhalts-Dialog des Barcode-Objekts können Sie den Barcode näher bestimmen.

§ Wählen Sie Text, wenn Sie festen Text als Barcode drucken wollen. In den ersten Teil des Eingabefeldes geben Sie den zu druckenden Wert ein. Aus dem zweiten Teil wählen Sie den gewünschten Barcode-Typ aus.

§ Für manche Barcodes, wie z.B. Maxicode und Premiumadress, gibt es noch zusätzliche Optionen, die Sie in einem weiteren Dialog bearbeiten können.

Abbildung 13.9: Barcodeoptionen

§ Wählen Sie Formel, wenn Sie eine Formel als Barcode verwenden wollen und definieren Sie über Bearbeiten einen gültigen Formel-Ausdruck. Der Rückgabewert dieser Formel muss vom Datentyp "Barcode" sein. Natürlich können Sie auch beliebige Variablen übergeben, diese müssen zuvor allerdings mit Hilfe der Funktion Barcode() in eine Variable vom Datentyp "Barcode" konvertiert werden.

§ Wählen Sie Variable, wenn Sie eine Variable als Barcode drucken wollen. In der Liste stehen Ihnen alle Variablen vom Typ Barcode zur Verfügung.


Unterstützte Barcodeformate

Eine Reihe von Barcodeformaten werden unterstützt. Hierfür sind in der Regel keine speziellen Drucker, Schriftarten usw. notwendig – die Barcodes werden direkt gedruckt.

Siehe auch:


Übersicht der allgemeinen 1-D-Codes

Name

Formate und erlaubte Zeichen

GTIN-13, EAN-13, UCC-13, JAN-13

Formate:

cc|nnnnn|aaaaa (normaler EAN13)

cc|nnnnn|aaaaa|xx (EAN13 für Zeitschriften, "ISSN")

cc|nnnnn|aaaaa|xxxxx (EAN13 für Bücher, "Bookland")

ppp|nnnn|aaaaa (normaler EAN13)

ppp|nnnn|aaaaa|xx (EAN13 für Zeitschriften, "ISSN")

ppp|nnnn|aaaaa|xxxxx (EAN13 für Bücher, "Bookland")

mit cc = Ländercode

ppp = Produktcode

nnnn, nnnnn = Firmencode

aaaaa = Artikelcode

| = Zeichencode chr(124)

xx, xxxxx = Zusatzcode

Erlaubte Zeichen: [0-9]

Die Prüfziffer wird automatisch berechnet und angehängt. Jedes Zeichen ist 7 Strichdicken breit, ein Code sollte damit mindestens eine Breite von (12*7+11)*0.3 mm = 2.85 cm besitzen.

Sollgröße (Strichsymbol) Nominalgröße SC2:

Breite: 31.4 mm, Höhe: 24.5 mm

Mindestrandabstände, die um das Symbol freigehalten werden sollten:

links: 3.6mm, oben: 0.3mm, rechts: 2.3mm, unten: 0.0mm (wenn mit Schrift, sonst 0.3mm)

Der Text wird teilweise außerhalb dieses Bereichs gezeichnet.

EAN-14, UCC-14

Format: nnnnnnnnnnnnnn (14 Ziffern)

Erlaubte Zeichen: [0-9]

GTIN-8, EAN-8, UCC-8, JAN-8

Formate: nnnnnnn, nn|nnnnn

(|= Zeichencode chr(124))

Erlaubte Zeichen: [0-9]

Jedes Zeichen ist ebenfalls 7 Strichdicken breit, ein Code sollte damit mindestens eine Breite von (8*7+11)*0.3 mm=2.01 cm besitzen.

Sollgröße (Strichsymbol) Nominalgröße SC2:

dx: 22.1mm, dy:19.9 mm

Mindest-Randabstände, die um das Symbol freigehalten werden sollten:

links: 2.3mm, oben: 0.3mm, rechts: 2.3mm, unten: 0.0mm (wenn mit Schrift, sonst 0.3 mm)

Der Text wird teilweise außerhalb dieses Bereiches gezeichnet.

UPC-A

Format: c|nnnnn|aaaaa, cnnnnnaaaaa

mit c = Zahlensystem

nnnnn = Firmencode

aaaaa = Artikelcode

| = Zeichencode chr(124)

Erlaubte Zeichen: [0-9]

Die Prüfziffer wird automatisch berechnet und angehängt. Jedes Zeichen ist ebenfalls 7 Strichdicken breit, ein Code sollte damit mindestens eine Breite von (13*7+6)*0.3 mm=2.88 cm besitzen.

UPC-E

Format: c|nnnnnn, nnnnnnn

mit c = Zahlensystem

|= Zeichencode chr(124)

nnnnn = Code, Interpretation abhängig von der letzten Stelle

Erlaubte Zeichen: [0-9]

Die Prüfziffer wird automatisch berechnet und angehängt. Jedes Zeichen ist ebenfalls 7 Strichdicken breit, ein Code sollte damit mindestens eine Breite von (13*7+6)*0.3 mm=2.88 cm besitzen.

2-aus-5 Industrial

Format: beliebig

Erlaubte Zeichen: [0-9]

Ein Code ist (14*Zeichenzahl+18) Strichdicken breit.

2-aus-5 Interleaved (ITF)

Format: beliebig, die Zeichenzahl muss gerade sein

Erlaubte Zeichen: [0-9]

Ein Code ist (9*Zeichenzahl+9) Strichdicken breit.

2-aus-5 Matrix

Format: beliebig

Erlaubte Zeichen: [0-9]

Ein Code ist (10*Zeichenzahl+18) Strichdicken breit.

2-aus-5 Datalogic

Format: beliebig

Erlaubte Zeichen: [0-9]

Ein Code ist (10*Zeichenzahl+11) Strichdicken breit.

Codabar

Format: fnnnnnf

Erlaubte Zeichen: f = Rahmen-Code [A-D], n = [0-9], [-$:/.+]

Jedes Zeichen ist entweder 2*3+6*1 (bei den Zeichen [0-9], [-$]) oder 3*3+5*1 (bei (':', '/', '.', '+', 'A'..'D') Strichdicken breit.

Die Zeichen des Rahmencodes werden nicht bei dem Text mit ausgegeben.

CODE11

Format: beliebig

Erlaubte Zeichen: [0-9],[-]

Code 11 hat je nach Länge 1 oder 2 Checksummen. Es wird nur 1 statt 2 Checksummen errechnet, wenn die Länge des Texts maximal 10 Zeichen ist.

Code39, 3-aus-9, Alpha39

Format: beliebig

Erlaubte Zeichen: [A-Z], [0-9], [-./$%+*]

Es müssen alle Zeichen angegeben werden; das übliche Start- und Stoppzeichen * ist jedoch nicht notwendig.

Erweiterter Code 39

Format: beliebig

Erlaubte Zeichen: beliebig

Der erweiterte Code kann durch Kombination von Zeichen des Standard-Codes angesprochen werden: z.B.: '+A' -> 'a'. Jedes Zeichen ist 16 Strichdicken breit, ein Text hat (16*Zeichenzahl-1) Striche.

Code 39 mit CRC

Format: beliebig

Erlaubte Zeichen: [A-Z], [0-9], [-./$%+*]

Code 93 (simple and extended)

Code 93 ist eine Erweiterung des Code 39 und deckt die vollen 128 Bytes des ASCII Zeichensatzes ab, incl. NULL-Character. Dieses muss als chr$(255) übergeben werden.

Er enthält zwei Prüfziffern, die automatisch erzeugt werden.

Die Zeichen bestehen aus 9 Strichdicken, die je aus 3 Balken und 3 Leerbalken bestehen. Es gibt zwei Optionen für den erweiterten Code:

LL) Übergabe der Shift-Zeichen vom Wirtsprogramm als

$ chr$(254)

% chr$(253)

/ chr$(252)

+ chr$(251)

b) Übergabe der gewünschten Zeichen, L&L fügt automatisch die zugehörigen Shift-Zeichen hinzu.

Code128

Format: beliebig

Erlaubte Zeichen: beliebig

Verwendetes Codeset festlegen: Als Startzeichen verwenden Sie einen der folgenden Codes:

chr$(135) – Beginn mit Code A

chr$(136) – Beginn mit Code B

chr$(137) – Beginn mit Code C

Um innerhalb des Barcodes zwischen den verschiedenen Codesets umzuschalten, können Sie die üblichen Steuerzeichen verwenden:

Ausgehend von Code A nach

B: chr$(132)

C: chr$(131)

Ausgehend von Code B nach

A: chr$(133)

C: chr$(131)

Ausgehend von Code C nach

A: chr$(133)

B: chr$(132)

Beispiel:

<Subset B> "RL" <Subset C> "04432476" <Subset B> "0DE110"

Barcode(chr$(136)+"RL"+chr$(131)+"04432476"+chr$(132)+
"0DE110", "Code 128")

Code128-Full

Dieser Code erlaubt im Unterschied zum "normalen" Code128 die Verwendung des gesamten Latin-1-Zeichensatzes. Sonderzeichen müssen wie folgt ersetzt werden:

NUL: chr$(256)

FNC1: chr$(102+32)

FNC2: chr$(97+32)

FNC3: chr$(96+32)

GS1 128, EAN128

Das Sonderzeichen FNC1 nach dem Startzeichen definiert eindeutig den EAN128. Sonderzeichen müssen wie folgt ersetzt werden:

NUL: chr$(255)

FNC1: chr$(254)

FNC2: chr$(253)

FNC3: chr$(252)

FNC4: chr$(251)

EAN128-Full

Dieser Code erlaubt im Unterschied zum "normalen" EAN128 die Verwendung des gesamten Latin-1-Zeichensatzes. Das Sonderzeichen FNC1 nach dem Startzeichen definiert eindeutig den EAN128. Sonderzeichen müssen wie folgt ersetzt werden:

NUL: chr$(256)

FNC1: chr$(102+32)

FNC2: chr$(97+32)

FNC3: chr$(96+32)

GS1 DataBar (Limited, Stacked, Stacked Omnidirectional, Stacked Truncated)

Format: nnnnnnnnnnnnn (13 Ziffern)

Erlaubte Zeichen: [0-9]

GS1 DataBar Expanded

Format: Daten beginnen mit AI. Max. 74 numerische/41 alphanumerische Zeichen

Erlaubte Zeichen: beliebig

IM (4CB/4-CB/USPS4CB)

Intelligent Mail Barcode (US Postal Services). Weitere Bezeichnung: One Code Solution bzw. 4-State Customer Barcode).

Format: 20, 25, 29 oder 31 Ziffern

Erlaubte Zeichen: [0-9]

ISBN

Format: nnn|nnnnnnnnnn (12-stellig, keine Prüfziffer)

Erlaubte Zeichen: [0-9]

MSI

Format: beliebig

Erlaubte Zeichen: [0-9], [A-F]

Es werden die Codes MSI, MSI PLAIN, MSI+10+10, MSI+10+CD, MSI+11+10 unterstützt.

Pharma-Zentral-Nummer

Format: nnnnnn (6 Ziffern)

Erlaubte Zeichen: [0-9]

Pharma-Zentral-Nummer (neu)

Format: nnnnnn (7 Ziffern)

Erlaubte Zeichen: [0-9]

SSCC/NVE

Format: {nn}nnnnnnnnnnnnnnnnn (17 oder 19 Ziffern)

Erlaubte Zeichen: [0-9]


Übersicht der allgemeinen 2-D Codes

Name

Formate und erlaubte Zeichen

Aztec

Format: beliebig. Beachten Sie beim Barcode-Inhalt-Dialog den Optionendialog.

Erlaubte Zeichen: beliebig

Datamatrix

Um nicht druckbare Zeichen (Binärdaten) im Barcodetext eingeben zu können, müssen sie in einer speziellen Zeichenkette verpackt werden. Man fügt die Daten über die Zeichenkette ~dNNN ein, wobei NNN für den ASCII-Code steht.

Beispiel: DEA~d065~d015~d000~d247~d220 (~d065 steht z.B. für "A")

Um einen EAN Datamatrix darzustellen, können Sie das Sonderzeichen FNC1 als ~1 codieren.

Der Datamatrix-Code verwendet den ECC 200 Fehlerkorrekturcode. Sie können weitere Optionen wie Größe, Modulformat und Codierung im Eigenschaftendialog des Barcodes einstellen.

PDF417

Kann alle verfügbaren und auch nicht druckbare Zeichen darstellen. Beachten Sie beim Barcode-Inhalt-Dialog den Optionendialog.

Um nicht druckbare Zeichen (Binärdaten) im Barcodetext eingeben zu können, müssen sie in einer speziellen Zeichenkette verpackt werden. Man fügt die Daten über die Zeichenkette "{binary:nn}" ein, wobei nn für eine beliebige Folge von (zweistelligen) Hexadezimalzahlen steht. Dies ist insbesondere wichtig, wenn Maxicodes gemäß der UPS-Spezifikation erstellt werden sollen; die dafür benötigten Sonderzeichen können z.B. auf diese Weise eingegeben werden:

Um ein Null und ein Backspace (BS) Zeichen in die Daten zu packen, verwenden Sie:"{binary:0008}" (entspricht "{binary:00}{binary:08}").

Um einen Zeilenumbruch zu übergeben, verwenden Sie "Hallo{binary:0d0a}Welt"

QR Code

Format: beliebig. Beachten Sie beim Barcode-Inhalt-Dialog den Optionendialog, hier können Sie weitere Optionen wie Fehlerkorrektur, Codierung, Modus und Mindestversion einstellen.

Erlaubte Zeichen: alle Zeichen

Um nicht druckbare Zeichen (Binärdaten) im Barcodetext eingeben zu können, müssen sie in einer speziellen Zeichenkette verpackt werden. Man fügt die Daten über die Zeichenkette ~dNNN ein, wobei NNN für den ASCII-Code steht.

Beispiel: ~d065 steht für den Buchstaben "A".


Übersicht der Postcodes (1-D und 2-D Codes)

Name

Formate und erlaubte Zeichen

DP-Identcode

Formate: nn.nnnnnn.nnn, nn.nnnnn.nnnn, nn.nnnn.nnnnn, nn.nnn.nnnnnn

Erlaubte Zeichen: [0-9]

Ein Code ist (9*Zeichenzahl+9) Strichdicken breit.

Breite: 32,0mm – 58–5mm (Hellzone rechts und links: mindestens 5mm). Höhe: 25mm.

Prüfziffer wird automatisch berechnet; Wichtung: 4:9; Spezialcode des 2 aus 5 IL.

DP-Leitcode

Format: nnnnn.nnn.nnn.nn

Erlaubte Zeichen: [0-9]

Ein Code ist (9*Zeichenzahl+9) Strichdicken breit.

Breite: 37,25 mm – 67–5 mm (Hellzone rechts und links: mindestens 5mm). Höhe: 25mm.

Prüfziffer wird automatisch berechnet; Wichtung: 4:9; Spezialcode des 2 aus 5 IL.

FIM

Formate: A, B, C

Erlaubte Zeichen: [A-C]

Mindestgröße: 1/2" * 5/8" = 12.7 mm * 15.87 mm.

Der FIM-Barcode wird immer in der von dem US Postal Office geforderten Größe gedruckt, kann also über den erlaubten Objektrahmen herausragen.

German Parcel

Formate: beliebig, gerade Zeichenzahl nötig.

Erlaubte Zeichen: [0-9]

Ein Code ist (14*Zeichenzahl+18) Strichdicken breit.

Gewichtung: 1:2

Japanischer Postcode

Japanische Post Leitcode.

Format: Postcode als nnn-nnnn, dann max. 13 Zeichen Adresse

Erlaubte Zeichen: n=[0-9], Adresse=[A-Z], [0-9], [-]

Maxicode

Kann alle verfügbaren und auch nicht druckbare Zeichen darstellen.

Um nicht druckbare Zeichen (Binärdaten) im Barcodetext eingeben zu können, müssen sie in einer speziellen Zeichenkette verpackt werden. Man fügt die Daten über die Zeichenkette "{binary:nn}" ein, wobei nn für eine beliebige Folge von (zweistelligen) Hexadezimalzahlen steht. Dies ist insbesondere wichtig, wenn Maxicodes gemäß der UPS-Spezifikation erstellt werden sollen; die dafür benötigten Sonderzeichen können z.B. auf diese Weise eingegeben werden.

Beispiel: um ein Null und ein Backspace (BS) Zeichen in die Daten zu packen, verwenden Sie:"{binary:0008}" (entspricht "{binary:00}{binary:08}").

Beispiel: um einen Zeilenumbruch zu übergeben, verwenden Sie "Hallo{binary:0d0a}Welt"

Maxicode/UPS

Format: Formatierung gemäß UPS-Spezifikation

Erlaubte Zeichen: alle Zeichen

Postnet

Formate: nnnnn, nnnnn-nnnn, nnnnn-nnnnnn

Erlaubte Zeichen: [0-9]

Mindestgröße: 1.245" * 4/16" = 31.6 mm * 6.35 mm (10-stellig).

Balkenabstand mindestens 1/24" = 1.058 mm.

Die Fehlerkorrektur-Ziffer wird automatisch ergänzt.

Dieser Balkencode wird automatisch in der richtigen Größe gedruckt, wenn das Objekt größer ist als die maximale Größe.

Premiumadress

Format: Gemäß DPAG-Spezifikation. Beachten Sie beim Barcode-Inhalt-Dialog den Optionendialog.

Erlaubte Zeichen: Gemäß DPAG-Spezifikation.

RM4SCC, KIXÒ

Royal Mail mit CRC

Erlaubte Zeichen: [A-Z], [0-9], [a-z]

Erlaubte Zeichen: [A-Z], [0-9], [a-z]

Format: Codiert wird entweder nur die Postleitzahl (z.B. LU17 8XE) oder die Postleitzahl mit einem zusätzlichen "Delivery Point" (z.B. LU17 8XE 2B). Die Maximale Anzahl von Nutzstellen ist damit auf 9 Stellen begrenzt.


Berichtscontainer-Objekt

Ein Berichtscontainer kann Tabellen, Kreuztabellen, Diagramme und Gantt-Diagramme enthalten. Neue Elemente sowie die gewünschte hierarchische Struktur definieren Sie im Toolfenster "Objekte".

Siehe auch:


Objekt-Eigenschaften

Siehe auch Kapitel Gemeinsame Objekt-Eigenschaften.

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Umbruch vor | Wenn die Bedingung "True" ergibt, wird vor der Ausgabe des Berichtscontainers ein Seitenumbruch ausgelöst. |  | True False Formel | Umbruch Kein Umbruch Formel-Assistent
Schriftart-Voreinstellung | Voreinstellung für die Schrift der Elemente. |  |  | Schrift-Dialog
Spaltenzahl | Anzahl der Spalten des Containers. Hinweis: Das Feld "LL.CurrentTableColumn" liefert den Index der aktuellen Spalte zurück. |  | 1 2 3 4 5 Formel | 1-spaltig 2-spaltig 3-spaltig 4-spaltig 5-spaltig Formel-Assistent
 | Abstand | Abstand der Spalten des Containers. | Zahl Formel | Formel-Assistent


Element-Eigenschaften

Um die Eigenschaften der Elemente anzuzeigen, markieren Sie das Element im Toolfenster "Objekte".

Siehe auch Kapitel Gemeinsame Objekt-Eigenschaften.

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Name | Name des Elements (wird in der Variable "LL.CurrentContainerItem" gespeichert). |  | Name |
Separatorenzeichen (nur Tabellen) | Um (Unter-)Tabellen und Spalten exakt aneinander auszurichten, lassen sich im Lineal Separatorenzeichen anzeigen. |  | True False | Ja Nein
Abstand nach | Abstand zum nachfolgenden Element (entfällt wenn das Element am Seitenende endet). |  | Zahl Formel | Formel-Assistent
Abstand vor | Abstand vom vorhergehenden Element (entfällt wenn das Element am Seitenanfang beginnt). |  | Zahl Formel | Formel-Assistent
Ausgabe-Höhe (nur Diagramm) | Höhe des Objekts (inklusive Rahmen). |  |  |
Ränder (nur Diagramm, Kreuztabelle und Gantt) | Abstand des Objekts (inklusive Rahmen) vom Druckbereich des Berichtscontainers. |  | Zahl Formel | Formel-Assistent
Sortierung (nur Tabelle, Diagramm und Gantt) | Mehrstufige Sortierungen können über einen Dialog definiert werden (sofern von der Anwendung unterstützt), z.B. die Daten erst nach Land und dann nach Ort sortieren. Einstufige Sortierungen können über die Liste ausgewählt werden. |  |  | Dialog Liste
(Seiten-) Umbruch vor | Wenn die Bedingung "True" ergibt, wird vor der Ausgabe des Objekts ein Seitenumbruch ausgelöst. Bei mehreren mehrspaltigen Objekten wird nach einem Objekt automatisch ein Seitenumbruch ausgelöst, wenn sich die Spaltenanzahl der Objekte unterscheidet (z.B. 2-spaltige Tabelle gefolgt von einer 3-spaltigen Tabelle) und für das nachfolgende Objekt kein Platz mehr vorhanden wäre. |  | True False Formel | Umbruch Kein Umbruch Formel-Assistent
Spaltenzahl | Anzahl der Spalten des Objekts. Bei mehreren mehrspaltigen Objekten wird nach einem Objekt automatisch ein Seitenumbruch ausgelöst, wenn sich die Spaltenanzahl der Objekte unterscheidet (z.B. 2-spaltige Tabelle gefolgt von einer 3-spaltigen Tabelle) und für das nachfolgende Objekt kein Platz mehr vorhanden wäre. Hinweis: Das Feld "LL.CurrentTableColumn" liefert den Index der aktuellen Spalte zurück. |  | 0 1 2 3 4 5 Formel | Voreinstellung Container 1-spaltig 2-spaltig 3-spaltig 4-spaltig 5-spaltig Formel-Assistent
 | Abstand | Abstand der Spalten des Objekts. | Zahl Formel | Formel-Assistent
 | Spaltenwechselbedingung (nur Tabelle) | Wenn das Ergebnis der Bedingung "True" ist, wird ein Spaltenumbruch ausgelöst. | True False Formel | Ja Nein Formel-Assistent
 | Spaltenwechsel vor | Vor Ausgabe dieses Objekts erfolgt ein Spaltenumbruch. | True False Formel | Ja Nein Formel-Assistent


Tabellenobjekte

Das Tabellenobjekt ist ein Element des Berichtscontainers.

Siehe auch:

Objekt-Eigenschaften

Spezifische Funktionen

Zeilen-Eigenschaften

Gruppenzeilen-Eigenschaften

Spalten-Eigenschaften


Objekt-Eigenschaften

Siehe auch Kapitel Gemeinsame Objekt-Eigenschaften und Berichtscontainer-Objekt.

Eigenschaft

Beschreibung

Wert

Beschreibung

Fixe Größe

(nicht für Untertabellen verfügbar)

Über die Eigenschaft "Fixe Größe" können Sie bestimmen, dass die Tabelle Ihre Größe nicht automatisch anpassen soll, wenn Sie nach dem Ersetzen der Feldnamen durch Feldinhalte weniger Datenzeilen enthält als Platz im Tabellenobjekt verfügbar ist. Bei ausgeschalteter Eigenschaft rückt das Ende der Tabelle in diesem Fall automatisch nach oben.
Eine eventuell definierte Fußzeile wird bei "Fixe Größe" um einen Leerraum von mindestens einer Zeile von der übrigen Tabelle abgesetzt. Der Leerraum übernimmt dabei die Rahmendefinition aus dem Zeilenlayout Nr. 1 der Datenzeilen. Ansonsten erscheint die Fußzeile unmittelbar unter der Tabelle.

Beachten Sie bitte, dass mit der Tabelle eventuell verkettete Objekte ihre Position natürlich nur dann automatisch an eine veränderte Tabellengröße anpassen können, wenn "Fixe Größe" ausgeschaltet ist.

True

False

Formel

Ja

Nein

Formel-Assistent

Separatoren durchziehen

Diese Eigenschaft bewirkt, dass die Spaltentrennlinien zwischen der letzten Datenzeile und der Fußzeile durchgezogen werden. Bei ausgeschalteter Option reichen die Spaltentrennlinien nur bis genau zur letzten Datenzeile. Diese Eigenschaft steht nur bei Tabellen "fixer Größe" zur Verfügung.

True

False

Formel

Ja

Nein

Formel-Assistent

Hintergrund

Farbe und Typ für den Tabellenhintergrund. (Je nach Anwendung nur im Berichtscontainer verfügbar).

Rahmen-Voreinstellung

Voreinstellung für den Tabellenrahmen.

Ausklappbarer Bereich

Die Unterelemente des Elementes sind initiell in der Vorschau nicht sichtbar, können aber interaktiv ausgeklappt werden. Nur verfügbar wenn eine Untertabelle vorhanden ist

True

False

Ja

Nein

Seitenwechselbedingung

Darüber können Sie eine Bedingung angeben, die bewirkt, dass Seitenumbruch nach einer Datenzeile durchgeführt wird, sobald die Bedingung eintritt.

Bei Seitenwechsel = True wird nach jeder Zeile ein Seitenwechsel gemacht, bei Seitenwechsel = False wird der Seitenwechsel nur dann durchgeführt wenn notwendig.

True

False

Formel

Ja

Nein

Formel-Assistent

Spaltenzahl

Anzahl der Spalten der Tabelle.

Hinweis: Das Feld "LL.CurrentTableColumn" liefert den Index der aktuellen Spalte zurück.

0

1

2

3

4

5

Formel

Voreinstellung Container

1-spaltig

2-spaltig

3-spaltig

4-spaltig

5-spaltig

Formel-Assistent

Abstand

Abstand der Spalten der Tabelle.

Zahl

Formel

Formel-Assistent

Spaltenwechselbedingung

Wenn das Ergebnis bei Ausgabe einer Datenzeile "True" ist, wird ein Spaltenumbruch ausgelöst.

True

False

Formel

Umbruch

Kein Umbruch

Formel-Assistent

Spaltenwechsel vor

Vor Ausgabe dieses Objekts erfolgt ein Spaltenumbruch.

True

False

Formel

Umbruch

Kein Umbruch

Formel-Assistent

(Seiten-) Umbruch vor

Wenn die Bedingung "True" ergibt, wird vor der Ausgabe des Objekts ein Seitenumbruch ausgelöst.

Bei mehreren mehrspaltigen Objekten wird nach einem Objekt automatisch ein Seitenumbruch ausgelöst, wenn sich die Spaltenanzahl der Objekte unterscheidet (z.B. 2-spaltige Tabelle gefolgt von einer 3-spaltigen Tabelle) und für das nachfolgende Objekt kein Platz mehr vorhanden wäre.

True

False

Formel

Umbruch

Kein Umbruch

Formel-Assistent

Datenzeilen

Datenzeilen unterdrücken

Wenn Sie die Option "Datenzeilen unterdrücken" aktivieren, so werden alle Datenzeilen komplett unterdrückt. Diese Option ist insbesondere in Verbindung mit der Option "Summierung forcieren" sehr nützlich. Letztere Option legt fest, dass die Summierung auch dann ausgeführt wird, wenn eine Datenzeile nicht gedruckt wird. Durch die Kombination beider Optionen und die Verwendung von Gruppen und Summenvariablen ermöglicht sich der Druck interessanter Statistiken.

True

False

Formel

Ja

Nein

Formel-Assistent

Summierung forcieren

Summenvariablen werden trotz Datenzeilenunterdrückung berechnet.

True

False

Formel

Ja

Nein

Formel-Assistent

Zebramuster

Die Datenzeilen werden mit einem Zebramuster hinterlegt. Sofern ein etwaiger Hintergrund gesetzt ist, erhält die sonst weiße Zeile diese Farbe. Sobald Sie den Hintergrund explizit setzen, wird das Zebramuster ignoriert.

0

1

2

3

4

5

6

8

102

103

104

105

Formel

Transparent

Muster/feste Farbe

horiz. Gradient (hell)

vert. Gradient (hell)

horiz. 2-teiliger Gradient (hell)

vert. 2-teiliger Gradient (hell)

teiltransparent

Glaseffekt

horiz. Gradient (hell)

vert. Gradient (hell)

horiz. 2-teiliger Gradient (hell)

vert. 2-teiliger Gradient (hell)

Formel-Assistent

Zeilen zusammen-halten

Bei einem Seitenumbruch werden Datenzeilen soweit möglich zusammengehalten, also zusammen auf die nächste Seite gedruckt.

True

False

Formel

Ja

Nein

Formel-Assistent

Fußzeilen

Fußzeilen zusammen-halten

Bei einem Seitenumbruch werden Fußzeilen soweit möglich zusammengehalten, also zusammen auf die nächste Seite gedruckt.

True

False

Formel

Ja

Nein

Formel-Assistent

Gruppenfuß-zeilen

Auch bei leeren Gruppen

Gruppenfußzeilen werden auch bei leeren Gruppen ausgegeben.

True

False

Formel

Ja

Nein

Formel-Assistent

Zeilen zusammen-halten

Bei einem Seitenumbruch werden Gruppenfußzeilen soweit möglich zusammengehalten, also zusammen auf die nächste Seite gedruckt.

True

False

Formel

Ja

Nein

Formel-Assistent

Gruppenkopf-zeilen

Folgezeile zusammen-halten

Eine Gruppenzeile wird wenn möglich nicht durch einen Seitenumbruch von den nachfolgenden Datenzeilen getrennt.

True

False

Formel

Ja

Nein

Formel-Assistent

Zeilen zusammen-halten

Bei einem Seitenumbruch werden Gruppenkopfzeilen soweit möglich zusammengehalten, also zusammen auf die nächste Seite gedruckt.

True

False

Formel

Ja

Nein

Formel-Assistent


Spezifische Funktionen

Funktion | Aufgabe
CurrentDataLineIndex | Gibt den fortlaufenden Index der ausgegebenen Datenzeilen einer Tabelle zurück.
CurrentLineIndex | Gibt den fortlaufenden Index der Zeilendefinition zurück, in der die Funktion benutzt wird.
CurrentLineTypeIndex | Gibt den fortlaufenden Index des Zeilentyps (Kopf, Fuß, Daten, ...) zurück, in der die Funktion benutzt wird.
FirstHeaderThisTable | Liefert zurück, ob die Kopfzeile der aktuellen Tabelle zum ersten Mal ausgegeben wird.
LastFooterThisTable | Liefert zurück, ob die Fußzeile der aktuellen Tabelle zum letzten Mal ausgegeben wird.
RemainingTableSpace | Gibt den in dem Tabellenobjekt für Daten und Gruppenzeilen zur Verfügung stehenden Platz zurück.
TableWidth | Gibt die Breite des Tabellenobjekts zurück. Kann verwendet werden um Spaltenbreiten relativ anzugeben.


Zeilen-Eigenschaften

Siehe auch Kapitel Gemeinsame Objekt-Eigenschaften:

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Im Designer anzeigen | Damit können Sie Zeilen im Arbeitsbereich ausblenden – sehr nützlich, wenn Sie z.B. sehr viele Zeilendefinitionen haben. |  | True False Formel | Ja Nein Formel-Assistent
Schriftart-Voreinstellung | Sie können die Schriftart für die ganze Tabellenzeile voreinstellen. Neu eingefügte Spalten erscheinen dann zunächst in dieser Schriftart. |  |  | Schrift-Dialog
Ränder | Hier definieren Sie die Abstände der Zeile nach oben, unten, rechts und links. Die Abstände "oben" bzw. "unten" bewirken dabei entsprechende Leerräume zwischen den einzelnen Tabellenzeilen. Über die Abstände "links" bzw. "rechts" erreichen Sie Einzüge relativ zum Tabellenobjekt, Sie können damit also Zeilen bzw. Spalten einrücken. |  | Formel | Formel-Assistent
Verankern an Zeile | Index (1-basierend) der Zeile, mit deren Position die Anfangsposition der Zeile verankert wird. 0=keine Verankerung. Diese Funktion wird nicht von allen Exportformaten unterstützt. |  | Zahl | Formel-Assistent
 | Anker | Bestimmt ob an die Anfangs- oder Endposition der Zeile verankert wird. | 0 1 | Oben Unten


Gruppenzeilen-Eigenschaften

Bei Gruppenzeilen zusätzlich noch folgende Eigenschaften:

Eigenschaft

Beschreibung

Wert

Beschreibung

Gruppensummen

Die markierten Summenvariablen werden auf "0" gesetzt, wenn die Bedingung der Gruppenzeile zutrifft.

Diese Einstellung ist nützlich, um sog. Gruppensummen zu realisieren, etwa um die Preise aller Artikel einer bestimmten Artikelgruppe aufzusummieren.

Dialog

Gruppieren nach

Der Schlüsselausdruck, dessen Ergebnis den Gruppenwechsel bedingt.

Formel

Formel-Assistent

Immer auch am Tabellenanfang

Gibt den Gruppenkopf nach einem Seitenumbruch erneut aus.

True

False

Formel

Ja

Nein

Formel-Assistent

Umbruch vor Ausgabe

Vor der Ausgabe der Gruppenkopfzeile wird ein Seitenumbruch ausgelöst, d.h. jede Gruppe beginnt auf einer neuen Seite. Wenn mehrere Gruppenzeilen mit dieser Option gleichzeitig gedruckt werden, so erscheinen sie untereinander auf der neuen Seite.

Über die Funktion RemaingTableSpace() können Sie bedingte Zeilenumbrüche durchführen, z.B. "Wenn nur 50mm Platz übrig, dann vorher umbrechen".

True

False

Formel

Ja

Nein

Formel-Assistent

Umbruch nach Ausgabe

Nach Ausgabe aller Gruppenfußzeilen wird ein Seitenumbruch ausgelöst, d.h. jede Gruppe beginnt auf einer neuen Seite.

True

False

Formel

Ja

Nein

Formel-Assistent


Spalten-Eigenschaften

Die Spalteneigenschaften entsprechen jeweils mit einigen tabellenbedingten Einschränkungen den Eigenschaften des jeweiligen Objekttyps.

Eine Besonderheit gibt es bei Spalten vom Typ Text und Formatierter Text. Diese beiden Textvarianten lassen sich auch über eine Spalteneigenschaft nachträglich ineinander überführen. Abhängig von dieser Eigenschaft ändert sich dann auch die Eigenschaftsliste entsprechend.

Siehe auch Kapitel Gemeinsame Objekt-Eigenschaften.

Eigenschaft

Beschreibung

Wert

Beschreibung

Optionen
(bei einigen Feldtypen)

Öffnet den "Inhalt"-Dialog des entsprechenden Objekttyps

Inhalt-Dialog

Drilldown-Verknüpfungen

Öffnet den Dialog zum Bearbeiten der Drilldown-Verknüpfungen. Darüber kann aus der Vorschau ein Drilldown-Bericht gestartet werden.

Drilldown-Dialog

Sortierung
(nur Kopfzeile)

Sortierungen (aufsteigend+absteigend) für interaktives Umschalten in der Vorschau.

Mehrstufige Sortierungen können über einen Dialog definiert werden (sofern von der Anwendung unterstützt), z.B. die Daten erst nach Land und dann nach Ort sortieren.

Einstufige Sortierungen können über die Liste ausgewählt werden.

Dialog

Liste

Als JPEG speichern

(nur bei Bild)

Das Bild als JPEG-Datei ausgeben, wenn möglich (nicht alle Dateitypen, z.B. ICO, WMF, EMF, unterstützen diese Option).

True

False

Formel

Ja

Nein

Formel-Assistent

Drehung

Dreht das Objekt gegen den Uhrzeigersinn. Mit dieser Funktion können Sie z.B. Spaltentitel oder Barcodes um 90° drehen.

0

1

2

3

Formel

0°

90°

180°

270°

Formel-Assistent

Formatierung

Beachten Sie, dass sich die Formatierung auf das Ergebnis des gesamten Ausdrucks bezieht. Möchten Sie nur Teilbereiche eines Ausdrucks formatieren (z.B. bei Text und Zahl innerhalb eines Ausdrucks) verwenden Sie die Funktionen Date$() und Fstr$() im Formel-Assistent.

True

False

Dialog

Balkenbreite
(nur bei Barcode)

Die dünnste Strichdicke eines einzelnen Balkens in SCM-Einheiten (1/1000 mm). 0 = automatische Anpassung. Wird nicht von allen Barcodes unterstützt.

Formel

Formel-Assistent

Orientierung

Orientierung des Barcodes innerhalb des Objektrahmens

0

1

2

Formel

Links

Zentriert

Rechts Formel-Assistent

Balkenfarbe (nur bei Barcode)

Die Farbe des Barcode.

Strichdicken-Verhältnis
(nur bei Barcode)

Das Verhältnis der Strichdicken verschiedener Balken oder Leerräume untereinander. Wird nicht von allen Barcodes unterstützt.

Formel

Formel-Assistent

Text ausgeben
(nur bei Barcode)

Hier können Sie bestimmen, ob der Inhalt des Barcodes auch noch im Klartext erscheinen soll.

True

False

Formel

Ja

Nein

Formel-Assistent

Hintergrund

Der Hintergrund der Spalten.

Text-Format

Unterscheidet die Darstellung der Textspalte.

True

False

Normaler Text

RTF Text

Link

Link der bei Klick auf das Objekt (in der Echtdatenvorschau, bei PDF- oder HTML-Export) aufgerufen wird.

Beispiel: file://c:\users\public\x.log oder URL

Link

Formel

Formel-Assistent

Anordnung

(nur bei Bild)

Beschreibt, wie das Bild auf der Fläche angeordnet werden soll.

0

1

2

3

4

5

6

7

8

9

Zentriert

Nebeneinander (Kacheln)

Links oben

Links unten

Rechts oben

Rechts unten

Links

Rechts

Oben

Unten

Ausr. Vertikal

(nur bei Barcode, Text)

Vertikale Ausrichtung des Inhalts in dem vorhandenen Platz.

0

1

2

Formel

Oben

Zentriert

Unten

Formel-Assistent

Ausrichtung

(nur bei Text)

Die Text-Ausrichtung. Dezimal bedeutet, Zahlenwerte werden an Ihren Dezimalpunkten ausgerichtet.

0

1

2

3

Formel

Links

Zentriert

Rechts

Dezimal

Formel-Assistent

Dezimalposition

Die Position des Dezimalpunktes innerhalb der Zelle gemessen von der linken Kante des vorherigen Rahmens in mm.

Zahl

Formel

Formel-Assistent

Blocksatz

Text ist rechts- und linksbündig.

True

False

Formel

Ja

Nein

Formel-Assistent

Breite

Die Breite der Spalte in mm. Überschreitet die Summe der Spaltenbreiten die Gesamtbreite des Tabellenobjekts, erhalten Sie eine Fehlermeldung.

Zahl

Formel

Formel-Assistent

Einpassen

Bestimmt das Verhalten wenn der Inhalt zu lang für eine Zeile wird.

Damit lange Wörter bei Wert "1" (umbrechen) nicht abgeschnitten werden, können Sie über die Option "Umbruch erzwingen" sicherstellen, dass nach dem letzten passenden Zeichen umgebrochen wird. Wert "3" (verschmälern) verringert den Zeichenabstand und sollte nur bis zu einer gewissen Grenze verwendet werden um die Lesbarkeit zu gewährleisten.

0

1

2

3

Formel

Abschneiden

Umbrechen

Verkleinern

Verschmälern

Formel-Assistent

Absatzkontrolle

Verhindert sog. Witwen und Waisenkinder.

Als Witwe wird die letzte Zeile eines Absatzes bezeichnet, wenn sie zugleich die erste einer neuen Spalte oder Seite ist.

Wenn eine Seite oder Spalte nach der ersten Zeile eines neuen Absatzes umbrochen wird, so wird diese allein am Ende der Seite oder Spalte stehende Zeile als Waisenkind bezeichnet

True

False

Formel

Ja

Nein

Formel-Assistent

Umbruch erzwingen

Wenn ein langes Wort nicht umgebrochen werden kann, wird ein Umbruch nach dem letzten passenden Zeichen erzwungen.

True

False

Formel

Ja

Nein

Formel-Assistent

Höhe (nicht bei Text, Formatierter Text).

Feste Höhe der Zelle, der Inhalt wird skaliert (0: keine feste Höhe). Die Gesamthöhe einer Tabellenzeile ergibt sich aus der Zelle mit der größten Höhe.

Zahl
Formel

Formel-Assistent

Feste Höhe (bei Text, Formatierter Text)

Feste Höhe der Zelle, unabhängig vom Inhalt. Überschüssiger Text wird verworfen (0: keine feste Höhe). Die Gesamthöhe einer Tabellenzeile ergibt sich aus der Zelle mit der größten Höhe.

Zahl
Formel

Formel-Assistent

Leerzeichen-Optimierung

Führende und doppelte Leerzeichen werden entfernt.

True

False

Formel

Ja

Nein

Formel-Assistent

Zeilenabstand (bei Text)

Abstand der Textzeilen untereinander.

Zahl
Formel

Formel-Assistent

Rahmen

Bestimmt die Rahmeneigenschaften und Abstände zu den Rahmen der einzelnen Zellen einer Tabelle. Zusammen mit der gewählten Schriftgröße bestimmen die Zellenränder "oben" und "unten" die Höhe der Tabellenzeile bei Text-Objekten.

Zahl

Formel

Dialog

Formel-Assistent


Diagramm-Objekte

Das Diagramm-Objekt ist ein Element des Berichtscontainers.

Siehe auch:

Objekt-Eigenschaften

Spezifische Felder

Kreis/Ring

Balken/Linien/Flächen/Blasen

Trichter

Landkarte/Shapefile

Diagrammbereich (alle Diagrammtypen)

Farben (alle Diagrammtypen außer Shapefile)


Objekt-Eigenschaften

Siehe Kapitel Gemeinsame Objekt-Eigenschaften und Berichtscontainer-Objekt.


Spezifische Felder

Feld | Aufgabe
LL.ChartObject.ArcIndex | Liefert den Index des aktuellen Segments. Das größte Segment hat den Index 1, das zweitgrößte hat den Index 2 usw.
LL.ChartObject.ArcPerc | Liefert den Prozentanteil des aktuellen Segments.
LL.ChartObject.ArcTotal | Liefert den absoluten Wert der gesamten Datenmenge beim Tortendiagramm.
LL.ChartObject.ArcTypeIsOthers | Liefert True, wenn das aktuelle Segment das "Andere"-Stück ist.
LL.ChartObject.ArcValue | Wert des Kreissegments.
LL.ChartObject.AxisCoordinate | Beschreibt den Inhalt des Quellwerts.
LL.ChartObject.AxisPercentage (nur im relativ gestapelten Diagramm) | Größe in Prozent (verwendbar in der Koordinatenbeschriftung der Größenachse).
LL.ChartObject.Shape.Attribute.* (nur bei Shapefiles) | Shapefile-Attribute
LL.ChartObject.ValueIsOthers (nicht bei Kreisdiagrammen) | liefert True, wenn der aktuelle Balken der "Andere"-Balken ist.


Kreis/Ring

Siehe auch:


Datenquelle

Auf der Registerkarte "Datenquelle" können Sie den Koordinatenwert für die Daten bestimmen.

Eigenschaft | Beschreibung |  |  | Wert | Beschreibung
Koordinatenwert | Wählen Sie hier die Datenquelle für die Kreisabschnitte. |  |  | Formel | Formel-Assistent
Mindestanteil | Gerade wenn Sie viele Werte mit einem kleinen Prozentanteil haben, kann es wünschenswert sein, diese unter einer gemeinsamen Rubrik "Andere" zusammenzufassen. Hier können Sie den Schwellenwert wählen, ab dem einzelne Segmente zu einem größeren zusammengefasst werden sollen. |  |  | Zahl | Formel-Assistent
Koordinaten sortieren | Gibt an ob die Koordinaten sortiert werden sollen (alphanumerisch oder alphabetisch). |  |  | True False Formel | Ja Nein Formel-Assistent
Zahl der Entwurfsdaten | Die Zahl der Datensätze für die Entwurfsvorschau, da der Designer noch nicht über die "echten" Daten verfügt. |  |  | Zahl | Formel-Assistent
Datenfilter | Hier kann eine Filterbedingung definiert werden. Es werden nur die Datensätze verwendet, die diese Bedingung erfüllen. Bei "True" werden alle Daten verwendet. |  |  | True False Formel | alle Daten keine Daten Formel-Assistent
Koordinatenbeschriftung | Bestimmt den Text für die Koordinatenbeschriftung. |  |  | Formel | Formel-Assistent
 | Schriftgröße fest | Die Schriftgröße soll fest sein (sonst wird sie verkleinert, wenn es zur Darstellung ohne Überschneidung nötig ist). |  | True False Formel | Ja Nein Formel-Assistent
Koordinatenbeschriftung "Andere" | Bestimmt den Text für die Koordinatenbeschriftung auf dem Segment für die zusammengefassten "Andere"-Restdaten. |  |  | Formel | Formel-Assistent
Legende | Platzierung der Legende. |  |  |  | Keine an Diagramm oben, links, rechts, unten
 | Äquidistant (nur bei Platzierung 'oben' oder 'unten'). |  | Beschreibt ob die Legenden-einträge gleichmäßig verteilt werden sollen (Ja) oder optimal aneinandergereiht (Nein). | True False | Ja Nein
 | Rand |  | Rand der Legende. |  | Rahmen- dialog
 | Anteil der Legende |  | Anteil des reservierten Bereichs vom verfügbaren Platz für die Legende. 0 bedeutet eine automatische Berechnung. | Zahl | Formel-Assistent


Segment

Auf der Registerkarte "Segment" können Sie Einstellungen zur Berechnung und Darstellung des Segments vornehmen.

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Koordinatenwert | Bestimmen Sie hier die Formel für den Koordinatenwert, der die Größe des Segments bestimmt (Summe der Umsätze, Durchschnittlicher Umsatz, Anzahl der Verkäufe usw.). |  | Formel | Formel-Assistent
Dicke | Segmentdicke in Prozent. |  | Zahl | Formel-Assistent
Explosions-Distanz | Die einzelnen Segmente werden hervorgehoben. Der Wert beschreibt die Distanz des Segments (als Prozentsatz des Radius). |  | Zahl | Formel-Assistent
Koordinatenbeschriftung auf Objekt | Gibt an, ob ein Text auf den Objekten ausgegeben werden soll. |  | 0 1 Formel | Nein Ja Formel-Assistent
 | Inhalt | Text auf dem Diagrammelement. | Formel | Formel-Assistent


Diagramm

Auf der Registerkarte "Diagramm" können Sie Einstellungen zum Erscheinungsbild vornehmen.

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Beleuchtet | Die Farbdarstellung wird geändert. |  | True False | Ja Nein
Farbmodus | Die Segmente werden mit wechselnden Farben gekennzeichnet, so dass die einzelnen Werte leichter zu unterscheiden sind. Farbeinstellung über die Registerkarte "Farben". |  | 0 1 Formel | monochrome Segmente farbige Segmente Formel-Assistent
Innerer Radius | Ring-Diagramm: Relative Position des inneren Ringradius (5-95%). |  |  |
Perspektive | Hier können Sie wählen, ob das Diagramm mit leichter oder starker Perspektive erstellt werden soll. Alternativ können Sie auch eine einfache Parallelprojektion verwenden. |  | 0 1 2 Formel | keine leicht verzerrt stark verzerrt Formel-Assistent
Perspektivischer Gradient | Der perspektivische Gradient erzeugt einen Helligkeitsgradienten über die Oberfläche des Diagramms. Angabe in Prozent. |  | Zahl | Formel-Assistent
 | Rand hervorheben | Rand des Diagramms hervorheben. | True False Formel | Ja Nein Formel-Assistent
Rotationswinkel x-Achse | Der Rotationswinkel um die x-Achse nach oben in Grad, maximal 90° (senkrecht). Bestimmt die Lage des Diagramms im Raum. Sie können diesen Winkel alternativ auch über die Rotationsschaltflächen bestimmen, die bei einem selektierten Diagramm auf der Arbeitsfläche angezeigt werden. |  | Zahl | Formel-Assistent
Rotationswinkel y-Achse | Der Rotationswinkel um die Diagrammmitte gegen den Uhrzeigersinn in Grad. Sie können diesen Winkel alternativ auch über die Rotationsschaltflächen bestimmen, die bei einem selektierten Diagramm auf der Arbeitsfläche angezeigt werden. |  | Zahl | Formel-Assistent
Separatorlinien | Anzeige von Separatorlinien zwischen den Segmenten. |  | True False Formel | Ja Nein Formel-Assistent


Balken/Linien/Flächen/Blasen

Siehe auch:


Rubriken- und Reihenachse

Wenn Sie sich für ein dreiachsiges Diagramm entschieden haben, stehen Ihnen beide Achsen (als x- bzw. y-Achse) zur Verfügung. Bei einem zweiachsigen Diagramm (z.B. ein einfaches Balkendiagramm) wird nur die Rubrikenachse (x-Achse) benötigt.

Eigenschaft

Beschreibung

Wert

Beschreibung

Koordinatenwert

Wählen Sie hier die Datenquelle für die Koordinate, z.B. "Monat".

Formel

Formel-Assistent

Mindestanteil (nur beim relativ gestapelten Diagramm)

Gerade wenn Sie viele Werte mit einem kleinen Prozentanteil haben, kann es wünschenswert sein, diese unter einer gemeinsamen Rubrik "Andere" zusammenzufassen. Hier können Sie den Schwellenwert wählen, ab dem einzelne Segmente zu einem größeren zusammengefasst werden sollen.

Zahl

Formel-Assistent

Koordinaten sortieren

Gibt an ob die Koordinaten sortiert werden sollen (alphanumerisch oder alphabetisch).

True

False

Formel

Ja

Nein

Formel-Assistent

Reihendefinitionen

Für die Reihenachse (y-Achse) bei einem dreiachsigen Diagramm haben Sie zusätzlich die Möglichkeit, die Werte nicht über Formeln sondern über Reihen zu bestimmen. Damit definieren Sie die verschiedenen Reihen (z.B. Messwert/Sollwert/Istwert) mit einem einzigen Datensatz und können diese z.B. in einem Liniendiagramm parallel darstellen.

Wechseln Sie auf der Reihenachse über die Combobox oberhalb der Eigenschaftsliste zum Eintrag "Werte über Reihen bestimmen". Damit ändern sich die Eigenschaften der Reihenachse und es steht die Eigenschaft "Reihendefinitionen" zur Verfügung. Öffnen Sie den Dialog "Reihendefinitionen" und definieren Sie die einzelnen Reihen. Sie können für jede Reihe eigene Eigenschaften definieren und die Reihen über die Pfeil-Schaltflächen verschieben.

Die Eigenschaft "Berechnungsart" ermöglicht z.B. die Darstellung von gleitenden Durchschnitten oder das Aggregieren von Daten.

Dialog

Zahl der Entwurfsdaten

Die Zahl der Datensätze für die Entwurfsvorschau, da der Designer noch nicht über die "echten" Daten verfügt.

Zahl

Formel-Assistent

Datenfilter

Hier kann eine Filterbedingung definiert werden. Es werden nur die Datensätze für das Diagramm verwendet, die diese Bedingung erfüllen.

True

False

Formel

alle Daten

keine Daten

Formel-Assistent

Start- und Endwerte gerundet

Achsenstartwerte und Achsenendwerte auf runde Intervallgrenzen setzen, falls der ausgenutzte Datenbereich nicht zu klein wird (mind. 80% des Wertumfangs der Achse).

True

False

Formel

Ja

Nein

Formel-Assistent

Achsenbeschriftung

Bestimmt den Text für die Achse.

Formel

Formel-Assistent

Drehung

Drehung der Achsenbeschriftung in Grad.

Zahl

Formel-Assistent

Koordinatenbeschriftung

Bestimmt den Text für die Koordinatenbeschriftung bzw. Legende.

Formel

Formel-Assistent

Drehung

Drehung der Koordinatenbeschriftung in Grad (für lange Texte).

Zahl

Formel-Assistent

Schriftgröße fest

Die Schriftgröße soll fest sein (sonst wird sie verkleinert, wenn es zur Darstellung ohne Überschneidung nötig ist).

True

False

Formel

Ja

Nein

Formel-Assistent

Koordinatenbeschriftung "Andere"

Bestimmt den Text für die Koordinatenbeschriftung auf dem Segment für die zusammengefassten "Andere"-Restdaten.

Formel

Formel-Assistent

Legende

Platzierung der Legende (Werte je nach Typ und Achse unterschiedlich).

Keine

an Achse

oben, links, rechts, unten

Äquidistant (nur bei Platzierung 'oben' oder 'unten').

Beschreibt ob die Legenden-einträge gleichmäßig verteilt werden sollen (Ja) oder optimal aneinandergereiht (Nein).

True

False

Ja

Nein

Rand

Rand der Legende.

Rahmen- dialog

Anteil der Legende

Anteil des reservierten Bereichs vom verfügbaren Platz für die Legende. 0 bedeutet eine automatische Berechnung.

Zahl

Formel-Assistent

Markierungsfarbe

Farbe der Koordinaten-Markierungslinien (Tickmarks).


Größenachse

Auf der Registerkarte "Größenachse" können Sie Einstellungen zur Berechnung und Darstellung der Größenachse eines Balken- und Liniendiagramms vornehmen.

Primärachse / Sekundärachse: Es wird eine zweite Werte-Achse unterstützt. Die zweite Achse wird auf der Registerkarte "Diagramm" eingeschaltet. Wechseln Sie über die Combobox zu den Eigenschaften der jeweiligen Achse.

Eigenschaft

Beschreibung

Wert

Beschreibung

Koordinatenwert

Bestimmen Sie hier die Formel für den Koordinatenwert (z.B. Summe der Umsätze).

Formel

Formel-Assistent

Achsenskalierung

Typ der Achsenskalierung.

0

1

2

Formel

keine (linear)

logarithmisch, Basis 10

logarithmisch, Basis 2 (binär)

Formel-Assistent

Berechnungsart

Ermöglicht z.B. die Darstellung von gleitenden Durchschnitten oder das Aggregieren von Daten.

Nicht verfügbar, wenn die Werte der Reihenachse über Reihen bestimmt werden. Dann steht diese Eigenschaft im Dialog "Reihendefinitionen" bei den einzelnen Reihen zur Verfügung.

0

1

2

3

4

5

6

7

Normal

Kumulative Summe

Kumulativer Mittelwert

Einfacher gleitender Mittelwert

Symmetrischer gleitender Mittelwert

Differenz zum Vorwert

Mittelwert

Ausgleichsgerade

Anzahl der Werte (nur bei Berechnungsart 3 und 4)

Anzahl der vorhergehenden oder umgebenden Werte, die für die Berechnung herangezogen werden.

Zahl

Formel-Assistent

Maximalwertautomatik

Soll die Größenachse bis zu einem bestimmten Maximalwert gehen, oder soll der Endwert automatisch bestimmt werden?

Sie können den angezeigten Bereich beschränken, um z.B. "Ausreißer" nach oben zu berücksichtigen. Enthalten Ihre Werte große Spitzen, so können Sie durch Setzen eines Maximalwertes die Spitzen abschneiden und den Verlauf der "kleinen" Werte besser darstellen. Wenn Sie die Voreinstellung "Nein" beibehalten, wird das Diagramm so angepasst, dass alle Werte dargestellt werden.

True

False

Formel

Ja

Nein

Formel-Assistent

Grenzwert

Maximalwert für die Achsendarstellung

Zahl

Formel-Assistent

Minimalwertautomatik (nur Linien, Flächen, Blasen)

Soll die Größenachse bei einem bestimmten Minimalwert beginnen, oder soll der Anfangswert automatisch bestimmt werden?

Sie können den angezeigten Bereich beschränken, um z.B. "Ausreißer" nach unten zu berücksichtigen. Wenn Sie die Voreinstellung "Nein" beibehalten, wird das Diagramm so angepasst, dass alle Werte dargestellt werden.

True

False

Formel

Ja

Nein

Formel-Assistent

Grenzwert

Minimalwert für die Achsendarstellung

Zahl

Formel-Assistent

Blasendarstellung (nur Blasen)

Darstellung der Blasen

0

1

2

3

4

5

6

7

8

9

Kreis

Gefüllter Kreis

Gefüllter Kreis mit Rahmen

Lichteinfall von links

Lichteinfall von oben

Lichteinfall von links oben

Kugel

Glastropfen

Glastropfen teiltransparent

Bild-Datei

Darstellung (je nach Ober- und Untertyp)

Visuelle Darstellung. Je nach Ober- und Untertyp stehen unterschiedliche Darstellungsarten zur Verfügung:

Torte, Flächen, Blasen: -

Balken einfach, gruppiert:1, 2, 3, 8, 9

Balken gestaffelt:1, 2, 3, 4, 8, 9

Balken gestapelt: 1, 2, 8

Linien: 5, 6, 7

1

2

3

4

5

6

7

8

9

Formel

Zylinder

Balken

Pyramide

Band

Linie

Symbole

Linie + Symb.

Oktaeder

Kegel

Formel-Assistent

Dicke

Balken-/Linien-/Segmentdicke in Prozent.

Zahl

Formel-Assistent

Koordinatenbeschriftung auf Objekt

Gibt an, ob ein Text auf den Objekten ausgegeben werden soll.

0

1

Formel

Nein

Ja

Formel-Assistent

Inhalt

Text auf dem Objekt.

Formel

Formel-Assistent

Koordinatenlinien

Gibt an, ob Koordinatenlinien auf den Hintergrund gezeichnet werden sollen.

True

False

Formel

Ja

Nein

Formel-Assistent

Zebramodus

Gibt an, ob ein Zebramuster auf dem Hintergrund ausgegeben werden soll.

Transparent

Muster/feste Farbe

horiz. Gradient

vert. Gradient

horiz. 2-teiliger Gradient

vert. 2-teiliger Gradient

teiltransparent

Achsenbeschriftung

Bestimmt den Text für die Achse.

Formel

Formel-Assistent

Drehung

Drehung der Achsenbeschriftung in Grad.

Zahl

Formel-Assistent

Koordinatenbeschriftung

Bestimmt den Text für die Koordinatenbeschriftung bzw. Legende.

Formel

Formel-Assistent

Drehung

Drehung der Koordinatenbeschriftung in Grad.

Zahl

Formel-Assistent

Schriftgröße fest

Die Schriftgröße soll fest sein (sonst wird sie verkleinert, wenn es zur Darstellung ohne Überschneidung nötig ist).

True

False

Formel

Ja

Nein

Formel-Assistent

Koordinatenmarkierungsabstand

Berechnung des Abstands der Koordinatenmarkierungen (Ticks).

True

False

Formel

Automatisch

Manuell

Formel-Assistent

Legende

Platzierung der Legende dieser Achse.

Keine

an Achse

Markierungsfarbe

Farbe der Koordinaten-Markierungslinien (Tickmarks).

Farbe

Zahl der Zwischenmarkierungen

Die Zahl der durch kleine Striche getrennten Unterabteilungen zwischen den Hauptkoordinatenmarkierungen

Zahl

Formel-Assistent


Diagramm

Auf der Registerkarte "Diagramm" können Sie Einstellungen zum Erscheinungsbild des Balken- und Liniendiagramms vornehmen. Die verfügbaren Eigenschaften unterscheiden sich je nach Typ.

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Alternativachse | Unterstützt eine zweite Werte-Achse auf der linken Seite. Die Achsen-Eigenschaften werden auf der Registerkarte "Größenachse" vorgenommen. Die jeweilige Achse wird über eine Combobox ausgewählt. |  | True False Formel | Ja Nein Formel-Assistent
 | Achsen-Zuordnung | Bestimmt zu welcher Größenachse der Wert zugeordnet wird. | 0 1 Formel | Primärachse Sekundärachse Formel-Assistent
Achsenfarbe | Farbe der Achsen (bzw. des Rahmens bei 3D-Darstellung) |  |  | Farbe
Ausrichtung | Ausrichtung der Grafikelemente, z.B. für ein horizontales Balkendiagramm. |  |  | Nach rechts Nach oben
Beleuchtet | Gibt an, ob das Diagramm beleuchtet werden soll. |  | True False Formel | Ja Nein Formel-Assistent
Farbmodus | Bestimmt die farbgebende Achse. |  | 0 1 2 Formel | monochrom x-Achse y-Achse Formel-Assistent
Hintergrundfarbe | Hintergrund des Diagramms. |  |  | Transparent Muster/feste Farbe
Lineare Datenachse | Beschreibt, ob numerische bzw. Datumswerte ihrem Wert entsprechend auf der Achse positioniert werden sollen. |  | True False | Ja Nein
Isotrop | Gleiche Größe der Einheiten auf den beiden Datenachsen (x- und y-Achse). |  | True False Formel | Ja Nein Formel-Assistent
Perspektive | Hier können Sie wählen, ob das Diagramm mit leichter oder starker Perspektive erstellt werden soll. Alternativ können Sie auch eine einfache Parallelprojektion verwenden. |  | 0 1 2 Formel | keine leicht verzerrt stark verzerrt Formel-Assistent
Projektion (nur beim 3D-Diagramm) | Bei flacher Projektion bleibt die vordere Achse immer gerade. |  | 0 1 Formel | flach 3D Formel-Assistent
Rotationswinkel x-Achse | Der Rotationswinkel um die x-Achse nach oben in Grad, maximal 90° (senkrecht). Bestimmt die Lage des Diagramms im Raum. Sie können diesen Winkel alternativ auch über die Rotationsschaltflächen bestimmen, die bei einem selektierten Diagramm auf der Arbeitsfläche angezeigt werden. |  | Zahl | Formel-Assistent
Rotationswinkel y-Achse | Der Rotationswinkel um die Diagramm-mitte gegen den Uhrzeigersinn in Grad. Sie können diesen Winkel alternativ auch über die Rotationsschaltflächen bestimmen, die bei einem selektierten Diagramm auf der Arbeitsfläche angezeigt werden. |  | Zahl | Formel-Assistent
Separatorlinien | Anzeige von Separatorlinien zwischen den Segmenten. |  | True False Formel | Ja Nein Formel-Assistent


combit List & Label

Trichter

Siehe auch:


Datenquelle

Auf der Registerkarte "Datenquelle" bestimmen Sie den Koordinatenwert.

Eigenschaft | Beschreibung |  |  | Wert | Beschreibung
Koordinatenwert | Wählen Sie hier die Datenquelle für die Daten. |  |  | Formel | Formel-Assistent
Datenfilter | Hier kann eine Filterbedingung definiert werden. Es werden nur die Datensätze verwendet, die diese Bedingung erfüllen. Bei "True" werden alle Daten verwendet. |  |  | True False Formel | alle Daten keine Daten Formel-Assistent
Koordinatenbeschriftung | Bestimmt den Text für die Koordinatenbeschriftung. |  |  | Formel | Formel-Assistent
 | Schriftgröße fest | Die Schriftgröße soll fest sein (sonst wird sie verkleinert, wenn es zur Darstellung ohne Überschneidung nötig ist). |  | True False Formel | Ja Nein Formel-Assistent
Legende | Platzierung der Legende. |  |  |  | keine an Diagramm oben, links, rechts, unten
 | Äquidistant (nur bei Platzierung 'oben' oder 'unten'). |  | Beschreibt ob die Legenden-einträge gleichmäßig verteilt werden sollen (Ja) oder optimal aneinandergereiht (Nein). | True False | Ja Nein
 | Rand |  | Rand der Legende. |  | Rahmen- dialog
 | Anteil des Texts(nur bei Platzierung 'an Diagramm') |  | Anteil des reservierten Bereichs vom verfügbaren Platz für den Text (in Prozent). | Zahl | Formel-Assistent


Trichterabschnitt

Auf der Registerkarte "Trichterabschnitt" nehmen Sie Einstellungen zur Berechnung und Darstellung des Trichterabschnitt vor.

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Koordinatenwert | Bestimmen Sie hier die Formel für den Koordinatenwert, der die Größe des Abschnitts bestimmt (Summe der Umsätze, Durchschnittlicher Umsatz, Anzahl der Verkäufe usw.). |  | Formel | Formel-Assistent
Explosions-Distanz | Der Wert beschreibt die Distanz der Trichterabschnitte (100% = 50% der Gesamthöhe des Trichters). |  | Zahl | Formel-Assistent
Koordinatenbeschriftung auf Objekt | Gibt an, ob ein Text auf dem Trichterabschnitt ausgegeben werden soll. |  | 0 1 Formel | Nein Ja Formel-Assistent
 | Inhalt | Text auf dem Trichterabschnitt. | Formel | Formel-Assistent


Diagramm

Auf der Registerkarte "Diagramm" können Sie Einstellungen zum Erscheinungsbild vornehmen.

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Beleuchtet | Die Farbdarstellung wird geändert. |  | True False | Ja Nein
Farbmodus | Die Trichterabschnitte werden mit wechselnden Farben gekennzeichnet, so dass die einzelnen Werte leichter zu unterscheiden sind. Farbeinstellung über die Registerkarte "Farben". |  | 0 1 Formel | monochrome Trichterabschnitte farbige Trich-terabschnitte Formel-Assistent
Relative Breite des Trichteranfangs | Breite des Trichteranfangs relativ zur Diagrammgröße (ggf. unter Berücksichtigung der Legende). |  | Zahl | Formel-Assistent
Relative Breite des Trichterendes | Breite des Trichterendes relativ zum Trichteranfang. Eine Breite von 100% ergibt ein Säulendiagramm (Pipeline). |  | Zahl | Formel-Assistent
 | Anteil des Trichterendes | Anteil des Trichterendes (in Prozent, -100% für Länge des letzten Trichterabschnitts). | Zahl | Formel-Assistent
Separatorlinien | Anzeige von Separatorlinien zwischen den Abschnitten. |  | True False Formel | Ja Nein Formel-Assistent


Landkarte/Shapefile

Siehe auch:

Shapefile-Auswahl

Zuordnung

Wert

Farben (Umriss-Legende)


Shapefile-Auswahl

Auf der Registerkarte "Shapefile-Auswahl" bestimmen Sie das zugrundeliegende Shapefile und den darzustellenden Bereich.

Eigenschaft

Beschreibung

Wert

Beschreibung

Daten-Shapefile

Dieses Shapefile wird für die Daten (Einfärbung usw.) verwendet.

Name

Name des Objekts

Dateiname

Dateipfad zur shp-Datei.

Wert

Formel-Assistent

Datei-Auswahldialog

Hintergrund

Die Füllfarbe eines Umrisses, z.B. LL.Color.LandMass

Farbe

Formel-Assistent und Farb-Dialog

Rahmen

Die Farbe eines Umrisses, z.B. LL.Color.LandMass

Farbe

Formel-Assistent und Farb-Dialog

Filter

Dieser Filter erlaubt eine Auswahl, welche Umrisse bzw. Linien aus dem Shapefile für die darstellung enutzt werden sollen. Über die Attribute ('LL.ChartObject.Shape.Attribute…'-Felder) kann die Auswahl eingegrenzt werden.

Formel

Formel-Assistent

Bereichsauswahl

Über diesen Filter wird der darzustellende Bereich ausgewählt.

Rechteck (bei Koordinaten): Die Koordinaten (links, unten, rechts, oben) auf die der dargestellte Bereich beschränkt werden soll. Für Landkarten ist der typische Koordinatenbereich -180°…180° in x-Richtung und -90°…90° in y-Richtung.

Formel: 'True' für alle Informationen (Umrisse, Linien) des Daten-Shapefiles. Über die Attribute ('LL.ChartObject.Sha-pe.Attribute…'-Felder) kann die Auswahl eingegrenzt werden.

True

False

Formel

Koordinaten

Zentriert

Zentrierte Darstellung (nur bei azimutaler Projektion). Die Daten werden anhand des Bereichsauswahl-Filters zentriert.

True

False

Formel

Ja

Nein

Formel-Assistent

Projektion

Die Projektionsart. Nur für Shapefiles mit Welt-Koordinaten sinnvoll (Koordinatenbereich -180°…180° in x-Richtung und -90°…90° in y-Richtung.)

0

1

2

3

4

5

6

7

keine

Mercator (Zylindrisch)

Braun (Zylindrisch)

Kavrayskiy (Azimutal)

Sinusoidal (Azimutal)

Eckert-Greiffendorff (Azimutal)

Hammer (Azimutal)

Winkel III (Azimutal)

Hintergrund-Shapefiles

Shapefiles in dieser Liste werden 'unter' die Daten gelegt, um bspw. Meere o.ä. darstellen zu können.

Dialog

Verschiebung

(im 'Shapefile-Liste bearbeiten'-Dialog)

Verschiebung nach unten rechts. So kann ein Shapefile als 'Schatten' verwendet werden.

Wert

Formel-Assistent

Vordergrund-Shapefiles

Shapefiles in dieser Liste werden 'über' die Daten gelegt, um bspw. Flüsse o.ä. darstellen zu können.

Dialog

Auf Bereichsauswahl einschränken

(im 'Shapefile-Liste bearbeiten'-Dialog)

Die Darstellung wird auf die Bereichsauswahl des Daten-Shapefiles beschränkt.

Wert

Formel-Assistent


Zuordnung

Auf der Registerkarte "Zuordnung" kann über die Attribute ein Bezug zu den Shapefile-Daten hergestellt werden.

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Koordinatenwert | Bestimmen Sie hier die Formel für den Koordinatenwert. |  | Formel | Formel-Assistent
Datenfilter | Hier kann eine Filterbedingung definiert werden. Es werden nur die Datensätze verwendet, die diese Bedingung erfüllen. Bei "True" werden alle Daten verwendet. |  | True False Formel | alle Daten keine Daten Formel-Assistent
Umriss-Zuordnung | Diese Formel ermöglicht die Zuordnung eines Umrisses zu einem Koordinatenwert. Über die Attribute ('LL.ChartObject.Shape.Attribute…'-Felder) kann ein Bezug zu den Shapefile-Daten hergestellt werden |  | Zahl | Formel-Assistent
Achsenbeschriftung | Bestimmt den Text für die Achse. |  | Formel | Formel-Assistent
Legende | Platzierung der Legende. |  | keine oben, links, rechts, unten | Legende
 | Äquidistant (nur bei Platzierung 'oben' oder 'unten'). | Beschreibt ob die Legenden-einträge gleichmäßig verteilt werden sollen (Ja) oder optimal aneinandergereiht (Nein). | True False |
 | Rand | Rand der Legende. |  | Dialog
 | Anteil der Legende | Anteil des reservierten Bereichs vom verfügbaren Platz für die Legende. | Zahl |


Wert

Auf der Registerkarte "Wert" können Sie Einstellungen zum Erscheinungsbild vornehmen.

Eigenschaft | Beschreibung | Wert | Beschreibung
Koordinatenwert | Bestimmen Sie hier die Formel für den Koordinatenwert. | Formel | Formel-Assistent
Koordinatenbeschriftung | Bestimmt den Text auf den Objekten. | 0 1 Formel | Nein Zentriert Formel-Assistent


Farben (Umriss-Legende)

Es ist möglich, bestimmten Achsenwerten feste Farben zuzuordnen. Über die Schaltfläche "Neu" können Sie eine neue Zuordnung eingeben. Für die tatsächliche Einfärbung wählen Sie die Bedingung "True".

Eigenschaft

Beschreibung

Wert

Beschreibung

Bedingung

Für die tatsächliche Einfärbung (7°C, 13°C, 21°C usw.) wählen Sie die Bedingung "True".

Für die Ausgabe diskreter Legendenwerte (5°C, 10°C, 15°C usw.) wählen Sie die Bedingung "False".

True

False

Formel

Einfärbung

Nur Legende

Formel-Assistent

Legendentext

Bestimmt den Text für die Legende, z.B. "5°C".

Formel

Formel-Assistent

Farbe

Für die tatsächliche Einfärbung ordnen Sie dem Achsenwert eine Farbe zu, z.B. HeatmapColor(LL.ChartObject. AxisCoordinate,-20,40).

Für die Ausgabe diskreter Legendenwerte definieren Sie feste Werte, z.B. HeatmapColor(0,-20,40).

Farbe

Formel-Assistent und Farb-Dialog


Diagrammbereich (alle Diagrammtypen)

Auf der Registerkarte "Objekt" finden Sie Einstellungen zum Titel und Hintergrund.

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Titel | Überschrift des Diagramms. |  | Formel | Formel-Assistent
Titelposition | Die Position der Diagramm-Überschrift. |  | 0 1 2 3 Formel | oben unten oben zentriert unten zentriert Formel-Assistent
Hintergrund | Hintergrund des Diagramms. |  | True False Formel | Anzeigen Nicht anzeigen Formel-Assistent
 | Rand | Rand des Begrenzungsrahmens |  | Transparent Muster/feste Farbe
 | Schatten | Schatten des Begrenzungsrahmens |  | Transparent Muster/feste Farbe
 | Rundung | Rundungsfaktor für die Ecken des Begrenzungsrahmens in Prozent (0=eckig, 100=kurze Kante ist rund) | Zahl | Formel-Assistent


Farben (alle Diagrammtypen außer Shapefile)

Eigenschaft | Beschreibung | Wert | Beschreibung
Design-schema | Bestimmt die Farben und Farbreihenfolge für diejenigen Datenreihen, die nicht über "Feste Farben" bestimmt werden. Über die Auswahlliste können Sie ein vordefiniertes Set von Farben auswählen. Über die Eigenschaften können diese Farben noch angepasst werden. | Farbe | Formel-Assistent und Farb-Dialog
Feste Farben | Es ist möglich, bestimmten Achsenwerten feste Farben zuzuordnen. Über die Schaltfläche "Neu" können Sie eine neue Zuordnung eingeben, z.B. Customers.Country="Germany". | Farbe | Formel-Assistent und Farb-Dialog


Kreuztabellen-Objekte

Das Kreuztabellen-Objekt ist ein Element des Berichtscontainers.

Siehe auch:

Objekt-Eigenschaften

Spezifische Funktionen

Eigenschaften der Zellen

Eigenschaften des Kreuztabellenbereichs


Spezifische Funktionen

Funktion

Aufgabe

Crosstab.Cells.Max()
Crosstab.Cells.Min()

Liefert den größten bzw. kleinsten Wert der gesamten Kreuztabelle zurück.

Crosstab.Cells.Avg()

Liefert den Durchschnittswert der gesamten Kreuztabelle zurück.

Crosstab.Col$()
Crosstab.Row$()

Liefert den Spalten- bzw. Zeilenbeschreibungstext für die aktuelle Zelle zurück

Crosstab.Value()

Liefert den Inhalt der Zelle (als Zahl) zurück.

Total()

Kann für Berechnungen über alle Zellen hinweg benutzt werden. Sonst laufen Berechnungen immer über alle Werte, die die jeweilige Zelle betreffen

Join$()

Liefert die gesammelten Zeichenketten, getrennt durch ein Trennzeichen.


Eigenschaften der Zellen

Selektieren Sie die entsprechende Zelle im Objekt-Dialog auf der Registerkarte "Zellendefinition". Um mehrere Zellen zu selektieren, halten Sie die Strg-Taste gedrückt oder ziehen mit der Maus einen Rahmen um die Zellen.

Eigenschaft

Beschreibung

Wert

Beschreibung

Wert

Formel für den Zellenwert. Dieser wird von den Crosstab.Cells-Funktionen ausgewertet.

Formel

Formel-Assistent

Dargestellter Inhalt

Text, der in der Zelle dargestellt werden soll. Dieser kann sich somit vom Wert unterscheiden, der in der Eigenschaft "Wert" angegeben wurde, z.B. für Formatierungen.

Formel

Formel-Assistent

Drehung

Dreht das Objekt gegen den Uhrzeigersinn. Mit dieser Funktion können Sie z.B. Spaltentitel um 90° drehen.

0

1

2

3

Formel

0°

90°

180°

270°

Formel-Assistent

Link

Link der bei Klick auf das Objekt (in der Echtdatenvorschau, bei PDF- oder HTML-Export) aufgerufen wird.

Beispiel: file://c:\users\public\x.log oder URL

Link

Formel

Formel-Assistent

Ausrichtung

(bei Text)

Die Text-Ausrichtung. Dezimal bedeutet, Zahlenwerte werden an Ihren Dezimalpunkten ausgerichtet.

0

1

2

3

Formel

Links

Zentriert

Rechts

Dezimal

Formel-Assistent

Ausrichtung vertikal

Vertikale Ausrichtung des Inhalts in dem vorhandenen Platz.

0

1

2

Formel

oben

zentriert

unten

Formel-Assistent

Beschränken auf
(nur Ergebnis-spalte)

Schränkt die Anzahl der Einträge auf dieser Ebene auf die angegebene Zahl ein (Top-N-Bericht in Kombination mit Sortierung nach Ergebnis). .

Zahl

Formel

Anzahl der Einträge

Formel-Assistent

Dezimalposition

Position des Dezimalpunkts (nur bei dezimaler Ausrichtung gültig, negativ bedeutet: von rechts.

Formel

Formel-Assistent

Darstellungsbedingung (bei Zusammenfassungen)

vor Daten

Gibt an, ob die Zusammenfassung vor oder nach den Datenzeilen ausgegeben werden soll.

True

False

Formel

Ja

Nein

Formel-Assistent

Leerzeichen-Optimierung

Führende und doppelte Leerzeichen werden entfernt.

True

False

Formel

Ja

Nein

Formel-Assistent

Maximalbreite

Gibt an welche Maximalbreite eine Zelle maximal haben darf. Wenn der Text breiter wird, wird ein Zeilenumbruch ausgelöst.

Zusammen mit der Funktion Join$() können dann z.B. die Einzelwerte innerhalb einer Zelle dargestellt werden.

Formel

Formel-Assistent

Mindestbreite

Gibt die Mindestbreite des Zellentyps an.

Formel

Formel-Assistent

Mindesthöhe

Gibt die Mindesthöhe des Zellentyps an.

Formel

Formel-Assistent

Sortierung (nur Achsen-definition)

Sortierung der Spalte, um z.B. den Kunden mit dem höchsten Umsatz in der ersten Zeile anzuzeigen.

0

1

2

3

4

Formel

Aufsteigend

Absteigend

Unsortiert

Ergebnis aufsteigend

Ergebnis absteigend

Formel-Assistent


Eigenschaften des Kreuztabellenbereichs

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Mindestgröße | Gibt an, wieweit die Kreuztabelle verkleinert werden kann, um einen horizontalen Seitenumbruch zu vermeiden. 50= verkleinert sich um bis zu 50% um einen Seitenumbruch zu vermeiden; 100=Originalgröße beibehalten. |  | Zahl | Formel-Assistent
Mindesthöhe | Gibt an, welche Höhe dem Objekt mindestens zur Verfügung stehen soll. Wenn weniger Platz vorhanden ist, wird ein Umbruch ausgelöst. |  | Zahl | Formel-Assistent
Spalten | Bestimmt Spalteneigenschaft bei einem Umbruch |  | Formel | Formel-Assistent
 | Bezeichner wiederholen | Gibt an, ob die Zeilenbezeichner bei einem Spaltenumbruch wiederholt werden sollen. | True False Formel | Ja Nein Formel-Assistent
 | Umbruch auf Schattenseiten | True: Wenn die Kreuztabelle in horizontaler Richtung zu groß wird, werden die Umbruchstücke auf Schattenseiten gedruckt. Eine Schattenseite wird nicht als "echte" Seite gezählt, erhält also auch keine Seitennummer. False: Die Umbruchstücke werden unterhalb der Tabelle ausgegeben. | True False Formel | Ja Nein Formel-Assistent
 | Abstand vor | Abstand vom vorhergehenden Element. | Formel | Formel-Assistent
 | Umbruchebene | Beschreibt die optimale Umbruchebene. 0=innerste Gruppe, d.h. die unterste Zeile der Spaltendefinitionen. | Formel | Formel-Assistent
 | erzwingen | Erzwingt Umbruch nach jeder entsprechenden Gruppe. | True False Formel | Ja Nein Formel-Assistent
Zeilen | Bezeichner wiederholen | Gibt an, ob die Spaltenbezeichner bei einem Zeilenumbruch wiederholt werden sollen. | True False Formel | Ja Nein Formel-Assistent
 | Umbruchebene | Beschreibt die optimale Umbruchebene. 0=innerste Gruppe, d.h. die unterste Zeile der Zeilendefinitionen. | Formel | Formel-Assistent
 | Erzwingen | Erzwingt Umbruch nach jeder entsprechenden Gruppe. | True False Formel | Ja Nein Formel-Assistent


Gantt-Diagramm-Objekte

Das Gantt-Diagramm ist ein Element des Berichtscontainers.

Siehe auch:


Spezifische Felder

Feld | Aufgabe
LL.GanttObject.CurrentBarLabel | Liefert die Balkenbeschriftung des aktuellen Balkens.
LL.GanttObject.CurrentProjectDepth | Liefert die Ebene des Sammelvorgangs (0..).


Inhalt

Eigenschaft

Beschreibung

Wert

Beschreibung

Sammelvorgangsname

Feld oder Formel für den Namen eines Sammelvorgangs.
Diese Eigenschaft ist ein Pflichtfeld. Sofern Sie keine Sammelvorgänge anzeigen möchten, geben Sie an dieser Stelle den gleichen Wert wie bei "Vorgangsname" an.

Formel

Formel-Assistent

Vorgangsname

Feld oder Formel für den Namen eines Vorgangs (Pflichtfeld).

Formel

Formel-Assistent

Beginn

Feld oder Formel für die Startzeit eines Vorgangs (Pflichtfeld). Bei Sammelvorgängen wird dies automatisch auf die Startzeit des ersten Vorgangs gesetzt.

Formel

Formel-Assistent

Ende

Feld oder Formel für die Endzeit eines Vorgangs (Pflichtfeld). Bei Sammelvorgängen wird dies automatisch auf das Ende des letzten Vorgangs gesetzt. Der Vorgang wird als Meilenstein interpretiert, wenn die Endzeit der Anfangszeit entspricht und die Dauer 0 ist.

Formel

Formel-Assistent

Dauer

Feld oder Formel für die Dauer eines Vorgangs (in Tagen). Bei Sammelvorgängen wird dies automatisch durch die Tagesdifferenz berechnet.

Formel

Formel-Assistent

Fortschritt

Feld oder Formel für den Fortschritt eines Vorgangs (in Prozent).

Formel

Formel-Assistent

Balkenbeschriftung

Feld oder Formel für die Balkenbeschriftung eines Vorgangs.

Formel

Formel-Assistent

Uhrzeit berücksichtigen

Bestimmen Sie, ob die übergebenen Start- und Endwerte exakt sind (Start=Ende bedeutet 0 Tage Dauer) oder in Tagen gerechnet werden soll (Start=Ende bedeutet 1 Tag Dauer).

True

False

Ja

Nein

Titelzeile

Eigenschaften der Titelzeile.

Sammelvorgangszeile

Eigenschaften der Sammelvorgangszeile.

.

Balkeneigenschaften

siehe Vorgangszeile.

Vorgangszeile

Eigenschaften der Vorgangszeile.

Balkeneigenschaften

Abrundung

Rundung des Balkens.

Formel

Formel-Assistent

Balkenhöhe (erledigt)

Balkenhöhe des erledigten Anteils in Prozent der Zeilenhöhe (0: keinen Balken anzeigen).

Formel

Formel-Assistent

Balkenhöhe (unerledigt)

Balkenhöhe des unerledigten Anteils in Prozent der Zeilenhöhe (0: keinen Balken anzeigen).

Formel

Formel-Assistent

Füllung (erledigt)

Eigenschaften der Balkenfüllung des erledigten Anteils des Vorgangs.

Siehe Kapitel "Gemeinsame Objekt-Eigenschaften"

Füllung (unerledigt)

Eigenschaften der Balkenfüllung des unerledigten Anteils des Vorgangs.

Siehe Kapitel "Gemeinsame Objekt-Eigenschaften"

Tabellenbereich

Bestimmt den angezeigten Tabellenbereich.

Index/ Name/ Beginn/ Ende/ Dauer/ Fortschritt

Bestimmt ob ein fortlaufender Index für (Sammel-)Vorgänge / der Vorgangsname /
der Vorgangsbeginn /
das Vorgangsende /
die Vorgangsdauer /
der Vorgangsfortschritt angezeigt werden soll.

Es kann jeweils die maximale Breite der Spalte, der Text der Titelzeile und die Formatierung definiert werden.

True

False

Anzeigen

Nicht Anzeigen

Diagrammbereich

Bestimmt den angezeigten Zeitbereich.

Startzeit/-datum

Bestimmt die Startzeit bzw. das Startdatum

Null()

Formel

Automatisch

Formel-Assistent

Endzeit/-datum

Bestimmt die Endzeit bzw. das Enddatum

Null()

Formel

Automatisch

Formel-Assistent

Zeiteinheit

Bestimmt die Zeiteinheit für die Ausgabe,

1

2

3

4

5

6

7

Jahrzehnte

Jahre

Quartale

Monate

Wochen

Tage

Stunden

Format

Format der Zeiteinheit.

Formatierung

Formel-Assistent

Markierte Tage

Wenn als Zeiteinheit "Wochen" oder "Tage" gewählt ist, kann hier definiert werden welche Tage markiert werden sollen. Z.B. ("6,7") für Samstag,Sonntag.

kommaseparierte Liste

Formel-Assistent

Übergeordnete Zeiteinheit

Bestimmt die übergeordnete Zeiteinheit

0

1

2

3

4

5

6

Jahrhunderte

Jahrzehnte

Jahre

Quartale

Monate

Wochen

Tage

Mindestbreite

Mindestbreite einer Zelle des Zeitintervalls.

Formel

Formel-Assistent

Bereichsmarkierung

Zeitpunkt oder Bereich markieren.

Gittermodus

Schwarz-weiß-Modus beim Druck auf einen monochromen Drucker einstellen.

0

1

2

Aus

Grau

Schwarz-Weiß

Link

Link der bei Klick auf das Objekt (in der Echtdatenvorschau, bei PDF- oder HTML-Export) aufgerufen wird.

Beispiel: file://c:\users\public\x.log oder URL

Link

Formel

Formel-Assistent

Abstand
vor

Abstand bei horizontalem Umbruch.

Zahl

Formel-Assistent

Mindesthöhe

Gibt an, welche Höhe dem Objekt mindestens zur Verfügung stehen soll. Wenn weniger Platz vorhanden ist, wird ein Umbruch ausgelöst.

Zahl

Formel-Assistent

Umbruch auf Schattenseiten

True: Wenn das Gantt-Diagramm zu breit wird, werden die Umbruchstücke auf Schattenseiten gedruckt. Eine Schattenseite wird nicht als "echte" Seite gezählt, erhält also auch keine Seitennummer.

False: Die Umbruchstücke werden unterhalb der Tabelle ausgegeben

True

False

Formel

Ja

Nein

Formel-Assistent

Bezeichner wiederholen

Gibt an, ob die Zeilenbeschriftung bei einem Umbruch erneut gedruckt werden soll.

True

False

Formel

Ja

Nein

Formel-Assistent

Umbruch gleichmäßig

Gibt an, ob ein Umbruch wenn möglich an den Grenzen des übergeordneten Zeitintervalls (z.B. Monat) durchgeführt werden soll.

True

False

Ja

Nein


Messinstrument-Objekte

Messinstrumente können in Tabellenspalten oder als Objekt platziert werden.

Siehe auch:


Objekt-Eigenschaften

Siehe Kapitel Gemeinsame Objekt-Eigenschaften.


Inhalt

Auf der Registerkarte "Inhalt" definieren Sie das Erscheinungsbild des Messinstruments.

Eigenschaft

Beschreibung

Wert

Beschreibung

Füllung

Hintergrund des Messinstruments

Farbe. Farbe des Hintergrunds.

Farbe

Einblendfaktor. Faktor für die Einblendstärke. Wertebereich 0 (transparent) bis 100 (deckend).

Wert

Formel-Assistent

Zeigeroptionen

Farbe. Farbe des Zeigers.

Farbe

(nur lineares Messinstr.)

Hintergrund. Hintergrund der Skala.

Farbe

(nur Tacho)

Größenfaktor. Bestimmt die relative Größe des Zeigers zum Skalenbereich.

Wert

Formel-Assistent

Darstellungsbereich. Beschreibt über die Eigenschaften "Minimum" und "Maximum" in welchem Prozentbereich der verfügbaren Fläche dieses Element dargestellt wird.

Wert

Formel-Assistent

Glasoptionen

Farbe. Farbe zur Glas-Einfärbung.

Farbe

Einblendfaktor. Wertebereich 0 (transparent) bis 100 (deckend).

Wert

Formel-Assistent

Länge/Breite-Verhältnis
(nur lineares Messinstr.)

Gibt das Länge/Breite-Verhältnis für das lineare Messinstrument an. Je größer der Wert, desto schmaler wird es im verfügbaren Platz gezeichnet.

0

1 - 5

Flächenfüllend

1:1 – 5:1

Skalenbereich-Rotationswinkel

Der Rotationswinkel der Skala (0°= unten, im Uhrzeigersinn).

Wert

Formel-Assistent

Skalenbereich-Anfangsabstand

Bestimmt den freien Platz zwischen dem Anfang des Messinstruments und dem Anfang der Skala (max. 50%).

Wert

Formel-Assistent

Skalenbereich-Endabstand

Bestimmt den freien Platz zwischen dem Ende des Messinstruments und dem Ende der Skala (max. 50%).

Wert

Formel-Assistent

Skalen-markierungen

Skalentyp.

0

1

2

3

Keine

Skalentyp 1

Skalentyp 2

Skalentyp 3

Darstellungsbereich. Beschreibt über die Eigenschaften "Minimum" und "Maximum" in welchem Prozentbereich der verfügbaren Fläche sich dieser Bereich befindet.

Formel

Formel-Assistent

Farbe. Farbe der Skalenmarkierung.

Farbe

Markierungsbreite. Gibt die Breite der Markierung der Skala an (Prozentwert).

Formel

Formel-Assistent

Detailtiefe. Gibt an, welche Ebenen der Skalenmarkierung maximal ausgegeben werden. 0=nur oberste Ebene.

Formel

Formel-Assistent

Füllung.

Zwischenmarkierungsposition. Bestimmt, wo die Zwischenmarkierungen platziert werden.

Berechnungsart. Berechnungsart des Abstands der Koordinatenmarkierungen (Ticks).

True

False

Formel

Automatisch

Manuell

Formel-Assistent

Abstand. Der benutzerdefinierte Abstand der Koordinatenmarkierungen (Ticks).

Formel

Formel-Assistent

Skalenbeschriftung

Die Eigenschaften der Skalenbeschriftung.

True

False

Anzeigen

Nicht Anzeigen

Darstellungsbereich. Beschreibt über die Eigenschaften "Minimum" und "Maximum" in welchem Prozentbereich der verfügbaren Fläche sich dieser Bereich befindet.

Formel

Formel-Assistent

Gedreht. Drehung der Schrift.

True

False

Ja

Nein

Größenanpassung. Bestimmt ob die Schriftgröße verkleinert werden kann, damit die Schrift in den Bereich passt.

True

False

Ja

Nein

Ausrichtung. Text-Ausrichtung.

0

1

2

Formel

Links

Zentriert

Rechts

Formel-Assistent

Signalbereiche

Die Eigenschaften der Signalbereiche. Durch Einfärbung kann so z.B. ein optimaler Bereich signalisiert werden. Über einen Dialog definieren Sie Startwert, Startfarbe, Endwert und Endfarbe der einzelnen Bereiche.

True

False

Anzeigen

Nicht Anzeigen

Dialog

Darstellungsbereich. Beschreibt über die Eigenschaften "Minimum" und "Maximum" in welchem Prozentbereich der verfügbaren Fläche sich dieser Bereich befindet.

Wert

Formel-Assistent

Textfelder

Liste der Textfelder. Über einen Dialog definieren Sie Drehung, Rahmengröße, Hintergrund, Schrift, Formatierung und Position der einzelnen Felder.

Die Position wird dabei in Prozent relativ zur Fläche des Messinstruments angegeben (gemessen von links bzw. oben). D.h. eine vertikale und horizontale Position von jeweils 50% positioniert das Textfeld genau in die Mitte.

True

False

Anzeigen

Nicht Anzeigen

Dialog

Minimalwert

Minimalwert der Skala, Berechnung z.B. über Precalc().

Wert

Formel-Assistent

An Abstand anpassen. Der Minimalwert wird automatisch so angepasst, dass er zum Koordinatenmarkierungsabstand passt.

True

False

Ja

Nein

Maximalwert

Maximalwert der Skala, Berechnung z.B. über Precalc().

Wert

Formel-Assistent

An Abstand anpassen. Der Maximalwert wird automatisch so angepasst, dass er zum Koordinatenmarkierungsabstand passt.

True

False

Ja

Nein

Startwert

Bestimmt, wo der Balken für die Anzeige des Werts anfängt. Bei 'Automatisch' gilt: wenn die Skala über 0 geht, ist es 0, ansonsten der Minimalwert.

True

False

Automatisch

Manuell

Wert

Wert, den der Zeiger anzeigen soll, Berechnung z.B. über Precalc().

Wert

Formel-Assistent


Datengrafik-Objekte

Datengrafiken können in Tabellenspalten oder als Objekt platziert werden.

Siehe auch:

Objekt-Eigenschaften

Allgemein

Balken-Eigenschaften

Symbol-Eigenschaften


Allgemein

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Wert | Wert der in der Datengrafik angezeigt wird. Bestimmt die Balkenlänge und/oder die Darstellung des Symbols. |  | Formel | Formel-Assistent
 | Sichtbar | Der Wert wird angezeigt. | True False | Ja Nein
Minimalwert | Entspricht 0%-Darstellung. Der Minimalwert bezieht sich auf eine prozentuale Skalierung, d.h. bei einem Wert '30', einem Minimalwert '0' und einem Maximalwert '50' werden z.B. 3 von 5 Symbole angezeigt. |  | Formel | Formel-Assistent
Maximalwert | Entspricht 100%-Darstellung. |  | Formel | Formel-Assistent


Balken-Eigenschaften

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Abrundung | Rundung des Balkens. |  | Zahl | Formel-Assistent
Ausrichtung | Ausrichtung des Balkens. |  | 0 1 2 3 | links zentriert rechts Von der Basis-linie ausgehend nach links oder rechts
 | Basiswert (bei Ausrichtung 3) | Unterhalb dieses Werts läuft der Balken nach links, oberhalb nach rechts. Berechnung z.B. über Precalc()-Funktion. | Formel | Formel-Assistent
 | Basislinie | Basislinie anzeigen. | True False | Ja Nein
Ausrichtung vertikal | Vertikale Ausrichtung des Inhalts in dem vorhandenen Platz. |  | 0 1 2 Formel | oben zentriert unten Formel-Assistent
Balkenhöhe | Höhe des Balkens. |  | Zahl | Formel-Assistent
Teilbereiche | Bestimmt, ob die Definition der Wertebereiche automatisch (prozentuale Skalierung) oder benutzerdefiniert über einen Dialog erfolgt. |  | True False | Automatisch Benutzerdef. Teilbereiche
 | Liste | Liste mit Wertebereichen für die Zuordnung der Balkenfüllung. Jedem Bereich mit Start- und Endwert (Absolutwert oder in Prozent) kann eine Füllung zugeordnet werden. |  | Dialog


Symbol-Eigenschaften

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Ausrichtung | Horizontale Ausrichtung. |  | 0 1 2 Formel | links zentriert rechts Formel-Assistent
Ausrichtung vertikal | Vertikale Ausrichtung des Inhalts in dem vorhandenen Platz. |  | 0 1 2 Formel | oben zentriert unten Formel-Assistent
Symbol-Gruppe | Liste der Symbolgruppen. |  |  | Liste
Symbol-Höhe | Höhe des Symbols. |  | Zahl | Formel-Assistent
Teilbereiche | Bestimmt, ob die die Definition der Wertebereiche automatisch (prozentuale Skalierung) oder benutzerdefiniert über einen Dialog erfolgt. |  | True False | Automatisch Benutzerdef. Teilbereiche
 | Liste | Liste mit Wertebereichen für die Symbolzuordnung. Jedem Bereich mit Start- und Endwert (Absolutwert oder in Prozent) kann ein Symbol zugeordnet werden. |  | Dialog


Checkbox-Objekte

Mit diesem Objekt kann ein Boolean-Wert (Wahr, Falsch, NULL) angezeigt werden. Checkboxen können in Tabellenspalten oder als Objekt platziert werden.

Siehe auch:


Objekt-Eigenschaften

Siehe auch Kapitel Gemeinsame Objekt-Eigenschaften:

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Darstellung für 'Wahr' bzw. 'Falsch' bzw. 'NULL'. | Darstellung wenn die Berechnung der Inhaltsformel 'wahr' bzw. 'falsch' bzw. "NULL' ergibt. |  | 0 1 2 | keine Grafik Interne Grafik Externe Grafik
 | Interne Quelle | Auswahl der internen Grafik. | Liste | Grafik
 |  | Rahmenfarbe. |  |
 |  | Iconfarbe. |  |
 | Externe Quelle | Quelle der externen Grafik. |  | Dateiname Formel Variable


Formatierte Textobjekte

In diesem Objekt können Sie im Gegensatz zum normalen Textobjekt auch Formatierungswechsel innerhalb einer Zeile vornehmen. Ab Windows 8 unterstützt der Dialog die Windows-Rechtschreibprüfung inklusive Korrekturvorschlägen.

Formatierte Textobjekte sollten stets in der maximal gewünschten Größe erstellt werden, die Höhe minimiert sich dann zum Druckzeitpunkt zur tatsächlich benötigten Größe. Dieses Verhalten ist besonders für Verkettungen nützlich.

Bitte beachten: Wenn Sie Bildobjekte in das Formatierte Textobjekte einbetten (z.B. über die Zwischenablage), werden diese von Windows in Bitmaps konvertiert. Um die Dateigröße zu minimieren, empfehlen wir direkt ein Bildobjekt zu verwenden (und dieses z.B. an das Formatierte Textobjekt zu verketten), da das Bildobjekt eine komprimierte Ausgabe unterstützt.

Über ein Kontextmenü stehen Ihnen diverse Formatierungsmöglichkeiten (z.B. Hochgestellt, Tiefgestellt, Optionaler Trennstrich) zur Verfügung.

Abbildung 13.10: Kontextmenü

Hinweis: Das normale Textobjekt kann wesentlich schneller gedruckt werden, daher sollten Sie das formatierte Textobjekt nur dann verwenden, wenn Sie Formatierungen zu realisieren haben, die Sie mit dem normalen Textobjekt gar nicht oder nur mühsam realisieren können.

Siehe auch:


Objekt-Eigenschaften

Siehe auch Kapitel Gemeinsame Objekt-Eigenschaften:

Eigenschaft | Beschreibung | Wert | Beschreibung
Drehung | Dreht das Objekt gegen den Uhrzeigersinn. | 0 1 2 3 Formel | 0° 90° 180° 270° Formel-Assistent
Seitenumbruch | Bestimmt, ob das Objekt einen Seitenumbruch, bzw. Textüberlauf auslösen kann. True: Ein die Größe des Objektes überschreitender Inhalt wird automatisch auf die nächste Seite (bzw. auf ein verkettetes anderes Formatiertes Textobjekt) umgebrochen. Dies ist z.B. bei Formatierten Textobjekten interessant, die über mehrere Seiten gehen sollen. Bei Etiketten wird das nächste Etikett erst angefangen, wenn alle Objekte mit dieser Option des vorherigen Etiketts komplett gedruckt wurden. Es ist möglich, dass diese Eigenschaft nicht verfügbar ist, wenn der Seiten-Umbruch vom übergeordneten Programm nicht unterstützt wird. | True False Formel | Ja Nein Formel-Assistent


Formularelement-Objekte

Formularelemente können vom Anwender direkt in der Vorschau und im PDF-Format ausgefüllt werden oder Aktionen wie z.B. das Versenden per eMail auslösen. Durch Auswahl eines Typs wird das grundlegende Verhalten des Elements bestimmt. Je nach Typ verändern sich die zur Verfügung stehenden Eigenschaften. Formularobjekte können auch in Tabellenspalten eingefügt werden.

Siehe auch Kapitel Gemeinsame Objekt-Eigenschaften.

Eigenschaft | Beschreibung | Wert | Beschreibung
Typ | Legt den Element-Typ fest. | 0 1 2 3 | Edit Checkbox Combobox Button
Tooltip | Tooltip der erscheinen soll |  |

Siehe auch:

Typ Edit

Typ Checkbox

Typ Combobox

Typ Button


Typ Edit

Eigenschaft | Beschreibung |  |  | Wert | Beschreibung
Eingabe erzwingen | Legt fest, ob der Benutzer eine Eingabe machen muss. |  |  | True False Formel | Ja Nein Formel-Assistent
Feldname | Legt den Feldnamen für einen evtl. Datenexport per XML/XFDF fest. Freier Text muss in Anführungszeichen gesetzt werden. |  |  |  | Name
Validierungs-ausdruck | Regulärer Ausdruck (regular expression) zur Validierung der Eingabe. Beispiele: Feld nicht leer: ".+" eMail-Validierung: "^.+@.+\..{2,3}$" |  |  |  | Formel-Assistent
 | Fehlerhinweis | Hinweistext, der ausgegeben wird, wenn die Validierung fehlschlägt. |  |  | Formel-Assistent
Wert | Vorschlagswert für das Eingabeobjekt |  |  |  | Formel-Assistent
Ausrichtung (bei Text) | Die Text-Ausrichtung. |  |  | 0 1 2 Formel | Links Zentriert Rechts Formel-Assistent
Hintergrund | Legt fest, ob eine Hintergrundfarbe angezeigt werden soll. |  |  | 0 1 Formel | Transparent Farbe Formel-Assistent
 | Farbe | Hintergrundfarbe. |  |  |
Mehrzeilig | Legt fest, ob das Eingabefeld mehrzeilig sein kann, oder nicht. Sofern einzeilig gewählt wird, können zwar bei der Eingabe mehr Zeichen eingegeben werden und das Eingabefeld scrollt automatisch, bei einem evtl. Ausdruck werden diese jedoch abgeschnitten. |  |  | True False Formel | Ja Nein Formel-Assistent
Rand | Legt fest, ob das Objekt einen Rand haben soll. |  |  | True False Formel | Ja Nein Formel-Assistent
 | Farbe |  | Farbe des Rands. |  |
 | Breite |  | Breite des Rands in der Maßeinheit des Arbeitsbereichs. | Zahl Formel | Formel-Assistent


Typ Checkbox

Eigenschaft | Beschreibung | Wert | Beschreibung
Feldname | Legt den Feldnamen für einen evtl. Datenexport per XML/XFDF fest. Freier Text muss in Anführungszeichen gesetzt werden. | Formel | Name
Wert | Vorschlagswert für das Eingabeobjekt |  |
Hintergrund | Siehe Typ Edit. |  |
Rand | Siehe Typ Edit. |  |
Typ | Aussehen der Checkbox. | 1 2 3 Formel | Häkchen Kreuz Gefüllt Formel-Assistent


Typ Combobox

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Eingabe erzwingen | Legt fest, ob der Benutzer eine Eingabe machen muss. |  | True False Formel | Ja Nein Formel-Assistent
Einträge | Zur Verfügung stehende Vorschlagswerte der Combobox |  | Liste | Liste von Vorschlagswerten
Feldname | Legt den Feldnamen für einen evtl. Datenexport per XML/XFDF fest. Freier Text muss in Anführungszeichen gesetzt werden. |  | Formel | Name
Validierungs-ausdruck (Nur bei variablem Text verfügbar) | Regulärer Ausdruck (regular expression) zur Validierung der Eingabe. |  |  | Formel-Assistent
 | Fehlerhinweis | Hinweistext, der ausgegeben wird, wenn die Validierung fehlschlägt |  | Formel-Assistent
Variabler Text | Legt fest, ob der Benutzer auch andere Werte als die Vorschlagswerte eingeben kann |  | True False Formel | Ja Nein Formel-Assistent
Wert | Vorschlagswert für das Eingabeobjekt |  |  | Formel-Assistent
Ausrichtung | Siehe Typ Edit. |  |  |
Hintergrund | Siehe Typ Edit. |  |  |
Rand | Siehe Typ Edit. |  |  |


Typ Button

Beim PDF-Format wird nur Wert 4 unterstützt.

Eigenschaft

Beschreibung

Wert

Beschreibung

Aufgabe

Legt das mögliche Verhalten fest. Nur beim Typ Button verfügbar.

0: Versenden als Mail. Die üblichen eMail-relevanten Felder können vorbelegt werden.

1: Speichern. Beim Klick auf die Schaltfläche wird die Vorschaudatei, bzw. werden die eingegeben Daten im gewählten Format gespeichert.

2: Versenden über http-Post

3: Link: Internetadresse, die bei Klick aufgerufen wird. Das Objekt ist transparent und kann somit auch über andere Objekte gelegt werden, um so für alle Objekte Links oder Tooltips zu erzeugen.

4: PDF Signaturfeld (nur für PDF)

0

1

2

3

4

Text

Buttonbeschriftung.

Formel

Formel-Assistent


HTML-Text-Objekte

Das HTML-Objekt dient der Anzeige von HTML-Inhalten.

Für die Darstellung von HTML-Inhalten wird eine eigene Komponente genutzt, die einen begrenzten Satz an CSS-Eigenschaften unterstützt. JavaScript wird nicht unterstützt. Die korrekte Wiedergabe ganzer Webseiten steht nicht im Zentrum, vielmehr bietet das Objekt die Möglichkeit, schnell und einfach simple HTML-Streams auszugeben.

Siehe auch:


Objekt-Inhalt

Eigenschaft | Beschreibung
Dateiname | Wählen Sie diese Option, wenn Sie den Inhalt einer HTML-Datei anzeigen möchten, die Sie gespeichert haben. Über die Schaltfläche "Wählen" erhalten Sie einen Dateiauswahldialog, über den Sie nach der Datei suchen können. Die Datei muss sich in diesem Falle auf einem lokalen Speichermedium oder Netzwerk befinden
URL | Über diese Option können Sie den Inhalt von Webseiten anzeigen (z.B. www.combit.net). Diese werden zur Laufzeit online aus dem Internet oder Intranet geladen, so dass Sie in diesem Falle eine Verbindung zum Internet haben müssen.
Formel | Wenn Ihre Anwendung bestimmte Inhalte im HTML-Format zur Verfügung stellt, so können Sie diese hier auswählen. Details entnehmen Sie in diesem Falle der Dokumentation zu Ihrer Anwendung
In Objekt einpassen | Wenn Sie diese Option aktivieren, wird der gesamte Inhalt des Objektes auf die Objektgröße eingepasst. Ansonsten wird die Breite eingepasst und die Ausgabe auf mehrere Seiten aufgeteilt.


PDF-Objekte

Das PDF-Objekt dient der Anzeige von PDF-Dokumenten.

§ Für die Ausgabe des PDFs in das EMF-Format wird wenn möglich der Standard-Drucker im System verwendet. Die Qualität kann daher ggf. verbessert werden, wenn der Standard-Drucker eine entsprechend hohe Auflösung hat.

§ Besonderheit eines PDF-Objektes innerhalb einer Tabelle, wenn eine variable Zeilenhöhe (Höhe = 0) eingestellt ist: Es wird für alle Seiten im PDF-Dokument die gleiche Höhe verwendet. Hierbei wird zunächst die erste zu druckende Seite (kann über die Eigenschaft 'Seitenbereich(e)' angepasst werden) im PDF-Dokument untersucht. Wenn diese in die Zeile passen sollte, so wird auch diese Höhe verwendet. Anderenfalls wird die Zeilenhöhe der folgenden Seite verwendet. Passt auch diese Seitenhöhe nicht, so wird das PDF-Objekt in der Tabelle unter Umständen "gestaucht" dargestellt.

§ Transparenz: Wird das PDF-Objekt außerhalb einer Tabelle verwendet, so ist dieses immer transparent. Innerhalb der Tabelle wird ein Hintergrund unterstützt.

§ Damit das PDF-Objekt auch das eingestellte PDF-Dokument darstellen kann, muss ein evtl. erforderliches Passwort korrekt sein. Zusätzlich muss im PDF-Dokument das Recht "Drucken erlaubt" definiert sein. Anderenfalls kann das PDF-Objekt das definierte PDF-Dokument nicht darstellen.

Siehe auch:


Objekt-Inhalt

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Datenquelle | Wählen Sie die PDF-Datenquelle. |  | Dateiname | Formel-Assistent
 | Dateiname | Der Dateiname wird ausgewertet, falls bei der Eigenschaft Datenquelle "Dateiname" ausgewählt wurde. Danach wählen Sie mit dem Dateiauswahldialog das gewünschte PDF aus. |  | Datei öffnen-Dialog
 | Relativpfad | Der Pfad ist relativ zum Projektpfad. | True False | Ja Nein
 | Formel | Der Dateiname ergibt sich aus einer Formel, falls bei der Eigenschaft Datenquelle "Formel" ausgewählt wurde. Das Ergebnis dieser Formel muss ein PDF-Dateiname sein. | Formel | Formel-Assistent
 | In Projekt aufnehmen | Das PDF wird in das Projekt eingebettet. Das PDF steht damit auch ohne die externe Datei zur Verfügung. Als Dateiname wird in diesem Fall (eingebettete Datei) angezeigt. | True False Formel | Ja Nein Formel-Assistent
 | Seiten-Bereiche | Geben Sie an welche Seiten angezeigt werden sollen. Dabei kann auch ein Bereich angegeben werden, z.B. 1,4,6-8,10- | "1-." Formel | alle Seiten Formel-Assistent
 | Passwort | Falls die PDF-Datei passwortgeschützt ist, muss hier das Passwort angegeben werden. | Formel | Formel-Assistent
 | Originalgröße | Beschreibt, ob das PDF in Originalgröße (wenn diese ermittelt werden kann) gezeichnet wird, oder sich der Rahmengröße des PDF-Objekts anpassen soll | True False nicht definiert | Ja Nein nicht definiert
 |  | Proportionen erhalten: Über diese Option können Sie festlegen, ob das PDF so eingefügt werden soll, dass das Verhältnis von Höhe und Breite erhalten bleibt (True) oder ob sich das PDF vollständig dem Rahmen des Bildobjekts anpassen soll, aber möglicherweise verzerrt ist. | True False Formel | Ja Nein Formel-Assistent
 |  | Anordnung: Beschreibt, wie das PDF auf der Fläche angeordnet werden soll. | 0 1 2 3 4 5 6 7 8 9 | Zentriert Nebeneinander (Kacheln) Links oben Links unten Rechts oben Rechts unten Links Rechts Oben Unten
 | Seitenumbruch | Bestimmt, ob das Objekt einen Seitenumbruch auslösen kann. True: Es werden alle Seiten der PDF-Datei gedruckt. False: Es wird auf jede Seite nur die erste Seite die unter "Seiten-Bereiche" angegebenen Seite der PDF-Datei gedruckt. | True False Formel | Ja Nein Formel-Assistent
 | Schriftartenbehandlung | Bestimmt, wie Schriftarten behandelt werden sollen. Die Option "als Kurven" ist sinnvoll, wenn die Schriftart auf dem Zielsystem nicht vorhanden ist. Bei aktivierter Option, kann die Vorschaudatei unter Umständen größer und die Vorschausuche nicht mehr verwendet werden. | 0 1 2 Formel | Windows Font-Mapping Fonts als Kurven rendern Eingebettete Schriftarten verwenden Formel-Assistent


OLE Container

Der OLE-Container dient der Anzeige von OLE-Server-Dokumenten (z.B. Word, Excel, Visio, MapPoint). Es wird dabei nur die erste Seite angezeigt, da kein Standard für mehrseitige OLE-Objekte existiert.

Siehe auch:


Objekt-Inhalt

§ Dateiname: Link zu einer Datei, die zum Druckzeitpunkt vorhanden sein muss.

§ Eigebettet: Das Dokument wird über den Windows-Standard-Dialog "Objekt einfügen" ausgewählt und in das Projekt eingebettet.Dies kann z.B. für einfache Grafiken oder eher statische Objekte sinnvoll sein.

§ Formel: Erlaubt die dynamische Übergabe des Dateinamens.


Vorlagen

Vorlagen werden im Hintergrund des Arbeitsbereiches platziert, um andere Objekte gezielt daran ausrichten zu können. Dies ist hilfreich bei der Gestaltung komplexer Formulare. Die Vorlage nimmt eine Sonderstellung ein, da sie später nicht mit ausgedruckt wird.

Siehe auch:


Objekt-Eigenschaften

Eigenschaft | Beschreibung |  | Wert | Beschreibung
Dateiname | Wählen Sie hier die Datei aus, in der die gewünschte Vorlage gespeichert ist. |  |  | Datei öffnen-Dialog
 | Relativpfad | Pfad ist relativ zum Projektpfad. | True False | Ja Nein
Auch in Vorschau | Gibt an ob die Vorlage auch in der Vorschau, aber nicht auf dem Drucker ausgegeben werden soll. |  | True False Formel | Ja Nein Formel-Assistent
Mischfarbe | Die hier angegebene Farbe wird mit dem Vorlagenbild bei der Darstellung über "oder" verknüpft, um das Bild aufzuhellen. |  |  | Farb-Dialog Auswahl vordefinierter Farben und Formel-Assistent
Proportionen erhalten | Sie können festlegen, ob das Bild so eingefügt werden soll, dass das Verhältnis von Höhe und Breite erhalten bleibt (True) oder ob sich das Bild vollständig dem Rahmen der Vorlage anpassen soll (False). |  | True False Formel | Ja Nein Formel-Assistent